Sendmail configuration.

Is it possible to configurate sendmail so it gives root al mail with wrong adress. (For exampel mail to users which not exist) Instead of replying with the MailerDemoan message???

How do I get it to work this way???
LVL 1
puckoAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

jlmsCommented:
Define the postmaster as root.
0
puckoAuthor Commented:
It's probably a good ansver, but can you tell me how to do that??? I don't know what to change, and where.

0
jlmsCommented:
Check your aliases file, in this place you define alias for addresses. By the way, there is usually a rule that re-routes all the MailerDaemon message to somebody of your choice already included in this file. MOre info in your man pages for sendmail and aliases
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

puckoAuthor Commented:
You can se my aliasesfile here. What is wrong in in???
And the man-pages for aliases doesn't say a ****!
(Have tou cheked them ??)


#
#      @(#)aliases      8.2 (Berkeley) 3/5/94
#
#  Aliases in this file will NOT be expanded in the header from
#  Mail, but WILL be visible over networks or from /bin/mail.
#
#      >>>>>>>>>>      The program "newaliases" must be run after
#      >> NOTE >>      this file is updated for any changes to
#      >>>>>>>>>>      show through to sendmail.
#

# Basic system aliases -- these MUST be present.
MAILER-DAEMON:      postmaster
postmaster:      root

# General redirections for pseudo accounts.
bin:            root
daemon:            root
games:            root
ingres:            root
nobody:            root
system:            root
toor:            root
uucp:            root
webmaster:      root

# trap decode to catch security attacks
decode:            root

# Person who should get root's mail
root:            pucko       abcdef
0
ahoffmannCommented:
It's not a good idea to alias root (root: pucko abcdef).

In your /etc/sendmail.cf set:

OPpostmaster

0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
jlmsCommented:
Yes I checked it, and I agree with ahoffman, but before you modify sendmail.cf get rid of the alias for root and give it a try.
0
puckoAuthor Commented:
Set???
Just a line with OPpstmaster????

It doesn't work!
0
puckoAuthor Commented:
OK! I have a # before root: pucko now....

It doesn't work anyway...
0
jlmsCommented:
Please, get rid of the alias for root, you have to restart your sendmail daemon and make sure it reads the correct files, also that it rebuilds the aliases database, if you try using the -v option (verbose) you can follow what is happening and maybe find out what is going on.
0
puckoAuthor Commented:
I have removet the alias a loong time ago...
0
puckoAuthor Commented:
How do I Kill and restart my sendmaildeamon whithout doing a reboot????
About the aliases part. just postmaster: root in the file don't work.
0
ahoffmannCommented:
if you have a SYS-V style UNIX:

  kill -9 'ps -ef | grep sendmail | awk '{print $2}'`

or if BSD style UNIX:

  kill -9 'ps -ax | grep sendmail | awk '{print $1}'`

then restart senmail as it will do by your rc* scripts.


It's less cryptic if you hace a rc script (usually in /etc/rc.d/) which starts and stops sendmail, then you can do:

  cd /etc/whereever_your_script_are
  ./sendmail_script stop
  ./sendmail_script start
0
puckoAuthor Commented:
But that you sai about set OPpostmaster.
Do you mean that I just shall have a row OPpostmaster ??
Nothing more???
(It doesn't eork for me...)
0
ahoffmannCommented:
Do you have the ErrorMode option set in your sendmai.cf, like:

Oem
0
puckoAuthor Commented:
Don't think so. I put my sendmail.cf in ftp://a201.ryd.student.liu.se/Incoming/

Mabe it easier for you to answer my question if you see it.

0
ahoffmannCommented:
change
  #O ErrorMode=print
  #O Postmaster=root
to
  O ErrorMode=mail
  O Postmaster=root

I'm not shure (for now) if
  #O PostMasterCopy=Postmaster
must also be enabled (by removing the initial #).

TAKE CARE, your sendmail.cf was generated by m4. So there is a master file, probaly sendmail.m4, where sendmail.cf was generated from. You should make changes there too.
0
puckoAuthor Commented:
It dosn't work. The O Postmaster=root that was in the file was something I tested before and sendmail doesn't like it.....

But anyway, The problem is solved. I took a look at
http://www.redhat.com/support/docs/rhl/Sendmail-Virtual-Hosts-Tips/Sendmail-Virtual-Hosts-Tips-4.html

And figured it out by my self.

Thank's for trying!


0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.