ms.Applet.securityexception, could not resolve IP host.

I can't get working a java applet from Microsoft named hhctrl (It's the java equivalent of the html help activeX control).
I installed it on an internal web server in our society. We've got IE 3.02 both on win95 and win3.11.
Under win95, if I point either on the url  http://mycomputer/HHtest,  or http://mycomputerIP.123.456.789/HHtest, it works fine.
under win3.11, it works only with mycomputer, not with the IP adress of my computer. I can load the Applet, but this one must load a html parameter file to work correctly, and in this case, I've got an error message:
Exception: ms.Applet.AppletSecurityexception: security, could not resolve IP for host.
cchAsked:
Who is Participating?
 
kollegovConnect With a Mentor Commented:
Here is problem with sequrity manager :)

Do not use full url in
<PARAM name="Item1" value="http://192.32.72.1/hhtest/tree-param.htm">

change it to
<PARAM name="Item1" value="/hhtest/tree-param.htm">

in this case Security Manager will use the document
URL to compare allow or disallow access to specified resource from the net.  And in this case it always will be the same
ones
So you will avoid problems with security manager :)

Hope this will help :)

0
 
webster030697Commented:
Could you post your HTML file that calls the applet. Maybe then I could give you a few pointers.
0
 
jpk041897Commented:
IDEM on webster's comment, additionaly, if the control launches threads internaly, you will never get it to work under 3.11.

Try running WinSPY or some other equivalent utility under WIN95 to determine if it is a single thread control.
0
 
cchAuthor Commented:
Ok, here is the main prog:
---------------------------------------------------------------------------------------------------
<HTML>  <body bgcolor="#FFFFFF" link="#0000FF" alink="#999999" vlink="#999999"><APPLET code="HHCtrl.class"
                width=100%
                height=80%
                codebase="java">
<PARAM name="Command" value="Contents">
<PARAM name="Item1" value="http://192.32.72.1/hhtest/tree-param.htm">
</APPLET></body></HTML>
---------------------------------------------------------------------------------------------------
And here is the param prog:
---------------------------------------------------------------------------------------------------
<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML//EN">
<HTML>
<HEAD>
<meta name="GENERATOR" content="Microsoft&reg; HTML Help Workshop 4.00">
<!-- Sitemap 1.0 -->
</HEAD><BODY>
<OBJECT type="text/site properties">
      <param name="FrameName" value="contenu">
      <param name="Category" value="test">
      <param name="CategoryDesc" value=" ">
      <param name="Type" value="test1">
      <param name="TypeDesc" value=" ">
      <param name="Type" value="test2">
      <param name="TypeDesc" value=" ">
      <param name="Window Styles" value="0x800025">
      <param name="ImageType" value="Folder">
</OBJECT>
<UL>
      <LI> <OBJECT type="text/sitemap">
            <param name="Name" value="titretest">
            <param name="Local" value="K:\InetPub\wwwroot\fbleue98\Admin\Default.htm">
            <param name="Local" value="K:\InetPub\wwwroot\QCM\Admin\default.htm">
            <param name="FrameName" value="contenu">
            </OBJECT>
</UL>
</BODY></HTML>
---------------------------------------------------------------------------------------------------

Note that all is not essential in the param file, but I tried with this one because it was generated by HTML Help, so it should be correct...
Thanks...
0
 
cchAuthor Commented:
I grade you because the explanation is quite clear, but badly it didn't work!!
I changed all urls in tree and tree-param, even just in tree, but nothing worked.
I'm going to try with Microsoft (huh!)
Thanks for all.

0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.