Solved

"Error 72 : Unit File Format Error "-->> HELP !!

Posted on 1997-10-20
5
265 Views
Last Modified: 2010-05-18
Hi....

I have been working on a project using Delphi 1.0
Recently worked on it using Delphi 2.0 and it worked fine.
Now when I try to run it using Delphi 1.0 I am getting an error :

"Error 72 : Unit file Format Error "

What Can I do to solve this problem ??
Is my project totally ruined ??
Please help....

CYA
sprawler
0
Comment
Question by:sprawler
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
5 Comments
 
LVL 3

Accepted Solution

by:
Pegasus100397 earned 50 total points
ID: 1348398
Sprawler,

Sorry to hear about your unit file problems. Delphi 2.0 probably added something to the unit file something that Delphi 1.0 does not support (hence an error in the unit file). My advice would be to print the unit out and print out a similiar one from Delphi 1.0 and remove references in the USES clause one at a time until the problem goes away. You can also load up the unit in something like NotePad, remove any strange/wierd characters, save it under a different name and see if that fixes the problem.

Good luck with your project
Pegasus
0
 

Author Comment

by:sprawler
ID: 1348399
Hi .....

Thanks alot for the help ....

sprawler
0
 

Author Comment

by:sprawler
ID: 1348400
Hi .....

Thanks alot for the help ....
If I had to load the file into Delphi 1.0 and then save it again, would that make any difference ?

sprawler
0
 
LVL 3

Expert Comment

by:Pegasus100397
ID: 1348401
Glad to help Sprawler.

If you cleaned up the file with notepad or removed any unusual references then you should still be able to use it in Delphi 1.0. In general though, be careful about using/compiling project in more than one version. I have 2.0 and 3.0 and have had a similiar problems if I SAVE a 2.0 project in 3.0, then it becomes a 3.0 project/unit and I might have problems trying to get it back to 2.0.

C Ya and good luck! :)
Pegasus

P.S. Stick with Delphi 2.0 if you have that option, much better! :)
0
 

Author Comment

by:sprawler
ID: 1348402
hi ...

Tanx ........  I decided to do just that - Use 2.0


Live long & prosper
sprawler
0

Featured Post

Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

In this tutorial I will show you how to use the Windows Speech API in Delphi. I will only cover basic functions such as text to speech and controlling the speed of the speech. SAPI Installation First you need to install the SAPI type library, th…
Hello everybody This Article will show you how to validate number with TEdit control, What's the TEdit control? TEdit is a standard Windows edit control on a form, it allows to user to write, read and copy/paste single line of text. Usua…
Nobody understands Phishing better than an anti-spam company. That’s why we are providing Phishing Awareness Training to our customers. According to a report by Verizon, only 3% of targeted users report malicious emails to management. With compan…
How to Install VMware Tools in Red Hat Enterprise Linux 6.4 (RHEL 6.4) Step-by-Step Tutorial

752 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question