Memo fields in QuickReport

G'day,

The QuickReport Help files say that when you pass a Memo field to a qrdbText component, it stretches the detail band to accomodate all the lines of the memo.

I say this: Crap. It does not.

My problem is that the qrdbtext component will only show the first line of the memo when its autosize property is false, and only shows the first letter when autosize is set to true.

What in QuickReport would cause this if it is not supposed to happen? Has anyone had this problem before?

BadBart.
BadBartAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

fsanchezCommented:
You need to set the AutoStretch property of the QRDBText to True (not the AutoSize). It is working for me (I am currently using the 2.0i version). If you are using an older version may be it won't work. You can download it from http://www.qusoft.no

Good luck
0
Pegasus100397Commented:
BadBart,

I had this same problem awhile back (in Delphi 1.0). If your qrdbText component is truncating the # of lines try this in the BeforePrint() section of the band:

(First determine the # of lines in the memo, use a temp memo object or something to get a count, in this example Memo1)

qrdbText1.Height := Memo1.Lines * 12 {If each line is 12 units high}
If qrdbText.Height < 12 then qrdbText.height := 12 {if no lines,then default to "normal" height. }

This should take care of the growing/shrinking height problem of the band, just make sure the length of the field is enough to accomidate the longest line.

Hope this helps & good luck with your project :)
Pegasus



0
BadBartAuthor Commented:
When I change the height of the QRDBText component, it still does not display more than one line of the Memo. I tried setting the QRDBText height and the Band height at 100 during design time and it still won't diaplay the rest of the Memo.

Could it be something else?
0
Cloud Class® Course: Python 3 Fundamentals

This course will teach participants about installing and configuring Python, syntax, importing, statements, types, strings, booleans, files, lists, tuples, comprehensions, functions, and classes.

BadBartAuthor Commented:
Sorry, but I think it's something else. Something to do with the data source it comes from, perhaps?

0
BadBartAuthor Commented:
I'm using QuickReport version 1, Delphi version 1, and paradox tables. I have noticed that the QRDBText fields used to display the entire memo in every QRDBText field there is in my project. But now they don't in any of them.

Is there some setting that makes paradox tables incompatible
with QuickReport, or something like that? What is going wrong?
0
ZonnaldCommented:
I don't know about QRDBText fields but I find the QRMemo field works just fine - by setting the QRMemo field during the detail bands BeforePrint method as such :

QRMemo1.Lines.Clear;
QRMemo1.Lines.Add(tblBOFQ.fieldbyName('Description').AsString);
QRMemo1.Wordwrap := True;

Did this in D1 /QR1 and still works in D3/QR2.XX
Where the table field is a MEMO, everything works great.
I don't use autostretch or autosize because they may mess up the band and if the user needs it larger then I can easily update the report.

Is there any reason that you are using the QRDBText field (other than the obvious datalink that it gives you?).

Any how try this - good luck

Zonnald


0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Delphi

From novice to tech pro — start learning today.