[Webinar] Streamline your web hosting managementRegister Today

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 183
  • Last Modified:

MS-DOS Compatibility Mode

My system is running its virtual memory by using MS-DOS compatibility mode. How can I change it to use 32-bit access? How can I determine which drivers are using MS-DOS compatibility?
0
ekrisch
Asked:
ekrisch
  • 2
  • 2
  • 2
  • +1
1 Solution
 
smeebudCommented:
Go to System Properties...Performance Tab....Virtual Memory Button... and then report back comprehinsively as to what is set, what boxes are checked.
Open your system.ini to the [386Enh] section. You should have a line that reads as below; If not, add that line, reboot and report the results.
32BitDiskAccess=ON

0
 
dew_associatesCommented:
Ekrisch: I presume you mean that windows 95 is accessing your hard drive via ms-dos compatibility mode. If this is the case, the following are the normal reasons for that occurring.
 - An "unsafe" device driver, memory-resident program, or virus
   hooked the INT21h or INT13h chain before Windows 95 loaded.
 
 - The hard disk controller in your computer was not detected by
   Windows 95.
 
 - The hard disk controller was removed from the current configuration
   in Device Manager.
 
 - There is a resource conflict between the hard disk controller and
   another hardware device.
 
 - The Windows 95 protected-mode driver is missing or damaged.
 
 - The Windows 95 32-bit protected-mode disk drivers detected an
   unsupportable configuration or incompatible hardware.
 
Let us know!
0
 
John_CCommented:
If your virtual memory is not using 32-bit access, then it probably means that you are running a hard drive that uses a DISK MANAGER.  This disk manager is commonly used for hard drives that are installed on older PCs whose BIOS cannot recognize the entire hard drive size without using such a utility.

There are two options.  One, go to the home page for that brand of hard drive and make sure you have the most recent version of disk manager for that particular drive.  If not, download it and use that.  You may have to start from scratch and re-install your stuff.  Option two is to simply partition your drive to smaller partitions.  Make sure that each partition is less than 540 MB.  These two options should get you 32-bit access on virtual memory.
0
Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
dew_associatesCommented:
Ekrisch: What type of computer do you have, how many hard drives and what are they (eg: manufacturer and size)?
0
 
smeebudCommented:
ekrisch, haven't heard from you.
With all due respect to John C, be very carefull using Disk managers.

0
 
John_CCommented:
Smeebud makes a good point.  You don't want to use a Disk Manager as much as possible.  But unfortunately, older systems can't see the entire Hard drive space without using one.  And sometimes the Disk Manager that the hard drive comes with basically is what causes your virtual memory to run at 16-bit access.  I have encountered this with a 850MB Maxtor hard drive which I was running on my 486-66 before I eventually upgraded to Windows 95.
0
 
GeneMCommented:
I had the same problem.  I solved it by reinstalling Win95.
0

Featured Post

Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 2
  • 2
  • 2
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now