Solved

Strange Decompression TEMP Dir problem

Posted on 1997-10-31
53
574 Views
Last Modified: 2013-12-29

Difficult question.  Internet search and no luck.  Getting
error:

The decompression of %s failed.  There may not be enough
            free space available in the TEMP directory.

Problem prevents me from decompressing uncompressable *.exe
           files (tried multiple) begin decompressing into
           the C:\Windows\Temp directory, but fail after
           partially decompressed.  The problem exists on
           two Win95 OEM 2 machines.  Description of
           machines below.

Things I've tried:
        1.  Verified TEMP and TMP variables were set
              correctly in C:\autoexec.bat and autoexec.dos
              files to be SET TEMP=C:\Windows\Temp and the
              environment sees them when typeing SET command
              with no options.
       2.  Cleaned out C:\Windows\Temp directory...which
              exists.
       3.  Verified that files like UnWise or Uninst
              or Uninstall on the machines don't exist and
              do not have bad permissions...based on a hint.
       4.  Did scandisk on both almost unfragmented
              machines.
       5.  Closed off running programs.

Machine 1:   Completely new/clean machine. Little software.
             Just put OS on it.  Not even a browser yet.
        - 200Mhz Pentium Pro
        - Machine 3 Gb free harddrive space
        - 128MB RAM
        - Elsa Winner Pro video card

Machine 2:
        - 233 Mhz MMX
        - 2 Gb free space
        - 64 Mb SDRAM
        - Verge S3 Dx video card

Never had this problem with Win95 OEM 1.  Making both
 almost useless.  Thanks for your help.

JohnE
0
Comment
Question by:johnike
  • 22
  • 16
  • 9
  • +3
53 Comments
 
LVL 4

Expert Comment

by:johnt082197
ID: 1699188
Sorry: It's a bug with install shield. It happens on some machines. I'd like to know if someone knows how to fix this, though :)
0
 
LVL 14

Expert Comment

by:smeebud
ID: 1699189
Try creating another temp.
C:\TMP OR TEMP
SET TEMP=C:\TMP along with your other temp directory.
Rem the windows\temp to see what happens.
0
 
LVL 25

Expert Comment

by:dew_associates
ID: 1699190
John: What is the name of the file your trying to decompress, and is it part of a package of disks, cd rom or a downloaded file?
0
 

Author Comment

by:johnike
ID: 1699191
Thanks for comment.  My C:\autoexec.bat has nothing in
it except
            SET TEMP=C:\Temp
            SET TMP=%TEMP%

I removed the C:\Windows\Temp directory and rebooted.
Same exact problem.  For each attempt it placed a ~exb0000
temporary folder in C:\Temp with a data.z file in it both of
size 3,289KB.  Trying with a different uncompressable *.exe,
it died as usual 94% complete with same error creating a
third temp folder ~exb002 and Data.z of size 19,360KB.
How strange the size difference.  Don't know what to do :(
Thanks for help.

0
 
LVL 14

Expert Comment

by:smeebud
ID: 1699192
Have you tried uncompressing from Real Dos Mode?
Not a windows dos screen?
0
 

Author Comment

by:johnike
ID: 1699193
Good try with the Real Dos Mode.  No go.
unzipping winbench says:
          "This program cannot be run in DOS mode.
Still no go.
0
 

Author Comment

by:johnike
ID: 1699194
Tried something new based on help in discussion group and it
failed to.  Person felt it might be because of Video card
driver and told me to run machine in Windows safe mode and
try to decompress.  Imagine this...still no go.

I appreciate everybodies responses though.  I am a C++/UNIX
developer and know this is often the only way to get to root
of problem.  Left message on installshield home page, but they
don't have good support unless have customer Id.  Grrrr.

0
 
LVL 14

Expert Comment

by:smeebud
ID: 1699195
How about Downloading another (same file). Perhaps the one you have is corrupt?
Can you uncompress any other zipped file without problem?
0
 
LVL 25

Expert Comment

by:dew_associates
ID: 1699196
John: Are you trying to decompress the downloable version of Winbench? If so, don't waste your time, it has a problem. We finally ordered the cd's and there's been no problem since.
0
 

Expert Comment

by:odedn
ID: 1699197
i had the same problem with two diferent files , i tryed to it on 5 diferent machines and still the decompresion failed.
im starting ti belive the problem is in the files and not the machine.....
0
 

Expert Comment

by:odedn
ID: 1699198
i had the same problem with two diferent files , i tryed to it on 5 diferent machines and still the decompresion failed.
im starting to belive the problem is in the files and not the machine.....
0
 

Author Comment

by:johnike
ID: 1699199
I've tried to uncompress over 4 different programs including
Netscape Communicator 4.03.  They have been downloaded from
the internet, but have succeeded to be uncompressed in both
OEM 1 machines, but not in either OEM 2 machines.  They
get variable way through decompression before dying, but they
all die.
0
 

Author Comment

by:johnike
ID: 1699200
I'm upping the points ;)
0
 
LVL 14

Expert Comment

by:smeebud
ID: 1699201
I see you have 128mg Ram. Still when you 1st boot open MSINFO andnsee how you memory is immediately after boot. It sounds like memory to me. Go you have a permanent Swapfile.
Try this. If you don't like it it can all be undone.
---------
Before you make these changes do a "Before" find *.dll and time it, then after you make them do the same search and see the time difference.
-------------
This covers Fixing "Windows95 seizing", "Lots of HD Activity"
and Optimizing "General Windows Performance" because of
random, pointless disk activity. This is due to the way that
Windows95 is set to handle disk caching and virtual memory.
Although Windows95 instructs you to "let Windows handle disk
cache settings" for best results, this obviously does not yield the
best results. Here's how to eliminate the random disk activity and
improve system performance:

Part One: Virtual Memory
1. Right click on My Computer, and select Properties.
2. Click the Performance tab, and then click Virtual Memory
3. Choose Let me specify my own virtual memory settings.
4. If you want to choose a different drive for your swapfile, run
Disk Defragmenter first.
5. Specify the same value for the Minimum size and the Maximum
size, so Windows95 won't spend so much time re sizing the file. A
good size is roughly 2 1/2 times the amount of installed RAM (i.e.
create a 40MB swapfile if you have 16MB of RAM).
6. Press OK, and then OK again, and confirm that you want to
restart your computer.
Note: if you have Norton Utilities, you'll be able to optimize the
swapfile. If you want to take the time, you can optimize it manually
by exiting windows, deleting the swapfile, defragmenting the drive,
and restarting. Once you've set the swapfile size to be constant,
you won't have to worry about a defragmented (broken up)
swapfile again.
"The advantage of this process is that Win95 doesn't waste CPU
cycles downsizing the swap file to its auto-set-minimum. Downsize
waste doesn't happen unless enough applications are loaded and
then closed which exceed that minimum. This will be a
low-probability situation if you set the minimum swap file
properly."

Part Two: Virtual Cache
1. Open SYSTEM.INI for editing.
2. Add the following two lines to the [vcache] section (add the
section if it's not there):

[vcache]
For 16mg
MinFileCache=4096
MaxFileCache=4096
 
[vcache]
For 32mg
MinFileCache=8192
MaxFileCache=8192

3. These values, in kilobytes, regulate the size of the VChache, so
you can stop it from filling up all available RAM and paging all
loaded apps to disk.

Here are several little modifications you can make to improve
Windows95 performance:

Speed up system restart:
1. Add BootDelay=0 to the [Options] section of C:\MSDOS.SYS
Speed up the Start Menu:
2. In the Registry Editor, go to HKEY_CURRENT_USER\
Control Panel\ desktop, and add a string value named
MenuShowDelay, with a value specifying the number of
milliseconds (400 is default, smaller numbers are faster).
           Set Your Computers Typical Role!
By making a few little tweaks to Windows 95's Control Panel
settings, you can realize some big performance gains.
Start by double-clicking on the Control Panel's System icon, then
clicking on the Performance tab. Next, click on the File System
button. You'll see two settings in the resulting Hard Disk dialog
box:
The setting labeled Typical Role of This Machine determines how
much space is set aside in main memory to handle path and
filename caching. The default Desktop Computer choice allocates
space for a paltry 32 paths and 677 filenames, whereas the
Network Server choice bumps those settings up to 64 paths and
2,729 filenames.
Even if your computer is used strictly for desktop applications,
change the Typical Role box to Network Server. Unfortunately, if
you're using the original release of Windows 95--not the recently
updated version titled OEM Service Release 2 (OSR2)--you'll
have to take an additional step to correct a bug in the Windows 95
Registry. Use the Windows 95 Registry Editor (see "Rule the
Windows Registry" for an introduction to the Registry Editor) and
change the value of HKEY_LOCAL_MACHINE\SOFTWARE\
Microsoft\Windows\CurrentVersion\FSTemplates\Server\
"NameCache"=hex:a9,0a,00,00 "PathCache"=hex:40,00,00,00
And Make that same change at:
[HKEY_LOCAL_MACHINE\System\CurrentControlSet
\control\FileSystem]
"NameCache"=hex:a9,0a,00,00 "PathCache"=hex:40,00,00,00
The Read-Ahead Optimization slider establishes how much
additional data Windows 95 should fetch every time you retrieve
data from your hard disk. Read-ahead buffering improves
performance by reducing the number of times your machine has to
go out to the relatively slow hard disk to get data. Set the slider all
the way to the right, giving Windows 64K of read-ahead buffering.

Next, click on the CD-ROM tab in the File System
Properties box. The Supplemental Cache Size slider adjusts the
room Windows 95 sets aside for read-ahead buffering of your
CD. The first three steps on the slider add 64K or 128K each to
the cache; the final three steps add 256K apiece. The box labeled
Optimize Access Pattern For doesn't control access speed to your
CD; the setting's real function is to reserve even more buffer space
for caching CD reads. The Single-Speed Drives and No
Read-Ahead settings don't increase the buffer size. But the
double-, triple-, and quad-speed settings add 50K, 100K, and
150K of cache, respectively.
If you use your CD drive frequently, move the Supplemental
Cache Size slider to Large, and specify that you have a Quad
Speed or Higher CD, even if you don't. The combination will set
aside about 1.2MB for CD caching, and ensure that your CD will
run as fast as possible.

More free memory in DOS windows:
1. Add LocalLoadHigh=1 to the [386Enh] section of
SYSTEM.INI. -
Warning: this may cause unpredictable results if you are not using
the EMM386 memory manager.
Remove DoubleSpace/DriveSpace from memory:
2. Whether or not you're using the DoubleSpace/DriveSpace disk
compression utility, these drivers are taking up valuable memory
and slowing system startup.
3. Simply delete DRVSPACE.BIN and DBLSPACE.BIN from
C:\ and your Windows\Command directory. Note: do not do this if
you are currently using DriveSpace or DoubleSpace to compress
your hard disk!!
Load DosKey in a DOS box automatically:
4. Right-click on DOSPRMPT.PIF (in your Windows directory),
and select Properties.
5. Click on the Program tab, and enter "DOSKEY" in the field
labeled Batch File. (FYI, I use Keyboost, an antique version of
DOSKEY)
6. Note: for more information, see Contents of the Windows95
MSDOS.SYS File.
Note: some of these settings can also be changed with TweakUI,
one of Microsoft's PowerToys. Warning: several users have
reported problems with this utility - use with caution.
0
 
LVL 25

Expert Comment

by:dew_associates
ID: 1699202
John: What anti-virus programs are you running?
0
 

Author Comment

by:johnike
ID: 1699203
You are going to hate this answer smeebud:  It didn't work.

I tried all you requested on 128Mb SCSI machine (other not SCSI).
Windows shows I have 132 Mb memory.  I set virtual memory size
to be 320 Minimum and Maximum (2.5 * 128Mb).  I did not know
where the swapfile was to delete it in dos mode before disk defragment.  Maybe you could let me know this...didn't figure
it would stop test.  Then I added two lines in SYSTEM.INI file
setting MinFileCache=32768 and MaxFileCache=32768  
(since 8192 * 4).  I rebooted system and all came up well.
Tried to uncompress and BOOM,  all InstallShield programs still
died at their same locations.  I will play with other options
you in text you gave me, but don't think they would prevent
files from uncompressing.  Terrible having both lovely machines
both somewhat out of commision.  Never had InstallShield on
other machine sitting here.  Still works on that OEM 1 machine.
Don't understand.

In regards to dew_associates, I just ran a slightly older version
of McAfee on the machine and it found nothing wrong.  If I
weren't crying so hard, I would be laughing at this point.
Owe you all a beer :)      ...but maybe not yet.

Thanks for continued advice.  I am learning interesting things as
we go.

JohnE
0
 
LVL 7

Expert Comment

by:busuka
ID: 1699204
Hey guys, I have one small but interesting thing: what differs
OEM2 (or OSR2 :) from OSR1 ? BUSMASTER DRIVERS by default.
I have my own wild guess: try to play first in Device Manager -
- HD controller (or HD's) - DMA checkbox.
If this not helped try to change busmaster drivers to standard
ones (remove HD controllers and rerun Win95, then install 'from
compatible ...' standard drivers (dual fifo))

NOTE: Backup your registry first !!!
0
 
LVL 14

Expert Comment

by:smeebud
ID: 1699205
busuka has a (stroke of genious) idea.
Let us know if CDROM parameters are REM'd in config.sys,
and if you BOOTGUI or to a C:\>
0
 

Author Comment

by:johnike
ID: 1699206
Excuse my lack of knowledge all.  I am a true certified UNIX
geek, but only have a medium knowledge of Win95 internals.
I need a little more step by step in this situation as I am
afraid I will goof up the computer...don't want to guess.

I do boot the computer up into Win95 graphical interface
automatically.

I can give some information:
Machine 1:  IDE controller having the following line only in
         the config.sys file and nothing in the autoexec.bat:
                  DEVICE=C:\CDPRO\VIDE-CDD.SYS /D:MSCD001
         This machine has:
               Creative Labs IDE controller
               Intel 82371AB PCI Bus Master IDE Controller
               Primary IDE Controller (single fifo)
               Secondary IDE Controller (single fifo)
          Generic Disk Types.

Machine 2:  SCSI controller using the EZSCSI having nothing
         in config.sys or autoexec.bat.  This machine, however,
         does have the Plextor Manager 96 driver installed.
         I could update this driver.
         It uses the Adaptec AHA-2940U/AHA-2940UW PCI SCSI                Controller (as expected) in the Controller section.
         The backup ARCHIVE tape drive (Python) is not set up
         yet.  The Hard Disk Controller is set up to be the
         Intel 82371SB PCI Bus Master IDE Controller, with
         Primary IDE controller (Dual fifo) and Secondary IDE
         Controller (dual fifo).  This SCSI machine has two
         Quantum 4.* Gb hard drives.

Actually both autoexec.bat filed have TEMP and TMP variable
        settings.
As you can see they are fairly different machines.  One was
        originally set up to be a Server and the other a desktop.

You are all amazing with this stuff.  I appreciate your help.
Apparently this isn't a common nor obvious problem.

JohnE
0
 
LVL 25

Expert Comment

by:dew_associates
ID: 1699207
Actually John, the problem you describe is more common than you think, however it more hardware related than windows necessarily. In any event, this is what the bus mastering controller identity should look like if installed properly.

Intel PIIX/PIIX3 Bus Master IDE Controller
Primary IDE Controller
Secondary IDE Controller

If you don't mind, in the interest of clarity, let's deal with one machine at a time, using the first one you noted. The fixes will become complex and there's no need to muddy the water bouncing from one to the other.

1. What make motherboard and chipset (eg: TX, HX, FX etc)

2. Have you downloaded and installed any Intel bus mastering drivers? If yes, which one's and where did you obtai them?

3. You state that your using OSR2 for the install on this machine, do you have the supplement to OSR2 for the various chipsets and USB?

4. There's two ways to approach this, one is easier than the other from a techinical standpoint and both require info on the system. System #1 has a creative labs sound card installed with a bus for the cd rom drive I presume. This sometimes confuses even OSR2. Post the info requested for the first machine and I'm sure we here can walk you through the fix.
Best regards,
Dennis
0
 
LVL 14

Expert Comment

by:smeebud
ID: 1699208
Johnike,
I'm gonna be brief, as to not get issues confused.
Would you REM the DEVICE=C:\CDPRO\VIDE-CDD.SYS /D:MSCD001
statement, re-boot and check your memory. Then try to uncompress.
What kind of archiving utilities are you using.
0
 

Author Comment

by:johnike
ID: 1699209
Will do Dennis.  Machine 1 is a Pentium 233 MMX TX chipset.
It does have a Sound Blaster 32 AWE soundcard which I will
later move to Pentium Pro (Machine 2) once it is set up
properly (hope this doesn't goof us up).  I have 24X CD ROM
on the machine. This machine is new and came with a disk
marked "m 550 TX IDE Driver."  I don't know what version.
It came pre-loaded and with little documentation.  It does
have installed Service Pack 1 (don't know if this makes sense)
and my other machine does not. I have personally loaded no other
drivers though the S3 Verge DX video card driver is loaded.
Surprised this is fairly common...did massive internet search
with no luck...usually this gets me by.  With Microsofts changed
support section, I had harder time locating usual resources.
:), JohnE
0
 
LVL 14

Expert Comment

by:smeebud
ID: 1699210
I tid-bit, usually for lockups, but also concerns all anomalies,
----
The retail release of Windows 95 does not properly support some MMX
instructions if they are called from a device driver or from
program code running in protection level 0 (Ring 0, also known as
privileged or Kernel mode). If these instructions are issued while
the processor is operating in Ring 0, a GP fault or other serious
error may occur.

STATUS

Microsoft has confirmed this to be a problem in Microsoft Windows
95. An update to address this problem is now available, but is not
fully regression tested and should be applied only to computers
experiencing this specific problem. Unless you are severely
impacted by this specific problem, Microsoft does not recommend
implementing this update at this time. Contact Microsoft Technical
Support for additional information about the availability of this
update.
0
 

Author Comment

by:johnike
ID: 1699211
HeHe...this is getting downright agravating.  Hate having to
ask others for help...but appreciate it.

On the 233 MMX, I commented out the:
           DEVICE=C:\CDPRO\VIDE-CDD.SYS /D:MSCD001
Machine booted up fine and tried to uncompress.  No go.
On the 233 MMX machine I have WinZip (none on P-Pro machine)
but am trying to uncompress *.exe InstallShield files.  Since
most files seem to come this way, I can not get systems kicking.
Actually I can uncompress the files via network over the old
OEM 1 machine.   But I am loosing this machine shortly and will
be caught with no way to load new software.

Should I try the Ring 0 patch above?  I don't think that is it
as the P-Pro has same problem and it mentions that it is for MMX.

Though I shed a tear in one way (this not working), I am very
happy that all 3 machines are running much faster.  ;)

JohnE
0
 
LVL 14

Expert Comment

by:smeebud
ID: 1699212
If you're not getting any other problems with the MMX, i would not patch it. You can if you have not already unrem your CD statement. That was a Busmaster test. If it went into windows alright chanches are your bus mastering driver is alright.

How do you fell about removing Winzip for a while and using PKZIP. Just a test. I did a search for your error message and foung 528 articles in scattered newsgroups so you're not along.
Same problem, many different kinds of systems. I think it's related to winzip because (just a hunch) it does use temp directories unlike some other archive programs.
It would be a test that could not hurt anything, but rather eliminate a possability.

0
 
LVL 25

Expert Comment

by:dew_associates
ID: 1699213
John, I understand your reluctance to ask, believe me I do! But sometimes OEM and MS support is so lacking, there's little choice than to ask those that have been there.

In any event, here's my suggestion for machine #1, the 233MMX machine. On the surface it's going to seem like the long way around, but when you think about the time used to track down every possibility, the "long way" gets shorter. With this in mind, here's my suggestion for machine #1.

1. Create a bootable floppy disk and transfer the following files to it:
HIMEM.SYS
MSCDEX.EXE
EDIT.COM
FDISK.EXE
FORMAT.COM
AUTOEXEC.BAT
CONFIG.SYS
*********.SYS (your cd rom driver)

2. Make sure that you have the OSR2 floppy disk, the OSR2 CD Rom disk and a floppy containing the 2.1 OSR2 update supplement. If you don't have the supplement, let me know and I'll point you to where you can obtain it. Also have the cd rom disk with the TX drivers handy.

3. Open the machine and pull the AWE 32 that your going to move anyway. Put the CD Rom drive on either IDE Bus #1 as a slave or on IDE Bus #2 as a master (assuming there isn't a hard drive already there). If your going to use a sound card, install the one your going to use and let us know what it is. If no sound card, let us know! Preferably, to get things running, leave the card out from now, we want a basic system. If there are any other cards other than video, remove them as well. Modems etc can be added later.

4. Using the small diskette from the Windows 95 OSR2 packet, boot to the OSR2 floppy, fdisk the hard drive, reset the partition as necessary and format the drive, transferring the system files as necessary.

5. Transfer Himem.sys as well as your other files from the floppy you made earlier. Setup your config.sys with Himem.sys and cd rom drivers and then reboot the system. Check to verify that you have access to the CD Rom drive. (Himem.sys is required in order for scandisk to run prior to the OSR2 install)

6. Install OSR2 and select the custom install. As you pass through the setup stages, choose carefully the components that you want to install.

7. After you have restarted the system after the install (windows first restart) rebbot the system again to make sure that windows has found everything. Go to control panel, system icon, device manager and check to see if there are any conflicts.  Put your TX chipset cd rom disk in the drive.

8. While in device manager, scroll down to the ide bus and expand it. In device manager, for the Intel chipset, click the change driver button and point it to the driver on the cd rom disk. (NOTE) of the cd rom has an auto install for these drivers, use it but note where they are installed. IF it installs the drivers, they should be in the \windows\system directory, therefore when you change the driver you can point windows to c:\windows\system and it should find the driver.

9. This won't make sense, but it works. After installing the drivers, go back to the device list, expand it again if need be and then remove the IDE BUS entries. This may freeze the system, but just reset it. During the reboot, windows should find the Bus devices as well as the new drivers. If windows asks for the drivers, point it to c:\windows\system.

10. You may have to reboor 3 times in order for windows to fully load the IDE Bus correctly. Check device manager again and make sure that the IDE Bus had installed properly. If so, then go on.

11. At this point, install the OSR2 supplement. Reboot the system. This should cause windows to find the remainder of the TX chipset functions. You may have to again point windows to c:\windows\system for the files it needs.

12. Again reboot. Your system should now have all of the components for the bus and TX chipset support installed without any conflicts in device manager.

13. Add back your sound card if one is to be installed, installing it's drivers as necessary from the software supplied with it. If you want to use the creative labs bus for the cd rom, fine, but you really do not need to. When the ide bus shows up for creative in device manager, just disable it within device manager.

14. Add back any other peripheral cards such as modems, network cards etc and install their drivers. After a reboot and confirmation that the hardware is installed and no conflicts in device manager, you should be able to add any additional software including those with installshield without a problem.

If you have a question, please let us know!

Best regards,
Dennis
0
Free book by J.Peter Bruzzese, Microsoft MVP

Are you using Office 365? Trying to set up email signatures but you’re struggling with transport rules and connectors? Let renowned Microsoft MVP J.Peter Bruzzese show you how in this exclusive e-book on Office 365 email signatures. Better yet, it’s free!

 

Author Comment

by:johnike
ID: 1699214
Wow...building it from scratch.  If I have to do it, then I
must.  The only thing I am nervous about is moving the CD ROM
to different bus...never did that before and the mother board
did not come with a manual.  I will try what you say,
but expect it to take a couple hours (probably tomorrow night).
I don't have the 2.1 OSR2 update suplement and didn't see it
on Microsoft sight (must have missed it).  Maybe you can point
me in right direction.  Maybe supplement will resolve the
problem.  I will have to transfer off personal files first
and get connection to internet via other computer...no big deal.
It will be done.  If have details about switching IDE BUS, let
me know.  I will take off sound blaster 32 AWE and put in an
older straight Sound Blaster 16 bit after all is done.

The 233MMX has Winzip, but the P-Pro has no compression software
on it at all and still fails.  Funny thing, they both fail at
exactly the same points in exactly the same way.

I will wait for a response...about the controllers.  Hope this
all works.

And I used to think UNIX was complex...HeHe...nothing compared
to windows 95 :)

0
 
LVL 7

Expert Comment

by:busuka
ID: 1699215
I think I got it !!! Everyone here can remember conflict between
busmaster drivers and SB. I personally ate this. Trying to
install busmaster drivers for 82437SB (PIIX3) and having SB 32
PnP card I got permanent 'Protection error' upon reboot. So I,
and this is my suggestion, returned to standard HD controller
drivers. Remove busmaster drivers.
I don't remember address on Intel site, where this was discussed
so maybe wise ones will put address here :)
0
 
LVL 25

Accepted Solution

by:
dew_associates earned 200 total points
ID: 1699216
Okay John, here goes. I have posted this as an answer, however you may feel free to reject it in the event it does not solve the problem.
================
1. The site for the OSR 2.1 supplement can be found at:

http://hppc920.external.hp.com/cposupport/personal_computing/software/waex1us.exe.html

2. As for moving the CD Rom ribbon cable, there should be two IDE buses on your motherboard, IDE #1 and IDE #1.

The edge of the ribbon cable should have a thin red stripe signifying that pin #1 is at that end. Look at how your hard drive is connected to the motherboard for an idea as to where pin one is for IDE Bus #1 and insert the cd rom cable in bus #2 the same way. Bus #2 should be clearly marked. If you have a question, just ask. Check the back of the cd rom drive and you should see a pin arrangement to pin it as a master or slave drive. If it's the only drive on the bus, pin it as a master. NOTE: Sometimes some of the cd rom drives (non-atapi) do not report themselves correctly, to cure this if it occurs, change the pin arrangement to slave, even though it may be the only drive on that IDE bus.

3. IF for some reason (an I doubt this is the case) your motherboard does not have a secondary IDE Bus ( and if device manager reports it, it should be there) you can make the cd rom drive a slave on the same bus with the hard drive. If you look at the ribbon cable connected from the motherboard to the hard drive, on the end where the hard drive is, there should be an empty connector on the ribbon cable in between the hard drive and the motherboard. Pin the cd rom drive as a slave and connect it to the empty connector on the ribbon cable, in the middle between the hard drive and the motherboard.

4. Do not install the sound card until you have installed the bus mastering drivers and have checked that they are installed without a problem in device manager. Next, install your video card and make sure they install correctly. Then proceed in order installing the sound card, modem and anything else in that order.

When your installing software drivers, especially those that update windows 95 files, it may help you each time prior to loading the drivers, that you use the "ctrl"  "alt"  and "del" keys and open the "close programs" dialogue box and close all running programs EXCEPT for "Systray" and "Explorer". Note, on a fresh Windows load in, Systray may not be there early on and there may be nothing in the system tray that windows has to be concerned with.

If there are any questions what so ever, please post them. If you have a problem during the reinstall, stop where you are and post what has occurred here since I note that you will have access through another computer.

Best regards,
Dennis
0
 

Author Comment

by:johnike
ID: 1699217
You are amazing Dennis.  I am in process of setting up for
reinstall.  It may take me a few days as I am busy Tues/Thurs
night.  Last night I downloaded OSR2.1 from some other sight
as the link must have changed on the hp sight and I could not
find it there...but I do have it and other upgrades ready.
I am setting up other machine (P-Pro) with access to internet
as well as copying files.  As I will need a few hours solid time,
I can not guarantee I will get through all this until weekend.
I will do it minimally then though.  Don't forget about me as I
guarantee there may be a question or two...or three...hehe.
My 233 MMX machine (one being reinstalled) did not come with
much (hardly any documentation) and I don't know pin arrangement
for the 24X CD ROM.  I may have to hunt this down.  I will try
the upgrade first then try reinstall.  I will grade your answer
when this is completed...though you are doing amazing to help
me...I do owe you a beer.  Again I will leave updates/results
and will probably work on this Friday/Saturday.

JohnE
0
 
LVL 14

Expert Comment

by:smeebud
ID: 1699218
Great answer Dew. I'm just hanging around to see what happen.
This then would probably not be a memory issue as I thought eariler, right?
0
 
LVL 25

Expert Comment

by:dew_associates
ID: 1699219
John: Let me know what brand and model of CD Rom and I'll post the pin arrangements for you.

On the USB site address, I screwed up, here's the correct one for anyone who needs it.

http://hpcc920.external.hp.com/cposupport/personal_computing/software/waex1us.exe.html

Bud: Although I never rule out memory issues, I've seen this same problem because of the HX, TX, FX and now the LX chipset and bus mastering. If all of the drivers are not setup properly (and not done in the correct order) Windows 95 tends to have you looking all over the place for hardware and software problems only to learn that it's because of the chipset and/or bus mastering. Aside from the obvious bus problems, the wrong chipset driver causes shadowing of IRQ's and DMA's that Windows 95 cannot recognize, therefore it doesn't report it. I first learned of the problem when I had a system that I couldn't get a mouse to work in any configuration and the 2nd IDE bus wouldn't work with any drive as a master. It took me days to find out that OSR2 wasn't loading the correct driver for the chipset which created a shadow on IRQ 12 and 13, mouse and ide bus.
0
 

Author Comment

by:johnike
ID: 1699220
Dennis...

You are going to kill me.  I can't get Netscape loaded
(uncompressed) on other machine so will lose access unless I
take care of that machine first.  We were going to shoot for
it anyway, do you mind earlier rather than later?

It actaully confuses me on how different the two machines are and
they both have exactly the same problem (coincidence???).
Strange since two different VARS set them up and sold them.
In a way this machine should be easier since it is not my home
machine and I have MUCH more information on individual hardware
as shown below.

The config of this machine follows:
     S1662 Dual Pentium Pro (1 CPU now) 440 FX PSI-ISA Board
                      8500 TVD Pentium VX System Board
     128MB FPM 60ns, Parity
     Adaptic 2940UW PCI-to-Fast SCSI Host Adapter
                      I have latest EZ-SCSI to support this.
     Two Quantum Atlas 4.2GB Fast/Wide SCSI III, 8ms, 7200 RPM
     Plextor 8X CD ROM Drive (may need proper settings)
     3COM 10BT Ethernet board (local lan)
     Connor 4Gb turboDAT, SCSI, 4mm, 1BM Buffer tape backup
     Zyxel Elite 2864IU 28.8/ISDN modem
     ELSA Winner 2000 Pro/X, PCI, 4MB RAM
     No Audio

If no input, I will resort to trying reload on primary machine.
I still understand the direct relationship between InstallShield
particulars and why it has hard time with TEMP directory.  No
other program has this problem.  I got a later version of virus
check and their are no problems.  There are no disk problems.
Other than InstallShield, the machines are running perfectly...
except I can't install much useful software :(.

Oh well, could you outline specific steps if different for this
new machine above and any particulars on hardware settings.
Remember I am somewhat the novice with hardware beyond putting
in a new video card.

I owe you two beers by this point(we'll leave first born daughter
out of this...hehe).

JohnE

0
 

Author Comment

by:johnike
ID: 1699221
Dennis...

You are going to kill me.  I can't get Netscape loaded
(uncompressed) on other machine so will lose access unless I
take care of that machine first.  We were going to shoot for
it anyway, do you mind earlier rather than later?

It actaully confuses me on how different the two machines are and
they both have exactly the same problem (coincidence???).
Strange since two different VARS set them up and sold them.
In a way this machine should be easier since it is not my home
machine and I have MUCH more information on individual hardware
as shown below.

The config of this machine follows:
     S1662 Dual Pentium Pro (1 CPU now) 440 FX PSI-ISA Board
                      8500 TVD Pentium VX System Board
     128MB FPM 60ns, Parity
     Adaptic 2940UW PCI-to-Fast SCSI Host Adapter
                      I have latest EZ-SCSI to support this.
     Two Quantum Atlas 4.2GB Fast/Wide SCSI III, 8ms, 7200 RPM
     Plextor 8X CD ROM Drive (may need proper settings)
     3COM 10BT Ethernet board (local lan)
     Connor 4Gb turboDAT, SCSI, 4mm, 1BM Buffer tape backup
     Zyxel Elite 2864IU 28.8/ISDN modem
     ELSA Winner 2000 Pro/X, PCI, 4MB RAM
     No Audio

If no input, I will resort to trying reload on primary machine.
I still understand the direct relationship between InstallShield
particulars and why it has hard time with TEMP directory.  No
other program has this problem.  I got a later version of virus
check and their are no problems.  There are no disk problems.
Other than InstallShield, the machines are running perfectly...
except I can't install much useful software :(.

Oh well, could you outline specific steps if different for this
new machine above and any particulars on hardware settings.
Remember I am somewhat the novice with hardware beyond putting
in a new video card.

I owe you two beers by this point(we'll leave first born daughter
out of this...hehe).

JohnE

0
 
LVL 25

Expert Comment

by:dew_associates
ID: 1699222
John: You have no clue what your getting into. You thought the other machine was involved, wait and see what's posted later. BTW: I've got to lay out the reply on a word processor for that so I don't inadvertantly miss something so it will take a few hours. On the Netscape issue, use IE 3.02, the both reside equally well on the same hard drive. In the meantime, I would like you to check 2 things. First, on either machine, boot into the Bios/Cmos setup and double check that antivirus has not been enabled. If it hasn't, then make sure ALL antivirul programs have been disabled, especially in any of your setup files. Lastly, using the  CTRL  ALT  and DEL keys, open the "Close Programs" dialogue box and close everything except systray and explorer and then try and decompress on of the problem files. Before we rebuild a scsi based system over the internet, I want to make sure we haven't missed something trivial.
0
 

Author Comment

by:johnike
ID: 1699223

Though I am highly interested in what you have to write,
it might be best to hold off (only to save you some effort).
I had a strange event today in testing this.  I downloaded the
same version of Communicator again from Netscape last night.
Just finished installing it "successfully" on P-Pro machine.
The old version still will not.  As I copied all the
installshield files from the old Win95 OEM 1 machine where
they successfully uncomressed and didn't on new machines, I am
somewhat confused.  The files copied over correctly (via network)
and scandisk came up blank and no viruses with latest McAfee.
Why did new download work and none of copied files would.
Also the files are of the same sizes between machines.
Strange.   Tonight I will download an assortment of other
installshield programs and see if they uncompress.  Despite
this hope, I am still very interested in what you were going
to write.  I always had a difficult time building a new machine
properly and know when I built the P-Pro, I did not.  I strongly
understand if you don't want to place the effort.  This is
pretty consuming.  Thanks.

JohnE
0
 
LVL 4

Expert Comment

by:johnt082197
ID: 1699224
Check out my first comment. I had said there that it was a bug with Installshield. Sometimes it works, sometimes it doesn't.
0
 
LVL 25

Expert Comment

by:dew_associates
ID: 1699225
John: Even though you may have solved the problem, I'll still layout a procedure for an all scsi system. The only thing that I haven't been able to resolve are two system components that you have listed and whether or not the cd rom drive is IDE/ATAPI or SCSI. If the cd rom is ide, then we have a problem since we cannot disable the ide bus. The components I am having difficulty with are, "S1662 Dual Pentium Pro (1 CPU now) 440 FX PSI-ISA Board" and "8500 TVD Pentium VX System Board". The FX motherboard I follow, but what is the 8500 TVD Pentium VX". Is this from the other system?
================================
Anyway, for the scsi setup, this presumes that the cd rom drive is scsi and not ide.
================================
1. From an existing windows 95 OSR2 computer, build a windows 95 setup disk. Add to the disk a config.sys file that loads Himem.sys and an autoexec.bat file. The autoexec.bat file (for now) need only have a path statement. Copy to this scandisk.exe and edit.com. This is only if there's a problem during setup.

2. Adaptec 2940UW are normally preset to scsi address #7,
verify that this has not changed. Install the Adaptec SCSI card in PCI slot #1.

3. Verify that the first scsi hard drive is set to scsi address #6 and the second hard drive is set to scsi address #5. This will resolve future scsi transfer speeds, although unless both the Adaptec UW and the drives are scsi III, you will only see 20mbs transfer speeds. If all are scsi 3 compliant, you will see transfer rates as high as 40mbs.

4. Verify that the cd rom drive is set to scsi addres #4 and then setup the Conner Tape Backup. Set the SCSI address for this drive at #3. If the tape backup is the last item in the scsi chain, then make sure it is properly terminated (terminator installed) or that its termination can be set with software. SCSI addressing is set in order of priority, 7 the highest, 0 the lowest.

5. Remove all other peripherals from the system, so that you have just the video card, the Adaptec card, the two hard drives, the scsi cd rom drive and the tape backup drive.

6. Although most hard drives leave the factory pre-formatted, it's always a good idea to format them again. Therefore, I'll take you through the sequence entirely.

7. You should have received at least 3 floppies with your Adaptec card and possibly a cd rom disk. Make sure these are available.

8. Put the setup diskette you made earlier in the floppy drive and boot the system into the Bios/Cmos setup. Although based upon the info you have provided I'm not sure which Bios is installed on your system, but the principles are the same.

In the Bios setup, you will need to do the following:

A. Disable the IDE Bus as well as indicate that there are no hard drives installed.

B. You will need to disable completely any references to bus mastering.

C. If you have one of the more recent Bios's installed, then you should be able to setup the boot sequence as "Floppy A", then "SCSI hard drive" and then "CD ROM". Please set them up in that order.

9. Exit the Bios/Cmos setup and save it.

10. As the system begins to boot through, the next item you should see will be the SCSI setup or configuration manager. This will enable you to setup which SCSI hard drive will be the boot drive. Choose SCSI ID #6 for the boot hard drive, and verify that the addresses and LUN numbers shown correspond to all of the drives installed.

11. If everything has been installed correctly, you should see all three devices and be able to partition and format the two hard drives from the floppy disk you received with your copy of OSR2.

NOTE: On some Bios setups, you may have to install Adaptec's EZ-SCSI software before going any further, however the OSR2 install disk normally handles this nicely.

12. You will need to choose between LBA mode or fat16 when using the OSR2 setup. Use LBA mode. Follow the OSR2 sequence completely and load the cd rom drivers for your cd rom. Verify that you indeed have access to it.

13. Load Windows 95 normally and watch the install closely. When asked whether you want a typical or custom install, choose custom, then select the components that you want. Make sure you select the backup utility set, as you will need this later.

14. Once windows 95 has been loaded, make sure there are no conflicts in device manager. There shouldn't be any, and there should be no indication of an IDE Bus or hard drive controller. If you check under disk drives, you should see your floppy and your two scsi hard drives. Under cd rom drives, your scsi cd rom drive should be shown. If this is what you see, then go on.

15. At this point, you should be able to load your EZ-SCSI software package. I believe the latest version is 4.01b. Make sure to reboot your system.

16. Next, add your Video card software. Using the "ctrl"  "alt"  and "del" keys, open the close programs dialogue box and close all running programs except systray and explorer and then load your video software. Verify that it has loaded properly and that there are no conflicts on the PCI bus.

17. You should now be able to install you NIC card (lan network card) without any difficulty. Since you didn't mention whether the NIC was PCI or ISA bus, I can't really go any further with that card.

18. last but not least, install the modem and set it up!

If everything has installed properly, you should have one quick system. Hopefully Windows 98 will enable a HAL layer for the second CPU. If not, there's always NT!

Let us know how you make out!

Best regards,
Dennis
0
 

Author Comment

by:johnike
ID: 1699226
I am trying Dennis.  I managed to get flu and have been in bed
last couple days.  Tried a little today but not much energy.
I got all drivers together and have been reading the Adaptec
manual a little.  I am not sure how to un-terminate my one
Hard drive and terminate the Conner Tape drive.  I have most
else set up but have never done this part before.  It may take
some more time before it is all done.  Can't find book on hard
drives so will have to try to find the information.  Your
description above is excellent and is not the setup the original
ventor placed machine in ...in fact they placed devices in exact
opposite order (the least efficient order).  I will move the
cables around as soon as I figure out their termination.  I will
continue working on this.  Thanks for the education.
I could just close this and keep commenting...you get an "A"
rating...but don't know if this will allow me to keep in touch
with you after closing it off.  I wish I knew where you got
all your info...pretty amazing.

JohnE
0
 
LVL 25

Expert Comment

by:dew_associates
ID: 1699227
John, you can grade this to take it off the daily screen and we can continue by just commenting here. Just let me know what's going on/your progress.
Best regards,
Dennis
0
 

Author Comment

by:johnike
ID: 1699228
Adjusted points to 200
0
 
LVL 25

Expert Comment

by:dew_associates
ID: 1699229
John, you can find the info regarding your hard drives right at the quantum site, www.quantum.com.

I'll be waiting...let's not dog this flu thing to long...at least get some play value out of the time off!
0
 

Author Comment

by:johnike
ID: 1699230
Thanks for your patience Dennis.
Feeling somewhat better today though slept the weekend away.
Machine open in front of me and information right on most
of drives (except Plextor). What a mess, but understand how
it is done now.  Fun actually.  I have come up with a glitch
your statements and wait for response.  I read another document
that agreed with the device ordering for SCSI, but last minute
with drives open, I happened across the small Adaptec Install
Guide.  It reads "SCSI ID 0 is best reserved for the SCSI hard
disk to be used as your computer's boot device and ID 1 is best
reserved for the second SCSI hard disk."  This is opposite of
your statement (saying address 5 & 6) and what this other sheet
said.  If 0 & 1 are correct, then system may have been in correct
order.  No big loss if so, can just put stuff back together.
Awaiting your view and for you to tell me where to send  beer. :)
JohnE

0
 
LVL 25

Expert Comment

by:dew_associates
ID: 1699231
Hi John:  Glad your feeling better!  On the adaptec issue, before the advent of the TX, VX, FX and LX chipsets with pci bus speeds at 50, 60 or 66 (whoa), that was correct. However adaptec has released new geometry with adaptec eszi scsi 4.0b that makes it more efficient when the scsi items are placed (as far as ID and LUN numbers are concerned) closer to the card.
From purely a hardware point of view, either will work as long as the last scsi items in the chain is terminated properly either via hard connector termination or software enabled termination.

BTW: Enjoy your system!  and have a beer on me!

Dennis
0
 

Author Comment

by:johnike
ID: 1699232
Hey Dennis,
Did work on P-Pro today.  Have much of worst part done, but
need your advice on BIOS configuration.  I switched all SCSI
ID's to correct ones and updated the BIOS successfully.  Now
I am trying to disable IDE Bus and Bus Mastering.
I see no references to Bus Mastering and the "IDE HDD AUTO
DETECTION" seems to be set to no.  The only thing I am uncertain
is that under "Integrated Peripherals" the following is set:
        IDE HDD Block Mode:  Enabled
        IDE Primary Master PIO:  Auto
                   other possible settings are  Mode 0 to Mode 4
        IDE Primary Slave PIO: Auto
        IDE Secondary Master PIO: Auto
        IDE Secondary Slave PIO: Auto
        On-Chip Primary PCI IDE: Enabled
        On-Chip Secondary PCI IDE: Enabled
        PCI Slot IDE 2nd Channel:  Enabled

I am currently leaving these settings until you say otherwise.
I did a low level formating of the Primary Hard drive now on
SCSI ID #6 and bios seems to be working correctly.  Wish I didn't
have these questions as I would finish tonight.  Hope you get
this.  As a developer I never crossed this hardware line.  It
has been great fun with the right help.  Thanks Dennis.

JohnE


0
 

Author Comment

by:johnike
ID: 1699233
As further, depressing information, I continued ahead with
install of Win95...successfully...except that upon looking
at the Hard Driver Controller it says Intel 82371SB PCI
Bus Master IDE Controller.  It does show that Adaptec
SCSI controller is also loaded, but don't feel you wanted
to hear the word Bus Mastering at all.  All went well with
install except that I did have to use the Adaptec Disk
to gain access to my CD ROM after formatting hard drive.
Windows 95 itself did not recognise CD ROM.
After loading Adaptec Disk, Win95 loaded well.  I will
not continue loading rest of software until you get back
to me.

JohnE
0
 

Author Comment

by:johnike
ID: 1699234
One last problem...I was playing around to get Connor CTD4004
Tape backup system (SCSI) to be recognised by Win95...and it
doesn't.  I've been looking around for drivers, but have not
found them yet.  Never had this running in Win95 as had Linux
on machine prior to these installs.

JohnE

0
 
LVL 25

Expert Comment

by:dew_associates
ID: 1699235
Kay John, first things first:

Boot your P Pro into the Bios/Cmos setup. Disable anything having to do with bus mastering and IDE/EIDE hard drives. In boot devices (if shown) show them as floppy, SCSI and CD Rom. Your Bios, when your done, should show no hard drives installed!  Save this setup in the Bios and let the system boot to Windows. If Windows boots through, fine, if it locks, then boot to safe mode.

Go to device manager and disable the PCI IDE bus, and then reboot the system. The only reference to a hard drive that should be shown in device manager is under hard drives except for the entry for the SCSI controller.

As for the SCSI Tape Backup drive, can you see it on the SCSI ID list during boot?, and is the SCSI Bios picking it up?

Best regards,
Dennis
0
 

Author Comment

by:johnike
ID: 1699236

Under the standard BIOS setup Primary Master through Secondary
Slave Hard Disks are all set to none. There is no reference in
my BIOS to Bus Mastering at all.  I looked everywhere.
The BIOS only allows me the A,C or reversed boot option. Seems
pretty antique thought the latest Tyan Pro BIOS Version 3.03
downloaded yesterday from their site.  All other settings
referencing Hard Drives are shown above (3 or 4 articles up).
I tried Disabling IDE HDD Block Mode.  Upon deleting the
Bus Mastering Driver, it sought to reinstall itself next boot.
Don't know what to do as I see nothing I can change to effect
desired result.  I have gone through BIOS and Adaptec settings
many times.

Tape backup shows up on boot as ARCHIVE Python 28388-XXX which
doesn't necessarily help me understand that it is a SCSI
Conner CTD4004 (which it is).  Maybe the Python is its chip type.
It is seen correctly on SCSI ID 3 as you desired.
Hope this helps you to help me.  Still waiting for that beer too.

0
 
LVL 25

Expert Comment

by:dew_associates
ID: 1699237
Okay John, as long as IDE hard drives are shown as "none" in the Bios, that's fine. It sounds as though the motherboards bios is a bit antiquated given todays Bios choices on how the system should boot and in which drive order. I think A/C should be fine as long as the SCSI device is "C".

Now you have to disable the IDE bus in Windows 95 (just make sure nothing is plugged into the IDE bus on the motherboard). Here's the procedure.
-------------------
Use Device Manager to disable the IDE controller that has no devices attached to it. To do so, follow these steps:
 
1. In Control Panel, double-click the System icon.

2. Click the Device Manager tab.

3. Double-click the Hard Disk Controllers branch to expand it, and then double-click the IDE controller.

4. Click the Original Configuration (Current) check box to clear it,
and then click OK.

NOTE: This procedure causes a red X to appear to the left of the controller in Device Manager, indicating that the device is present, but is currently disabled. If the device is Plug and Play compatible, disabling the device in this manner allows the resources that are normally allocated to the device to be used for another device.

To see if the resources have been freed after disabling the device, click the device in Device Manager, click Properties, and then click the Resources tab.
 
Let me know how you make out!

Your gonna have on heck of a bar tab!

Den
0
 
LVL 25

Expert Comment

by:dew_associates
ID: 1699238
John: On the tape drive, that is a support device, so it will require a driver just like a cd rom device. Try Conner's site to see if theres a driver for it, and in the meantime I'll try and find one as well.
Den
0
 

Author Comment

by:johnike
ID: 1699239
Hey, success Dennis.  I disabled both Primary and Secondary
Hard Drive Controllers in Device Manager.  I then had to
specify inside the Intel PCI Bus Master IDE Controller
Settings pull down menu for Dual IDE Channel Settings the
"No IDE Channells enabled" option.  Upon
rebooting, the Device Manager's Bus Master IDE Controller
line is still there, but with an "!" next to it instead of an
"X".  Upon going into Resources it says that "Windows cannot
determine which resources thsi device is using.  This is
probably because Windows cannot assign a configuration due to
a conflict with other devices in the computer."  And the
Conflicting device list is empty.  I hope this was what you
were looking for.

Does this mean it worked and does it mean I will never be able
to use any IDE type devices in the future?

Yesterday I tried going to www.connor.com web site and tried to
find a new driver, but they only have them in reference to NT
and OS/2.  None refer to Win95.  Upon doing a web search somebody
else was having the same problem...so I wrote them in hopes
they resolved it.  I don't know if they will respond, but this
problem should be not so bad.

You are right about the bar tab!  Glad to.  My wife cooks great
too!!!  If ever in New Jersey!!!  :)


0
 
LVL 25

Expert Comment

by:dew_associates
ID: 1699240
Hi John: As for the "!" when you had the red "X", that was fine and what it should have been, however if it's working properly, fine. As for future use of IDE, you can reverse the process at any time. Just enable in the Bios setup and then remove the bus in device manager and reboot. When Windows finds the bus, just load the bus mastering drivers. As for being in NJ, e-mail me sometime dew_associates@email.msn.com
Den
0

Featured Post

Do email signature updates give you a headache?

Do you feel like all of your time is spent managing email signatures? Too busy to visit every user’s desk to make updates? Want high-quality HTML signatures on all devices, including on mobiles and Macs? Then, let Exclaimer solve all your email signature problems today!

Join & Write a Comment

A few months ago I had an issue with LaserJet 1020 printer which was installed to XP and Windows 7.  It was installed to XP and working, but when I tried to connect from a Windows 7 PC, it would attempt connection and then fail.  Sometimes the Spool…
Storage devices are generally used to save the data or sometime transfer the data from one computer system to another system. However, sometimes user accidentally erased their important data from the Storage devices. Users have to know how data reco…
The viewer will learn how to successfully create a multiboot device using the SARDU utility on Windows 7. Start the SARDU utility: Change the image directory to wherever you store your ISOs, this will prevent you from having 2 copies of an ISO wit…
Windows 8 came with a dramatically different user interface known as Metro. Notably missing from that interface was a Start button and Start Menu. Microsoft responded to negative user feedback of the Metro interface, bringing back the Start button a…

760 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

18 Experts available now in Live!

Get 1:1 Help Now