Solved

Playing MPEG in ActiveMovie & Media Player

Posted on 1997-11-01
12
423 Views
Last Modified: 2013-12-29
I've encountered this problem several times among severl computers.  My MPEG files only play through ActiveMovie, but not through Media Player.  This is where I need it to play due to the MCI calls in my program.  I'm using a RealMagic Hollywood card.  Any ideas?
0
Comment
Question by:fouchi
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 3
  • 2
  • +3
12 Comments
 
LVL 14

Expert Comment

by:smeebud
ID: 1699284
Go to MY Computer\\Files\\options\\File types.
There associate what ever extentions you want i.e; .mp2 using the Edit function associating mpeg's to: C:\WINDOWS\mplayer.exe.
0
 

Author Comment

by:fouchi
ID: 1699285
This is not a file type association issue.  This happens even if I go into Media player and play the MPEG from there.  I get audio, but no video - even after I adjust the border and auto-calibrate the RealMagic card.
0
 
LVL 7

Expert Comment

by:busuka
ID: 1699286
What playing device you select in Media Player ?
0
Get 15 Days FREE Full-Featured Trial

Benefit from a mission critical IT monitoring with Monitis Premium or get it FREE for your entry level monitoring needs.
-Over 200,000 users
-More than 300,000 websites monitored
-Used in 197 countries
-Recommended by 98% of users

 
LVL 14

Expert Comment

by:smeebud
ID: 1699287
Go you get a video screen but nothing playing, or just audio?
0
 
LVL 9

Expert Comment

by:magigraf
ID: 1699288
I think that the problem is much complex than this, we had last week the same problem installing a MATROX video editing card where after installing the Matrox drivers it did disable the MPEG with the media player.

I'll follow the case and post results.
Regards
0
 

Author Comment

by:fouchi
ID: 1699289
Just to answer the above questions, in media player, I select my RealMagic Hollywood card, and I get just audio and no video (sometimes not even this works).  However, everything is fine when played through ActiveMovie.
0
 
LVL 25

Expert Comment

by:dew_associates
ID: 1699290
Fouchi: Search your hard drive for a file called Fmpdrv.ini. Use any text editor (such as Notepad) to edit the Fmpdrv.ini file and check the lines listed, especially any referring to sound or video.
The software for this board also looks for an Int=<x> which MUSt be present. If it's not, then add the line
 
   Int=<x>
 
to the [Sound] section of the file, where <x> is an available interrupt, and then restart your computer.
 
There may also be an Int=<x> under the video section, please post what is shown. This interrupt can be the same as assigned to the video card.

Windows 95 Media Player does not support MPEG files, see Knowledge Base article Q132992, however thrid party software may provide limited support. If you were able to use Media Player before to support MPEG, you will have to reinstall the software that provided the support.

Right now, Active Movie is providing the support you describe for the MPEG files.
0
 

Author Comment

by:fouchi
ID: 1699291
I don't have a file named fmpdrv.ini.
-fouchi
0
 
LVL 25

Expert Comment

by:dew_associates
ID: 1699292
Did you receive any software with your Realmagic card?
0
 

Author Comment

by:fouchi
ID: 1699293
Yes, I have software, but that file is not included.  I did notice, however, that the fmpdrv.ini file is included in the RealMagic Maxima software package (which is an older card than the Hollywood)

0
 
LVL 5

Accepted Solution

by:
johnsavior earned 100 total points
ID: 1699294
Hi fouchi,

I think your special driver .DRV from RealMagic Hollywood Card is not registered on the Windows System.
To registered that driver .DRV, try this several step :

1.  Run C:\WINDOWS\REGEDIT.EXE

2.  Choose this ROOT :

HKEY_LOCAL_MACHINE  --->  System  --->  CurrentControlSet  --->  control  --->   MediaResources  --->  mci  --->  MPEGVideo

the setup parameter usually look like follow :

[Default]                      [value not set]
Description      "ActiveMovie MCI Driver"
Driver            "mciqtz.drv"
FriendlyName      "ActiveMovie MCI Driver"

If MCIQTZ.DRV is not support your card, try to change with
driver that usually included with your Real Magic Card.

0
 
LVL 25

Expert Comment

by:dew_associates
ID: 1699295
Fouchi: Did your Hollywood software come with an "inf" file of any kind?
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I was prompted to write this article after the recent World-Wide Ransomware outbreak. For years now, System Administrators around the world have used the excuse of "Waiting a Bit" before applying Security Patch Updates. This type of reasoning to me …
When asking a question in a forum or creating documentation, screenshots are vital tools that can convey a lot more information and save you and your reader a lot of time
In this video, viewers will be given step by step instructions on adjusting mouse, pointer and cursor visibility in Microsoft Windows 10. The video seeks to educate those who are struggling with the new Windows 10 Graphical User Interface. Change Cu…
If you’ve ever visited a web page and noticed a cool font that you really liked the look of, but couldn’t figure out which font it was so that you could use it for your own work, then this video is for you! In this Micro Tutorial, you'll learn yo…

636 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question