Solved

Second ide hard disk does not work.

Posted on 1997-11-07
4
150 Views
Last Modified: 2013-12-16
Here is what I did.
1. Installed the hard disk (350 Megs) on ide controller.
It worked for the first time,  Windows 95 recognized it and I was able to use space.
2.  Then I decided to install Linux on this second hard disk.  After installation, LILO asked me a question about where to put boot image, I put it on disk a which was primary disk.  
3.  After rebooting, I could only use linux on second drive.  At LILO prompt hitting tab give me option for only one boot image and that was linux.  I panicked and reinstalled windows 95 on primary hard disk, it fixed the boot problem and I was back to sqaure one.  

4. Now,, I cannot use my slave hard disk, everytime I enable it in Bios win95 takes me to Dos compatible mode, after telling me that some device has child processes, etc.  I suspect that boot image on second hard disk is gone and that's why it is giving me this trouble.  I reinstalled dos on second hard disk (using my other 386 computer) but it won't come up in this 386 machine either.  On win95 it gives me the same problem about "child processes attached" and takes me to Dos compatible mode.  

IS this second hard disk gone?

thanks
0
Comment
Question by:bajwa110797
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
4 Comments
 

Expert Comment

by:edhill
ID: 1751488
I would reformat both drives and first restore the computer to working order for MS-DOS.

Then I would consider using a third party program, such as System Commander, which would allow you to run multiple operating systems on a single computer.

After installing System Commander, set up the computer for both Windows 95 and linux.

I am not familiar with linux, but I have used system commander.  it is a very good program to run multiple operating systems.

This is an option to try.
0
 

Author Comment

by:bajwa110797
ID: 1751489
I cannot backup my data so formatting first hard disk is out of question.   My question is why can't win95 see the second drive?  How can I change the boot image of this second drive, or even better I do not care about boot image (since this is a secondary hard disk), how can I use this hard disk which has become unusable.

Thanks

Sandeep
0
 
LVL 4

Accepted Solution

by:
johnt082197 earned 100 total points
ID: 1751490
Windows 95 writes on the master boot record. Linux also. That's why you're having problems. The best way to solve your problem is to:
1) type fdisk /mbr d:
2) format d:
3) uninstall Windows 95 on C:
4) install Linux on D:
5) reinstall Windows 95 on C:
0
 
LVL 4

Expert Comment

by:johnt082197
ID: 1751491
Why did I get a D?
0

Featured Post

Easy, flexible multimedia distribution & control

Coming soon!  Ideal for large-scale A/V applications, ATEN's VM3200 Modular Matrix Switch is an all-in-one solution that simplifies video wall integration. Easily customize display layouts to see what you want, how you want it in 4k.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Join Greg Farro and Ethan Banks from Packet Pushers (http://packetpushers.net/podcast/podcasts/pq-show-93-smart-network-monitoring-paessler-sponsored/) and Greg Ross from Paessler (https://www.paessler.com/prtg) for a discussion about smart network …
Determining the an SCCM package name from the Package ID
This Micro Tutorial will give you a basic overview of Windows DVD Burner through its features and interface. This will be demonstrated using Windows 7 operating system.
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.

738 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question