Apostrophe in html text??

How do I place an apostrophe in my text of my homepage without it being translated into some foreign symbol once it is on the web.  I thought maybe it was the font I was typing my html doc in, but I've tried other fonts and it still happens.
MaddyAsked:
Who is Participating?
 
pscroggsConnect With a Mentor Commented:
Try this: (if your word is ... don't)
don’nt
0
 
ozoCommented:
like 'this'
0
 
alamoCommented:
Should be nothing special happening to the apostrophes, could you give us a URL which illustrates the problem? Does it look the same when viewed from other computers? Makes me wonder if there is something funny about your system which makes you have problems displaying apostrophes.
0
Get your problem seen by more experts

Be seen. Boost your question’s priority for more expert views and faster solutions

 
wilfriedsCommented:
Did you open a < bracket somewhere before to create a link and forgot to close it?
0
 
Holger101497Commented:
Well, there seems to be some vagueness as to which character you mean. Are you talking about the "single quotes" ozo typed? I agree that there should be nothing happening to ' and ` characters.

I guess you mean the "nicer" apostrophes like "don´t"? (They might be "standard" depending on your keyboard) Try character code &acute; instead and see if it helps.

One thing will (almost) definitely solve your problem if you are using Netscape: Open the built-in HTML Editor, type the characters you mean, save the page, open it in Notepad and check how it saved them. Netscape automatically converts all "non-standard" characters to their proper representation in &entities;
You don't have to create your document in Netscape (I don't), but it shows you the proper representation of the characters.

Good luck and let me know if this comment helped...
0
 
ozoCommented:
´this´ also displays with no problem in HTML, as you can see on this page.
'´` all display ok, (at least in an iso-8859-1 font)                                         ¡¢£¤¥¦§¨©ª«¬­®¯°±²³´µ¶·¸¹º»¼½¾¿ÀÁÂÃÄÅÆÇÈÉÊËÌÍÎÏÐÑÒÓÔÕÖ×ØÙÚÛÜÝÞßàáâãäåæçèéêëìíîïðñòóôõö÷øùúûüýþÿ
0
 
MaddyAuthor Commented:
The type of apostrophe I mean is the one in contractions like "Don't"  In place of the apostrophe I get something that lookds like a Greek letter. I took it off the page once I realized it wasn't being displayed correctly so I can't show you now.  I am going to try the &acute.  Do I type &acute in place of the ' without any tags?  ie: didn&acutet
0
 
Holger101497Commented:
For the special characters, it is &acute; including the semicolon. I agree with ozo that the straight single quotes should be ok, there's not even a special code for them. The ´ is not necessarily ok. As long as all of our PCs have more or less the same settings, we can't see what might happen somewhere else. If the ' appear as Greek characters on your own computer, there's most likely something wrong with your settings. Well, somebody in the world will probably have these settings (why else would they exist?), so the &acute; is always the "better" things to do. The line ozo typed would look like a complete chaos for somebody in Japan, while &auml; should be displayed as "ä" anywhere in the world.
0
 
p_reynoldsCommented:
The problem is because your program that your typing the HTML in is using smart quotes. Smart quotes are the kind of quotes that automatically curl towards the quoted statement. You could either use a straight text program like SimpleText or WordPad. Or be sure you Save as... ASCII or just text whatever options it gives you. Hope this helps!
0
 
Holger101497Commented:
Which program that generates an HTML-page would use "smart quotes"??? I think that programs that generate HTML-pages (including the tags etc.) also replace special characters by the proper &entities;
If Maddy uses some word-processor and doesn't save as plain text, the page wouldn't be readable in a browser in the first place!

Still: which program do you use to generate your page, Maddy? Could you maybe post a short page that causes the problem somewhere on the web? (don't post it here, Expert-Exchange automatically replaces certain characters to make them display properly)
0
 
p_reynoldsCommented:
Not true, entirely. BBedit would gladly save smart quotes to a plain text file. But they would be system-specific characters and come across as funny symbols in a browser. However, I do agree WYSIWYG programs should output encoded characters. *All* of them have major shortcomings if you ask me.
0
 
MaddyAuthor Commented:
As per your request, I posted the problem text on my homepage until I can fix it.  It is located at http://www.beth.k12.pa.us/schools/east_hills/team_info/gr6/sgodiska.html#Class Author  You may need to scroll down a bit.  It is the 3rd descriptive I did try the Simple Text solution but it doesn't appear to be working.  I intend to try the &acute;
Thanks
0
 
ozoCommented:
You're using Õ, (&#213;) you want ´ (&#180;) or ' (&#39;)
(like up at the top where you have "Godiska's Class")
0
 
Holger101497Commented:
Hey pscroggs!
I think there were several suggestions in the posted comments that should be considered as answers first, don't you think? Specifically, my first comment suggested both the use of entities like &acute; (well, &#146; is just a different one, but definitely the same idea) and a solution for solving this and any related problems by using the Netscape-Editor (Have you tried that suggestion, Maddy)? If either one of those suggestions solves the problem, that comment should be accepted as an answer.

btw, Maddy: Which program did you use to create the file? Make sure its characterset is set to "Western (ISO-8859-1)" like in Netscape. It is surprising that only "some paragraphs" are afected. Did you maybe *import* the affected paragraphs from some other program by using cut&copy? If you open the page in Notepad and replace the wrong characters by plain ', that should also work!
0
 
ozoCommented:
And what font is &#146; supposed to be in anyway?
0
 
p_reynoldsCommented:
This happened to me before when moving text files from a proprietary publishing system to a Unix workstation through a Mac gateway. Basically, the file was coming across in hex and a program (extension) on the Mac converted the characters to ASCII equivalents. Ths was fine and dandy except the quotes were being converted to curly "smart" quotes. Then all of the pages on the Unix box displayed apostrophes as Õ and quotes as ÕÕ. The solution was to change the conversion tables on the conversion program to make the quotes straight quotes. But in SimpleText and BBedit on the Mac, they looked fine. A system specific character is being printed in this mysterious program maddy is using.
0
 
MaddyAuthor Commented:
Thanks,  I'm sure I'll run into something like this again. I'm really a true novice.  In response to some of your questions: This page was typed in ClarisWorks and saved as plain text then I used Winsock FTP to transfer.( I origionally typed in on a pc, but at school we use Macs, so when I ran into this problem, it was being saved as .html and transferred using Anarchie.)  If I open it in or copy and paste into BBedit Lite will I be ok next time???? Or how can I get Western font in my ClarisWorks program?
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.