No Drive Letter for CD ROM

I repartitioned my drive using Partition Magic which changed my CD ROM from D to F.  No problem with audio CDs or with running software.  However, I just realized that windows explorer doesn't recognize the drive letter.  It lists A,B,C,D,E,G.  File Manager recognizes the drive so there's no problem there.  The thing is, I want to run windows setup again and I can't because the CD ROM drive letter isn't an option.

I went to system../CD ROM and the correct drive letter is displayed there.  Thanks for any assistance.

Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Would you please check if you have a:

last drive=???

statement in your startup file (config.sys)
If it is =G, here is your answer.
Wait for your post, or reject if it's not.
BonnieWAuthor Commented:

Thanks anyway.....
I have LASTDRIVE=G in my config.sys.  I also tried LASTDRIVE=Z, H, and deleted the line altogether with no difference.  The Windows DOS prompt reads the drive correctly as F, G being my zip drive.  Since windows' file manager, windows' Dos prompt, and windows' Run command recognize it as drive F, why not the explorer?
Under Control Panel/system, does your cdrom have a "!" on it?
And in your cdrom settings tab, does it have the correct drive letter displayed?

Answer 1. TweakUI has many useful options. One in the "My Computer" tab you click on the Drive letter you want to show in explorer. Checking "E" will display your CD drive by clicking it.
I also use it to automatically logon as a certain user, to remove these ugly arrows in the desktop icons and to do many other things.

Answer 2. Try changing your CDROM DRIVE Letter manually:

You can change the drive letter of a CD-ROM drive by performing the following steps:
1.Click the Start button, point to Settings, and then click Control Panel.
2.Double-click the System icon, then click the Device Manager tab.
3.Select the CD-ROM you want to change from the list, then click the Properties button.
4.Click the Settings tab.
5.In the Reserved Drive Letters section, set Start Drive Letter and End Drive Letter to the drive letter you want the CD-ROM drive to use.
Click OK until you return to Control Panel.
6.Restart the computer.
The CD-ROM drive letter should now be the letter you selected.

Answer 3. Shutdown your system and boot to dos, CD to Windows,
Then Extract a fresh copy of Explorer from your Win95 CD-ROM
To extract from CD, 1st CD to the E:\WIN95 prompt, then type the following:
-------(X:\WIN95\*.CAB)x being your CD drive letter.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
BonnieWAuthor Commented:
Tweak UI did the trick - and reassigned the G letter to the CDROM while making my zip drive the elusive F drive.  The CDROM is now listed in The Explorer and in My Computer.  The zip drive, however,  shows only in The Explorer.  No concern.  I can now run windows setup and my problem is solved.  Thank you all for your efforts.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows OS

From novice to tech pro — start learning today.