Solved

Sharing CD-ROM through Win95 on Netware

Posted on 1997-11-12
13
273 Views
Last Modified: 2013-12-16
I am trying to share my CD-ROM drive from my Win95 workstation on a Netware 3.12 network.  My win95 configuration doesn't include the "sharing" option when looking at the settings for my CD-ROM drive.  Therefore not being able to share it.

When I go into the properties of the CD-ROM drive (D:) through My Computer, there is no Sharing tab, just a General tab.   I've obviously got some settings incorrect.   What "background" info do I need to take
care of?

The full set of installed components in my network "control box" within the Control Panel is:
 
Client for Microsoft networks
Novell Netware Client32
Dial up adapter
NE2000 compatible
Novell ODINSUP  
IPX 32 bit protocol for Client32 -> Dial up adaptor
IPX 32 bit protocol for Client32 -> NE2000 compatible
IPX 32 bit protocol for Client32 -> Novell ODINSUP  
IPX/SPX compatible protocol -> Novell ODINSUP
NetBEUI -> NOvell ODINSUP
TCP/IP  -> Dial up adaptor
File and printer sharing for Microsoft Networks.
 
 
0
Comment
Question by:raheesom
  • 6
  • 2
  • 2
  • +3
13 Comments
 
LVL 12

Expert Comment

by:j2
ID: 1751696
Have you actually enabled teh filesharing? There is a button for "file and print sharing" in teh networking control panel. Is the sharings enabled?
0
 

Author Comment

by:raheesom
ID: 1751697
Yes, I would have thought that the

"File and printer sharing for Microsoft Networks. "

line in the network settings above would have reflected this.

I've double checked, and yes:  one is able to share files and/or printers through that button.  I have the file sharing enabled.

Perhaps there are settings elsewhere which I am unaware of?
0
 

Author Comment

by:raheesom
ID: 1751698
I've checked whether disabling, then enabling the file sharing helped: it did.   Perhaps it had been disabled when I installed Novell's Client32 onto the machine.

However, now, even though I'm able to specify any device are sharable, with names, etc.    When I look in Explorer's Network Neighbourhood for my CD drive, it ISN'T THERE.    That goes for any device I try to share.

If I try to access the CD by using Start/Run then "\\computer\device" as a UNC, I can see it at my machine, but no-one else's.

I've tried sharing another machine's C drive with the same results:  locally they can see it, but not remotely.  

It looks very much like the workstations aren't advertising the shared devices on the netBEUI network (or netBEUI is not working).

Right this moment; when I tried connecting to the internet via DUN, I was informed that the file sharing was using TCP/IP (and whether to disable it for internet access).    How would file sharing use TCP/IP? The only line in my network setup which could come close to this is "NetBEUI -> ODINSUP".   Looking at the properties of this confirms it's use:  "client for Microsoft networks" and "File and printer sharing for Microsoft networks".

Does this make the problem any clearer?

BTW I'm now using Novell's Intranetware client 2.2 for win95.
0
 

Author Comment

by:raheesom
ID: 1751699
Adjusted points to 100
0
 

Expert Comment

by:TMS
ID: 1751700
is Novell ODINSUP a real mode driver (resident TSR) support ?
0
 
LVL 1

Accepted Solution

by:
lkandia earned 100 total points
ID: 1751701
Depending upon which protocol you want to be the one doing the sharing, make sure that you have File and Printer sharing turned on under your THAT protocol's "properties/bindings" tab.  More than likely it is turned off.
0
Are your corporate email signatures appalling?

Is it scary how unprofessional your email signatures look? Do users create their own terrible designs and give themselves stupid job titles? You can make this a lot easier for yourself by choosing an email signature management solution from Exclaimer today.

 
LVL 9

Expert Comment

by:rmarotta
ID: 1751702
Have you tried right-clicking on the CD icon under "My Computer"?
Then select sharing to enable the network to use that drive.
0
 
LVL 9

Expert Comment

by:rmarotta
ID: 1751703
I forgot to mention: Don't click on properties of the CD-Rom uder My Computer.  There should be a "Sharing.." option in the drop-down menu when you right-click on the CD's icon.
0
 

Expert Comment

by:berneyz
ID: 1751704
If you really have sharing enabled, a hand should appear under the icon of the shared device.  With a hard there, windows should be setup correctly.    Just because sharing is turned on doesn't mean that windows knows how to advertise it.
R click on cd rom drive.  L click sharing or properties.  Click on sharing tab to tell windows what to advertise the cd rom drive as, name, comments, password access etc. This should create that hand symbol on the icon for the drive and allow other nodes to see it.
0
 

Author Comment

by:raheesom
ID: 1751705
I would like IPX to be carrying the sharing traffic, so I've tried fiddling around with IPX and TCP/IP settings.  

To get sharing enabled under IPX, I had a look at the
NOvell ODINSUP adaptor and enabled IPX under it.   Also enabled MS networks / sharing under the IPX ->ODINSUP protocol.   Of course the file/printer sharing was enabled under the "File/Printer sharing" button.   After rebooting sharing was NOT available.

When trying the sharing under TCP/IP, I enabled "MS networks" and "sharing" under the "TCP/IP ->Dial up Adaptor" protocol.  After rebooting, sharing seemed to be active (hand under D:, sharing tab in object menu) but CD-ROM was NOT visible in Networkneigbourhood.

One thing I did see was the warning: "You have not selected any drivers to bind with.." when deselecting "MS network" and "sharing" under the "TCP/IP -> Dial up Adaptor" protocol.

I'm now suspecting that I'm trying to do things backwards:
Is Novell's ODINSUP there to be able to run Intranetware client over MS's NDIS drivers?   If so, and I'm using Novell's ODI driver to access the network, then my ODINSUP is doing nothing...
0
 
LVL 1

Expert Comment

by:lkandia
ID: 1751706
You have a small issue here.
In order to share something, you have two options.
1. You can be in charge of WHO gets to share your CDROM.
2. Your PDC (if you log into a Microsoft domain) can be left in charge.
Go to control panel/network/Access Control
Make sure that if you User-level access Control has been set if you don't want to be bothtered with setting up a password for the cdrom share.  Otherwise, pick share level access control, and you will be responsible for putting a password on that share.

Now in order to broadcast your CDROM, go to control panel/file and print sharing/properties and make sure that Browse Master is ENABLED.  This forces you to keep a copy of the master browser list locally (I don't know your setup so we'll start here).

0
 

Author Comment

by:raheesom
ID: 1751707
I've tried using all the protocols of IPX, NetBEUI and TCP/IP
in relation to MS file sharing.   I don't have luck with any of them, although I am more used to how to work with the drivers and protocols.

I've tried enabling the MS sharing on a colleague's machine with Win95 and an older version of Client32.   I managed it with no problem.

However that version of Client32 doesn't use ODINSUP, which makes me think that my problem lies with my use of ODINSUP.  

The other machine has Novell's IPX and MS's IPX/SPX compatible
protocol both bound to his network card driver.

My network card driver, "NE2000 compatible" only has the 32bit IPX for intranetware hanging onto it.   The Novell ODINSUP driver has the IPX/SPX compatible protocol bound to it.   In the File Sharing line, the browse master was on Automatic; I've changed that to Enable.

I'm doing to try and find out more about Novell's ODINSUP.
0
 

Author Comment

by:raheesom
ID: 1751708
Sorry to have taken so long to get back.  Someone else suggested trying the NDIS driver with Intranetware client.   I tried this, but got an error when trying to login with the Inet client.

The other suggestion was to use the MS client which would probably have worked better with the file sharing.   However I didn't want to use the MS client cause I was accessing a NW4 server from my WS for test purposes.

In the end, I was told to drop the whole project of sharing my CD-ROM, so I have!

I appreciate all the help that everyone here has given me, therefore, although the has been no solution yet, I'll try to keep the "score" for the answer high with a B.
0

Featured Post

Don't lose your head updating email signatures!

Do your end users still have the wrong email signature? Do email signature updates bore you or fill you with a sense of dread? You can make this a whole lot easier on yourself by trusting an Exclaimer email signature management solution. Over 50 million users do...so should you!

Join & Write a Comment

Several part series to implement Internet Explorer 11 Enterprise Mode
Recently Microsoft released a brand new function called CONCAT. It's supposed to replace its predecessor CONCATENATE. But how does it work? And what's new? In this article, we take a closer look at all of this - we even included an exercise file for…
Windows 8 came with a dramatically different user interface known as Metro. Notably missing from that interface was a Start button and Start Menu. Microsoft responded to negative user feedback of the Metro interface, bringing back the Start button a…
With the advent of Windows 10, Microsoft is pushing a Get Windows 10 icon into the notification area (system tray) of qualifying computers. There are many reasons for wanting to remove this icon. This two-part Experts Exchange video Micro Tutorial s…

762 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

24 Experts available now in Live!

Get 1:1 Help Now