Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 235
  • Last Modified:

Calling .pl from <!--include exec...-->

I am running NT4.0, IIS 3.0, and need to call a .pl from an include line, I went through the registry and found nothing wrong, but the browser is still ignoring the SSI.  HELP!
0
mgfranz
Asked:
mgfranz
1 Solution
 
mortenmoCommented:
<!--#include exec="program" --> is something the server has to
accept and not the browser. the <!--#include ..> never reaches
the browser (or shouldn't at least).

I don't know about the web-server you got, but make sure it at
all have SSI (server side include) support (many servers doesn't
or they have another way of including).
Mark tho that it is normally <!--#include not <!--include.. in
the question you forgot the # (hash).
Next is, that if you want to execute a command, you don't use
#include, but you use #exec try <!--#exec cmd="a.pl" ..

Hope this helps

 

0
 
mgfranzAuthor Commented:
As I stated in my original Q, I am running IIS 3.0 on a NT4.0 server, I am able to run .pl scripts from a <frameset> page, but not from a SSI, this issue is the same on a PWS also, Here is what I am trying to do;

----------------------------------

<HTML>
<HEAD>
<META HTTP-EQUIV="Content-Type" CONTENT="text/html;>
<TITLE>Doc2</TITLE>
</HEAD>
<BODY TEXT="#000000" BGCOLOR="#ffffff">
<!--#include cmd="\cgi-bin\countdown.pl" -->
<P></P></BODY>
</HTML>

I have tried <!-- #exec cgi="....pl --> and <!--#exec cmd... -->
also, I dont have access to other server types.

IIS should not be this difficult to set-up for SSI!
0
 
bizsystemsCommented:
The httpd server daemon probably needs a mime type designated
as acceptable as an executable.  I am unfamiliar with what runs
on windoze. But in the unix world, this would go into
the httpd.conf file.
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
mgfranzAuthor Commented:
NT and IIS dosn't use a HTTPD.CONF file, or any real config file, only registry entries.  After much research and many e-mails from various sources, it has been determined that IIS and NT does not recognize <!--#exec ...--> includes fromm HTML files, ... but, with ASP pages, there are certain includes that will run, with much registry work.  I ended up writing a perl file that opened up the tables inside of the script, like a "auto-generate".
0
 
maholtCommented:
I had trouble getting nt to run perl scripts.  And yes, NT can be that hard to get perl to run.  Check your registry.  Make sure ...
HKEY_LOCAL_MACHINE on Local Machine
    SYSTEM
         CurrentControlSet
              Services
                   W3SVC
                        Parameters
                             ScriptMap
has a field like
.pl:REG_SZ:c:\ntperl\bin\perl.exe %s

You could also try making a runit.bat file that is
    perl c:\counter\count.pl

Good luck
0
 
mgfranzAuthor Commented:
Perl scripts run fine, but it would be nice if we could run <include...> lines from inside of a print << statement.  What I have found out so far is that IIS has no <include exec...> capabilities unless you are running ASP.  Which would mean re-writing about 100 pages... :-(
0
 
ozoCommented:
print <<HERE;
<include>@{[`\cgi-bin\countdown.pl`]}</include>
HERE

0
 
nanullnetCommented:
The default file mapping for SSIs on IIS3.0 is .stm,  Change the name of your html file from whatever.html to whatever.stm, and it will probably work.
0
 
mgfranzAuthor Commented:
nope, OZO hit the nail on the head...
0
 
ozoCommented:
In that case, here's an Answer:
print <<HERE;
<HTML>
<HEAD>
<META HTTP-EQUIV="Content-Type" CONTENT="text/html;>
<TITLE>Doc2</TITLE>
</HEAD>
<BODY TEXT="#000000" BGCOLOR="#ffffff">
${\(`\cgi-bin\countdown.pl`)}
<P></P></BODY>
</HTML>
HERE

0
 
ozoCommented:
If it didn't hit the nail on the head, you could have rejected it for another answer.
0
 
mgfranzAuthor Commented:
nope, this is ~almost exactly what I was looking for, either way, this actually works better than my original, cause I can put all my script into the same page.
0
 
ozoCommented:
Then why the low grade?  One might think you were dissatisfied in some way.
0
 
ozoCommented:
Actually, there is a problem with the answer as given,
It should have been `/cgi-bin/countdown.pl`, or else `\\\\cgi-bin\\\\countdown.pl`
0
 
ozoCommented:
And with the ${\(...)} construct, you would have wanted ${\(scalar `command`)}
if command returns more than one line
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Tackle projects and never again get stuck behind a technical roadblock.
Join Now