Solved

Windows 95 Start-up Error

Posted on 1997-11-17
23
309 Views
Last Modified: 2013-12-16
While trying to install 56K drivers for my Aptiva Lucent modem, something went wrong.

1. I used the IBM Update Connector to download a group of patches, inluding the drivers, an updated rmm.pdr file to fix an I/O subsystem problem, and several small patches to some IBM software.

2. All the other patches loaded fine and I then loaded the new drivers.      I was then instructed to restart to the computer.

3. However, the computer now hangs everytime during the Win95 loading.  The Windows logo comes on the screen, the hard drive churns for a while, and the it just stops.

4. It will load in Windows 95 Safe Mode, but now there isn't a Lucent modem listed anymore.

I tried doing step-by-step confirmation, disabling the load= and run= statements in win.ini, even disabling the modem and sound drivers.

Here's the fun part - IBM says that I can uninstall any the updates it had me run, but the Uninstaller was upgraded to a new Java version which can only run in 256 color mode, but safe mode only supports 16 colors!

Any help would be greatly appreciated.

1. How do I get 256 colors in safe mode?
2. How do I get a list of drivers that Windows is trying to load and disable them one by one?
3. Should I switch back to the previous rmm.pdr version?
4. Anything else that will prevent me from having to reinstall Win95?

Thanks,
Eric Christ
echrist@harbinger.com
0
Comment
Question by:echrist
  • 8
  • 7
  • 6
  • +1
23 Comments
 

Author Comment

by:echrist
ID: 1751806
Adjusted points to 200
0
 
LVL 7

Expert Comment

by:busuka
ID: 1751807
1) No. Safe mode works ONLY in 16-color mode because no SVGA
driver is loaded, only standard VGA-driver to exclude video conflicts
2) Press F8 upon restart after 'Starting Windows ...' to get menu
   Select BOOTLOG.TXT Logged Mode. Win95 will hang as usual.
   Restart. Enter menu again. Select Command Prompt only. Take
   BOOTLOG.TXT file from C:\. Examine it for FAILed drivers and
   pay special attention to several last lines. Now tricky part.
   These drivers can be loaded through SYSTEM.INI in device= in
   [386enh] section or in Registry. If they in SYSTEM.INI you
   know what to do (little ; in start of line). If they in
   registry, enter Safe Mode and run Regedit from \Windows folder
   Search for your driver and remove entry.
3) You can try if your modem not works with new rmm.pdr
4) Try these steps. I have Win95 installed long time and NEVER
   reinstalled it. But if you want to you can reinstall it with
   command: setup /p f
   This will clean registry and replace broken files. You can add
   /d if you want to build win.ini and system.ini from scratch.
0
 

Author Comment

by:echrist
ID: 1751808
BOOTLOG.TXT only shows that Load Failed for CS4232C.EXE (my CrystalWare sound driver) and SETVER.EXE.  It doesn't show any Windows drivers.  However, when I start in safe mode, it shows a bunch (20+) Windows drivers being loaded successfully.
0
 
LVL 25

Expert Comment

by:dew_associates
ID: 1751809
Hi Eric!

Sometimes Windows 95, because of the number of changes occuring at the same time, becomes confused or in actuality does not load or it incorrectly loads certain drivers, which causes a lockup. MS would have you believe this doesn't happened, but unfortunately it happens more frequently than not.

PDR files normally load device drivers, especially involving your Windows 95 IO Subsystem, the base system that runs windows.
I suspect that even though these drivers have been added to your system, they have not properly loaded and registered.

There's three ways to approach your problem!

1. You can remove the sound, modem and any other non-essential peripheral cards and reboot the system. Since they are not there and therefore not detected by Windows, Windows will not load the drivers. You can then sort out a basic system and make it run properly, then begin adding back each component and the correct drivers for it.

2. You can use device manager in safe mode to remove some of the devices, reboot and let windows 95 detect the device and then manually load the correct driver from a floppy.

3. The last, and really just a deviation from the above, would be to strip down the system to its basic components, no sound, no modem etc, just what you need to run the system, plus the cd rom drive, fdisk the hard drive, format it and load windows and setup a basic system using the custom install. At this point, you would load just the drivers (like the PDR) which involve the basic system. Once this is running properly, you can then add back one component at a time based upon their difficulty level as an install.

If this appeals to you and you need a more specific procedure, let me know and I'll help you along.

Best regards,
Dennis
0
 
LVL 1

Expert Comment

by:david_r
ID: 1751810
Hey Dennis, what about the system.da0 and user.da0 files?
0
 
LVL 7

Expert Comment

by:busuka
ID: 1751811
To David, *.da0 files are miserable Micro$oft try to backup system
registry. But, unfortunately, registry is changed EVERY startup,
thus once you have broken registry ... next startup -> broken
registry copied as backup. The best proven way is to backup these
files manually in some place when you have working system. Dennis
most probably right about multiply changes. I ate something like
that when installed modem software and couple of programs with it
Win95 wanted to reboot, but I (stupidly) not gave it to do this
until last setup, then I rebooted and what was after startup:
"Now it's safe to turn your computer off" screen. Very funny.

Now to business: what was last line in BOOTLOG.TXT ?
0
 
LVL 25

Expert Comment

by:dew_associates
ID: 1751812
david_r, restoring a registry from da0 files would normally work had Eric not updated his files, especially the PDR layer which is part of the IO subsystem which is not involved in the registry. If Eric does as you suggest, he runs the risk of an unrecoverable crash of the IO Subsystem and possible loss of the MBR.

Busuka, as Eric notes above, he had a failed video driver and setver.exe. Since the video driver shouldn't have caused the problem Eric is dealing with, especially when booting to safe mode, I suspect that there is either some memory conflicts in the video area and/or Interrupt 13, 14 & 15 that aren't being resolved by the psr file.

Dennis
0
 
LVL 7

Expert Comment

by:busuka
ID: 1751813
Eric, can you post your CONFIG.SYS and AUTOEXEC.BAT files ?
(maybe he has infamous CD-ROM SYS driver conflict: IRQ 15)
0
 
LVL 1

Expert Comment

by:david_r
ID: 1751814
buska and Dennis, thank you for the education (really) I thought the da0 files were only changed when windows said "Your configuration files are being updated...." and Dennis I directed my comment at you because I wasn't suggesting that he do anything with them, I have read your previous posts and knew that YOU would know if that was a viable alternative...
again, thank you guys

0
 

Author Comment

by:echrist
ID: 1751815
First of all, thanks everyone for your time in reviewing this problem.  Last night I reread busuka's suggestion and tried commenting out everything in the 386enh section of system.ini.  Through a process of elimination, I found one entry that was causing the system to lock and by commenting that out, I was able to load Windows.  That entry was "mouse=*vmouse", which means that now Device Manager shows my "PS/2 Mouse" as unavailable, even though I can use it fine.

I reloaded the Lucent 56K drivers, restarted Windows and it said that it loaded the modem, but I can't get it to dial and diagnostics says that it can't communicate with the modem.

1. How do I get my mouse back?
2. How do I get the modem working?

Here is the 386enh section of my system.ini:
[386enh]
device=d:\afterdrk\adw30.386
DEVICE=C:\CSW70\CSDVXD.386
DEVICE=C:\CSW70\CSSAFE95.386
ebios=*ebios
device=*vshare
device=*dynapage
device=*vcd
device=*vpd
device=*int13
woafont=dosapp.fon
display=*vdd,*vflatd
; mouse=*vmouse
keyboard=*vkd
device=*vpowerd

Here are the items from my bootlog.txt that show failure:
[001711C0] Loading Device = C:\WINDOWS\CS4232C.EXE
[001711CD] LoadFailed     = C:\WINDOWS\CS4232C.EXE
[001711CE] Loading Device = C:\WINDOWS\SETVER.EXE
[001711CF] LoadFailed     = C:\WINDOWS\SETVER.EXE
...
[0017121B] Loading Vxd = ndis2sup.vxd
[0017121B] LoadFailed  = ndis2sup.vxd
[0017121C] Loading Vxd = vserver.vxd
[0017121D] LoadFailed  = vserver.vxd
[0017121F] Loading Vxd = vshare
[0017121F] LoadFailed  = vshare
[00171286] INITCOMPLETE = SDVXD  
[00171286] INITCOMPLETEFAILED  = SDVXD
...
LoadStart = ATILCD.DLL
LoadFail = ATILCD.DLL Failure code is 0002
LoadStart = C:\WINDOWS\fonts\dummy.lyt
LoadFail = C:\WINDOWS\fonts\dummy.lyt Failure code is 0002

3. How do I give points to busuka for his idea?
0
 
LVL 25

Expert Comment

by:dew_associates
ID: 1751816
Eric: If Busuka solved your entire problem(s) which he hasn't, he would post an answer and you would accept it. However your problems aren't over. I do see the problems now that you've posted this information. I'll give Busuka an opportunity to solve the mouse and modem problem before I post the answer. In an effort to help him (Busuka along, there are three things that need to be chnaged on your system)
Dennis
0
What Is Threat Intelligence?

Threat intelligence is often discussed, but rarely understood. Starting with a precise definition, along with clear business goals, is essential.

 

Author Comment

by:echrist
ID: 1751817
Didn't mean to imply that Busaka would get alll the points, Dennis.  Your answer helped as well. I'll be glad to split the points, if that's possible.

Thanks,
Eric
0
 
LVL 25

Expert Comment

by:dew_associates
ID: 1751818
Hi Eric: I have no problem in sharing points, that wasn't the point, the problem your seeing has nothing to do with the entry you made for the mouse in the *ini* file. It just disabled the device in protected mode which causes your mouse to revert to real mode Bios drivers. By doing this, you resolved a bus conflict by disabling the mouse and enabling the modem. Here's the proper fix for the problem.
-----------------------------------------
1. Boot your system to Bios/Cmos setup and enable PS/2 support (or confirm that it is enabled) and make sure that IRQ 12 is enabled for the mouse.

2. Go into peripherals and disable serial port 1 or 2 (Com 1 or 2) your choice.

3. Save the Bios setup and let your system boot through to Windows 95.

4. Click on Start, Run and type in "Sysedit" without quotes and touch enter. Go to your System.ini file and verify that the following lines are present. If the aren't, then add them.

       [boot]
       mouse.drv=mouse.drv
       drivers=mmsystem.dll
 
      [386Enh]
       mouse=*vmouse

5. In the [386Enh] section, add a semi-colon before this line like this:

;device=d:\afterdrk\adw30.386

**After Dark has several known problems and conflicts with Windows 95.

Save your System.ini file and close Sysedit.

6. Click Start, Settings, Control Panel. Click on the System Icon and then go into device manager.

a. Scroll down to modem, expand it by clicking on the + sign, highlight the entry and then click remove.

b. Scoll to the Mouse entry, click on the + sign, highlight it to expand it and then click remove.

c. Scroll down to Ports [LPT-COM] and make sure the Com port you disabled in the Bios IS NOT shown.

7. Reboot the system. Your PS/2 mouse should be found as well as your modem. At this point, you can add your modem software or use a standard modem driver from Windows, however the one that came with the modem is better.

8. If the modem still doesn't work (like you noted above), go to control panel, then click the modem icon. Remove the modem then add a new modem, but this time, instead of letting windows detect it, choose it from a list and then use "Have disk". Once it's loaded, then use the modem diagnostic.

Best regards,
Dennis
0
 
LVL 7

Expert Comment

by:busuka
ID: 1751819
I was some time off. So I didn't solved your problem and I'm not
greedy for points :)
I thought that situation is following:
Mouse driver installed in memory, hanging on COM1/IRQ4
Modem driver *searches* COMs for modem hardware, but falling on
mouse. Maybe moving mouse on COM2 will easily solve this conflict
(physically moving). About PS/2 mouse ... not sure. You may
receive PS/2 mouse support, but I doubt that this PARTICULAR mouse,
connected to the PARTICULAR COM port will respond to Win95 mouse
driver for PS/2.

Best way is to try.
Ian
0
 
LVL 25

Expert Comment

by:dew_associates
ID: 1751820
Besuka: Eric's using a PS/2 mouse not a serial mouse!
Dennis
0
 
LVL 7

Expert Comment

by:busuka
ID: 1751821
To Dennis: uhh, where you found that ? I re-read whole discussion
and failed to find Eric's comment that he have PS/2 mouse.
0
 
LVL 25

Expert Comment

by:dew_associates
ID: 1751822
Busuka: Eric says it here:

 "Through a process of elimination, I found one entry that was causing the system to lock and by commenting that out, I was able to load Windows. That entry was "mouse=*vmouse", which means that now Device Manager shows my "PS/2 Mouse" as unavailable, even though I can use it fine. "

Dennis
0
 
LVL 7

Expert Comment

by:busuka
ID: 1751823
Eric, last shot: do you have PS/2 mouse ? Do you have PHYSICAL
PS/2 port, or mouse connected to COM port ?
0
 

Author Comment

by:echrist
ID: 1751824
1. I went into BIOS but only one serial port (port A) was listed, so I disabled that.
2. By continually deleting and re-adding the modem and the mouse, I got both working with the following settings:
Mouse: IRQ 12
Modem: COM2, 02F8-02FF, IRQ 3, DMA 07 and 06
No COM1 is listed in device manager.
3. Although both the modem and mouse work, starting Win95 now seems to take much longer than before and I still get the following errors in bootlog.txt:

[00160043] Loading Device = C:\WINDOWS\CS4232C.EXE
[00160050] LoadFailed     = C:\WINDOWS\CS4232C.EXE
[00160051] Loading Device = C:\WINDOWS\SETVER.EXE
[00160053] LoadFailed     = C:\WINDOWS\SETVER.EXE

[001600C0] Loading Vxd = ndis2sup.vxd
[001600C0] LoadFailed  = ndis2sup.vxd
[001600C2] Loading Vxd = vserver.vxd
[001600C3] LoadFailed  = vserver.vxd
[001600C7] Loading Vxd = vshare
[001600C7] LoadFailed  = vshare
[001601E0] INITCOMPLETE = SDVXD  
[001601E1] INITCOMPLETEFAILED  = SDVXD

LoadStart = ATILCD.DLL
LoadFail = ATILCD.DLL Failure code is 0002
LoadStart = C:\WINDOWS\fonts\dummy.lyt
LoadFail = C:\WINDOWS\fonts\dummy.lyt Failure code is 0002

4. How do I eliminate those load failures?
0
 

Author Comment

by:echrist
ID: 1751825
cs4232c.exe is my CrystalWare(tm) CS4232 Audio Initialization Utility, Version 1.70.  The error message at start-up is that it was unable to load cwaudio.bin from c:\windows and it will use the firmware version instead.  There is a cwaudio.bin file in that directory.

0
 
LVL 25

Accepted Solution

by:
dew_associates earned 200 total points
ID: 1751826
Well done Eric:

Now that the modem and mouse are where they belong, we'll sort out the rest.

As for the CS4232C.EXE file, that can come from either your card manufacturer or from the Windows 95 Service Pack 1.

PSS ID Number: Q150444
Article last modified on 07-26-1996
PSS database name: WIN95X
95
WINDOWS
---------------------------------------------------------------------
The information in this article applies to:
 - Microsoft Windows 95
---------------------------------------------------------------------
SUMMARY
=======
This article lists the directory contents of the Microsoft Windows 95 Service Pack 1 CD-ROM.
Contents of the \Drivers\Audio\Crd4232 Folder
---------------------------------------------
CRYSTAL  INF         9,055  12-31-95  9:50a crystal.inf
CS32BA11 DRV       111,712  12-31-95  9:50a cs32ba11.drv
CS32BA11 INI         4,536  12-31-95  9:50a cs32ba11.ini
CS4232   INI           774  12-31-95  9:50a cs4232.ini
CS4232C  EXE        79,808  12-31-95  9:50a cs4232c.exe
CSFM     DRV        20,752  12-31-95  9:50a csfm.drv
CWAUDIO  VXD        55,875  12-31-95  9:50a cwaudio.vxd
LICENSE  TXT         4,015  12-31-95  9:50a license.txt
PNP      BAT            36  12-31-95  9:50a pnp.bat
PNP      INI         3,833  12-31-95  9:50a pnp.ini
README   TXT         1,361  12-31-95  9:50a readme.txt
RESOURCE EXE       113,892  12-31-95  9:50a resource.exe
RESOURCE TXT        24,264  12-31-95  9:50a resource.txt
        13 file(s)        429,913 bytes


1. On the loadfail for CS4232C.EXE, this file comes from Service Pack 1 to the retail version of Windows 95. Unless you have the Service Pack 1 CD Rom disk to extract it from, you'll have to reload the service pack. Before doing it though, use your "Ctrl"  "Alt"  and  "Del" keys and open the "Close Programs" dialogue box and close all running programs except for "Systray" and "Explorer". Then click on the service pack to install it.

2. On the Loadfail for SETVER.EXE, make the following change to your config.sys file. Windows 95 cannot report the correct MS-DOS version to applications unless the version table is loaded into memory. To load the version table, include a device command in CONFIG.SYS; for example:
 
device=c:\windows\setver.exe

You can put this at the end somewhere in config.sys.

3. As for the loadfails for  ndis2sup.vxd, vserver.vxd, Vshare and SDVXD, these are normal load failures. As noted in Microsoft's Knowledge Base, however they bear checking. Here's MS comments.
 
PSS ID Number: Q127970
Article last modified on 04-28-1997
PSS database name: WIN95X 95
WINDOWS
======================================================================
---------------------------------------------------------------------
The information in this article applies to:
 - Microsoft Windows 95
---------------------------------------------------------------------
SYMPTOMS
========
When you review the Bootlog.txt file in the root folder on your hard disk, you may see the following lines even though your computer seems to function properly:
 - LoadFailed = dsound.vxd
 - LoadFailed = ebios
 - LoadFailed = ndis2sup.vxd
 - LoadFailed = vpowerd
 - LoadFailed = vserver.vxd
 - LoadFailed = vshare
 - InitCompleteFailed = SDVXD

CAUSE
=====
These load failures do not necessarily mean that there is a problem. It is common for some, if not all, of these to fail, depending on your system configuration.
 
DSOUND
------
Many sound drivers are DirectSound enabled. DirectSound is part of Microsoft DirectX, a set of libraries used by most newer Windows-based games. When a DirectSound-enabled sound driver is loaded, it attempts to register with the DirectSound library so that games can use it. If no DirectX-based games are installed on your computer, the DirectSound library fails to load. This is normal.
 
EBIOS
-----
The extended BIOS driver did not find an extended BIOS, so it does not load.
 
Ndis2sup.vxd
------------
The NDIS 2 support driver did not find any NDIS 2 drivers to support, so it does not load.
 
VPOWERD
-------
The Advanced Power Management (APM) driver determined that your computer does not support APM, so it does not load, or APM support may be disabled. To determine if you have inadvertently disabled APM in Device Manager, follow these steps:
 
1. In Control Panel, double-click System.
2. Click the Device Manager tab.
3. Double-click the System Devices branch to expand it.
4. Double-click the Advanced Power Management Support branch. (If this branch does not exist, your computer does not support APM.)
5. Click the Settings tab.
6. Verify that the Enable Power Management Support check box is selected.
 
Vserver.vxd
-----------
Vserver.vxd does not load statically so that it can save memory by loading later in the boot process only if it is needed. For example, Vserver.vxd might not be needed when you start a laptop computer while it is out of its docking station.
 
VSHARE
------
If you examine the Bootlog.txt file, you will notice that VSHARE loaded successfully earlier in the boot process. The second copy of VSHARE detects that VSHARE is already loaded and does not load.
 
Font Failures
-------------
After the first boot of Windows 95, the Bootlog.txt file may list many font load failures. This is a normal occurrence. When Font Manager searches the hard disk for fonts, it may find them in several folders. After it finds them, it records the information so that future attempts to locate a font proceed more quickly.
 
InitCompleteFailed=SDVXD
------------------------
Windows 95 automatically loads a miniature disk cache to increase the speed of the boot process. When the boot process is complete, the miniature disk cache is unloaded from memory. When it is unloaded, the above line is added to the Bootlog.txt file to indicate that the miniature disk cache has been removed from memory.
 
This is normal behavior.
=======================================

4. As for the Loadfail for ATILCD, this appears to be a data library link for an ATI video card, but I haven't verified that yet.
Since several video card manufacturers use ATI's dll files it's hard to tell where this may be called from. What type of video card do you have?  This may take searching through your registry to locate where this is coming from.

5. The Loadfail, "dummy.lyt Failure code is 0002" is due to a damaged font file. You can deal with this in one of two ways, you can rebuild the font list (depending on what your using for a word processor as dummy.lyt is a non-standard windows font, or you can rename the dummy.lyt file to dummy.000 and then add the font from the original software package.

I think this gives you what you need except for the ATILCD issue, and to go forward with that, we need more info from you.
Dennis
0
 

Author Comment

by:echrist
ID: 1751827
I'll save the ATI.DLL problem for another date.  Thanks for all the help.
0
 
LVL 25

Expert Comment

by:dew_associates
ID: 1751828
Eric: What ever you choose is fine, we'll still help you here with the ATI issue!
Dennis
0

Featured Post

Free Trending Threat Insights Every Day

Enhance your security with threat intelligence from the web. Get trending threat insights on hackers, exploits, and suspicious IP addresses delivered to your inbox with our free Cyber Daily.

Join & Write a Comment

For a variety of reasons, it sometimes makes sense to reboot a Windows-based computer on a regular, perhaps daily basis. This "cures" a lot of ills by resetting processes, flushing caches, refreshing memory, and reestablish network connections. In a…
Recently Microsoft released a brand new function called CONCAT. It's supposed to replace its predecessor CONCATENATE. But how does it work? And what's new? In this article, we take a closer look at all of this - we even included an exercise file for…
Windows 8 comes with a dramatically different user interface known as Metro. Notably missing from the new interface is a Start button and Start Menu. Many users do not like it, much preferring the interface of earlier versions — Windows 7, Windows X…
The viewer will learn how to successfully create a multiboot device using the SARDU utility on Windows 7. Start the SARDU utility: Change the image directory to wherever you store your ISOs, this will prevent you from having 2 copies of an ISO wit…

707 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

12 Experts available now in Live!

Get 1:1 Help Now