Go Premium for a chance to win a PS4. Enter to Win

x
?
Solved

Setting the system clock.

Posted on 1997-11-17
4
Medium Priority
?
323 Views
Last Modified: 2013-12-15
My systemclock is always one hour more than it shall be.
It doesn't matter that I change it in control-panel (rh 4,3)
Here is a bit of my rc.sysinit. I think that I shall change something in it, but how ???
(I think that the -u is wrong.)

# Set the system clock.
echo -n "Setting clock"

ARC=0
UTC=0
if [ -f /etc/sysconfig/clock ]; then
    . /etc/sysconfig/clock

    # convert old style clock config to new values
    if [ "${CLOCKMODE}" = "GMT" ]; then
          UTC=true
    elif [ "${CLOCKMODE}" = "ARC" ]; then
          ARC=true
    fi
fi

CLOCKFLAGS="-a"
if [ $UTC = "true" ]; then
    CLOCKFLAGS="$CLOCKFLAGS -u";
    echo -n " (utc)"
fi
if [ $ARC = "true" ]; then
    CLOCKFLAGS="$CLOCKFLAGS -A";
    echo -n " (arc)"
fi
echo -n ": "
clock $CLOCKFLAGS

date# Set the system clock.
echo -n "Setting clock"

ARC=0
UTC=0
if [ -f /etc/sysconfig/clock ]; then
    . /etc/sysconfig/clock

    # convert old style clock config to new values
    if [ "${CLOCKMODE}" = "GMT" ]; then
          UTC=true
    elif [ "${CLOCKMODE}" = "ARC" ]; then
          ARC=true
    fi
fi

CLOCKFLAGS="-a"
if [ $UTC = "true" ]; then
    CLOCKFLAGS="$CLOCKFLAGS -u";
    echo -n " (utc)"
fi
if [ $ARC = "true" ]; then
    CLOCKFLAGS="$CLOCKFLAGS -A";
    echo -n " (arc)"
fi
echo -n ": "
clock $CLOCKFLAGS

date
0
Comment
Question by:n94magho
  • 2
  • 2
4 Comments
 
LVL 2

Accepted Solution

by:
bjacobs earned 120 total points
ID: 1630669
Set the time in your bios setup and remove the clock part fron rc.sysinit. Keep it simple.
0
 

Author Comment

by:n94magho
ID: 1630670
Mabe it's a good answer. Could you tell me what's good and whats bad with that???
(And I like to know how change in rc.sysinit anyway)


0
 
LVL 2

Expert Comment

by:bjacobs
ID: 1630671
Hello,
I run Slackware and don't have a rc.sysinit. Here is what is in rc.S which I think is the equivalent file:

if [ -x /sbin/clock ]; then
  /sbin/clock -s
fi

You would have to change to suit your clock program path or move clock to /sbin.
If you are in the U.S have you always had this problem of did it start when Daylight Savings time ended?

Hope this helps!
0
 

Author Comment

by:n94magho
ID: 1630672
Perfect. But I'm in sweden. The -u option seems to override my local time. (my timezone settings) Now it works perfect...
0

Featured Post

Get free NFR key for Veeam Availability Suite 9.5

Veeam is happy to provide a free NFR license (1 year, 2 sockets) to all certified IT Pros. The license allows for the non-production use of Veeam Availability Suite v9.5 in your home lab, without any feature limitations. It works for both VMware and Hyper-V environments

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

If you have a server on collocation with the super-fast CPU, that doesn't mean that you get it running at full power. Here is a preamble. When doing inventory of Linux servers, that I'm administering, I've found that some of them are running on l…
The purpose of this article is to demonstrate how we can use conditional statements using Python.
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.
This demo shows you how to set up the containerized NetScaler CPX with NetScaler Management and Analytics System in a non-routable Mesos/Marathon environment for use with Micro-Services applications.
Suggested Courses
Course of the Month10 days, 20 hours left to enroll

886 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question