Solved

Diskless Win95 Setup Problem

Posted on 1997-11-18
9
274 Views
Last Modified: 2013-12-16
I'm in the process of seting up diskless Win95 clients booting off on NT4.0 server.  I'm almost through the setup procedure (Win95 rebooting to complete the setup) and I get the following error message "Cannot find or load required file KRNL386.EXE. The path was not found."
I'm using a 486 machine there is a hard drive in it now.  I'm not using the bootrom yet I'm just trying to create a bootable diskette to create the bootimage.  I have a machines.ini with appropriate settings.  The registry is being set to the clients machine directory on NT server.  The bootup echos that the registry is transfered to the right location.  
I booted with a bootlog.txt and showed only four files that did not load:
loadfailed = ndis2sup.vxd
loadfailed = x:\system\vmm32\ebios.vxd
loadfailed = x:\system\vmm32\vshare.vxd
loadfailed = x:\system\vmm32\ebios.vxd

Now if the machine is a 486 would it need extended bios drivers?  I don't think so but I could be wrong.

Good luck boys and girls.
0
Comment
Question by:bleedinggums
  • 5
  • 4
9 Comments
 
LVL 25

Accepted Solution

by:
dew_associates earned 200 total points
ID: 1751841
Hi BG!

Let's deal with your load fails first, then the Krnl386.exe file. During the boot process, various system *.dll files call basic components, such as Ebios, Vshare etc to determine their applicability and availability.

During initial boot, Win.com, controls the initial checks and loading of the core Windows 95 components, while Vmm32.vxd
creates virtual machines and initiates VxD loading and System.ini is read for entries that differ from Registry entries

After all static VxDs are loaded, VMM32.VXD switches the processor to operate in protected mode, and the last phase of the boot process begins. This phase involves loading the protected-mode components of the operating system.

Loading Protected-Mode VxDs at Startup

The protected-mode Configuration Manager is initialized for importing configuration information from a Plug and Play BIOS (if available); otherwise, it develops the Plug and Play hardware tree by enumerating devices and loading dynamically loadable device drivers. These device drivers are identified by loading drivers from a specific directory.

The next phase resolves device resource conflicts for every device in the tree and then informs the devices of their configuration. When all devices have been enumerated, all conflicts have been resolved, and all devices have been initialized, Windows 95 is ready to be used.

In conjunction with the load fails;

Ebios
-----------
The extended BIOS driver did not find an extended BIOS, so it does not load.
 
Ndis2sup.vxd
------------
The NDIS 2 support driver did not find any NDIS 2 drivers to support, so it does not load.

Vshare
--------------
I think if you examine the Bootlog.txt file, you will notice that Vshare may have loaded successfully earlier in the boot process. The second copy of Vshare detects that Vshare is already loaded and does not load.
 
Krnl386.exe
--------------------

As you move through the boot process, the remaining Windows 95 system components are loaded in the following sequence:

KERNEL32.DLL provides the main Windows components, and KRNL386.EXE loads the Windows device drivers

GDI.EXE and GDI32.EXE provide the graphic device interface code

USER.EXE and USER32.EXE provide the user interface code

Associated resources, such as fonts, are loaded

WIN.INI values are checked

The shell and desktop components are loaded

****Your getting an error that states, "Cannot find or load required file KRNL386.EXE. The path was not found."

The path where Krnl386.exe should be is: \windows\system

You will have to determine the path that is being developed during the network install that windows is seeing. I suspect that Windows is looking back towards the server for this file -or- it is not being copied to the correct subdirectory.

Double check your setup and let me know if you need something further.

Best regards,
Dennis
0
 

Author Comment

by:bleedinggums
ID: 1751842
I have a couple questions regarding your answer:

To start the setup I connected to the server after booting into dos622 and net using a couple of shares.  I then start setup msbatch.inf via these shares.  When I got to the networking portion the adapter was ndis in use (paraphrasing), so I think that ndis2sup.vxd might be part of the problem.  I tried setting the adapter to SMCEtherEZ and I could create connect to the machine share on the server.  I also verified that the adapter resources were correct.

Next upon reboot on the floopy, I echo the path and at that point the path is:
PATH=X:\;X:\COMMAND;x:\system;x:\system\vmm32;d:\win001
net use X: \\CS1\WIN95
net use d: \\cs1\machines
so it should be finding the windows\system directory

Is it possible that after reboot the networking if failling and the shares aren't there anymore or it doesn't know about the shares?

What about when running netsetup copying using a drive instead of unc would that have set some registry values that are not the same with my client setup? (grasping at straws here)

Let me know.

Bleeding Gums
0
 

Author Comment

by:bleedinggums
ID: 1751843
A couple of spelling mistakes, should read:
I tried setting the adapter to SMCEtherEZ and I could NOT create a share to the machine share on the server.

Is it possible that after reboot the networking IS failling and the shares aren't there anymore or it doesn't know about the shares?

0
 
LVL 25

Expert Comment

by:dew_associates
ID: 1751844
BG, it looks to me that the net is dropping out on reboot. There's an easy way to check though. Take a look and see where your installing Krnl386.exe if at all. This may lead to a clue as to when or where the drop is occuring during the process. Since your load-in appears to be fine up to the point where Windows begins the GUI, I suspect that the dropout is occuring either just before or just after windows boots for the first time and the vxd's are being built, presuming that you are not push loading, but rather controlling the install from the server.

Yes, and it is possible networking is failing after the reboot, and it might be right as Windows sets up GUI.
Dennis
0
Do email signature updates give you a headache?

Do you feel like you are constantly making changes to email signatures? Are the images not formatting how you want them to? Want high-quality HTML signatures on all devices, including on mobiles and Macs? Then, let Exclaimer solve all your email signature problems today.

 

Author Comment

by:bleedinggums
ID: 1751845
OK

I tried booting into safe mode with network support and I got the following error:
"While initializing device VFBACKUP:
VFBACKUP could not load VFD.VXD.  Please run setup again."

So I booted into command prompt only and that completed properly.
At that point I wanted to look at the registry so I typed:
regedit /l:.\system.dat /e .\system.txt
I searched for \hkey_local_machine\root\net\0000
and it was not there which tells me the networking is not being setup properly.
microsoft answer to this is to reinstall, but I've done this more times than I care to remember and it hasn't changed jack...


In response to your last response all the files are in areas that should be accesible
win95\system\krnl386.exe
win95\system\vmm32\ebios.vxd
....
So when I boot off floppy it runs autoexec.bat asks me to log in, creates above shares, echoes path which includes above shares, transfer from micro registry on floppy to full registry on machine directory then craps out.

So where do I go from here?

0
 
LVL 25

Expert Comment

by:dew_associates
ID: 1751846
BG: There's 2 ways to handle this problem.

1. Would be to load the network inf files and drivers from Msbatch during the setup routine and just before the first boot into windows.

2. The other would be to create a setup on the machine and upload it to a server directory and push load it to the individual workstations (we push load here).

Let me know which flavor appeals to you!
Dennis
0
 

Author Comment

by:bleedinggums
ID: 1751847
Well Dennis

You're working hard to earn your points here.

Would there be problems doing 2 locally then switching to diskless after the fact?

I'll look into both options and see which one is better.

Thanks
0
 

Author Comment

by:bleedinggums
ID: 1751848
Dennis

SUCCESS!!!!

I tried loading adapter drivers from SMC and that would cause a GPF in SETUPX.DLL so for the hell of it I tried the SMC drivers that came with win95 again and this time it worked.  So know I can get it booting into Win95 off a floppy.  Next step is to create image and work from there.

Thanks for all the feedback, it's nice to be able to bounce ideas around.

I'll give full marks after I submit this

L8R
Bleeding Gums
0
 
LVL 25

Expert Comment

by:dew_associates
ID: 1751849
Okay BG: I'll wait on you!
Dennis
0

Featured Post

Too many email signature updates to deal with?

Do you feel like you are taking up all of your time constantly visiting users’ desks to make changes to email signatures? Wish you could manage all signatures from one central location, easily design them and deploy them quickly to users? Well, there is an easy way!

Join & Write a Comment

For a variety of reasons, it sometimes makes sense to reboot a Windows-based computer on a regular, perhaps daily basis. This "cures" a lot of ills by resetting processes, flushing caches, refreshing memory, and reestablish network connections. In a…
A few months ago I had an issue with LaserJet 1020 printer which was installed to XP and Windows 7.  It was installed to XP and working, but when I tried to connect from a Windows 7 PC, it would attempt connection and then fail.  Sometimes the Spool…
This video Micro Tutorial explains how to clone a hard drive using a commercial software product for Windows systems called Casper from Future Systems Solutions (FSS). Cloning makes an exact, complete copy of one hard disk drive (HDD) onto another d…
In this video, we discuss why the need for additional vertical screen space has become more important in recent years, namely, due to the transition in the marketplace of 4x3 computer screens to 16x9 and 16x10 screens (so-called widescreen format). …

757 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

20 Experts available now in Live!

Get 1:1 Help Now