Blank screen on PB 5300ce with MacOS 8

Posted on 1997-11-20
Last Modified: 2010-05-18


I just finished installing MacOS 8 on a Powerbook 5300ce. After restarting it I got a blank screen. For this I was
warned, because it is written in the "about MacOS 8" file. There it is written that restarting it again or initializing the
PRAM should help this. But after restarting it about 50 times or resetting the PRAM, still I get nothing on my screen. When I connect an
external screen to it I can see the machine is running fine, because I can see the desktop of MacOS 8 on the other screen
and also the mouse pointer is moving around.
Restarting from an installation diskette of an older system (7.5.2) does not change anything.

Can you help me please?

Thanks a million.

Question by:Raf_Br
  • 2
  • 2
  • 2
  • +1

Expert Comment

ID: 1537958
Have you turned up the brightness and contrast with the little buttons at the bottom right of the screen?  (I had this same problem on a 5300cs when going to 7.6.1 and it magically corrected itself after I booted it the second time.  Havent' put it up to OS8 yet though...)

Expert Comment

ID: 1537959
Did you use Drive Setup 1.3.1? Apple claims that the problems with Drive setup 1.3 do not affect this model, but Apple has a history of conflicting and/or missing documentation. ipierce is probably correct though.

Expert Comment

ID: 1537960
Did you use Drive Setup 1.3.1? Apple claims that the problems with Drive setup 1.3 do not affect this model, but Apple has a history of conflicting and/or missing documentation. ipierce is probably correct though.
Courses: Start Training Online With Pros, Today

Brush up on the basics or master the advanced techniques required to earn essential industry certifications, with Courses. Enroll in a course and start learning today. Training topics range from Android App Dev to the Xen Virtualization Platform.


Expert Comment

ID: 1537961
Since the system appears to be running fine with the external monitor, the problem is not the "flashing question mark" (though I would agree with TheHub to use Drive Setup 1.3.1).

Also, since the screen works if you revert to 7.6.1, it is clear there is not a problem with the hardware.

I believe the problem is in the assumed default monitor setting.  Use the Monitors and Sound Control Panel to ensure that the monitor color depth and size are compatible with the 5300.  THEN ALSO go into the ColorSynch Profile control panel and choose the monitor specification option for the 5300.  

Then shutdown the computer and unplug your external monitor before restarting the system.  Then do a couple of restarts AFTER completing the Color Synch specification before you make any attempt to reset PRAM.

Author Comment

ID: 1537962

according to the answers I received,it seems that I did not explain my problem correctly.
First of all, the screen does not display again when I start up with a diskette containing an older system. But the screen works, because it lights up when I start the computer
Secondly, changing the settings of the computer seem a little bit hard to do : the default settings on a PowerBook 5300ce for a second monitor is that he simply adds an extra desktop, not mirroring the desktop which is displayed on the PowerBook's own screen. So this second desktop does not contain the menubar or the Apple menu, and there is no way to change the settings. Because the menubar, the harddisk icon are on the other screen, but this one is not displaying anything.
To my opinion, the problem is the following : the PRAM settings are not the correct one, but in some way or another, the system is not detecting the right settings for the monitor and not writing them to the PRAM.
So I hope I explained my problem better this time and that somebody has any bright ideas to help me.


Accepted Solution

ipierce earned 100 total points
ID: 1537963
Try holding the reset button on the back (near all the ports) in for thirty seconds and then releasing it.  Then see if the screen will come on.  This is really just a guess since I'm not even sure if the 5300 series has a power manager, but it seems like you've tried everything else...I think you may have to take out the battery pack and the ac power for this to work.

Author Comment

ID: 1537964
I have tried the suggestion of ipierce, but without any succes. Anyway , thanks for the responce.


Featured Post

Gigs: Get Your Project Delivered by an Expert

Select from freelancers specializing in everything from database administration to programming, who have proven themselves as experts in their field. Hire the best, collaborate easily, pay securely and get projects done right.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Chroot Group Jail Help 8 52
Finder searched too broad a disk region 8 64
screenshot part of desktop and past to MS Office Word. 7 62
Reocurring Mac pop up message 7 93
In this article we will discuss some EI Capitan Mail app issues and provide some manual process to resolve them.
Set up iPhone and iPad email signatures to always send in high-quality HTML with this step-by step guide.
In this video I am going to show you how to back up and restore Office 365 mailboxes using CodeTwo Backup for Office 365. Learn more about the tool used in this video here: (…
Two types of users will appreciate AOMEI Backupper Pro: 1 - Those with PCIe drives (and haven't found cloning software that works on them). 2 - Those who want a fast clone of their boot drive (no re-boots needed) and it can clone your drive wh…

813 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

11 Experts available now in Live!

Get 1:1 Help Now