Solved

Links Ls locking up due to sound card problem

Posted on 1997-11-21
28
252 Views
Last Modified: 2013-12-26
I have LS 98 V1.32 and Direct X5. When I first get the player to swing, as soon as you hear the Swoosh sound the computer locks up. I have an old SB16 sound card that normaly works fine with other games + apps.
0
Comment
Question by:gordm
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 10
  • 9
  • 8
  • +1
28 Comments
 

Expert Comment

by:larockd
ID: 1101735
Did you check to make sure your settings for sound under LS 98 match the settings for your board.  This problem has happened to me under other games, because the wrong dma channel was selected...

0
 

Author Comment

by:gordm
ID: 1101736
Don't know how to manualy set DMA channel in Links LS98. However,  other games are locking up during play like Panzer General II (at introduction) Jack nicklaus 4 (@ bottom of swing as in LS and  my old problem with C&C Red Alert is happening again. It will not get past PLEASE WAIT message at begining of game. HELP!!
0
 

Expert Comment

by:larockd
ID: 1101737
Thanks For Mentioning that other games are locking up also.  
Did you recently add something new to the system?  Did you ever have this sound card working before?  When did you notice it start locking up?  After you installed what piece of hardware or game?  Did you install any service packs, driver updates, make any configuration changes?

0
Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 

Author Comment

by:gordm
ID: 1101738
Yes I replaced Motherboard with and ASUS TX97, Proccessor with a P200 MMX and changed to 32MB SD RAM.Changed to a new Video card as well (ATI expert@Play 4MB). Sound card worked on old system 100%. Started locking up after installation of new components. Installed DirectX 5.
0
 
LVL 7

Expert Comment

by:busuka
ID: 1101739
Do you know that after installation you MUST wipe out Win95 and
reinstall it from scratch. You may experience all sorts of crashes,
lockups and weird behaviour. Usual way is bring DOS prompt (pure
DOS) and from Win95 CD run: setup /d /p f
0
 
LVL 7

Expert Comment

by:busuka
ID: 1101740
Yeah, and don't leap on DX5. It's still buggy. Stick with DX3
0
 

Expert Comment

by:larockd
ID: 1101741
Nww it makes sense.  Go figure I have the same motherboard and chip..  I like it too...  What I would do now as gordm has suggested is reinstall windows 95.  If a simple reinstallation doesnt help I would format the old hard drive and start over...

0
 

Author Comment

by:gordm
ID: 1101742
I reinstalled Windows 95 2 or 3 times to try and get it to work. Also completely formated my harddrive. I would like to get rid of DirectX5 but some of my newer games say that they need it to run properly. i.e. Links LS98 v1.3 Jack Nicklaus golf V4. Do you think that a new AWE64 Sound Blaster card would fix my problems?
0
 
LVL 7

Expert Comment

by:busuka
ID: 1101743
Hmm, I still think that it's DX5 failure. I have Total Annihilation
and ran it flawless with DX3 (however it complains on startup).
BTW, I heard rumor, that Micro$oft updated DX5 pack on their site
to less buggy one (I'm not going to take that either).
0
 

Expert Comment

by:larockd
ID: 1101744
Hey Gord...
I upgraded myself to an AWE64 gold "value edition" card, I have the same motherboard as you and everything runs beautiful.  I do suggest the upgrade to the card.  However, your SB16 card should work just fine.  I have been running dx5 here for awhile and it runs fine.  I haven't had any problems with it myself..  Yes, microsoft did update directx5, they have a patch called directplay something or other...



0
 

Author Comment

by:gordm
ID: 1101745
Just one last note to this seemingly impossible fix. I did have directX 3 running during initial upgrade for about 1 week and had the same problem. I even experienced a lockup last night while surfing with Internet Explorer 4.0 were by as soon as a sound started to play from a Web page my system locked up.
0
 
LVL 7

Expert Comment

by:busuka
ID: 1101746
Ahh, infamous IE4 :)
To larockd: you have IE4 installed ?
Gordm, you have some background-type system agent, like antivirus or
Norton's Crashguard ?
0
 

Author Comment

by:gordm
ID: 1101747
I have the ATI Icon for my Vdeo card and Quick Res running thats about it.
0
 

Expert Comment

by:larockd
ID: 1101748
Busuka -> no, I havent installed IE4 yet, I am a Netscape man myself (running communicator).  Once they have had it out for awhile (IE4) and pressed out most of the bugs I will install it.  
Gord..  In the system properties, what devices are listed under sound, and what are there settings?  The old SB16 cards (atleast) my old SB16 requires jumpers to be set on the card unlike my new SB AWE.  A thought here is maybe win95 is trying to set the card via plug and play to another configuration then what the cards actual jumpers are set to.  It would do this because it detects that the irq you have the card set to is in use and therefor couldnt possibly use it...  Let me know...
0
 

Author Comment

by:gordm
ID: 1101749
Yes my SB16 is OLD (5-6 years old). Here are my settings as of today under sound,video,game controllers.

Creative Sound Blaster 16 or AWE-32

Properties-General
-Device Type: Sound,Video,Game Controller
-Manufacturer: Creative
-Hardware Version: N/A
Device Status:This Device is Working Properly
Device Usage: Check Mark beside - Origional Configuration Current

Settings
-allow full duplex is Not Checked

Driver
-too may files to list
-Provider:Creative Technology Ltd.
-File Version 1.01.0

Resources

input/output range   0220-022F
input/output range   0330-0331
interupt request        05
direct memory access    01
direct memory access    05

Settings Based on (Basic Configuration 4)

Conflict Device List:
No Conflicts  


0
 

Expert Comment

by:larockd
ID: 1101750
Now, what are the jumper configurations for the card, you will probably have to remove the card to see what the actual jumpers are set to.

PS.  Does your sound under windows 95 work with out any problems?  Playing wav files and such?

PS.  Happy late Thanksgiving..

darrell
0
 
LVL 7

Expert Comment

by:busuka
ID: 1101751
Gordm, do you have Wavetable driver in list of sound drivers ?
AWE, something ?
0
 

Author Comment

by:gordm
ID: 1101752
Well I may have found part of the problem myself. After buying a AWE64 Value sound card I reinstalled Windows 95 using a 3 1/2 floppy version. At startup it made reference to a possible problem with my hard drive configuration. It looks like I was setting up my WD Caviar 2.1 Gig HD without LBA. After a bit of reading I found out that if you set up Wester Digital EIDE hard drives without LBA it can cause corruption of files. So I reset to LBA Mode for the drive and everything works great EXCEPT LINKS LS98:(( The sound still locks the computer up at very begining. By the way I checked all the jumper settings on my old SB16 after I replaced it and everything was fine. I then found my old version of Links LS97 and installed that. It works great and actually runs faster than 98 ever ran. So I have no problems now but I do have a LS98 game for sale. If you can now figure out what may be causing 98 to lock up I am still more than interested in getting it to work.
0
 
LVL 7

Expert Comment

by:busuka
ID: 1101753
If you want to remove a question, change ShowQ to DeleteQ and
open this link.
0
 

Expert Comment

by:larockd
ID: 1101754
Have you contacted the maker of links?  I have links 98, and it runs fine with my sb awe.

DArrell
0
 
LVL 1

Accepted Solution

by:
jsouth earned 130 total points
ID: 1101755
That all seemed to complex. Why don't you start with the simple thing and make sure that your games all configured for the right kind of sound system.
If that doesn't working make sure your sound card is in the same port that your computer says it is in.
If that doesn't work, I'm not sure.
0
 

Expert Comment

by:larockd
ID: 1101756
Nice answer Jsouth...
If you looked at the question history you would have seen that the first comment covered making sure the game was setup properly??  And the history all covers making sure that the card is setup properly via windows and jumper specific on the card..

Not that it matters to me....
0
 

Author Comment

by:gordm
ID: 1101757
I did a clean install last night with freshly formatted drive and installed software for AWE64 and ATI exprt@play. Installed only Red Alert for Win95 and the friggin game locked up right away before the opening screen came up. I did read a blurb in the Red Alert manual that stated that some video cards say they support 640X400 (Yes 400) resolution but actualy dont. Also one other addittion that may help. When I finish installing Win95 I get an error message that says that the onboard PCI controller has detected MS Dos compatability mode file drivers of file system and that because of this both the CD ROM and the harddrive have to use MS-DOS compatability mode file system. Could this be causing games like Mechwarrior II, Mechwarrior Mercenaries and Links LS97 that are actually MS-DOS base platforms to work fine on my computer while Win95 based games such as C&C Red Alert, Links LS98 and Jack Nicklaus 4 to lock up??

Getting desparate
0
 
LVL 7

Expert Comment

by:busuka
ID: 1101758
DOS based games will work fine, I suspect a virus, or:
TADA !!!
You have OSR2 right ? Anyway, do the following:
1) open the case of computer
2) pull out SB card (yes, yes)
3) install Win95 *from scratch*
4) check that all installed OK and HD work in normal 32-bit mode
5) insert SB card back, start Win95
6) install SB drivers and software

OSR2 install busmaster drivers for PCI HD controller, they
conflicts with SB card.
0
 

Author Comment

by:gordm
ID: 1101759
I will try that busuka.Another question. Could the MS-DOS compatability Mode File system be preventing my CD ROM from being recognized in the Systems/Hardware profiles area of Control Panel? It is not there. And Auto Play has not worked since upgrade either. I'll be back in a while.

Gord
0
 
LVL 7

Expert Comment

by:busuka
ID: 1101760
Yes, when your CONTROLLER switched to compatibility mode (16-bit)
real-mode driver (SYS and MSCDEX) required to access CD-ROM.
Is your CD-ROM on secondary IDE port ?
0
 

Author Comment

by:gordm
ID: 1101761
OK tried your last suggestion of taking AWE64 out and reloading WIN95 but ended up with same error message again. Should I type out complete error message for you or have you seen it before?

When I go to install Win95 from CD and formatted HD I have to do the following:

1. CD ROM shows at startup that it is detected (Pioneer 10X DR-411), but it will not show as D: drive after bootup complete.

2. System needs a bootable floppy @ startup to access A:  so I install MS-DOS 6.0 so that I can get to the C: prompt at startup. If I don't install dos I get an error saying non system disk.

3. So I get to C: and insert CD ROM driver disk in A: and install driver.

4. I restart and D: is now alive. I Install Win95 and reboot 2 times then I get the 32-bit drive error on a blue screen. I am forced to reboot and the computer wants to start in safe mode. I do this and restart WIn95 it opens up fine and I still have no sign of CD ROM in Hardware profiles and it will not auto detect and C: and D: are in MS-DOS Compatability mode.

Am I installing CD ROM incorrectly.

My CD ROM is hooked up to secondary IDE port with its own cable and shows at startup as secondary slave MODE 3


0
 
LVL 7

Expert Comment

by:busuka
ID: 1101762
First: set your CD-ROM as Master, if you don't have already HD on
secondary IDE line. ATAPI standard dictates, that ATA (IDE) device
MUST be set to Master/Single if it only one on IDE line.
Second: in BIOS setup you can set Secondary (master/slave) as None
Win95 doesnt need BIOS detection and I suspect that this can bring
a mess.

BTW, you know that when you switch mode (Normal,LBA) on HD you MUST
reformat it ?
You can prepare startup floppy from DOS 6.22. Only things you need are:
Files: SYS driver for you CD-ROM (say ATAPI.SYS), MSCDEX.EXE
Create CONFIG.SYS with
device=ATAPI.SYS /D:MSCD001

Then in AUTOEXEC.BAT:
MSCDEX /D:MSCD001 /V

Boot from this floppy (assuming you have freshly formatted HD and
SB card is rest on table unplugged :). Now you have access to CD
(master on secondary IDE port). Try to setup Win95. If you got it
unsuccesseful, don't enter Safe Mode, instead try BOOTLOG.TXT
option. Post its failed lines and last couple of lines.

Last: if you still get HD in compatibility mode, this is firm sign
that you have boot virus. Try to check for one (I recommend F-PROT 2.28)
 
0

Featured Post

Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Article by: Joseph
CONTENTS I.      What is a MOBA?   a. Definition   b. Origin   c. Current Generation II. The New Games   a. League of Legends   b. Heroes of Newerth   c. Dota 2   d. Smite III. Comparison IV. Conclusion ------------------------…
As we all know Counter Strike is a very popular computer game. Usually it is played over a network for which people create a server and users join it but it is interesting to know that one can creates a dedicated server which not only hosts the game…
How to Install VMware Tools in Red Hat Enterprise Linux 6.4 (RHEL 6.4) Step-by-Step Tutorial

751 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question