Solved

Line drops after connection

Posted on 1997-11-25
24
458 Views
Last Modified: 2013-12-27
OK, first off, I am a semi-neophyte with Macs, but I am very familiar with Unix, OS/2, MS Win, etc and modems and all that.  However, this one on the "simple" Mac has me scratching my head.

My wife has a Mac Performa 475 (68LC040) with 36 mb RAM and MacOS 7.6.1.  The modem is an external US Robotics Sportster Voice 33.6, the special Mac variety.  No special modem software is installed, since my wife primarily uses (shudder) AOL for email.  We used to use a 14.4 kb modem which also exhibited this same problem, but less frequently (faster modems fail quicker, perhaps?...)  In addition, just to confuse life a little further, I have installed FreePPP 2.5.2 so we can contact my ISP (Earthlink).

OK, here is the problem:  Whether you use AOL or FreePPP, the connection is usually at some low speed (9600, 12000, 16000, etc).  Then the connection only holds on for a minute or two before the line drops spontaneously.  With AOL's eternal connect delays, this often means that we don't even complete the connection ritual before it goes away.  With Earthlink, you can get Netscape or Eudora running and try to check mail or something before it drops.

I have watched the modem lights, and I notice that the Send Data light blinks every second or so, but the Receive Data light does not blink in return, just before it gives up.  I suspect some sort of protocol/handshake problem here, but have no idea where to look for clues.  The modem settings specify 8N1, RTS/CTS, and 57600 baud.

I called AOL tech support, and the guy there said to check the Extensions folder for anything having to do with communications, and disable anything that was not needed.  I don't know what OT is all about, so I left that alone.  Is it necessary in order to use FreePPP and/or AOL?  Is it a substitute for those, or what?  More importantly, can someone give me some guidance on how to track down this line-drop problem?

Thanks

Justin Harlow
0
Comment
Question by:harlow
  • 9
  • 3
  • 3
  • +8
24 Comments
 
LVL 6

Expert Comment

by:TheHub
ID: 1542373
You need OT 1.1.2, TCP/IP, AppleTalk and FreePPP 2.5.3 or later. The OpenTransport upgrade can be downloaded from Apple at:
http://support.info.apple.com/ftp/swhome.html
Run the OT 1.1.2 installer with all extensions on (exactly backwards).

Root around in FreePPP Setup. Check the box:
Check line every [20 seconds]
Uncheck the box:
Disconnect if idle for [greyed out]
Set AutoDetect init string

Set AppleTalk to the port that the modem is NOT plugged into.
Set TCP/IP to FreePPP using PPP server (enter other relevant info like your isp addr).

-GoodLuck, TheHub
0
 
LVL 5

Expert Comment

by:paulvaneykelen
ID: 1542374
I downloaded OT 1.1.2, but was unable to install it.  It consists of 4 disk images, and each one reports a checksum error when I try to open or mount them.  I blew them away, downloaded them again, and repeated the process, with identical results.  I tried overriding the checksum error, but the install died.  I can't keep the line up long enough to download the full 5+ mb installation file, so I'm stumped.  Any ideas how I can install this?

I did download FreePPP 2.5.3 (which, by the way, reports itself as 2.5v2), and it is much nicer, but I don't see any behavior changes.

Since originally asking this question, I have had numerous dialogs with Earthlink about the problem.  I think we have the modem setup and dialer setup OK now, but the symptoms now seem to focus squarely on OT and/or MacOS 7.6.1.  I have discovered that I can get connected and use Netscape 3.0 to go to several URLs successfully.  However, the data transfer rate visibly "slows down" as I go to more sites, eventually showing transfers down to about 10 bytes/sec and then reporting that the DNS queries are timing out.  Rebooting doesn't seem to help, but powering it all the way down does: it returns to good performance and then bogs down again.

I am now pretty convinced that the line drops have to do with timeouts, which are apparently due to this slowdown phenomenon. One thing I tried was upping the memory for netscape to about 10 mb (it wants 5.7 mb).  This provided an amazing performance increase for a while, but eventually it bogged down just like before. I am thinking now that there may be a memory leak or something in OT or MacOS.  

PS:  I tried the same modem and setup  on my daughter's Mac, which runs MacOS 7.5, FreePPP 2.5v2, and MacTCP 2.0.6.  Everything works fine on this system, which again, seems to point the finger at OT and/or MacOS 7.6.1.

JEH
0
 

Author Comment

by:harlow
ID: 1542375
FreePPP 2.5v3 reports itself as v2 on my computer too.  Don't worry.  If you try to patch it to v3, it says that the resources have already been patched to v3.
0
 
LVL 3

Expert Comment

by:caeisenb
ID: 1542376
I still haven't got this resolved.  OT 1.1.2 refuses to install.  Diskcopy 6.1.3 reports that the checksum is wrong on all four disk images (it computes zero, and shows the presumably correct hex value).  I can disable checksum evaluation and mount the four images, but the install gets right to the end and aborts with "Install encountered an error; your system disk has been left unchanged".  Of course there is no hint as to what the error is, so there seems to be no diagnosis or recovery possible.  

Short of reinstalling MacOS from the ground up, does anyone have any ideas what I can do here?

I'll raise the ante on this complicated set of issues.  For anyone who joins the fray because of the additional points, please review the whole dialog.  I have done everything that has been suggested here, but still can't get things to work right.

Thanks
0
 

Author Comment

by:harlow
ID: 1542377
This might work:  Use your daughter's mac to download OT 1.1.2, then install that on the wife's machine.  I feel your pain.  Strangely I had the opposite problem and coulnd't reach internet under 7.5.5 but got there with no problems using 7.6.1.
0
 
LVL 2

Expert Comment

by:ipierce
ID: 1542378
Actually, I did manage to download it (on a PC...) and bring it over to the Mac using floppies.  The problem comes when I try to install it: DiskCopy reports a bad checksum on each image, with exactly the same problem:  it says it computes a zero checksum, and lists the checksum on the image.  I don't think this has to do with the way the images were imported; they were all .hqx files, which restore as .sea files, which then turn into image files.  All of that worked just fine with no hints of trouble.

I can ignore the checksums and mount the images, which appear to be perfectly normal.  The installer runs normally right up to the last moment, when it reports that it has a problem and bails out.  Sure wish I knew what its problem is; the message gives no hint at all.

I think I'm gonna punt and install MacOS 8.  That will probably confuse the issue even further....
0
 

Author Comment

by:harlow
ID: 1542379
Many of the older Macs work better with a slower serial port setting.  try 38.4 and see if that helps.  You will also need to verify you are usign a HWH cable, and not X-On/Off flow control.  It sounds like your problem is flow control related.  Make sure you have the proper cable, and set your nram in your modem to use hardware chanshaking (CTS/RTS) and not Xon/Off flow control.  Computer stores should carry a "High Speed Modem Cable" for your Mac which is a hardware handshakling cable.  Most of the older cables out there are not wired for hardware handshaking.  Good luck.
0
 
LVL 2

Expert Comment

by:lmar
ID: 1542380
I've definitely got a HW handshake cable, and I'm definitely using RTS/CTS flow control.  I'll check the serial port speed; I think I'm already at 38.4; wouldn't want to go any lower though, since it's a 33.6Kb modem.
0
 

Author Comment

by:harlow
ID: 1542381
RTS/CTS is also a nram setting, so you want to go into the modems nram and verify (using something like Zterm)
0
 
LVL 2

Expert Comment

by:lmar
ID: 1542382
Also, verify there is no fax or other software mapping to the com port, when more than one app grabs the comm port, wierd things happen.
0
 
LVL 2

Expert Comment

by:lmar
ID: 1542383
OK, here's where my lack of Mac depth shows.  What's an nram?  Is that the nonvolatile RAM in the modem itself, or something in the Mac?  If it's the former, I think I am OK; this particular modem (USR Sportster Voice for Mac) comes with factory profiles which are supposed to eliminate all the usual AT-hacking one does to get a complex modem working.   AT&F0 gives you the XON/XOFF setup, and AT&F1 gives you the RTS/CTS flavor; each of these profiles allegedly sets up everything optimally for the style of flow control involved.  However, it never hurts to check.  I'll dump all the settings and see what it is actually giving me.

Thanks

0
 

Author Comment

by:harlow
ID: 1542384
Based on the way lmar phrased it nram means the modems settings (i.e. the at command settings, etc.)  You had mentioned earlier upgrading to OS8.  If you do that MAKE SURE TO DO A CLEAN INSTALL or it really will get ugly!  The Apple Internet Connecttion Kit which comes with os8 works pretty well in my opinion.  This may be the easiest sol. for you since you can't seem to get OT1.1.2 installed.
0
IT, Stop Being Called Into Every Meeting

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

 
LVL 2

Expert Comment

by:ipierce
ID: 1542385
I had the same problem with a PowerMac 7300, using 7.5.5, and a USRobotics 28.8. Once I thought about it for a few days, I solved the problem simply by increasing the memory size for FreePPP to 500k, instead of the default 210k. It has been working smoothly for about 4 months now.
0
 

Expert Comment

by:eribac
ID: 1542386
I like eribac's idea.  Upping the memory helps lots of programs run more smoothly, such as desktop printing, and netscape.  just my 2 cents.
0
 
LVL 2

Expert Comment

by:ipierce
ID: 1542387
Get OS8 - 7.6.1 gave me nothing but nightmares with the internet. OS8 has PPP that works!
0
 

Expert Comment

by:lammons
ID: 1542388
As a matter of fact, I did a clean install of MacOS 8 this weekend and....   same thing!  It connects fine, runs for a while, but things slow down over a period of about 5-10 minutes, and then I start getting messages like "no DNS entry for URL" or "PPP connection lost".  If I immediately reconnect, it is invariably at a slower baud rate.  This repeats for several cycles of connect-drop-reconnect until I get to a point where it won't even complete the PPP negotiation.  Rebooting doesn't help, but shutting off power and restarting restores things to their original condition: I get a connection at 28.8 or above, and then the whole thing happens again.

This is driving me nuts!  I have upped the memory available to FreePPP, Netscape, Eudora, etc; I have reinstalled the OS; what else is there?

JEH
0
 

Author Comment

by:harlow
ID: 1542389
one thing that it could be is your phone line. Sometimes the line has alot of noise on it and you can't connect fast try unpluging any phones that have external power suplies

0
 

Expert Comment

by:crashoverride
ID: 1542390
This whole thing seems to be going nowhere.  None of the answers and suggestions seem to have gotten me any closer to a solution.  Thanks very much to all of you who have helped.  I am reopening this one in hopes of drawing in some additional ideas from others.

JEH
0
 

Author Comment

by:harlow
ID: 1542391
I have had similar problems on a Quadra 605 (68LC040). I found that using Classic Networking (TCP/IP) with Free PPP and Open Transport with OT/PPP to be stable, but I get the described problems when mixing Free PPP with Open Transport on the Quadra 605. Recommend downloading OT/PPP 1.0 from Apple and sticking with Open Transport. OT has better performance than Classic Networking, but Classic Networking is more stable on the 68LC040. Control over networking is available in the Apple Extras Folder with an application called "Network Selection" or similar title. I have moved this file to the Control Panels Folder for convience even though it is not a control panel.
0
 
LVL 1

Accepted Solution

by:
jbman earned 200 total points
ID: 1542392
Let me see if I understand what you are saying...

Do you recommend running Apple's PPP with OT, and not using FreePPP?  If that's the right interpretation, what do I have to turn on, turn off, disable, delete, etc. to get to this configuration under MacOS 8?  I am still mystified by all these interlocking options on the allegedly "simple" Mac.

Thanks

JEH
0
 

Author Comment

by:harlow
ID: 1542393
Do you get this problem, after a clean install of the OS, but before installing the AOL software?

Try your Earthlink account before installing AOL.

I would recommend using OT/PPP 1.0., not FreePPP.

I use a SE/30 (68030, 20MB) with the same modem, System 7.5.5, OT, OT/PPP, serial port set at 57600bps with excellent results.

No AOL though...

Good luck,

Richard

0
 
LVL 1

Expert Comment

by:birchallr
ID: 1542394
I did a clean install of MacOS 8.0 a while back and switched over to OT/PPP.  It seemed to help some, but I still seem to have the slow-death effect; it just takes longer to happen.  

I think you may be on to something with the AOL comments though.  We are no longer using AOL at all, so I am going to poke around and look for any extensions and other sneaky stuff they may have stuck in there.  Stay tuned....
0
 

Author Comment

by:harlow
ID: 1542395
Look for an extension named "AOLink".

Also try resetting the PRAM memory; hold down Option-Command-P-R as the Mac restarts.  (Command is the key with the cloverleaf symbol on it)

Be sure to remove OpenOT and ObjectSupportLib. These are the extensions not needed for OS 8 (and the source of potential trouble).





0
 
LVL 1

Expert Comment

by:birchallr
ID: 1542396
OK, I nuked all the extraneous extensions, and things appear to be working OK now (keep fingers crossed....)

To all of you who made suggestions and provided helpful inputs on this saga, I offer my sincerest thanks.  Your patience and support have been invaluable; Experts Exchange is the greatest!

0

Featured Post

What Security Threats Are You Missing?

Enhance your security with threat intelligence from the web. Get trending threat insights on hackers, exploits, and suspicious IP addresses delivered to your inbox with our free Cyber Daily.

Join & Write a Comment

Apple's line of laptop computers has made significant strides forward in the last few years. The biggest change being the switch to Intel processors in 2005. One thing about Apple hardware, especially that from a few years ago, is the tendency for i…
How can this article save you time AND money?  In just a few minutes you may discover something you didn't know existed that is easy enough for you to fix yourself!
Excel styles will make formatting consistent and let you apply and change formatting faster. In this tutorial, you'll learn how to use Excel's built-in styles, how to modify styles, and how to create your own. You'll also learn how to use your custo…
When you create an app prototype with Adobe XD, you can insert system screens -- sharing or Control Center, for example -- with just a few clicks. This video shows you how. You can take the full course on Experts Exchange at http://bit.ly/XDcourse.

760 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

21 Experts available now in Live!

Get 1:1 Help Now