Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people, just like you, are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
Solved

Getting PPP running on Redhat 4.1

Posted on 1997-11-25
3
227 Views
Last Modified: 2012-05-04
I have just installed RedHat Linux 4.1 on a new system, and can't seem to get networking going.  On my previous system, I managed to get it going by trial and error hacking, but would like to do it "right" this time (especially since I can't remember what I did before!).  

My initial kernel build had modules enabled; I got the old favorite problem with incompatible versions and undefined symbols in modules, and finally in disgust, disabled the modular kernel stuff and compiled everything right into the bloody kernel.  

I used RedHat's control panel for network setup and configured a ppp0 device as per instructions.  I made sure I had the loopback device configured, and made sure that networking was enabled in the kernel.  

On my previous system, I used Dip to dial up my ISP;  I am using the exact same script on this system, which dials and connects uneventfully.  However, when it gets to the very last step, switching to PPP mode, it drops the line.  I tried going through the whole procedure manually so I could see the dialog, and all looks normal.  I suspect that Dip is unable to make a socket connection or whtever the kernel uses, and bails out, but that is only a guess.

BTW, I have OS/2 installed in another partition on this system, and it connects happily to the same ISP through the same modem;  therefore, I am quite sure I am dealing with a Linux configuration issue here, not a hardware problem.

Any ideas?  What should I check?

Thanks

Justin Harlow
0
Comment
Question by:harlow
3 Comments
 
LVL 1

Accepted Solution

by:
demiurg earned 100 total points
ID: 1586973
recompile your kernel with TCP/IP networking enabled,
as well as PPP. BTW, you can make them modules if you
install kerneld and make "make modules; make modules_install"
afterward. Then write a simple script for "chat" (from "pppd")
or send me your email and I'll send you mine as attachemnt,
but this should not be necessary - it's rather simple
0
 
LVL 2

Expert Comment

by:frowijn
ID: 1586974
You can also make a PPP script in the /usr/doc/ppp-...../scripts/ppp-on
Edit this file with the appropiate numbers and launch it with
./ppp-on, check first on what device your modem is !

0
 

Author Comment

by:harlow
ID: 1586975
Thanks to all.  I went back to square 1 and rebuilt the kernel.  This time, I enabled some of the network things (e.g. Ethernet) that I had disabled before, and pretty much let it have its way on defaults.  Now it seems to work fine, although I really don't know which of the changes made the difference.  Oh well...
0

Featured Post

Master Your Team's Linux and Cloud Stack

Come see why top tech companies like Mailchimp and Media Temple use Linux Academy to build their employee training programs.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
url shaping application 8 59
ACK Attack 5 61
IPA - change main server? 3 150
Website content filtering at different level 5 84
I have seen several blogs and forum entries elsewhere state that because NTFS volumes do not support linux ownership or permissions, they cannot be used for anonymous ftp upload through the vsftpd program.   IT can be done and here's how to get i…
Note: for this to work properly you need to use a Cross-Over network cable. 1. Connect both servers S1 and S2 on the second network slots respectively. Note that you can use the 1st slots but usually these would be occupied by the Service Provide…

829 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question