Kernel 2.0.32 can't find my eth0

I'd like to upgrade my Linux to 2.0.32 from 2.0.27. However, the new kernel I complied with network card option enabled could't find my eht0, which works perfect under 2.0.27. Any one know how to fix the problem?
Here is the fragment of boot log for 2.0.27:

Nov 26 11:25:52 pooh kernel: ne.c:v1.10 9/23/94 Donald Becker (becker@cesdis.gsfc.nasa.gov)
Nov 26 11:25:52 pooh kernel: NE*000 ethercard probe at 0x220: 00 a0 76 c0 1e 07
Nov 26 11:25:52 pooh kernel: eth0: NE2000 found at 0x220, using IRQ 5.

And I saw the error message like: Delay initializing eth0. when the system boot up.

Thanks for your help.
yxw1Asked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

yxw1Author Commented:
Adjusted points to 85
0
XMSCommented:
1) Have you compiled your netcard driver as a module ?

2) Do you have more than one netcard driver compiled in the kernel ?

3) Try appending "ether=5,0x220,eth0" to the kernel boot parameters (either manually at boot time, during testing, or using the "append" option in /etc/lilo.conf , to disable netcard auto-probing.

Good luck.

0
df020797Commented:
Its obvious the netcard is found by the kernel... somehow ot wasnt initialized.

I dont think its wise to have the card at IRQ 5 and I/O adress 0x220 hence this normally is the resources for the soundcard.
 
I suggest you change IRQ to 10 and I/O adress to 0x300 on the network card and see if it solves the problem.

Is doesnt help check:

Is your networkcard support compiled as a module?
If it is, recompile the kenrel and include the driver into the kernel directly, no modules.

Go into the /etc/lilo.conf and enter:
append = "ether=10,0x300,eth0" to hard probe that adress.
Then if you continue moving round the cardsresources, always update the lilo.conf file

G'luck!

0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux Networking

From novice to tech pro — start learning today.