Solved

TX430 FLASH BIOS UPGRADE PROBLEM

Posted on 1997-11-26
14
262 Views
Last Modified: 2013-12-16
I have tried to upgrade my QDI board BIOS, the board is TX430 Titanium I Motherboard. I have tried to upgrade bios to version 2.4 fro version 2.2  but it seems that something must be wrong with the bios upgrade because it just blocked out and I had no other alternative than to reset computer.. After reset it gives a strange sound but I can't have video or anything else. Flash upgrade just started (some 10% finished maybe) before it blocked out so I think that BIOS is gone. Is there any way to recover my BIOS? I heard that there's some way with the recovery disc but I don't know the procedure.

P.S. Is there way to upgrade VX boards? I found out a way to upgrade TX board even if flash bios is damaged... but is there such util for VX boards..

PLEASE DON'T SEND ME ANSWERS LIKE: CONTACT THE MANUFACTURER OR RETAILER etc..

TX board has emergancy recovery procedure.. you can just insert bootable disk with BIOS on and upgrade BIOS (there's no video but you can do it by looking at the lights and listening to speaker)

None of the answers so far included this option! It seems that the guy's that were answering this never heard of it...

Thnx.
0
Comment
Question by:dpavusin
  • 6
  • 4
  • 2
  • +2
14 Comments
 
LVL 6

Expert Comment

by:joe_massimino
ID: 1752093
There is usually a prgram on the disk and a copy of the original BIOS. It shouldn't be hard to figure it out, and there should be a readme file on it.  Have you taken a look at  what files are on the disk?

0
 

Expert Comment

by:TMS
ID: 1752094
Is the computer able to boot ?
if not, guess you're out of luck, how will you boot on the upgrade disk and re-write the backup file (if it exists) when the computer's bios is so  messed up that the computer won't boot...
Well, this is not going to help. Some motherboards have a 'freshen rebuld BIOS' jumper (but they are rare). Check your maual, or with your dealer...
0
 
LVL 6

Expert Comment

by:joe_massimino
ID: 1752095
Good point, I would contact the manufacture.
0
 
LVL 7

Expert Comment

by:busuka
ID: 1752096
Usually, if you have failed flash and you not able to boot DOS and
run simple program, you doomed :(_
Only option here is take out BIOS chip and replace it with normal
one from manufacturer.
0
 
LVL 4

Author Comment

by:dpavusin
ID: 1752097
Edited text of question
0
 
LVL 4

Author Comment

by:dpavusin
ID: 1752098
Edited text of question
0
 
LVL 25

Expert Comment

by:dew_associates
ID: 1752099
Dpavusin:

1. Make sure the system is shut down and unplug the power cord.

2. Look in your motherboard setup booklet and identify the Cmos clear pins and then close a jumper on the pins to clear the Cmos setup and return the board to its defaults, then return the pins to their original configuration.

3. Plug the power cord back in.

4. Insert the Bios upgrade disk in your floppy drive, hold the shift key down and start the computer. Hold the shift key until your motherboard accesses the floppy and reloads the Bios and completes the update.

5. After the update has completed, restart the system normally and boot to the Bios setup and make the changes you desire, save it and let your system boot normally.

If you have a problem, let me know.
Dennis
0
How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

 
LVL 4

Author Comment

by:dpavusin
ID: 1752100
I liked proposed solution from dew associates but, is this solution generally for all board or only for TX or VX board?

I know the procedure to freshen TX board, but I have problem with VX board.. I went to my hardware dealer and replaced the BIOS wit new ver. 1.3 (this is JET VX board, ) but now I can't upgrade it to v.1.5  BIOS (my original intention)

When I try upgrading the message appears, error erasing flash BIOS.. and I have to reboot computer..

Can you help...
0
 
LVL 25

Accepted Solution

by:
dew_associates earned 100 total points
ID: 1752101
dpavusin: Your question was, " Is there any way to recover my BIOS? I heard that there's some way with the recovery disc but I don't know the procedure", to which we posted the appropriate procedure to re-enable the Bios. At that time, you were upgrading the Bios from 2.2 to 2.4 ona QDI motherboard. Now your question seems to be how to upgrade from 1.3 to 1.5 on a "JET VX" board. Which is it, QDI or Jet? Are you upgrading from 2.2 to 2.4 or 1.3 to 1.5? In addition, you stated in your original post, "PLEASE DON'T SEND ME ANSWERS LIKE: CONTACT THE MANUFACTURER OR RETAILER", but yet you went to the dealer who replaced the Bios. We do not mind providing free assistance, however there are limits. If you, indeed, have a flash upgradable Bios, and are using a Jet board (and it's an AMI Bios) then create a bootable floppy with the *******.ROM bios file on it, insert the floppy in the "A" drive and start the computer while holding the "CTRL" + "HOME" keys down. The computer will beep several times indicating that the Bios has been upgraded and then reboot itself. If it doesn't do this, the boards boot rom is damaged.
0
 
LVL 4

Author Comment

by:dpavusin
ID: 1752102
Sorry, I did not want to upset you, but I had problem which was urgent, I tried to upgrade BIOS (we had some problems with CD ROM recognition on some company machines). On two machines QDI TX 430 Titanium I and JET VX board (I'm not sure which exact model) upgrade operation was not successful. We had to do something about it quickly. I tried posting message to E.E. but as you can see until you came all the answers were really uncomplete or very basic.
 
I'm not computer guru, but I can help myself and this kind of answers could not help me much, I know this myself. Your answer was first complete and exact answer.
I tried waiting for an answer but we needed these machines quickly.. I saw that QDI TX board tries to boot from the floppy even if BIOS was damaged, so I tried to find out is there a way to use this (I did not know about the emergancy recovery procedure than), and soon after posting my first question to E:E. (after 20 min maybe) I found out that there's way to upgrade some Intel boards automaticaly, so I tried with QDI board (just inserted disc and waited till it booted up, than ran the procedure "blindly")

But I could not help myself with VX board, so after waiting day or two for an answer about BIOS upgrade I went to service and they changed BIOS , I repeat, I could not wait, we needed this machine desperately!

Now, I have two problems:

1. QDI board BIOS upgrade v2.4 seems to be invalid, I tried upgrading BIOS couple of times, but it always halts after 10% done, than I have to use emergancy recovery procedure (I'm pro in this operation now..) I can restore (write to BIOS) v2.2 without any problems. I tried contacting QDI about this but without success.

2. After changing BIOS on VX board service put v 1.3 (they said that they couldn't put later version chip because of incompatibility with other board components). I tried upgrading this chip to v 1.5 but without success, every time I try I get error flash bios could not be erased.. (or something like that).

So far theese machines are running fine, with some minor problems. Until I find out the sure way to upgrade BIOS I'll leave them like this. (There's ancient proverb: Don't mend what's working... now I know what they ment by it..)

Thnx for your help, If you know how to safely upgrade my BIOS-es (especially VX, because I think there must be something wrong with it) I would be grateful. Anyway thanx for your answers so far, they helped me a lot.

Regards,

Damir
0
 
LVL 25

Expert Comment

by:dew_associates
ID: 1752103
Okay, on the VX board, check the booklets that came with the board. There may be a set of pins that need to be changes to unprotect the bios and allow it to be rewritten.

On the QDI board, have you visited their Internet site and looked for any Bios upgrade files. The Bios you now have may be damaged, and in addition, you may want to check for pin protection as well.

Normally earlier flash upgradable boards protected the bios from viruses by setting a pin-out. As an example, Supermicro uses pin 1-2 closed on J-11 to protect, and pin 2-3 to unprotect and allow upgrade.
Dennis
0
 
LVL 4

Author Comment

by:dpavusin
ID: 1752104
No, unfortunatelly there's nothing about BIOS upgrading in the booklets that came with the VX board. I thought that there was virus protection turned on when I tried to upgrade flash, but it wasn't. I think it's possible that there's pin-out, only, I'm not sure how I menaged to erase BIOS the first time, maybe the service set this pin-out. But the guy in service told me that he tried upgrading this v1.3 to v1.5 but he received the same response (could not erase flash..). Maybe this chip they replaced could not be rewriten.

About QDI board, I have downloaded BIOS upgrade from http://www.qdigrp.com/html/bios.html it's dated 11-25-97, first I thought that there must be something wrong with the archive I downloaded, but it's zip archive and if it was damaged in any way I would of seen it. Anyway, I downloaded it again, but it's all the same.

I think that there must be something wrong with this upgrade. It's not possible that QDI has pin protection because I updated v2.2 several times (almost every time after trying to apply 2.4 it damages BIOS so I have to emergancy recoverv 2.2 from boot disc)
I thought that there was problem with my BIOS settings, before upgrading almost all the manufacturers suggest you to turn off all the caching settings in your BIOS, I've tried this, even tried seting it to default values (most compatibile) but nothing helps.

Well, I won't waist more of your time. Thanks for all the suggestions, I've learned a lot. (I bet this was the worst earned 100 points in your life..)

Damir
0
 
LVL 25

Expert Comment

by:dew_associates
ID: 1752105
Damir: Relax, we are all volunteers here just trying to help in areas where there is much help. I would call the motherboard manufacturers and raise a little hell about the problem.
Dennis
0
 
LVL 4

Author Comment

by:dpavusin
ID: 1752106
Thnx for suggestion, I already have! But, only problem is that they're not responding at all. Looks like they ignoring this.. Well, I can always post this to some certain newsgroups...

I'll send you an answer from QDI if I ever get one..
0

Featured Post

Shouldn't all users have the same email signature?

You wouldn't let your users design their own business cards, would you? So, why do you let them design their own email signatures? Think of the damage they could be doing to your brand reputation! Choose the easy way to manage set up and add email signatures for all users.

Join & Write a Comment

The use of stolen credentials is a hot commodity this year allowing threat actors to move laterally within the network in order to avoid breach detection.
Join Greg Farro and Ethan Banks from Packet Pushers (http://packetpushers.net/podcast/podcasts/pq-show-93-smart-network-monitoring-paessler-sponsored/) and Greg Ross from Paessler (https://www.paessler.com/prtg) for a discussion about smart network …
Windows 8 comes with a dramatically different user interface known as Metro. Notably missing from the new interface is a Start button and Start Menu. Many users do not like it, much preferring the interface of earlier versions — Windows 7, Windows X…
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.

708 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

15 Experts available now in Live!

Get 1:1 Help Now