[Webinar] Streamline your web hosting managementRegister Today

x
?
Solved

Midi sound not playing in html

Posted on 1997-11-28
4
Medium Priority
?
347 Views
Last Modified: 2013-12-27
Hello Experts:

I have my "Midiplay.exe" at two locations. Earlier, I was having problems with background noise  on a midi file when I opened the file. I rebooted, and the background sound was
eliminated. "Midiplay.exe" is at two locations because I thought I might have a path problem. If I simply open the file "Ballgam.mid", the sound is fine. If I open
"testmidi.html" [below], I  get no sound from "Ball.mid".

My Midplay.exe is located with it's associated programs at:

C:\Program Files\Audiosta\Midiplay.exe
and at
C:\Voyetra\Audiosta\Midiplay.exe

They are duplicates

This is my source coding:

<HTML>
<HEAD>
<TITLE>testmidi</TITLE>
<BODY BGCOLOR=FFFFFF TEXT=000000>
<H1>Hey Test Midi</H1>
<EMBED SRC="Ballgam.mid"
HIDDEN="True">
<BGSOUND SRC="Ballgam.mid">
</HEAD>
</BODY>
</HTML>

It is located at C:\Program Files\Coffeecup Software\
working\testmidi.html

I would appreciate any suggestions of how I might get my sound to work in an HTML file. I have other HTML files
with sound files on my disk. They do not produce sound as of now.

Lou
0
Comment
Question by:LouHall
  • 3
4 Comments
 
LVL 1

Expert Comment

by:cutetech
ID: 1600839
Make sure the midi file is located in the same directory of the HTML file. And the correct format of your HTML file will be....

<HTML>
  <HEAD>
    <TITLE>testmidi</TITLE>
  </HEAD>
  <BODY BGCOLOR=FFFFFF TEXT=000000>
    <H1>Hey Test Midi</H1>
    <EMBED SRC="Ballgam.mid" HIDDEN="True">
    <BGSOUND SRC="Ballgam.mid">
  </BODY>
</HTML>
0
 
LVL 4

Accepted Solution

by:
johnt082197 earned 800 total points
ID: 1600841
Try this:
(Make sure Ballgam.mid is in the same directory your html file is)

<html>
<head>
<title>testmidi</title>
<bgsound src="Ballgam.mid" loop="infinite">
</head>
<h1>Hey Test Midi</h1>
<hr size="5" align="left" noshade width="80">
<em>Midi player</em><br>
<embed src="Ballgam.mid" align="baseline" border="0" width="50" height="15" autostart="true" loop="true" controls="smallconsole">
<hr size="5" align="left" noshade width="80">
</html>
0
 
LVL 4

Expert Comment

by:johnt082197
ID: 1600845
First, I can now say that you have a midi problem taht is independant from your HTML code. The option "autostart=true" means it should start automatically.
Second, to help you more with this, could I ask you to send me your entire site, along with GIF's, JPG's, and MIDI's all zipped up at: johnt@mail.club-internet.fr
Third, I'm gonna try to answer all your questions one ny one:
1) The console is just there for the user to be able to start / stop the midi from playing. It's not indispensable.
Instead of writing:
<hr size="5" align="left" noshade width="80">
<em>Midi player</em><br>
<embed src="Ballgam.mid" align="baseline" border="0" width="50" height="15" autostart="true" loop="true" controls="smallconsole">
<hr size="5" align="left" noshade width="80">
Write:
<embed src="Ballgam.mid" autostart="true" loop="true hidden=true" > 
In any case, the option "autostart=true" should automatically start the midi file.
2) The crash might not be caused by the midi player, but that's not 100% sure. First test, try to remove Norton from memory and see if you actually crash. If you do, uninstall your browser and reinstall it. If it still doesn't work, install another midi player.
3) As I said before. the option "autostart=true" should allow you to not clic on the play button for the sound to start.
4) Yes, i think you might need to get another midi player. Or at least start with reinstalling the one you currently have. As for the midi player you should get, I guess any would do.
5) The option "hidden=true" hides the console
6) Your code: <Embed SRC="Ballgam.mid" Width=1 Height=1>
does effectively hide the console, but try this instead:
<Embed SRC="Ballgam.mid" hidden=true>

0
 
LVL 4

Expert Comment

by:johnt082197
ID: 1600848
Thanks for the points :)
0

Featured Post

SMB Security Just Got a Layer Stronger

WatchGuard acquires Percipient Networks to extend protection to the DNS layer, further increasing the value of Total Security Suite.  Learn more about what this means for you and how you can improve your security with WatchGuard today!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Monitor input from a computer is usually nothing special.  In this instance it prevented anyone from using the computer.  This was a preconfiguration that didn't work.
Dramatic changes are revolutionizing how we build and use technology. Every company is automating, digitizing, and modernizing operations. We need a better, more connected way to work together as teams so we can harness the insights from our system…
The purpose of this video is to demonstrate how to make a WordPress Site faster and smaller in size by cleaning up the database. This will be demonstrated using a Windows 8 PC. Plugin WP Optimize will be used. Go to your WordPress login page. T…
How to fix display issue, screen flickering issue when I plug in power cord to the machine. Before I start explaining the solution lets check out once the issue how it looks like after I connect the power cord. most of you also have faced this…
Suggested Courses
Course of the Month9 days, 11 hours left to enroll

591 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question