XWindows with Slackware distribution

This is a lengthy question, but I award only a small amount of points for I think that the answer is (or must be) quite easy. If not, I'll raise the amount.
On my second HD, I installed the Slackware Linux distribution (Linux 2.0.0 or so) and then tried to launch XWindows.
I ran xf86config and after answering all questions correctly, tried startx.
However, I got the following error (the XF86Config file is in /home/Chris, where Chris is my login name):

No config file found!
Note, the X server no longer looks for XF86Config in $HOME.

Any ideas here how to permanently make this disappear? I am an absolute beginner at Linux, so please be patient! :-)
LVL 5
Christian_WenzAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Christian_WenzAuthor Commented:
Edited text of question
0
terrycjCommented:
Put it in /etc

i.e., as root:

mv $HOME/XF86Config /etc

0
Christian_WenzAuthor Commented:
sorry, "permission denied" :-(
0
The Ultimate Tool Kit for Technolgy Solution Provi

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy for valuable how-to assets including sample agreements, checklists, flowcharts, and more!

terrycjCommented:
you mean you can't become root?

if it's your machine at home, just run 'su' and enter the root
password, then move the file to /etc as i said.

i'm guessing that this is all you need to do.


if you're trying to install XFree86 but don't have root permissions, you can put the file into either of the following
locations under the root of the X installation tree.

        ROOT/lib/X11/XF86Config.hostname
        ROOT/lib/X11/XF86Config

where hostname = the host name of your machine (i.e.,
what you see when you run the command 'hostname').

terry.

0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Christian_WenzAuthor Commented:
I can login as "root" (no password required yet), but strangely cannot write to /root. But I'll try your suggestions, please stay tuned.
0
Christian_WenzAuthor Commented:
Wonderful. It worked!!! I guess 'su' stands for "Super-User"?!

Thank you very much for your help.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.