Solved

XWindows with Slackware distribution

Posted on 1997-12-04
6
328 Views
Last Modified: 2013-12-15
This is a lengthy question, but I award only a small amount of points for I think that the answer is (or must be) quite easy. If not, I'll raise the amount.
On my second HD, I installed the Slackware Linux distribution (Linux 2.0.0 or so) and then tried to launch XWindows.
I ran xf86config and after answering all questions correctly, tried startx.
However, I got the following error (the XF86Config file is in /home/Chris, where Chris is my login name):

No config file found!
Note, the X server no longer looks for XF86Config in $HOME.

Any ideas here how to permanently make this disappear? I am an absolute beginner at Linux, so please be patient! :-)
0
Comment
Question by:Christian_Wenz
  • 4
  • 2
6 Comments
 
LVL 5

Author Comment

by:Christian_Wenz
ID: 1630862
Edited text of question
0
 
LVL 1

Expert Comment

by:terrycj
ID: 1630863
Put it in /etc

i.e., as root:

mv $HOME/XF86Config /etc

0
 
LVL 5

Author Comment

by:Christian_Wenz
ID: 1630864
sorry, "permission denied" :-(
0
Complete VMware vSphere® ESX(i) & Hyper-V Backup

Capture your entire system, including the host, with patented disk imaging integrated with VMware VADP / Microsoft VSS and RCT. RTOs is as low as 15 seconds with Acronis Active Restore™. You can enjoy unlimited P2V/V2V migrations from any source (even from a different hypervisor)

 
LVL 1

Accepted Solution

by:
terrycj earned 40 total points
ID: 1630865
you mean you can't become root?

if it's your machine at home, just run 'su' and enter the root
password, then move the file to /etc as i said.

i'm guessing that this is all you need to do.


if you're trying to install XFree86 but don't have root permissions, you can put the file into either of the following
locations under the root of the X installation tree.

        ROOT/lib/X11/XF86Config.hostname
        ROOT/lib/X11/XF86Config

where hostname = the host name of your machine (i.e.,
what you see when you run the command 'hostname').

terry.

0
 
LVL 5

Author Comment

by:Christian_Wenz
ID: 1630866
I can login as "root" (no password required yet), but strangely cannot write to /root. But I'll try your suggestions, please stay tuned.
0
 
LVL 5

Author Comment

by:Christian_Wenz
ID: 1630867
Wonderful. It worked!!! I guess 'su' stands for "Super-User"?!

Thank you very much for your help.
0

Featured Post

U.S. Department of Agriculture and Acronis Access

With the new era of mobile computing, smartphones and tablets, wireless communications and cloud services, the USDA sought to take advantage of a mobilized workforce and the blurring lines between personal and corporate computing resources.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
add a 1000 ms delay after each sending email operation 12 68
Linux Scripting 3 95
Best way to virtualise a remote Linux server 2 49
AD LDAP LDS 3 47
Setting up Secure Ubuntu server on VMware 1.      Insert the Ubuntu Server distribution CD or attach the ISO of the CD which is in the “Datastore”. Note that it is important to install the x64 edition on servers, not the X86 editions. 2.      Power on th…
Linux users are sometimes dumbfounded by the severe lack of documentation on a topic. Sometimes, the documentation is copious, but other times, you end up with some obscure "it varies depending on your distribution" over and over when searching for …
Connecting to an Amazon Linux EC2 Instance from Windows Using PuTTY.
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.

929 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

8 Experts available now in Live!

Get 1:1 Help Now