• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 246
  • Last Modified:

modem setting

i use redhat 3.0.3 with kernel 2.0.30. how to set modem in com3 IRQ 5 in linux? usually com3 is IRQ4 but i want it to 5(i set the jumper  5). the device is cua2 which i believe right.
the reason is the my 33.6 modem is extremely slow(few characters per minute) in linux so terminal software(like minicom) and PPPd don't work. someone suggest it may be the wrong IRQ of modem in linux.
0
wini072297
Asked:
wini072297
  • 2
1 Solution
 
XMSCommented:
Basically, you must use the /bin/setserial command to specify your particular setting to the serial driver. This can be easily accomplished by taking the following steps :

1) Look up your /etc/rc.d directory for a script named rc.serial. If it does exist, rename it to something else.

2) Create a new rc.serial file as follows (2 lines) :

#!/bin/sh
/bin/setserial /dev/cua2 port 0x03e8 irq 5 uart 16550A spd_vhi

3) Make the file executable (chmod +x)

4) Run the file, watch for system messages. If you get any, add "skip_test" to the setserial command-line (see man setserial for an explaination)

5) Make sure that your /etc/rc.d/rc.sysinit contains a line to run /etc/rc.d/rc.serial

Good luck.

0
 
XMSCommented:
Correction : At step 4, use the "skip_test" parameter if you get any _ERROR_ messages. :) Sorry.

0
 
wini072297Author Commented:
is setserial builtin command in linux? i don't think there is rc.serial file there in rc.d, so just create it anyway? someone said i should download a program called setserial from some site.
0

Featured Post

New feature and membership benefit!

New feature! Upgrade and increase expert visibility of your issues with Priority Questions.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now