Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

Primary Hard Disk Failures, Maxtor 3.8Gb IDE

Posted on 1997-12-05
18
Medium Priority
?
457 Views
Last Modified: 2012-06-21
I have a system with a Maxtor drive on which I've just received a Primary Hard Disk Failure message on boot.  Can't boot to a floppy, either.  System ran fine before I installed the Maxtor, which I've been using for several weeks with no troubles.  Generic Pentium motherboard, AMD K5-133.  This is the *second* Maxtor drive installed in this machine, by the way; same problem happened with the first one, and I returned it to Maxtor.  Suggestions?  My user is frantic.
0
Comment
Question by:mwk20
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 3
  • 3
  • +6
18 Comments
 

Expert Comment

by:alexkai
ID: 1120696
I'm afraid that you're dealing with the case when BIOS is unable to handle a disk which is larger then 2GB. This is very common on older motherboads/BIOSes, for instance, all of the Intel Neptune boards are incapable of handling >2GB disks and there are plenty of other cases. Long ago IDE disks were limited to 528MB which was 1024 cyls, 16 heads, 63 sector/cyl. Many early LBA capable BIOSes can handle up to 1024/64/63 but not more.

Moreover AMD K5 is not the latest technology so I assume you've got the same age motherboard.

You have essentually two options:
1 -- Try to a find BIOS update for the motherboard
2 -- Replace motherboard

Hope this helps...

0
 
LVL 12

Expert Comment

by:j2
ID: 1120697
i have NEVER heard of a LBA capable motherboard that cannot handle more then 2GB disks... could you please supply me with details to verify that claim, as i find it hard to beleive?
0
 

Expert Comment

by:alexkai
ID: 1120698
Hej!

In my personal experience:
-- Intel Neptune and Mercury Pentium Motherboards (~1993 - 1996)
-- Generally most of early pentium AMI BIOSes hang when a disk > 2GB is connected.

The problem is simply that the BIOS cannot handle >64 sides; if so happens, some bits wrap somewhere and it dies. Intel has acknowledged this problem in late 1995 or so, but it never got fixed because the motherboards were essentially out of production by then... so the people who have them (I used to have one) just cannot use large disks.
 
0
Better audio for more successful meetings

Challenge: S&ME was tired of poor audio quality of Skype for Business calls in mid-sized meeting and training rooms. They were looking for a reliable and cost efficient solution to replace the existing conferencing system.

 
LVL 12

Expert Comment

by:j2
ID: 1120699
*scratches his head* Wierd.. i have a OOOOOLD Neptune board.. never been upgraded... and it works? very wierd indeed... ah well, have a nice weekend! :=)
0
 
LVL 9

Expert Comment

by:magigraf
ID: 1120700
??? to be continued or confirmed ???
0
 

Author Comment

by:mwk20
ID: 1120701
Ah, me...this gets deeper and deeper.  Certainly the disk was working for a while, partitioned into 1Gb chunks or so.  As I said, though, this is the second drive I've installed into the machine, and the second time the system has ceased to function with the same error messages.  Won't boot *at all*, not even from a floppy.  Any more thoughts on this???
0
 

Expert Comment

by:Dr_LC
ID: 1120702
I just ran into the same problem with a K5 on an older board that DOES support LBA but still failed to recognize the Maxtor drive. Since BIOS upgrades can be VERY tricky and are an extremely delicate operation I would suggest using translation software.  You can find such software at Maxtor's web site.

http://www.maxtor.com

Good Luck!
0
 
LVL 12

Expert Comment

by:j2
ID: 1120703
Funny... i ran into this problem at a friends machine.. however.. by manually entering the Heads/cyls/sec values.. it worked great.. only the autodetec failed to detect more then 2112MB...
0
 

Author Comment

by:mwk20
ID: 1120704
Okay...I double-checked the motherboard's specs, and sure enough it supports 4 IDE drives up to 8.3Gb each.  Autodetect picked up on the drive with no troubles, but perhaps that's the problem.  My user has since sent the Maxtor drive back and ordered a new Seagate. I'll fill you all in when the new one arrives and is installed.
0
 
LVL 1

Expert Comment

by:ngpudding
ID: 1120705
Have you checked the cable connections ? Pin 1 of your IDE connector (identified by a coloured line) must be at Pin 1 of your hard disk (look at the number on the IC board).

I assume your having 2 physical hard-disk, if your motherboard is unable to detect both drives as Primary Master and Secondary Master respectively, you'll have to set the jumpers on the hard-disk manually, one as the slave.

Regards,
ngpudding
0
 

Author Comment

by:mwk20
ID: 1120706
No.  Only one hard disk.  Cable connections are fine.  The drive works for a couple of weeks, then *kaboom*.
0
 

Expert Comment

by:delocke
ID: 1120707
if this was causing an inability to boot from floppy too, maybe the maxtor was being less than friendly in general with the bios . . . to satisfy the collective curiousity, be sure to pst your user's results with the seagate
0
 

Expert Comment

by:delocke
ID: 1120708
if this was causing an inability to boot from floppy too, maybe the maxtor was being less than friendly in general with the bios . . . to satisfy the collective curiousity, be sure to pst your user's results with the seagate
0
 
LVL 1

Expert Comment

by:bravado042997
ID: 1120709
If all was working fine one moment and fails the next well
come on.. H/W failure of some kind .
Dang flaky hard drives...  better he got it killed early then later though...
I am waiting for a drive replacement myself at the moment 8(
My case 1.4 gig SCSI Quantum though, croaked hard and was obvious... it just about carried a tune if connected hehe


0
 

Author Comment

by:mwk20
ID: 1120710
I thought about h/w failure myself, but to have the same failure occur on *two* brand-new Maxtor drives?  Maybe Maxtor isn't as reliable as it once was...I'll post what happens as soon as I know.
0
 
LVL 9

Expert Comment

by:magigraf
ID: 1120711
mwk20...

Reading all the previous comments, where I have seen that case before, once it turned out to be the motherboard that is causing the drives to fail.  (now could you try it on another motherboard??)
The other one, I was pretty sure it was the motherboard, but turned out to be that another make of drive solved the problem.
(now again could you try another make)

This is as far as I can see it from here
Hope this helped.
**Since that I'm not sure it will work in your case, I'll post it as a comment**
Regards
0
 
LVL 5

Accepted Solution

by:
JBURGHARDT earned 400 total points
ID: 1120712
FIRST OF ALL, check all cables and make sure that they   are conected correctly power cables too, set hardisk to master and second to slave
0
 
LVL 9

Expert Comment

by:magigraf
ID: 1120713
That was an easy answer...
0

Featured Post

Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Stuck in voice control mode on your Amazon Firestick?  Here is how to turn it off!!!
This article shows how to use a free utility called 'Parkdale' to easily test the performance and benchmark any Hard Drive(s) installed in your computer. We also look at RAM Disks and their speed comparisons.
This course is ideal for IT System Administrators working with VMware vSphere and its associated products in their company infrastructure. This course teaches you how to install and maintain this virtualization technology to store data, prevent vuln…
In this video you will find out how to export Office 365 mailboxes using the built in eDiscovery tool. Bear in mind that although this method might be useful in some cases, using PST files as Office 365 backup is troublesome in a long run (more on t…

722 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question