Solved

NT/DOS DualBoot - DOS not running auto/config

Posted on 1997-12-07
21
326 Views
Last Modified: 2013-12-14
I have NT 4.0 and DOS 6.22 both installed...Boots to NT just  fine, and boots to DOS so-so.  When I choose DOS, it just dumps me to a prompt with MINIMAL startup execution.  The config.sys and autoexec.bat files are not even TOUCHED!

My temporary (it's been long enough to seem permanent) workaround for this problem is a boot floppy that boots DOS, and runs slightly modified copies of the startup files.  It works, but is annoying, slow, and defeats the purpose of
multi-booting :)

I have tried everything I know, and everything that 5 other people have told me to try, and I still cannot get it to work properly :(  I've probably tried 3 or 4 different lines in boot.ini, 4 or 5 locations for autoexec.bat/config.sys and/or autoexec.nt/config.nt and/or command.com, and a few other strange things    ...nothin'

I have a friend who is using NT/DOS, and his works perfectly.  We compared everything we could thing of and didn't find any settings that were different!
0
Comment
Question by:drcheap
  • 5
  • 4
  • 4
  • +5
21 Comments
 
LVL 5

Expert Comment

by:cer
ID: 1768985
I also have this running fine.
Did you first install DOS and then NT ?
How big is your HD / your boot partition?
Do you boot from FAT?
If you do the minimal HD-boot and make a DIR, are you on C:\ and do you see autoexec.bat and config.sys (the *.nt files are useless for DOS).
Do you use the NT multiboot or a different one (OS/2, ...)?

General hints:
upgrade the BIOS if possible.
Boot from Floppy and use FDISK /MBR and SYS C: to (re)enable DOS booting, then insert the NT Setup Floppies again and choose "repair system files only", do not repair the registry. To enable NT booting again.

Since I do not know if this will work for you I do not lock the question (for now).

0
 
LVL 3

Author Comment

by:drcheap
ID: 1768986
Yes, DOS has been on my computer for a while, then I installed NT .
My drive is a 1.2Gig, single FAT partition
When I do the minimal boot everything is okay except for the lack of startup files...all the files and directories are there, even the nice ~1 ~2 etc. for the long names.
I am using the standard NT multiboot, here is the lines that make up the menu:

[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINNT="NT Workstation 4.0"
C:\="MS-DOS 6.22"

My BIOS is dated sometime in August of 1995, perhaps that could be a problem since NT4 wasn't out then...

I also haven't tried repairing the system files yet...that has the potential to get messy and I wanted to try the least drastic methods first :)

My bios IS flashable (is that a word?), so I will see what I can do there.  I have a feeling that could work...I already had to update the firmware for another device to make it properly NT-compatible.

0
 
LVL 1

Expert Comment

by:mert
ID: 1768987

I think that for some reason the autoexec and config are getting
written over NOT parsed with deletions being made to the original.Turn off automatic parsing in the Registry.

2. Modify the following value within HKEY_CURRENT_USER:
 
Software\Microsoft\Windows NT\CurrentVersion\Winlogon\ParseAutoexec
 
      1 = autoexec.bat is parsed
      0 = autoexec.bat is not parsed
 

0
 
LVL 1

Expert Comment

by:p05010
ID: 1768988
mert... ,

That's true, but it has nothing to do with the old DOS (or running it).
This is only used when NT needs to run Old dos applications, then you can say that NT must use the old autoexec.bat.

Bye,
P05010

0
 
LVL 1

Expert Comment

by:p05010
ID: 1768989
DRCheap,

Do an attrib *.* -s -r -h and give us a listing of the root, it can be useful.

Bye,
P05010

0
 
LVL 3

Author Comment

by:drcheap
ID: 1768990
Okay, here's a directory listing of the root, I left out the list of 53 subdirectories :)  The only significant directories are \DOS and \WINNT

11/16/97   3:59p            794  AUTOEXEC.BAT
11/16/97   3:05p            183  boot.ini
10/18/97   6:19p            512  BOOTSECT.DOS
 5/31/94   6:22a         54,645  COMMAND.COM
 9/01/97   7:27p            352  CONFIG.SYS
 5/31/94   6:22a         40,774  IO.SYS
 5/31/94   6:22a         38,138  MSDOS.SYS
 7/12/96   8:21p         26,800  NTDETECT.COM
11/15/97   4:57p        156,496  ntldr
12/08/97  11:05a     67,108,864  pagefile.sys
 5/31/94   6:22a          9,349  WINA20.386

0
 
LVL 3

Author Comment

by:drcheap
ID: 1768991
ugn...damn variable width fonts!  oh well.

0
 
LVL 1

Expert Comment

by:p05010
ID: 1768992
The three mainfiles are on the disk with the same Timestamp.
That's OK.

5/31/94 6:22a 54,645 COMMAND.COM
5/31/94 6:22a 40,774 IO.SYS
5/31/94 6:22a 38,138 MSDOS.SYS

Make a bootable floppy and do an attrib a:\*.* -r -s -h. (Use format a: /u /s)
Try to boot from an ordinary floppy, if this works then you have to replace the above mentioned files on your C:.
Please make a backup of these files on the C: and rename the files with a xxx extension.
Reboot the machine. It's possible that the command.com or the other two files are corrupt (cross links, etc.)

Bye,
P05010
0
 
LVL 51

Expert Comment

by:ahoffmann
ID: 1768993
Sounds that you have a corrupted BOOTSECT.DOS :(
Your're lucky if you can access your disk with a UNIX system. Using dd there to repair it is easy.

If not, you need a tool to write and save the MBR of your harddisk, or to generate a new BOOTSECT.DOS

If there is also no such tool (I don't know any) you may try  cer's method (see first comment)

Locked the question, 'cause the dd method works fine for me :)
0
 
LVL 5

Expert Comment

by:cer
ID: 1768994
MBR and Bootsec.dos are two different things. MBR is responsible for the multiboot (which works) and the other vor loading DOS (which also works). Executing Autoexec.bat and config.sys is done while (after) loading dos from the IO.sys and msdos.sys
Therefore I still suggest you try the method I suggested before.

The UNIX thing I don't understand at all.


0
Threat Intelligence Starter Resources

Integrating threat intelligence can be challenging, and not all companies are ready. These resources can help you build awareness and prepare for defense.

 
LVL 51

Expert Comment

by:ahoffmann
ID: 1768995
cer, we're both wrong or right, depends on the point of view.
bootsect.dos is a copy of the MBR before installing NT (that's not my statement, but that of M$ in their books).

So, I think drcheap should explain (print herein) what's meant by
  "prompt with MINIMAL startup"
I assume that config.sys and/or autoexec.bat was not executed completetly, may be because of errors in there.
How about using F8 key to single-step through these files.
NOTE that they're both identyfied and executed anyhow (as far as I understand the question).

BTW, don't care about the UNIX stuff. Someone used to UNIX will understand ;) And if one don't have, you don't need either ..
0
 
LVL 1

Expert Comment

by:p05010
ID: 1768996
Cer, ahoffman,

I thought that ontrack bootmanagers used the MBR (like quantum).
The bootmenu from NT sits in the BR.
Before installing NT, The BR has the information how to load the  IO.SYS and MSDOS.SYS for MS-DOS 6.22 or WIN 95.
After installing NT, NT will make a kind of mirror (Bootsect.dos) so the NT loader can call an older OS.

I have installed NT's on HD's with Quantum Ontrack Bootmanagers. Imagine that NT writes the MBR, how can the BIOS know what type of HD to use.

But I agree that Bootsect.dos could be corrupted.

Bye,
P05010
0
 
LVL 3

Author Comment

by:drcheap
ID: 1768997
I would like to clarify a few things I have seen in various replies...

First off, what I meant by "minimal startup" is that obviously io.sys, msdos.sys, and command.com are being loaded properly as I am able to get to a prompt and use DOS.  What *isn't* happening is the automatic loading of config.sys and autoexec.bat as they should.  The effect is somewhat like what happens when you boot an only-DOS system and hold the shift or F5 key down -- you get a simple prompt in a matter of milliseconds.

Since I'm not running UNIX on my system, then I guess I'm out of luck there.  ...unless there is some REALLLY strange way of using a remote UNIX system to create a new bootsect.dos (doubt it).  On a side note: I read the man page for dd and don't see anything about boot sectors.

And to make this whole thing even more confusing, here's an update on my system's weird booting behavior:

When I boot to NT, then restart and choose DOS of the menu, it still doesn't run the auto/config.  BUT, if I hit F8 then it starts prompting each line of MY auto/config files!  Think that is strange?  Well, if I then reboot and pick DOS again...it will not work either way! (with or w/o F8).

I have a feeling that it just may be a corrupt bootsect.dos file, but in such a screwed up way that it works under the circumstance of (for those C programmers out there):

if ( (NT_was_the_last_boot) && (user_pressed_F8) )
   load(config.sys,autoexec.bat);
else
   puke;

It almost sounds like some sort of sick M$ joke!

I will try to restore the system files of DOS, then NT, and let everyone know what happens then :)r
0
 
LVL 51

Expert Comment

by:ahoffmann
ID: 1768998
just about dd>
to read MBR use
  dd bs=446 count=1 if=/dev/hda of=your_file
to write MBR just swap if= and of= parameters (it's so easy:)

Without UNIX (Linux) you have to laugh about M$ jokes, and beside do the hard work (see cer's 1'st comment), sorry.
0
 
LVL 1

Expert Comment

by:p05010
ID: 1768999
DrCheap,

Try also another keyboard. (stupid idea isn't it :-) )
You can have a sticky F5 key and when you can dissable the 'Stop on all erors' in the BIOS the problem could be invisible before.

Bye,
P05010
0
 
LVL 5

Expert Comment

by:cer
ID: 1769000
ahoffman: I had a look in the bootsec.dos and it is clearly the DOS bootsector (which was at the beginning of the partition) and not the MBR (which is at the beginning of the HD = 1st physical sector). The MBR should also contain the partition table.

p05010: You are right, the MBR is untouched. Thats also the reason why it has to copy the bootsector to bootsec.dos
The programm contained in the MBR just loads the first sector of the active partition and executes it. Guess NT loader is too long to fit in place of the MBR.
Because of this you can have two bootmanagers (one in the MBR and NT's) installed.

drcheap: M$ joke or a virus, did you scan ?


0
 

Expert Comment

by:Eddyvdw
ID: 1769001
Can you post your config.sys file?
0
 
LVL 37

Accepted Solution

by:
Bing CISM / CISSP earned 150 total points
ID: 1769002
Let's think:

NT's startup menu appears, so MBR and boot sector  are good and ntldr is good as well.

NT boots and runs well, so there is no problem with NT's partition and NTFS. Oh, It looks you only have one FAT that DOS and NT reside?

DOS boots, so bootsect.dos is good, only config.sys and autoexec.bat cannot be executed.

Okay, the related files are io.sys, msdos.sys and command.sys. So, do replace these three files with newers from other source, and try it again.

:-) a odd way it is but maybe it is the right way, although I am not sure by myself.

To try makes answer. :-)


0
 
LVL 5

Expert Comment

by:cer
ID: 1769003
bbao: I suggested THIS already (see very first comment). Also you can not just replace the files, as they won't work. They have to be at a certain location and therefore must be replaced with  the "SYS" command, after which you must repair NT.
But all this is discussed above.
Since drcheap didn't want to do just this, I didn't make it an answer.
Hope he finds a solution for his problem soon, review all the comments and grades the one who helped him most.

0
 

Expert Comment

by:vaxel
ID: 1769004
Did you try to transfer the system(DOS) a:\sys c:
After this you can recover your boot image of NT by using
the shareware utility bootpart.exe (http://www.winimage.com/bootpart.htm)

0
 

Expert Comment

by:Eddyvdw
ID: 1769005
Do you have a shell command in your Dos config.sys?
Is there a /P parameter? If not, add it to the end of the shell.
It could look like this:
SHELL=C:\COMMAND.COM /E:1024 /P
0

Featured Post

Are your corporate email signatures appalling?

Is it scary how unprofessional your email signatures look? Do users create their own terrible designs and give themselves stupid job titles? You can make this a lot easier for yourself by choosing an email signature management solution from Exclaimer today.

Join & Write a Comment

NTFS file system has been developed by Microsoft that is widely used by Windows NT operating system and its advanced versions. It is the mostly used over FAT file system as it provides superior features like reliability, security, storage, efficienc…
If you need to start windows update installation remotely or as a scheduled task you will find this very helpful.
Windows 8 comes with a dramatically different user interface known as Metro. Notably missing from the new interface is a Start button and Start Menu. Many users do not like it, much preferring the interface of earlier versions — Windows 7, Windows X…
In this video, we discuss why the need for additional vertical screen space has become more important in recent years, namely, due to the transition in the marketplace of 4x3 computer screens to 16x9 and 16x10 screens (so-called widescreen format). …

708 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

17 Experts available now in Live!

Get 1:1 Help Now