Solved

3com 3c562c won't connect past 19,200

Posted on 1997-12-07
31
313 Views
Last Modified: 2013-12-27
I have a Compaq Armada 4120T with a 3com 3c562c PCMCIA
33.6 modem + 10baset ethernet combo card.  I'm running
with Windows NT 4.0, service pack 3.  Both the modem
and the laptop have the latest firmware.  I'm using
Netscape Communicator 4.04.  Anyway, I'm using this to
connect to our office where we have USR Courier 33.6
modems.  The fastest connection I can get is 19,200 (my
co-workers are getting 28800 connections) and even then
downloading files shows fluctuations between ~2k/sec to
60 bytes/sec!

Can someone help me figure out what to tweak to get a
faster connection?  I know my phone lines are capable of
it (I've tested with other computers) and I know the
modem is capable of going faster (same configuration
connects to Mindspring (my ISP) at 26,400) ... The only
"correct" answer is the one that enables me to connect
higher than 19,200 and have a relatively consistent
connection.

Thanks in advance,
Jason
0
Comment
Question by:jff
  • 14
  • 4
  • 2
  • +9
31 Comments
 

Author Comment

by:jff
ID: 1144541
Edited text of question
0
 
LVL 1

Expert Comment

by:bravado042997
ID: 1144542
hmmmm perhaps your 'work' modems aren't fully high speed compatible with your 3com modem... that answer stinks I know ;)
I'm figuring most likely if you have a laptop so do other  co-workers. So that answer is probably off..

Make sure your port settings for your dialup networking  for 'WORK' in NT are set to above 19200... if set to 19200 then there you go...

Are you getting 16800 and 14400 connects as well?

Also the phone line could be at fault, sure it can go from u to ISP fine, but perhaps to go from you to WORK has some old lines in there somewhere...  that my friend is quite possible and stinks too...

BTW if just connecting to work computers why do you need to go super fast?   unless of course u are folks with huge uploads or
downloads...   I come from the days of 300 bauds, I have no sympathy for ppl who get into computers at 56k ;)



0
 
LVL 1

Expert Comment

by:twexperts
ID: 1144543
Have you tried installing your modem into an associates computer and seeing the speed of connection? Or even trying it over one
of their phone lines?
Are you using a mobile phone to connect or a regular phone line?
and is the modem in your associates computers the same as yours, or the same brand as the office modem?
I know, a lot of questions, but all will lead to a comprehensive solution (I hope).
Robin (twexperts) (who likes fast connections... ;+) )
0
 

Expert Comment

by:Digital
ID: 1144544
I have the same problem with my Cirus Logic.
What it is (I found after extensive testing) is that the modems aren't fully compatible. For example:
I have a Cirrus Logic, I connect at 24000 insted of 33.6 to my ISOP (CTS) they have USR modems and 56k Flex modems. I took my client's modem and dialed in to my ISP (on same line) and connected at 38400. The problem is that the modems aren't fully compatible, and in the words of the CTS tech (who I called), "the modems don't like each other"
Hope that answers your question...
-Digital
0
 

Author Comment

by:jff
ID: 1144545
Digital, nice try but no cigar.  I have to co-workers with the
*exact* same configuration who both regularly dial in at
26,400 or 28,800 (still not sure why they aren't getting
past 28,800 as we have 33,600 modems).  

Bravado, you were closer.  I poked around and discovered in
the dial-up networking settings that I did in fact have the
initial bps set to 19,200!  I set it to 57,600 (maybe I'll
try 33,600 next) and connected at 21,600.  I dialed in 5
times and all five times connected at 21,600.  There must
still be something set improperly as my co-workers still get
a faster connection than I do.  As for your other points: I
know it's not the phone line to my office as I can connect
much faster using my desktop PC & USR Sporster.  It regularly
connects at 28,800 -- definitely not the phones between my
house and my office.  Also, I had a 300 baud modem (and a 1200
and a 2400 ...) -- but once you get used to full ISDN (which
I have at work) even 56K seems slow! :)

twexperts, I tried borrowing a co-workers modem and got the
exact same results.  I haven't had the luxury to borrow one
of their laptops and see what happens -- that would be a tough
sell.  BTW, it is a regular old phone line.

Anyone know of other specific settings I should check?  The
initial bps definitely helped -- but I want to run slightly
faster than 21,600 every time.

Thanks everyone!

Jason

0
 
LVL 9

Expert Comment

by:cymbolic
ID: 1144546
Jason,
 The higher speed modems all operate outside of the voice tariff frequency band which the telco has used and expected for years for a voice only network.  The last modems that actually worked within the band were the 2400 baud technology.  Generally, unless you have an exceptionally clean circuit and a modern CO, you will not achieve the rated maximum on 28.8 and above modems.  Central Office equipment alone tends to clip off your signal even when your local loop cirucuits are fine.  The theoretically clean circuits that you need to acheive maximum speed exist mostly in the minds of modem marketers.

Also, because of local line characteristics and often the number of open loops off of your circuit that used to be drops to other homes, etc., the frequency spectrum quality is not uniform on your loo, and varies widely from local loop to local loop.  Unterminated older drops act like radio receivers to interject noise that reduce your speed, and sometimes higher speed modems run slower because they try to push the frequency farther into areas where the quality is worse, ergo a 28.8 may get  higher average throughput than a 33.6.

Now, you can bitch at the local telco, but until you get them out to use a frequency analysis wth analogue testers at both ends of the circuit, they proabably will not do you any good.  Their position is that if you can talk on it, it's good enough.
0
 

Author Comment

by:jff
ID: 1144547
cymbolic:
What your saying makes perfect sense, but then how do you
explain that I can connect using the same modem faster to
my ISP and also using a different modem (from the same
location) faster to my office?  Additionally, others with
the same modem also connect faster to my office.  Something
doesn't add up -- I was hoping that various settings would
be pointed out for me to check (in fact, the initial bps I
found through someones help did make a marginal improvement).
Also, I heard a rumor that the 3com PCMCIA modems had some
"register" that needed to be set (via AT commands in the init
string) to operate at speeds higher than 2xxxx.  I know what
your saying is true, but I still believe this can work faster.
On my desktop w/ USR, I regularly connect to my ISP at 52,000
and to my office at 26,400 -- the laptop should be able to do
better than 21,600.

Thanks so much for the explanation though -- I really appreciate
your time helping on this.  If I don't get a better answer at
some point I'll try and figure out a way to divy up a bunch
of points amongst those who helped (if that's possible).  So
far bravado's suggestions have been best as I actually stumbled
on a setting that was holding me back.  Anyway, thanks everyone.

Jason
0
 
LVL 9

Expert Comment

by:cymbolic
ID: 1144548
Don't forget that you have local loops at bothe ends of the connection.  That's why you can get an average higher speed to one number, and an average lower speed to another.  your local loop to the CO stays the same, but the local loop out of the CO to your target number will have differring quality characteristics.  Also, the far end modem will probably be different as well.  Sometimes the step down emulation from a higher speed modem to a lower speed standard is not perfect either even within the same manufacturer..  
0
 

Author Comment

by:jff
ID: 1144549
Good point, that could account for the fact that I can connect
from the same line to the same line faster using my USR modem.
I guess the real test would then be to bring another of the
identical machines/identical modems over to my house and try
that.  I'll see what I can do.  My guess is that there is still
some setting somewhere (maybe even in the firmware of the modem)
that could be tweaked to do a little better than 21,600 on my
33,600 modem.

Thanks,
Jason
0
 
LVL 2

Expert Comment

by:lmar
ID: 1144550
Definately sounds like an improper com port setting.  Open the Com Port control panel and verify propler speed is entered there (57.6 should work) and also that you are using hardware flow control and not x-on/off flow control.  Also make sure you have FIFO enabled in the advanced setting.   You may also have to get into your modem nram and make sure it is set to connect at higher speeds.  Also borrow another like modem to verify you do not have a bad modem.  It may be more sensitive to line noise than your compadres in the office.  Borrow one that can connect faster and it will tell you if it is a setting on your machine, or your modem.  good luck
0
 

Author Comment

by:jff
ID: 1144551
lmar, I think that you and bravado are on the right track.
I checked my port settings, definitely have Flow Control
set to hardware.  I did *not* have the FIFO enabled, but
unfortunately enabling this, then rebooting and dialing in
again didn't seem to have any effect (in fact, I got a
19,200 connection).  It could certainly be this specific
modem and the office modem (it's not the phone lines -- I
proved that by dialing into the office from the same line
on my desktop and getting a faster connection) -- but I
would like for someone to help me check the modem "nram"
settings for correctness.  A guy I know suspects my modem
isn't set properly ...

Thanks for the try -- I don't mean to be rude by rejecting
but as I stated in the original question, a correct answer
is one that gets me a faster connection (I think 26,400 is
reasonable as my modem connects at that speed to Mindspring).
This may be impossible, I realize that but I don't want to
give up until someone who knows about the modems init string
capability/nram settings comes along (or is that you?).

Thanks again everyone for all the help,
Jason
0
 

Author Comment

by:jff
ID: 1144552
Today I went into the BIOS/CMOS setup area (in Compaq
terms I did an INSPECT).  I noticed that when probing
the system devices, it took a LONG time on "Modem".  When
I selected Inspect Modem, the "Current Modem Register Summary
(Decimal)" had columns for 0-6,7-13,14-20,21-27.  In each
column were gobbly-gook (the technical term for extended ASCII
characters that look like "gobbly-gook").  I'm still thinking
that my modems registers are screwed up -- I'm going to check
on the 3com/USR page about ways to reset the firmware or
registers (when I get a chance).  Anyone got a good "solution"
for me?

Thanks,
Jason
0
 

Author Comment

by:jff
ID: 1144553
Sorry, one more comment.  When I go to the WinNT Control
panel and select "PC Card (PCMCIA)", I see my 3com card
in Socket 1, but two strange things.  First of all, there
is a Yellow question mark on the left side below the picture
of the other card, next when I click properties the Device
Status says "This Device is working properly", but under the
"Driver" tab (driver is elpc3x) the driver status is "The driver
installed and started but didn't configure this device".  Wonder
if that is related to all of this or the norm?
0
 
LVL 4

Expert Comment

by:dpavusin
ID: 1144554
Your modem should be ready to run at highest speed when started (it does a self test and makes AT&F command for auto initialization. These settings should be the best for your modem, any other aditional settings shoud degrade your modem's speed). If you want I can give you few AT commands to try out, but I think they'll be antiproductive.

It is importanat that your modem has right inf file which states all available AT commands for this modem as well as init strings. Without this file your modem can be detected and configured as standard 28.8 or 33.6 modem but will run on all modems default settings and have poor performance.

a. Go to Control Panel/Modems and see which modems are listed there.
There should be only one modem listed and it's name should be 3com XXXXX. It should be exactly the same as your modem name.
If there's just something like standard 33.6 modem than you don't have modem inf file installed.

b. You should have drivers disks that you received with modem. Please install them (go to add button in Control Panel/Modems and then check don't detect...and select your modem manually. Click on have disk and point to the location where you have inf's for your modem. Delete the old modem). If you don't have inf files, you might try copying the files from your colegues computer and using them. (You stated that there are more such modems in your company and they all have better performance It might be good idea to check out their modem settings and apply them to your computer).

c. Let us check the settings:
Control Panel/Modems/Properties

1. "Maximum Speed" = 115200 (if you have 33.6 modem)
2. uncheck "only connect at this speed"
3. Connection tab:
Data bits: 8
Parity: none
Stop Bits: 1
4. Port Settings:
Use FIFO (if you have UART 16550) you said that you receive even worse results when enabling this. Please try out with these settings and if the're worse then disable FIFO ( BUT it should prevent you from achiving the highest performance)
Set receive and transmit buffers to highest possible
5. Click advanced
Check:
Use error control
Compress data
Use flow control - hardware
Modulation type - standard
Record a log file (you'll post me data from this file if this doesn't help you)

About you previous questions. It would be fatal to reset your modem's firmware, if noone messed up with it they should be correct. Anyway, you might wanna specify AT&F (or AT&F0, deppending on your modem) command at modems extra settings (ControlPanel/Modems/Properties/Connection/Advanced), this will reapply the modem's default settings (the best possible).

Your question about special setting that would enable you to use speed over 2X XXX bps, there is an Hayes compatibile setting for line modulation. It is ATFn where n is: 0 for an auto detect mode or example: 19 for 28.800..by default the setting is auto, and this is the best.

Yellow quetion mark. Which other card? NetAdapter (ethernet card on same PCMCIA card) or other (second) PCMCIA card.
If it is for ethernet card, than it is not configured after instalation, but if you're not using it, then this shouldn't be important. (I strongly advise you to ask you company computer maintaining personall to set up ethernet adapter).

Please, post me the results. (you might includelast 10-20 lines from modemlog.txt file if you still have problems.

Regards,

Damir
0
 

Author Comment

by:jff
ID: 1144555
Damir,
Thanks for all the info.  Here's what I did:
a. Control Panel/Modems - confirmed, it has only one
   modem listed and it's my exact 3com model.
b. Refreshed drivers (had already done this months ago).
c. Checked, settings, turned on modem log and tried again.
   Connected at 19,200.  Here is my modemlog.txt file (with
   date/time strpped off):

3Com (3C562C-3C563C) EtherLink III LAN+336 Modem PC Card in use.
Modem type: 3Com (3C562C-3C563C) EtherLink III LAN+336 Modem PC Card
Modem inf path: 3commdm.inf
Modem inf section: Modem1
115200,N,8,1
115200,N,8,1
Recv: <cr><lf>OK<cr><lf>
Interpreted response: OK
Send: AT&FE0V1&C1&D2 S0=0 W2 <cr>
Recv: AT&FE0V1&C1&D2 S0=0 W2 <cr>
Recv: <cr><lf>OK<cr><lf>
Interpreted response: OK
Send: ATS7=60S40=0L3M1\N7%C1&K3B0N1X4<cr>
Recv: <cr><lf>OK<cr><lf>
Interpreted response: OK
57600,N,8,1
Initializing modem.
Send: AT<cr>
Recv: <cr><lf>OK<cr><lf>
Interpreted response: OK
Send: AT&FE0V1&C1&D2 S0=0 W2 <cr>
Recv: <cr><lf>OK<cr><lf>
Interpreted response: OK
Send: ATS7=55S40=0L3M1\N7%C1&K3B0N1X4<cr>
Recv: <cr><lf>OK<cr><lf>
Interpreted response: OK
Dialing.
Send: ATDT;<cr>
Recv: <cr><lf>OK<cr><lf>
Interpreted response: OK
Dialing.
Send: ATDT##########<cr>
Recv: <cr>
Interpreted response: Informative
Recv: <lf>
Interpreted response: Informative
Recv: CONNECT 19200/V42BIS
Interpreted response: Connect
Connection established at 19200bps.
Error-control on.
Data compression on.

Sorry to keep rejecting good tries -- I realize the situation
may be hopeless but it nevers hurts to give everyone a
chance at it.  

THANKs for all the help,
Jason
0
How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

 
LVL 4

Expert Comment

by:dpavusin
ID: 1144556
You have specified your modem to use V42 protocol. It might be possible that your AT init set limits your connection to 19200.
Also set Max. speed to 115200, your 33.6 modem requires it!

Please let me study your modemlog file and I'll reply. I think that the answer is in it.

Please is it possible to try borrowing someone else's portable computer (from some of your colegues) and trying it with your line?

What happened to the question mark in system devices? (look at my previous question)?

Be aware that different modems has different response to telephone lines. It is possible that your desktop modem handles bad telephone lines better than your PCMCIA modem. It looks to me that you have at slightly worse tel. lines than normal (because even with a great modem like USR you have at your desktop, you aren't able to connect to the highest possible speed).

Regards,

Damir
0
 
LVL 1

Expert Comment

by:dunnaway
ID: 1144557
You may want to try "AT+MS=11,1,26400,33600" in ControlPanel/Modems/Properties/Connection/Advanced. This will set the Modem to V.34 with a minimum connect rate of 26.4 and a max of 33.6. If it won't connect at all with these settings try dropping the 26400 down to 24000 and see what happens.
Hope this helps.

Joe                        
0
 

Author Comment

by:jff
ID: 1144558
Damir -- max speed was already set to 115,200 on the Ctrl-Pnl,
         Modems setting.
Joe -- tried that AT string in 'Extra Settings' but then it
       wouldn't dial at all, got an error message that said
       there was an error in my modem or attached device!  I
       retried several times with same results.  Then I removed
       the AT line and it dialed in perfectly.  Did I put the
       string in the wrong place?  I went exactly where you
       said and then put the string in extra settings.
Thanks, Jason
0
 
LVL 5

Expert Comment

by:JBURGHARDT
ID: 1144559
Setings are incorect for your modem since it pccard it can be hard to get the right setings first after you install your modem you will see in control panel modem choose setings and speed 115200 and check only connect at this speed and also your win nt will asign com port make sure that speed selected is fastest
0
 

Author Comment

by:jff
ID: 1144560
Setting the "connect only at this speed" prevents me from
getting connected at all.  The other idea was already
suggested.  Thanks for the try, but no cigar.  Jason
0
 
LVL 5

Expert Comment

by:JBURGHARDT
ID: 1144561
Are all modems you using the same ITU standardrs if not then your problem is that modems can't connect at higher speed that 19,200
0
 

Author Comment

by:jff
ID: 1144562
I don't know what an ITU standard is, but both of my modems
connect faster to Mindspring (my ISP) over the same phone
line that I'm trying to connect to my office with.  Jason
P.S. - If you write back again, just out of curiosity let
       me know where your from?
0
 

Expert Comment

by:John_C
ID: 1144563
I tried to follow all the comments and proposed answers to your problem but it's just an awfully long list and I may have missed some of the stuff they've suggested.

Have you tried twexperts' suggestion of bringing your laptop and connecting it to another phone line?  Yes, I am aware that your other computer can connect at a higher rate.  The reason I wanted you to try another phone line is because I've had that exact problem with someone's 56.6 modem.  The modem seemed to connect are really low rates and I tinkered and tinkered with it and could get it working.  I even went as far as re-installing everything.  And I mean everything.  

After almost completely ruling out a software/driver problem, I decided to take his PC and modem and bring it over to my house and just plug it there.  Surprise, surprise, without changing a thing it was running perfectly.  It turned out to be the phone line.  Please note that he has 2 PCs and the second PC was connecting at the proper rate (without any problems) in the very phone line that was causing the other one problems.  So, I'm really curious to find out what happens if you try using another phone line (without making any changes to your modem or PC).

Good luck.
0
 
LVL 4

Expert Comment

by:jetx
ID: 1144564
first did you upgrade your modem drivers? if not, upgrade it call or email your modem distributor for driver download location

second is your modem's compatible with each other? Make sure that your modem is compatible and can support the same speed.

third check your modem speed setting at both ends. Make sure that each modem is in it's maximum baud rate.

regards,

jetx
0
 
LVL 4

Expert Comment

by:dpavusin
ID: 1144565
Jetx,

If you read all the previous messages you'll se that all of your suggestions have already been sugested and that jff tried them already.

1. Answered in the question from jff: "Both the modem
and the laptop have the latest firmware.."

2. "I have to co-workers with the
*exact* same configuration who both regularly dial in at
26,400 or 28,800..."

3. dpavusin:
 "c. Let us check the settings:
Control Panel/Modems/Properties
 "Maximum Speed" = 115200 (if you have 33.6 modem)..."

I know you only wish to help but you have to use some time and read all the question history, otherways it's just a waist of time (yours as well..)

Regards,

Damir
0
 

Author Comment

by:jff
ID: 1144566
Jetx,
Damir was right, I have tried all of that.
Jason

P.S. - JohnC, I still owe you an answer (and maybe some
others) -- sorry but it's been difficult to borrow a machine
and try some of the requests.  Thanks and I'll keep working
on it!
0
 

Expert Comment

by:retroman
ID: 1144567
If you are experiencing better peroformance with the exact same line on the same modem to another server (your ISP) then I would suggest that either a) the switched between you and your office are not the best, and b) since you aren't using a router/hub/server setup at your office, just modem to modem connections, the throughput may be down because you've got multiple modems working across the same lines. That will always cut down on bandwidth.

Here is something to try though:
Trace your entire phone line as much as you can, especially wherever there is a connection box (i.e. on your floor, in the basement, outside, etc). Look for a) stripped insulation off the wires anywhere, and b) points where the wire is kinked or bends at a steep angle in a small amount of space. Phone signals are just like plumbing. The straighter your run, the less friction you generate, and stripped insulation, even the smallest scuff, is just like puttine a small leak in your pipe, i.e. your pressure goes down.
0
 

Expert Comment

by:retroman
ID: 1144568
Also: if your phone line goes anywhere near a power cord, an appliance, a light ballast, or any other device carrying a decent current or inducing a good sized electromagnetic field, it will induce noise into the line. I just had to have my own new network connection totally rerouted cause it was going too near some electrical equipment, which was limiting my network connection to sending no more than <1K files at a time (useless).
0
 

Author Comment

by:jff
ID: 1144569
Thanks Retroman, but the other computers I share the
phone line with (I have a laptop and several desktops)
regularly dial-in and sustain 56K connections to my ISP.
For that reason alone I doubt it's the phone line.  I
think this whole thing is some incompatibility between my
3com PCMCIA modem and the US Robotics Courier modems we
have (although friends with the same laptop/modem do better
than I do! so who knows).
0
 
LVL 4

Accepted Solution

by:
dpavusin earned 120 total points
ID: 1144570
Jff, I'm almost sure that your problem is because your PCMCIA modem doesn't like the bad phone lines.. so it always connects at the lower rate..
USR is a great modem and it is possible that it handles problems on tel. lines better than your PCMCIA modem... The fact that you can connect to your office at the lower and to ISP at higher rate only confirms my suggestion.

SOLUTION: Check if this theory is correct. You have said that some of your colegues can connect using same configuration at higher rates.. Well take your laptop and go to the friend you know has the better connect rate. Than try dialing your office and your ISP from there, try changing modems (try his OCMCIA and let him try your..)
So we can finally move from here...

If it runs normally than phone lines are problem.. /from your house to office probably)
If at your friends PCMCIA run's better in your computer than your PCMCIA than PCMCIA is the problem.
If at his computer your PCMCIA runs normal (as his) and his PCMCIA at your comuter runs the same as yours (under performance) than your LAPTOP/Windows Configuration is wrong.. Check and compare his settings and yours (also compare BIOS settings)

We have to move from here, when you try this we will be able to detect what's the problem and than try fixing it.. but we cannot move on if we're not sure what's the problem..

Damir
0
 

Author Comment

by:jff
ID: 1144571
Damir,

I'm accepting because I don't have more time to spend on
this.  Once my work slows down I'll try out some of the
various suggestions -- in the meanwhile I hate to keep
you waiting.  

Thanks to everyone for all the time on this -- !!!! Sorry
I couldn't distribute points (I would if I could!) as a few
people deserve them!

Jason
0

Featured Post

How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

Join & Write a Comment

Hi there, This article summarizes what you need if you are going to set up your home or small business Network Attached Storage (NAS) to be accessible from the internet. Of course there are configuration differences based on your NAS or router ma…
#Citrix #Citrix Netscaler #HTTP Compression #Load Balance
This tutorial demonstrates a quick way of adding group price to multiple Magento products.
This video demonstrates how to create an example email signature rule for a department in a company using CodeTwo Exchange Rules. The signature will be inserted beneath users' latest emails in conversations and will be displayed in users' Sent Items…

759 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

18 Experts available now in Live!

Get 1:1 Help Now