WORDBASIC ERR=7 !Out of Memory

I am using Word 6 on a computer with 8M RAM. Whenever I start the computer it comes up with the message WordBasic Err=7 !Out of Memory. After that the message keeps on coming whenever I want to load a new document or save an old one. In short I cannot used Word anymore. How can I fix this problem?

I am using Win3.1
MGAYAKVAsked:
Who is Participating?
 
Steve GronerConnect With a Mentor Lead Systems EngineerCommented:
Delete all of the files in your C:\temp, and c:\windows temp directory.  This problem occurs when you have to many temp files.  Also you can try to start word while holding down a shift key.  This will prevent any macros that may be autostarted from starting.
0
 
LlandrCommented:
Are you using Win 3.1 or 3.11?
0
 
MGAYAKVAuthor Commented:
Edited text of question
0
Cloud Class® Course: CompTIA Cloud+

The CompTIA Cloud+ Basic training course will teach you about cloud concepts and models, data storage, networking, and network infrastructure.

 
LlandrCommented:
Usually this problem is not due to loss of 8 MB of memory but instead due to loss of resources. You may wan't to check your config.sys and autoexec.bat and also chekc how much dos-memory you have when running windows.
Go to DOS-prompt and type mem.
If memory is below 450 you may have problems here, also if you have a lot of programs running that eats resources (like Lotus Notes)
0
 
MGAYAKVAuthor Commented:
Thank you Sgroner and Landr. The largest executable program size is 612K and the largest free upper memory block is 37K. There aren't any TSR running in the background. There aren't any temp directories in windows or root directory.


0
 
Steve GronerLead Systems EngineerCommented:
Thats part of your problem, create a dir on root called temp,  in your autoexec.bat file place these entries

set tmp=c:\temp
set temp=c:\temp

Also check you swap file, and make sure it is not currupted.  Best way is to remove it and reboot, then run scandisk on the drive, then recreate your swapfile.
0
 
MGAYAKVAuthor Commented:
I have tried Sgroner's suggestions but it does not work. I am sure there is enough memory because whereas Winword complains about "Not Enough Memory" I can make it run in the background and start Excel in the foreground, load a big worksheet and Excel does not complain about lack of memory.
0
 
Steve GronerLead Systems EngineerCommented:
Sorry, the only thing I would try is just to reload word, over top of the existing, I think you can do a re install with Word 6, which keeps all the settings, but re-installs all of the .exe, and .dll files.


0
 
Steve GronerLead Systems EngineerCommented:
Also, does this happen with all files or just a particular file ?
0
 
MGAYAKVAuthor Commented:
Sgroner, Winword does not like to open any file. It hates the commands "open", "save" and "save as". Thank you for your time. I am going to reload the program.
0
 
misteraguyCommented:
This is lousy answer. It does now work.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.