PPP within linux slackware 3.2

modem is setup properly as it will dial out of minicom, however, it doesn't seem to setup a propper PPP connection with the command "ppp-on" the resolv.conf script has my domain name and my nameserver IP's in it.  The hosts.conf is setup as well.  entries hvae been made to ppp-on to reflect the login and pass as well as the dynamic IP addressing.  Now I'm stumped as when ppp-on command is issued not hing happens I just get another command line... after sometime thinking its working in the back ground I attempt a ftp connect or telnet, lynx neither of the above worked.  When issuing PPP-OFF I was informed ERROR: socket or something isn't connected.  I would like to find away to connect PPP so that I can use web browsing ftp, telnet, and BitchX.  I have been unsuccessful.  Any help would be greatly appreciated.
sirwyattAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

bjacobsCommented:
Hello,
You can get setup info at www.ibm.net. Go to helpdesk and get the linux ppp connection setup instructions. Substitute you ISP's info where appropriate if you are not using IBM for access. Make sure to follow all the instructions and you should be online soon!
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
frowijnCommented:
Forget it, the only thing what you have to do is :

1. Edit your resolv.conf, there must be the ipnumber and name of the domainnameserver of your internet provider !
2. copy the ppp-on & ppp-off script to the /etc/ppp
3. adjust the ppp-on with the correct telephone number etc., but before your login name your must type a capital P, so when your loginname is siwyatt, its Psiwyatt, supply a password with it.
4. launch the ppp-on with ./ppp-on
5. type route del default
6. type route add default ppp0
7. you're connected !
8. for logoff, type ./ppp-off or simply turn off your modem !

Oscar Frowijn
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.