We help IT Professionals succeed at work.

SCSI drive reporting wrong ID

caspian121197
on
Medium Priority
361 Views
Last Modified: 2008-02-01
Can someone please help with the following situation:
We have a Dell OmniPlex 590.
Sco Unix System V, Version 3.2.4.
One internal 500MB DEC SCSI drive (ID 0) on a built in NCR SCSI adapter.
One external HP DAT Tape drive (ID 1)
Three external SCSI drives (ID 4=2GB, ID 5=1GB, ID 6=1 GB)
    The tape drive and the three external drives are on an     Adaptec 2940 SCSI adapter.
The 2GB external replaced a 1GB external at the same position on the chain and at the same ID (4).
When we boot, the NCR SCSI BIOS now reports the internal drive as ID 4, even though the jumpers are set to ID 0. No modifications were made to this drive, the PC case wasn't even opened. The Adaptec still reports all of the other drives correctly (IDs 1, 4, 5 & 6) when viewed in the
SCSI Select utility during boot up.
However, UNIX now fails to boot and gives the following message:
PANIC: srmountfun - error 6 mounting rootdev hd (1/40).
It then tries to dump pages, fails and puts me at the "safe to power down or reboot" message. No previous versions of UNIX worked (unix.old, etc.). It will however boot into DOS.
We reformatted the internal drive, and attempted to configure the internal drive and restore the root file system from our last full backup using CTAR. However when you choose the internal drive (/dev/rhd00) it says that there is no such device available. I am assuming this error is because the drive is assigned as ID 4 instead of the correct ID 0.
I also tried disconnected all of the external drives and it still gets assigned the ID 4.
Does anyone know why this is happening and how I can remedy the situation?
Dell tech support seems to think the drive itself is bad. Before we order a replacement I just want to make sure I covered all of the bases.

Sorry this is so long but I wanted to include as much info as possible.
Any advice will be greatly appreciated.

Thank you.

Comment
Watch Question

go to scsi select and make sure you selected the drive with id 0  as your boot drive
Commented:
Not sure that this will help, however as you have a different type of drive in what seems now to be an older system, the problem could easily reside in a termination issue.

Many of the newer drives handle termination differently than old drives.

It appears that you have checked most or all of the options quite thoroughly.  So far as disconnecting the external chain, you want to be certain that the last drive in the chain is terminated, and this is likely not the case.

I would suggest you disconnect the external drives, terminate the internal drive which should show as ID 0.

If the system now boots, the drive is most likely OK.

If the system still does not boot, I would suggest you check the cables.  Replace the internal SCSI cable with a one drive cable, ensuring that pin one is aligned correctly (of course).  

If the system still does not boot, then odds are the drive is toast, or at least on it's way to being toast.

I would also try subbing in the replaced 1gb drive where the internal 500 mb is now, format with dos and see if it boots as ID 0.  If this works, remove termination and add the external drives as required by documentation, then see if it still boots with the proper drive id's.

Good luck.

Chris Maylor

Not the solution you were looking for? Getting a personalized solution is easy.

Ask the Experts
Access more of Experts Exchange with a free account
Thanks for using Experts Exchange.

Create a free account to continue.

Limited access with a free account allows you to:

  • View three pieces of content (articles, solutions, posts, and videos)
  • Ask the experts questions (counted toward content limit)
  • Customize your dashboard and profile

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.