We help IT Professionals succeed at work.

Replacing a D: Drive in Win95

McDorman asked
Medium Priority
Last Modified: 2013-12-16
I recently had to replace a hard drive.  It is an external unit.  I also have 3 CD-Roms, therefore A, C, D, E, F, G.  I can see the hard drive in Explorer, but if I try to open it, I get a message that says D:\ is not accessable.  A device attached to the system is not functioning.  I can Fdisk it with no problems, it shows up in Explorer, I can select it from DOS, but can not write to it, or read from it.  All my hard drives are Ultra SCSI drives running through an Adaptec Ultra SCSI card.  1 CD is IDE, the other 2 are SCSI.  It used to work with this same drive, but the drive was reformated between then and now.

I'm running Win 95 OSR2, with a Pent II, 266.

What am I missing?

Watch Question

Hi McDorman ...

I recognize this particular problem <g>..

What i think that happened is that you fdisked it with the osr2 fdisk and that you created a fat32 partition (while don't use it on osr2).
simply boot up from a floppy with msdos 6 and format the drive either using adaptecs scsifmt or use the old dos fdisk and format if the id is suitable to do so ..

that should do it , it occurs here every now and then and this should help you to if i understood your problem .

best regards eddie

Not the solution you were looking for? Getting a personalized solution is easy.

Ask the Experts



It is true, I am using the fdisk from OSR2, but that is what I used on my C: drive.  I want to have partitians the full size of my 4 gig drive, rather than 2 gig maximum.

I will try adaptec's SCSI format and let you know.



to evil_ed...

Am I missing something in your answer or what??
He is running OSR2, he used FDISK which came with OSR2, he could have refused or accepted to disable or enable FAT32.  Where does it say in any litterature that Windows OSR2 will not recognize the DRIVE if it's a FAT32???

This is an absolute wrong statement (sorry)

Hi Tom,

Could you elaborate more as I really need to understand the situation here:

Can you list which drives are SCSI or not, which are externals drive letter in sequence.

How was the setting before and after the problem.  Did you check on the pins for master and slave??

Will wait for your update.

What happen with the other system?? did you use my step by step way to the window?? *lol*


Raouf, Eddie

Same system, just expanding on it, and learning more.

I have no IDE Hard drives.  I have the primary IDE channel connected to an IDE CD-ROM, and an LS 120, Ultra High Capacity Floppy.  That is all that is connected to the IDE Channel.

The LS 120 is Drive A:  The IDE CD-ROM is Drive E:  Drive C: is my SCSI hard drive, ID=0.  I used the OSR2 Fdisk command on Drive C: to get it to be 4 Gig.  This was the only way I could a partition larger than 2 gig.  Drive D: was originally formated with a non OSR2, with multiple partions.  That worked fine.  Then I reformatted it with Fdisk from OSR2 and now I can not access the drive, although it shows up in DOS, and in Explorer.

The other CD-ROMS are drives F: and G: and they are SCSI.  They work just fine.

Today I tried reformatting with Adaptecs SCSI format, but OSR2 does not recognize the drive at all now, so I will reformat with fdisk, OSR 2 and wait for more input from you guys.

Drive A: Internal IDE UHD Floppy
Drive C: Internal SCSI 4 GB Hard Drive
Drive D: External Tower Case, SCSI 4GB Hard Drive
Drive E: Internal IDE CD-ROM
Drive F: Internal SCSI CD-ROM
Drive G: External Tower Case, SCSI CD-ROM

The external tower is a 4 bay drive case, with 2 bays still open.

Hope this helps you solve my problem.




Try the following:

1) Boot your system
2) When the "Starting Windows 95..." is displayed hit F8
3) From the menu, select Dos prompt
4) Use the Fdisk command
5) Answer yes to enable FAT32 when prompt for the large media
6) In your FDISK, change hard drive to switch to drive 2
7) Delete the partition on DRIVE 2
8) Repeat step 4 to 6
9) Create a new EXTENTED partition
10) Don't format the drive in DOS
11) Boot to windows
12) Right click on drive D, and select format.

Please update what happens



I have solved the problem.  Stupid Me!  First, there are two versions of setup in OSR2.  The first "setup" is on the primary directory, the other is called "oemsetup" and is in the Win95 subdirectory.  When installing on a new system, even if you have fdisk'd the drive, the oemsetup version will "format" the drive.  However, apparently, it will only format Drive C:.  When I used fdisk again, I made sure the partition was made active, then I saw the message that said to be sure to "format" after restarting the computer.  So when I got back to Win95, and looked at Explorer, I right clicked on Drive D:.  Sure enough, there was the good old "format" command.  I chose this "format", and now everything works great. The fdisk and Format command are obviously different levels, but I was not aware of the subtle differences.

Thanks for your support anyway.


Tom McD

Good for you Tom.
Now remove the question if I was of no help to you by e-mailing:
linda@experts-echange.com and ask her to credit back the points.
Regards and have a nice holidays


Sorry Ed, but since the real answer lies in using Win95, right click, format, I am giving a poor grade.  I actually tried to decrease the points, but the exchange system does not support that idea.  

Raouf,  thanks for your reply.  As I accessed the exchange to tell you the answer, you also had the correct idea.

See you guys on the next problem.


Tom McD

Next time select REOPEN THE QUESTION to other tech, if you want to give me the chance to post my comment as an answer.



I already sent a message to Linda on this subject.  I told her that you gave the correct answer.  I will see what she says.

Thanks, take care,


Yoo Magigraf ...

Where's the fire ...

I read that he wasn't able to read or write to the disk from DOS
meaning that dos can't use the drive, if it is fat 32 dos can't do anything with it IMHO..

grtx eddie

Hi Mcdorman ...

Thanks for grading me without the proper answer <g>
it mustbe christmas ...

more luck next time ....

have some happy holidays ...

grtx eddie
Access more of Experts Exchange with a free account
Thanks for using Experts Exchange.

Create a free account to continue.

Limited access with a free account allows you to:

  • View three pieces of content (articles, solutions, posts, and videos)
  • Ask the experts questions (counted toward content limit)
  • Customize your dashboard and profile

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.


Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.