Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 250
  • Last Modified:

IDE Zip with SCSI Adapter

I have just finished building a Pentium II 300 on a LX motherboard, no problems there. Installed a SCSI 6X 4X CD writeable, no problems there. During all of this process the system contained a IDE Zip drive that was recognised by both CMOS & Windows 95 without problems. When you try to access a disk it says "Device not Ready" and doesn't even powerup the motor (except when the disk is inserted). The IDE bus contains:- Primary 4.3Gb & CD-Rom Secondary 6.4Gb & Zip.
I have removed the card and drivers for the SCSI but to no avail, the Zip is O.K. as it works in another system. I am assuming the IDE in the Zip is simulated SCSI as with the parallel drive.
0
arutha
Asked:
arutha
  • 4
  • 4
1 Solution
 
dew_associatesCommented:
Arutha: As I understand what is happening, everything works fine until the scsi card is installed, at which time the zip drive stops working (btw: what type of zip drive?) When you pull the scsi card back out the zip drive starts working again. If this is correct, and unless there is a specific issue with your brand of zip drive, put the scsi card and drivers back in and check as follows:

1. Go to Control Panel, System Icon, Device Manager and check both the Zip Drive and the SCSI card entries and look for device conflicts.

2. Using either NotePad or WordPad, open a file on the root of drive "C" called bootlog.txt, and review the last 10 or 20 lines looking for failures. Some are normal to windows 95, but others are not. Post what you find here (if any) and we will sort them out with you.
Best regards,
Dennis
0
 
aruthaAuthor Commented:
Dennis,
It now doesn't matter whether the SCSI card is in or not. It is a Iomega Zip 100 purchased 5/97, my own is announced as a LS-120 Iomega Zip 100 purchased 11/97. I will review the files and get back to you. Thanks for the quick response.
Arutha
0
 
PHOENIXCommented:
I would assume tht somewhere the drive letter assignments are not what they used to be and when you try to run a program,( I imagine that is when you have the problem), the drive is looking for a cd/rom and finds a zip drive.
0
What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

 
aruthaAuthor Commented:
Thankyou Phoenix, the drive allocations HAVE been changed in Windows95 to put the 2 x CD-Roms as the last devices as requested. I will look at this and see if it makes the difference and get back to you all.
0
 
dew_associatesCommented:
Hi Arutha, sorry it took so long to get back, we had server access problems with this site.

The cd rom drives will always be the last letter assignments. First will be IDE/EIDE (if any), then SCSI, then CD Rom. There are a couple of issues regarding Iomega zip drives, however the fixes are dependant upon the version of Windows 95 you have!
Dennis
0
 
aruthaAuthor Commented:
Dennis,
I tried resetting the CD-Rom & Zip assignments, the Zip now appears last. This didn't solve the access problem. I would be keen to find the fixes you spoke of as this is becoming quite stressful trying to resolve this.
Regards,
Arutha

0
 
dew_associatesCommented:
Arutha, are you using version 950/950a  or  950b of Windows 95?
Dennis
0
 
aruthaAuthor Commented:
Dennis,
It has Windows95 OSR-2.1.
Regards,
Arutha

0
 
dew_associatesCommented:
Arutha: Let's start here, as it appears as the most likely area.

An Iomega Zip Drive normally should attach either to a Parallel port or SCSI port connector, however you note that it is attached to an IDE/EIDE connector on the motherboard as a slave device. This being the case, then yours is either the IDE or the Atapi version. Which do you have. If either version, has the drive been pinned as a slave device?

Also, have you installed the protected-mode driver for the Iomega Zip Drive? If not. here's how to do so manually using the Add New Hardware tool in Control Panel. To do so, follow these steps:
 
1. In Control Panel, double-click the Add New Hardware icon, and then click Next.
 
2. Click No, and then click Next.
 
3. In the Hardware Types box, click Other Devices, and then click Next.
 
4. In the Manufacturers box, click Iomega, and then click Have Disk.
 
5. In the Copy Manufacturer's Files From box, type the location of the driver files on the CD-ROM, and then click OK. For example, type:
 
      d:\drivers\storage\iomega
 
6. Click Next to install the driver.
 
Normally a Zip Drive is connected to a parallel port, however, you can install the driver whether or not a Zip Drive is currently connected to that parallel port.
 
The protected-mode driver is located in the Drivers\Storage\Iomega folder on the Windows 95 CD-ROM, or you can obtain the driver directly from Iomega.
 
NOTE: After you install the protected-mode driver, make sure to remove the real-mode drivers for the Zip Drive from the Config.sys and Autoexec.bat files. For information about removing these drivers, please consult the Zip Drive's documentation.
 
NOTE: Getting a "Device Not Ready" error usually means that you are loading both real mode and protected mode drivers, but when you mention the SCSI issue, it becomes unclear what type of system arrangement you have. What does the SCSI interface have to do with this drive?

I'll pull additional issues if they seem relevant.
Dennis
0

Featured Post

What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

  • 4
  • 4
Tackle projects and never again get stuck behind a technical roadblock.
Join Now