3Com 905TX speed problem

My 905 card runs in 10Mbit. My connection is 100.
In NT the card works fine. I have checked the card
with the diagnostics from 3Com, OK.
MessiasAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

jeffa072897Commented:
You will need to use 3Com's utility to manually set the card for 100mb. What the utility does is disable plug and play. Then the 3Com congif program will let you lock the speed at 100.
If you're running a kernel older than 2.0.29 then look at
http://cdes.gsfc.nasa.gov for the latest "vortex driver that supports this card. In the doc for the driver you may also be able to set the card up as a module and with a command line option (i.e. insmod 3c59x <opt.> ) set the speed as well.
Try the latest driver first, copiled in the kernel.
Then the module.
Lastly manually the card.

0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux Networking

From novice to tech pro — start learning today.