• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 813
  • Last Modified:

DOS application codepage

There's a font file called DOSAPP.FON which NT uses to display full-screen DOS applications. But that font file is codepage 437. Where do I find a version of DOSAPP.FON that is codepage 850 and/or codepage 865?
0
jke
Asked:
jke
  • 6
  • 6
  • 2
1 Solution
 
bbaoIT ConsultantCommented:
You may find these files at NT CD-ROM's \i386 directory.

APP775   FO_
APP850   FO_
APP852   FO_
APP857   FO_
APP866   FO_

Use NT's Expand utility to decompress them to your hard disk.
0
 
jkeAuthor Commented:
First of all, these are application window fonts and not DOS application fonts. Secondly, I need the 865 codepage, since it contains danish/norwegian o-slash characters (ASCII 155 & 157), but still has graphics where codepage 850 contains international characters. The proposed files are for codepages 775, 850, 852, 857 & 866 which is pretty useless to me. Sorry.
0
 
bbaoIT ConsultantCommented:
Sorry, I dont think these fonts are for Windows, they are for DOS applications, I have checked their content for verifying this, you may also do it.

As for the file to assist code page 865, could you tell me what version of NT 4 you have? English version of Danish version? Maybe you need right version and specify which language you are using during NT setup.

BTW, you mentioned you need  a version of DOSAPP.FON that is codepage 850 and/OR codepage 865. :-)

Hope this helps.
0
Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

 
jkeAuthor Commented:
Yup, APPxxx.FON and DOSAPP.FON looks pretty much the same, but they're still only codepages 850 and 437.

The NT version is danish, BUT it's the same problem on the english version. Same files, same everything except for the language that it's using. The danish version is one, that I'm setting up for a friend of mine, but I'm running the english version myself.the danish is
0
 
bbaoIT ConsultantCommented:
At first, codepage 865 uses app850.fon as its DOS application font, the description is:

865= 2:xlat865.bin, 2:vga865.fon, 2:app850.fon, "Nordic (865)"

Secondly, these files are for DOS prompt, although they stays at WINNT\Fonts directory. There are many Windows fonts at there.

You may change your MSDOS prompt's codepage by do the following:

1. Change the language to Danish in Control Panel/Regional Settings,
2. Add Danish to Control Panel/Keyboard/Input Locales,
3. Open MS-DOS prompt,
4. Change Language to Danish by clicking task bar's EN  icon,
5. Type "mode con: cp select=850" or  "mode con: cp select=865" to change the codepage.

Hope this helps. :-)
0
 
jkeAuthor Commented:
But that only works if the DOS application is started in windowed state and THEN changed to full-screen via <Alt-Enter>.

If I set the program's properties to start in full-screen mode, it uses codepage 437! Unfortunately, the mode con cp select=865 doesn't work here.

I cannot believe that this is something I just have to live with.
0
 
cerCommented:
What if you specify these settings in the default DOS-startup file AUTOEXEC.NT / CONFIG.NT ?

0
 
jkeAuthor Commented:
Just putting "mode con cp select=865" into the AUTOEXEC.NT file doesn't work unless you start the DOS application in windowed state and THEN press <Alt Enter> to go into full-screen mode.
0
 
cerCommented:
I remember an old question where one wanted to have hebrew font in the fullscreen dos-box. Don't remember if he succeeded, but you may want to look in the PAQ's of NT-setup or NT-general.
0
 
bbaoIT ConsultantCommented:
Only works in full-screen mode? Maybe caused by some character re-mapping could not be done in Windowed DOS prompt, which is a simulated text mode. If so, how about  set the MS-DOS properties with full-screen mode?

Let me know how it works.
0
 
jkeAuthor Commented:
The MS-DOS properties with full-screen mode is exactly what does not work. If it is set to window at startup and then converted into full-screen with <Alt-Enter>, it'll work. But surely, that cannot be the way to do it?
0
 
bbaoIT ConsultantCommented:
It is not a normal way, but it maybe work: copy app850.fon overwrite the existing dosapp.fon, force NT use this font file. :-)
0
 
jkeAuthor Commented:
Nope, that didn't work. Still codepage 437. I've just found out, that my DOS application initializes the graphics adaptor to a screen mode, that is defined within the application. That unfortunately causes the screen mode to go back to the ga's default, which is 437.

I have closed this question as it suddenly appeared to me, that my problem is with the DOS application, really, so I have to find a way to workaround it from here.

Sorry for the time I took but thank you for the suggestions as they've taught me a little bit more about how NT handles it's textmode fonts.
0
 
bbaoIT ConsultantCommented:
It seems that I did not answer your question, so it is not necessary to accept this question.

Anyway, glad to hear that you have known the cause.
0

Featured Post

What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

  • 6
  • 6
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now