Mouse Trouble

I recieved a new Mouse as a christmas gift.

It works fine under X when I use the MouseSystems protocol and ClearDTR but I can't get iit to work in console-mode or under qwcl (quake world client)  (using svga-lib with MouseSystem and ClearDTR in /etc/libvga.conf)

Can someone help me get the mouse to work???
chuckenAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

bjacobsCommented:
use the gpm mouse program for console-mode.
0
chuckenAuthor Commented:
That is just what I did.
It does not work!

0
bjacobsCommented:
What type of mouse is it?(serial, bus, ps2)
0
The Ultimate Tool Kit for Technolgy Solution Provi

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy for valuable how-to assets including sample agreements, checklists, flowcharts, and more!

chuckenAuthor Commented:
I'ts a serial Mouse. It works with MouseSystems under X when i enable ClearDTR. Under DOS I can run it in MouseSystems mode or as a Microsoft Mouse. But I can't get it to work in MouseSystem mode under Linux (console mode and svgalib, Under X it works)
I like to use the third buttom, (It's bad to play squake (svga quake) withoute the third button.
0
bjacobsCommented:
Here is some info from the mouse mini-howto:

 6. Using gpm to Switch Mouse Modes
 
   gpm is the program that lets you use the mouse in console mode. It is
   usually included in linux distributions, and can be started from the
   command line or in the startup script /etc/rc.d/rc.local. gpm is the
   cause of much problem to people using bus mice, since it locks the
   mouse and stops X from using it - those of us using serial mice don't
   have this problem.
   
   The two main modes for serial mice under gpm are:

     * gpm -t ms for Microsoft mode;
     * gpm -t msc for MouseSystems mode.
       
   To run gpm in MouseSystems mode, you may need a -3 flag, and possibly
   a DTR option, using the -o dtr flag:
   
     * gpm -3 -o dtr -t msc
       
   You may also be able to use gpm to probe the mouse for you and tell
   you what protocol the mouse is currently using:

     * gpm -t help
       
   However, gpm is often able to recognise all three buttons of the mouse
   even in Microsoft mode. And newer versions (Version 1.0 and later (?))
   can then make this information available to other programs. For this
   to work, you need to run gpm with the -R tag, like this:

     * gpm -R -t ms
       
   This will make gpm re-export the mouse data to a new device, called
   /dev/gpmdata, which looks like a mouse to any other program. Note that
   this device _always_ uses the MouseSystems protocol. You can then set
   your Xconfig to use this instead of /dev/mouse as shown below, but of
   course you must ensure gpm is always running when you use X. Some
   people have reported that some middle-button events are not correctly
   interpreted by X using this technique, this may be down to an
   individual mouse setup.
   
   Changing button mapping for gpm and X (gustafso@math.utah.edu)
   
   You may find that gpm uses different default button mappings to X, so
   using both systems on the same machine can be confusing. To make X use
   the same buttons for select and paste operations as gpm, use the X
   command

     * xmodmap -e "pointer = 1 3 2"
       
   which causes the left button to select and the right button to paste,
   for either 2-button or 3-button mice. To force gpm to use the X
   standard button mapping, start it with a -B command, eg:

     * gpm -t msc -B 132
   ------------------------------------------------------------
Let me know if you still have problems.
Bob Jacobs
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
chuckenAuthor Commented:
Thanks. I missed the -o dtr flag. It seems to work under svga-lin also after changing this (I thought it would be enough to set MouseSyste3ms and clear dtr in libvga.conf.
The strange thing is that al my buttons started to work under console when i chosed Microsoft (But not in svga lib). But now everything works. Thanks!
0
chuckenAuthor Commented:
Thanks. I missed the -o dtr flag. It seems to work under svga-lin also after changing this (I thought it would be enough to set MouseSyste3ms and clear dtr in libvga.conf.
The strange thing is that al my buttons started to work under console when i chosed Microsoft (But not in svga lib). But now everything works. Thanks!
0
chuckenAuthor Commented:
No I was wrong! It worked when I tried to start quake one time, but now it does not work anymore. (in quake) It works in console mode....
0
chuckenAuthor Commented:
Where did you find the mouse mini-howto?? I can't find it anywhere...
0
bjacobsCommented:
You can get it at:
 
  http://kipper.york.ac.uk/mouse.html

I don't have Quake so don't know about that.

Bob
0
chuckenAuthor Commented:
You use svga-lib to configruate the mose in quake....
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.