Solved

Using pppd dialinginto a WINS

Posted on 1998-01-03
2
344 Views
Last Modified: 2010-05-18
Dialing into sprint.ca, I don't get a username or password prompt.  Using Windows95, I place my username & password in the dial-up box, I do not have to configure my "Dial-up" connection with any IP addresses OR use any scripting.  Sprint says they are using Windows95/NT for ther server?!

Has anyone figured out how to make pppd work with this type of a dial in?  Sprint somehow gets my username and password from the Win95 dialup box, without scripts!?  Alas in Linux, it seems to connect, jump into ppp and the connection hangs up.
0
Comment
Question by:riki
2 Comments
 
LVL 1

Accepted Solution

by:
abidn earned 190 total points
ID: 1635138
NT Server uses PAP (also, CHAP, etc.) security which your Win95's dialup networking knows how to deal with. PPPD needs to be helped a little bit. Here is how:

1. goto /etc/ppp directory and edit pap-secrets file to include your user name & password assigned by Sprint (also give Sprint a name). By the way, if the file is not there, create one.
2. Use pppd with following command line options:
crtscts defaultroute lock remotename sprint
(in above line, replace "sprint" with whatever name you gave them in your pap-secrets file)

This should let you connect.

Optional But Recommended: I am afraid you will have to tell your linux box to use domain name server which sprint uses/has. You could edit your /etc/resolv.conf file and add those DNS IP's. The trouble with this approach is that when you are not using sprint, your name searches may be a bit slow (because your resolver will try to connect to sprint's DNS IP which will not be reachable). Solution is a bit involved & merits reading HOWTO's. However, for the time being you can hard code Sprint's DNS IP's in your resolv.conf file.

Hope above helps.

tks -an.


0
 

Author Comment

by:riki
ID: 1635139
This answer got me on the right track, but if did not resolve my problem solely on this answer, it took a download of a more recent PPP-HOWTO.gz than I had, and this answer to finally solve the problem.  Thanks, I can now access my ISP using PAP.  Easier than using "normal" loging prompting!! :)

Failed to mention: name <loginname> in /etc/ppp/options file
Could have mentioned: pap-secrets format.

Thank-you again, I'm on the net via Linux.........
0

Featured Post

Backup Your Microsoft Windows Server®

Backup all your Microsoft Windows Server – on-premises, in remote locations, in private and hybrid clouds. Your entire Windows Server will be backed up in one easy step with patented, block-level disk imaging. We achieve RTOs (recovery time objectives) as low as 15 seconds.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

If you have a server on collocation with the super-fast CPU, that doesn't mean that you get it running at full power. Here is a preamble. When doing inventory of Linux servers, that I'm administering, I've found that some of them are running on l…
Introduction We as admins face situation where we need to redirect websites to another. This may be required as a part of an upgrade keeping the old URL but website should be served from new URL. This document would brief you on different ways ca…
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.
This demo shows you how to set up the containerized NetScaler CPX with NetScaler Management and Analytics System in a non-routable Mesos/Marathon environment for use with Micro-Services applications.

863 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

25 Experts available now in Live!

Get 1:1 Help Now