Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win

x
?
Solved

A Problem with Frames in Netscape

Posted on 1998-01-06
8
Medium Priority
?
270 Views
Last Modified: 2013-12-25
Here is the problem I'm having:  I have a frameset that splits the page in half one side is called Left and the other Right.  The links in the left side fill in the right side of the screen.  It works fine in IE, but in netscape the links are opening a new copy of netscape instead of filling the right side of the screen.

Here is the Frameset HTML:
<html>


<head>
<title>Central Listing Service - Results</title>
<meta name="GENERATOR" content="Microsoft FrontPage 3.0">
</head>


<frameset framespacing="0" border="false" frameborder="0" cols="260,*">
  <frame name="Left" src="Pictures.asp" target="Right" scrolling="Yes" noresize>
  <frame name="Right" src target="Right" scrolling="auto" noresize>
  <noframes>
  <body>
  <p>This page uses frames, but your browser doesn't support them.</p>
  </body>
  </noframes>
</frameset>
</html>


Here is the HTML for the page on the left:
<html>

<head>
<meta name="GENERATOR" content="Microsoft FrontPage 3.0">
<base target="right">
<title>Central Listing Service - Results</title>
</head>

<body background="images/background.gif">
<a href="Print.asp" target="_blank">

<p>To Print all listings fitting this criteria</p>
</a> </p>


<p><center><a href="Print.asp?CLS=Mike21" target="Right">
Sandwich<br>
<img src="images/Mike21.jpg" width="230"
height="150" border="1" vspace="2"><br>
<table width="100%" border="0">
  <tr>
    <td colspan="2" align="center">139000</td>
  </tr>
  <tr>
    <td width="50%">3 Bedroom</td>
    <td width="50%">Cape
  </tr>
  <tr>
    <td width="50%">1 1/2 Bath</td>
    <td width="50%">.89 Acres</td>
  </tr>
  <tr>
    <td colspan="2">Michael Johnson Realty Assoc.</td>
  </tr>
</table>
</a></center></p>




</p>
<p>
</p>
</body>
</html>



I stumped as to why it's not working so any help would be greatly appreciated:  BTW I'm using FrontPage 98 to develop the pages.
0
Comment
Question by:Jagar
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
  • 2
  • +1
8 Comments
 
LVL 1

Expert Comment

by:jello
ID: 1856196
The problem is the line that reads

<a href="Print.asp" target="_blank">

it should read

<a href="Print.asp" target="_right">

The "_blank" tag is what's causing a new window to open.
0
 
LVL 6

Expert Comment

by:tecbuilder
ID: 1856197
you're right about the  "_right", tecbuilder.
That's what I get for typing too fast  ; )
0
 
LVL 1

Expert Comment

by:jello
ID: 1856198
tecbuilder...

You are sharp..

Regards
0
Simplify Your Workload with One Tool

How do you combat today’s intelligent hacker while managing multiple domains and platforms? By simplifying your workload with one tool. With Lunarpages hosting through Plesk Onyx, you can:

Automate SSL generation and installation with two clicks
Experience total server control

 
LVL 9

Expert Comment

by:magigraf
ID: 1856199
Sorry I havent been around lately to check on this, but I'm going to check it right now and I'll get back to you later today.
Also you right it is the second Anchor tag that I was having problems with.

0
 
LVL 2

Author Comment

by:Jagar
ID: 1856200
I made all of your changes, but the same thing still happens.
This is really bugging me because I use frames throughout the site and this is the only place that gives me a problem.  If you want to go to the site and check it out that way it's www.centlist.com then go to Search then click the find button

0
 
LVL 2

Author Comment

by:Jagar
ID: 1856201
The problame appears to lie in your frameset, rather than in the final document.  first, a few little things:

"border" in the frameset line should="0", not "false."
There is a "src" attribute in your second frame tag with no value -- try removing it or placing a dummy page in that frame to begin with.
The src attribute should preceed the name attribute in the frame tag (this may be merely aesthetic, but these things sometimes make a difference.)
Your frameset tag should close before the noframes tag is opened.

Here's the biggie. remove the target attribute from the frame tag.
In the actual source of your document, name the target in the a href command. (as Tecbuilder correctly described.)

Let me know if this helps.

-jello
0
 
LVL 1

Accepted Solution

by:
jello earned 280 total points
ID: 1856202
I was going to put this as the answer, but jello beat me to it.  If what I described below works, please allow me the opportunity to post it as the answer.

tebuilder

I believe your problem rises from having a frameset defined within a frame.  Therefore, I would drop the <Base Target="SearchMain"> and include the target property within the anchor.  I will do my best to explain what I see.

You first defined a frameset with frame names 'header' and 'main'.  Within frame main you defined another frameset with frame names 'left' and 'right'.  The 'left' frame has your anchor and tag with text and image enclosed and table of information below.  The 'right' frame seems to have defined another frameset with frame names 'SearchContents' and 'SearchMain'.  Here is where I see something that may be part of the problem.  In frame 'SearchMain you do not define a source file.  It could be that as far as the browser is concerned it the frame doesn't exist, but I don't think so.  A simple fix is to create a blank html file with <html></html> tags in it. or use src="<html></html>".  The 2nd may not work on all browsers.

Where I believe the problem is that you are referencing a frame within a differnet frameset.  In your anchor tag use the target property as target="right.SearchMain".  This will tell the browser to go look in the 'right' frame for the 'SearchMain' frame.
0
 
LVL 6

Expert Comment

by:tecbuilder
ID: 1856203
Tecbuilder I'll post a dummy question for you answer it and I'll give you 50 points.  Since you both answered by question and were a big help.
Thanks guys for helping me the problem was with the src being set to nothing  I made a blank page and it works fine.  Just so you know there some minor changes which caused some of the problems that you guys thought you say.  I rename Right and Left to SearchMain and SearchContents.  So that part was not actually a problem there.
0

Featured Post

Plesk WordPress Toolkit

Plesk's WordPress Toolkit allows server administrators, resellers and customers to manage their WordPress instances, enabling a variety of development workflows for WordPress admins of all skill levels, from beginners to pros.

See why 2/3 of Plesk servers use it.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Because your company can’t afford for you to make SEO mistakes, you’ll want to ensure you’re taking the right steps each and every time you post a new piece of content. This list of optimization do’s and don’ts can help you become an SEO wizard.
Although a lot of people devote their energy toward marketing for specific industries, there are some basic principles that can be applied to any sector imaginable. We’ll look at four steps to take and examine how those steps were put into action fo…
This tutorial walks through the best practices in adding a local business to Google Maps including how to properly search for duplicates, marker placement, and inputing business details. Login to your Google Account, then search for "Google Mapmaker…
Any person in technology especially those working for big companies should at least know about the basics of web accessibility. Believe it or not there are even laws in place that require businesses to provide such means for the disabled and aging p…
Suggested Courses

609 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question