Solved

IBM Deskstar 5 HD spins down too fast

Posted on 1998-01-09
14
338 Views
Last Modified: 2010-08-05
This ought to be fairly simple, but it's stumped me.  
I recently purchased a 6.4gig IBM Deskstar 5 hard drive for use under Linux, but it spins down after about 15 seconds of disuse.  This causes intolerable pauses while I'm working as the drive spins up to look for another command, and then promptly spins down again.  The IBM storage page claims that the spindown speed is adjustable "via standard ATA commands", but I can't find anything that will let me change the spindown rate.  I need it to be *at least* two minutes for it to be workable.  I had a similar problem with a Quantum Bigfoot that I returned (it had a spindown of almost exactly 60 seconds, and a very long spin-up time); the IBM has replaced it, and the problem has gotten worse.  Am I just having rotten luck with hard drives, or is there something simple I'm missing?  I don't have this problem with either my Quantum Fireball 3.2gig or my Connor 1.2 (neither of them spins down at all, as far as I can tell)
0
Comment
Question by:Resonance
  • 4
  • 3
  • 2
  • +4
14 Comments
 
LVL 32

Expert Comment

by:jhance
ID: 1122627
Two possibilities:

1) Check the POWER MANAGEMENT settings in your motherboard BIOS CMOS.  You should either disable or set the spindown for HDD to a longer time.

2) See the documentation for the drive itself.  Many of them have a jumper setting to diable the spin down operation.
0
 
LVL 9

Expert Comment

by:magigraf
ID: 1122628
Resonance...

What's your BIOS manufacturer, I will give you the steps then.

Regards
0
 
LVL 15

Expert Comment

by:jrhelgeson
ID: 1122629
Is it IDE- Or SCSI?
0
 
LVL 2

Author Comment

by:Resonance
ID: 1122630
Sorry.  Basic info:  IDE Drive (secondary master), AMI BIOS on a Tyan Tahoe II motherboard.  BIOS settings checked; spindown occurs at the same time no matter what the time specified in the BIOS says, or in fact whether you disable it completely.  *REALLY* strange that it is only affecting the new hard drives I picked up, except that they are of course much newer models than the Connor 1.2 that used to be in that slot.  I didn't see any options in the BIOS distinguishing between the two.  

Sorry it's taking me so long to respond.  I'm in the middle of preparing for a cross-country move and it's taking up a lot of my time (the reason why I finally posted a question here :)

Anyways, I'm starting to wonder if maybe I really *haven't* done anything wrong, and there is a fault with the motherboard that is only affecting newer drives, and only on the secondary master position.  If I can get some time free I'll swap the drive out with the primary master and let you know what happened.
0
 
LVL 11

Expert Comment

by:alexo
ID: 1122631
Try disabling power mgmt altogether.  Does it help?

0
 
LVL 5

Expert Comment

by:JBURGHARDT
ID: 1122632
did you to connect your hard disk to different power cable
0
 
LVL 2

Author Comment

by:Resonance
ID: 1122633
Alexo: Tried that.  No change

Jburghardt:  Tried that incidentally to the other things I was doing, no change.  If the power cable were bad, however, I'd think that it wouldn't function at all...

I'm going to be off the net for at least a week or two (I'm in the process of moving), but if someone comes up with something brilliant, I'll assign points when I get back :)
0
How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

 
LVL 11

Expert Comment

by:alexo
ID: 1122634
Maybe older drives just ignore the spindown command?

There are utilities that allow setting normally hidden BIOS options.  Try them.

* http://www.frankeser.net/drivers/rabbs/utility/ut-syste/AMISE270.ARJ

0
 

Expert Comment

by:abrasion
ID: 1122635
i didnt bother reading the other peoples things

but are u SURE its spining down and stopping or is it spinning down and then re-starting on its own

i suggest disconnecting some devices .. booting the thing with a boot disk and just LEAVING it .. if the cdrom / other hdd's are NOT plugged in and it dosent do it

it MAY just be low in power ...you would be surprised :)
try another power plug

and try running it on the secondary / primary ide ON THEIR OWN

since u r using linux i have no idea on pwm mgt i would assume it has none .... i know win 95 turns the spindown ON automatically (b version) but linux ..... nope .... dont think so .. just my 2 cents

try it


0
 
LVL 2

Author Comment

by:Resonance
ID: 1122636
1) Try reading the other responses and my responses to them.  It helps avoid wasting time.

2) Yes I'm sure.

3) It's not a power issue.  I tried yanking other devices, and I'm on a 300 watt supply anyway.

4) It was the only device on the secondary IDE when I was testing it.  The primary drive was still connected, but that was because it was the drive I was using to boot.  

5) Linux has power management if you enable it.  I hadn't.

6) Even Win95 doesn't spin down 15 seconds after the last access.  

7) If you aren't going to read the previous commentary, please don't lock the question with an answer.  

=======

Alexo: Thanks for the utility tip.  I'll test it out as soon as my computer arrives (I just moved, and my belongings haven't caught up to me yet...  I'm on a university machine right now).

0
 
LVL 5

Expert Comment

by:JBURGHARDT
ID: 1122637
try to install your drive as primary slave this does not help then jumpers setings are incorrect
0
 
LVL 15

Expert Comment

by:jrhelgeson
ID: 1122638
I'm pretty sure that you are experiencing the problem that caused a recall on your motherboard from tyan.
Try flashing the bios, if it doesn't work.  I think that's your problem.

Joel
0
 
LVL 2

Author Comment

by:Resonance
ID: 1122639
Jrhelgeson:  That was the correct solution.  System works fine now.  Resubmit comment as an answer for points.

0
 
LVL 15

Accepted Solution

by:
jrhelgeson earned 100 total points
ID: 1122640
I'm pretty sure that you are experiencing the problem that caused a recall on your motherboard from tyan.
Try flashing the bios, if it doesn't work. I think that's your problem.

Sorry it took so long to re-post my answer, got busy elsewhere.
Glad I could help!

Joel
0

Featured Post

How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

Join & Write a Comment

Suggested Solutions

this article is a guided solution for most of the common server issues in server hardware tasks we are facing in our routine job works. the topics in the following article covered are, 1) dell hardware raidlevel (Perc) 2) adding HDD 3) how t…
Great sound, comfort and fit, excellent build quality, versatility, compatibility. These are just some of the many reasons for choosing a headset from Sennheiser.
Sending a Secure fax is easy with eFax Corporate (http://www.enterprise.efax.com). First, Just open a new email message.  In the To field, type your recipient's fax number @efaxsend.com. You can even send a secure international fax — just include t…
This demo shows you how to set up the containerized NetScaler CPX with NetScaler Management and Analytics System in a non-routable Mesos/Marathon environment for use with Micro-Services applications.

759 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

21 Experts available now in Live!

Get 1:1 Help Now