No communication with LPT1 in Windows

Trying to install a printer, HP deskjet 692, on a new computer.  Using manufacturer's setup disks, the installation ends with a "no communication" message.  I've replaced the parallel cable, deleted and reinstalled the printer several times, and still can't get communication. However, the printer WILL print in DOS mode...so I suspect it's not the cable, but something in the Windows program. The computer manufacturer says to call Hewlett Packard; HP says to call the computer manufacturer. Any help would be appreciated.
BonnieWAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

magigrafCommented:
BonnieW...

Could you make sure that you are using a BI-DIRECTIONAL cable to begin with.  A "no communication" is most of the time caused by a non-bidirectional cable.
Also check your bios to see what your port is set for (ECP, EPP SPP)

Regards
0
jelloCommented:
You may also try switching your spool settings from EMF to RAW.  This has been known to help getting certain computers (such as the Compaq Presario series) to work with certain Cannon and HP  printers.

-jello
0
tstaddonCommented:
If you have an ISA I/O board your parallel port may not support bidirectional printing.

If that's the case, this message usually comes up when:

- A cartridge needs replacing
- No paper is available
- Paper jam

Assuming you're using Windows 95 or NT, of course. If you are using Windows 3.1 you may need to update your port settings or driver to allow bidirectional printing.
0
Cloud Class® Course: MCSA MCSE Windows Server 2012

This course teaches how to install and configure Windows Server 2012 R2.  It is the first step on your path to becoming a Microsoft Certified Solutions Expert (MCSE).

BonnieWAuthor Commented:
I appreciate all the suggestions and will address them as soon as I shake this flu bug.  Thanks for your responses.
0
nebworthCommented:
  Hey, Jello, where'd you learn all that fancy stuff about the spooling...  You may remember though, that the result of incorrect spooling usually leads to unpredictable results like black sheets or half pages.  Hmm...  Sorry to hear about your bug, Bonnie.  I'm sick myself right now.  Ugh.  Ok.  Remove the port from the device manager, and remove the printer driver from windows.  Restart the computer and go into your CMOS setup (usually press DEL on startup) probably under integrated peripherals you will find your parallel port mode settings.  I like something fairly simple like 378, EPP mode.  (378 is the usual address for the printer port)  save your changes and exit.  When windows restarts, it should re-detect you parallel port, and then it should find the printer and ask you to install the drivers.  As always, make sure there are no conflicts with IRQ7 like those nasty legacy soundcards or anything like that.

0
nebworthCommented:
 That's BLANK, not black sheets...
0
jelloCommented:
Nebworth,
you ought to know where Iearned it.  you used to sit next to me.

Besides.  Newer HP Printers (as in the last few years) can handle the RAW data just fine.
0
nebworthCommented:

    It was never the RAW spooling that was the problem, Jelman, it was the EMF spooling that caused the problem.
0
nebworthCommented:
 Oh, I just realized what you meant when you said you said something wrong...
0
jrhelgesonCommented:
The only thing that I can think of that hasn't been mentioned before..
Have you tried installing this printer under windows 95 on another machine?
Outside of that, I think you'll find your answer in magigraf's first comment.

Good Luck!
0
magigrafCommented:
jrhelgeson..

That is indeed another alternative that was hanging in my sleeve. *lol*

BonnieW...

I want you to try the following, which often solves things:

1) In win95, go to Device Manager
2) Expand the Ports (Com & Lpt) section
3) Delete the printer port you 've got now
4) Restart windows and let it detect your port
5) Try the printer now.

Also it would be safe to verify in your Device Manager, that you are not using any other Parallel port device that is sharing the same IRQ7 or any I/O address.  This often can cause a printer malfunction (communication problem).

This option is due to your confirmation that the printer works fine in DOS. (conflict is under windows)

Give it a ty and let me know how did it go.
Regards
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
nebworthCommented:
  Hey, where have I heard that before?
0
magigrafCommented:
On the Internet " Under Printer troubleshooting" propably??
I guess everything is documented for who wants to find it.
Right??

0
nebworthCommented:
  Yeah.

0
nebworthCommented:
 (Ok, I admit it...  I don't give very detailed answers...)
0
magigrafCommented:
nebworth...
That's alright, nobody's perfect, I cannot assume that you are like us specialized in troubleshooting.  We always give the MAXIMUM details possible answers.  We cannot speculate with whom we are dealing.
Regards
0
BonnieWAuthor Commented:
Magigraf, your solution did the trick.  I removed the port and reinstalled it.  Thanks once again for your help.
0
magigrafCommented:
You're always welcome!
0
nebworthCommented:
Magigraf,

   Yeah, my problem is I have to have the computer in front of me.  I just work on them.  Understanding what I'm thinking comes naturally; trying to explain it to others would take a miracle.

   Ben
0
agustCommented:
you must try changing the ecp.port by printer port inside the control panel. can you update the lpt.vxd driver
in this model you must have a bidirectional cable to have a comunication with the printer.
if you don't have the bidirectional cable you must go into windows and look for an executable file of hp driver that edit the win.ini to put the printer in unidirectional mode.
0
BonnieWAuthor Commented:
Thanks for the suggestions, Agust.  The printer is working just fine (for the time being), but I will put your comment in my folder to reference if a future problem crops up.
0
ssconnellyCommented:
LPT1 failed completely after I attempted to configure COM4 to work with my new palm pilot (which never worked, see next sentence).  According to 3COM, COM4 uses the same address as S3-based video chipsets, which is 02e8.  I disabled COM4 and my LPT1 port came back to life immediately.


0
nebworthCommented:
SSConnelly (if you're still listening out there)  If you have a Diamond Stealth video card, use the Diamond drivers that came with the card, not the S3 drivers that Windows95 detects it as.
0
ssconnellyCommented:
Thank you nebworth.  I do have a Diamond Stealth driver and will hunt down that driver and try it.  I appreciate your help.  For now, I let the mouse and palm pilot share com1.  Of course it is a pain in the neck, so I only sync from time to time.


0
nebworthCommented:
  Good!  A good way to test, actually, is drop down to the standard VGA driver and see if the com ports work correctly.  If they do, then you've found your problem!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Printers and Scanners

From novice to tech pro — start learning today.