Solved

This MS-DOS Compatability Mode problem wont go.

Posted on 1998-01-12
20
322 Views
Last Modified: 2013-12-16
My system is  :-

- i430VX chip set
- Windows 95 V4.00.950a
- 1* Seagate ST32531A 2.1Gb  - Primary Master - C:
- 1* Creative Infra 2400 CD-ROM - Primary Slave - H:
- 2* Seagate ST32531A 2.5Gb - Secondary Master and Slave - D: E: F: G:

My MS-DOS Compatability mode problem is :-

Both the HDDs on the secondary IDE port run with 16-bit drivers, if I
physically remove either one of the drives the other goes to 32-bit
drivers. The HDD and the CD-ROM on the primary IDE channel run OK in 32
bit mode no matter what.

I have done ALL the standard things and nothing changes the problem.

- Read and digested the two Microsoft help articles on the subject that
  I could find.
- Checked autoexec.bat and config.sys
- Checked system.ini
- Checked for viruses
- Looked of a "NOIDE" entry in the registry, (I dont have one).
- Removed and then re-installed the drivers manually, and automatically  
  with "Add/Remove Hardware".
- Removed and then re-installed different drivers from the set supplied
  on the Win95 CD.
- Downloaded and tried anything I could find on Intel`s web site.
- Done a logged startup. (Drivers loaded OK).
- Looked in ios.log. (Error message was "ESDI head mismatch").
- Cursed a lot.
- Reinstalled windows from scratch.
- Set the BIOS to not auto detect the drives but follow the specs I gave
  it.
- I have hunted high and low on the net for a solution, and have tried
  everything that was suggested.

I have seen the idea that the i430VX chipset is to blame. How well
accepted is this fact ? If I am going to buy another motherboard to cure
the problem that I am having what chipsets should I avoid ?, is the
i430VX chipset the only crap one ? Got any other ideas ?

If only the operating system was as stable as the bugs that lived in it.

Thanks in advance.

Cam...
0
Comment
Question by:cweeks
  • 8
  • 6
  • 5
  • +1
20 Comments
 
LVL 14

Expert Comment

by:smeebud
ID: 1753262
I've seen this work.
Create a NOIDE and give it a value of 0.
HKEY_LOCAL_MACHINE\SYSTEM\CURRENT CONTROLSET\SERVICE\VXD\IOS
There make your "String value key" NIODE=00

Also try value 1.

I'm going to mark this answered in hopes of working with you.
You may of course reject.
0
 
LVL 14

Expert Comment

by:smeebud
ID: 1753263
You've probably seen this:
To cause Windows 95 to attempt to reinitialize the protected-mode
IDE driver, remove the NOIDE entry from the following registry key:

HKEY_LOCAL_MACHINE\SYSTEM\CURRENT CONTROLSET\SERVICES\VXD\IOS

After you update the registry, restart Windows 95. Windows 95 will
then attempt to initialize the protected-mode driver for the
controller. If no problems are encountered, the file system and
virtual memory will operate in 32-bit mode, and Device Manager will
not display an exclamation point in a yellow circle for the IDE
channels.

If the protected-mode driver is not initialized properly, an error
message will be displayed and the NOIDE registry entry will be
re-created. Windows 95 will use the MS-DOS compatibility mode file
system the next time you start the computer.

MORE INFORMATION

This problem can occur with an IDE controller that requires
serialization between the primary and secondary IDE channels. The
protected-mode drivers for these IDE controllers can fail to be
initialized if one of the following situations occurs:

* One IDE channel has a supported hard disk, and the second
channel has a CD-ROM or other type of drive that requires
real-mode drivers to be loaded. Because of the serialization
between the two IDE channels, it is impossible to access the
hard disk in protected mode and use the other device in real
mode. This causes the protected-mode driver to fail
initialization, and the NOIDE switch is placed in the registry
to prevent future errors. Both disk devices then operate in
real mode.
* The driver for the IDE controller is manually removed from
Device Manager and then reinstalled, or the protected-mode
driver is disabled and then re-enabled. Some PCI controller
drivers are not designed for dynamic enabling and disabling,
and can cause the protected-mode driver to fail
initialization.

The Windows 95 device drivers for the following controllers are
known to exhibit this behavior:

* CMD PCI-0640 PCI-IDE controller
* Standard Dual PCI-IDE controller
* Opti Dual PCI-IDE controller

Other PCI-IDE controllers that use serialization between the IDE
channels may also exhibit this behavior.
0
 
LVL 14

Expert Comment

by:smeebud
ID: 1753264
This cleans you registry, ignors your system.ini and gives you controls over every step of re-setup without loosing anything;
-----------
X:\setup /d /p f
Where X is your CD drive letter
This will cause windows 95 to re-examine your setup.
This will clean, read and rewrite your Win.ini and System.ini,
without over-writing your updated dll's vxd's extensions.
f - This switch enables Clean Registry mode. It forces Detection
to clean and correct the root branch of the registry before starting.
This switch is ignored when Setup is run in the Windows 95
graphical user interface (GUI).
When setup prompts you for "Typical or Custom Setup", choose Custom.
This allows you to have control over every step of the setup.
This will do a compare and replace missing or corrupted files and
will take you back where you were before the error.

This has Become a;
"Standard Procedure". It's not always a fix all, but it never
hurts to try it. I've never seen any ill effects from it yet. The
only thing I've seen it do negative is once in a while an association
or two may get lost. Which Is easy to fix. I always recommend a
Registry backup along with this for safety.
ALWAYS BACKUP YOUR REGISTRY FIRST!
Get WRP. WRPV3.ZIP is the Best and easiest Backup/Restore I've Seen.
Go To: http://www.webdev.net/orca/system.html Search WRP
0
 
LVL 25

Expert Comment

by:dew_associates
ID: 1753265
CWeeks, this problem and the VX chipset bugs of which you speak, can be asily fixed with a little rearranging of hardware and the addition of an appropriate driver. Sometimes all of the gripes we read regarding these chipset problems arise more from a lack of understanding than real errors or bugs.

The employment of NOIDE was an early Windows 95 fix before the busmastering issues came to the forefront. Additionally, unless your system has other problems unrelated to the hard drive issue, I see no reason to reload or reinstall windows.

If you would like to try Bud's methods first, please do so. If you would like to setup your motherboard along with the VX chipset, please let me know, as I will post where you can find the correct drivers as well as the procedure for rearranging the hardware and installation of the appropriate drivers.

Best regards,
Dennis
0
 
LVL 14

Expert Comment

by:smeebud
ID: 1753266
Dennis, I didn't know that the NOIDE was outdated.
I was going to call you to this page anyway.
because you're the 'Chipset master';)

If you care to post you solution, go ahead, and I gladly
ask cweeks to reject my suggestion. I think he should try it first however.

I'm still following:
http://support.microsoft.com/support/kb/articles/Q130/1/79.asp
and
http://premium.microsoft.com/support/kb/articles/q151/9/11.asp
that says,
"....The protected-mode driver for the hard disk controller was not properly initialized when you started Windows 95 previously. When this occurs, a NOIDE entry is placed in the registry, preventing Windows 95 from making future attempts to initialize the protected-mode driver.".

I've found that creating that key, and changing the values will sometimes cause esdi_506.pdr not to load. I don't know why this happens. I found out thru experimentation.

Still this is a work around and I'd love to know the true fix.
Please join us.
0
 

Author Comment

by:cweeks
ID: 1753267
Thanks for the replies, but :-
 
I tried making NOIDE=00, NOIDE=01 and NOIDE=02, non of them worked.
I suspect that reinstalling Windows will not change anything as I installed it on a blank drive with all of my current hardware present and the problem was present immediately after the install. I also must of formatted the drive and repeated the install process about 3 times to make sure. I also tried to install Intel`s bus mastering drivers and all they did was cause blue screen errors and Windows not to boot. I again formatted C: and reinstalled without them.
After Windows installed the device manager showed the following entries under "Hard disk controllers" :-

Standard Dual PCI IDE Controller
Primary IDE Controller (single fifo)
Standard IDE/ESDI Hard Disk Controller

The "Standard IDE/ESDI Hard Disk Controller" entry had a yellow circle containing a black exclamation mark next to it, I deleted it, it never reappeared, and nothing changed, the problem drives still remained in 16 bit mode. I recently decided to try and finally solve the problem. I let the "Add new hardware" wizard redetect and reinstate the "Standard IDE/ESDI Hard Disk Controller" entry. Again nothing changed. I then downloaded some/any drivers that I could find on the Intel web site. I installed them and now I have the following entries for HDD controllers :-

Intel 82371SB PCI IDE Controller
Primary IDE Controller (dual fifo)
Secondary IDE Controller (dual fifo)

The "Secondary IDE Controller (dual fifo)" entry now has the yellow circle containing a black exclamation mark next to it, and the problem remains.

I have looked at both the microsoft articles

http://support.microsoft.com/support/kb/articles/Q130/1/79.asp
http://premium.microsoft.com/support/kb/articles/q151/9/11.asp

and without success I have tried all they suggest.

I am not that knowledgable when it comes to Windows 95, however its seems to me that the problem is more that just the drivers, as my C: drive and my CD-ROM are working in 32bit mode. I have no idea what serialization is however both the Microsoft articles and Smeebud suggest that if a problem with it occurs then all the connected drives go to 16bit drivers. This is not my case. The primary channel is working OK, the problem is the secondary channel that contains two identical HDD`s. The only clue windows has given me to the error is in the ios.log file. It currently and has always reported "ESDI head mismatch" on the first line, and then lists the drives that it is puting to 16bit drivers.

I am interested in your suggestion "Dew_Associtates", and of course anything else that might work.

0
 
LVL 2

Expert Comment

by:Smedley
ID: 1753268
I have found that checking the Device Manager in "SAFE MODE" will often show up extra hardware installed or duplication of  installed hardware.  These items can only be removed from Safe Mode.  I find that it is essential in the case of duplicateds to remove both items.  Also remove the  DRVDATA.BIN & DRVIDX.BIN files from the hidden C:\WINDOWS\inf subdirectory.  This forces a regeneration of the "Inf" files data base.  Also try this: Copy the contents of the CD's WIN95 subdirectory into a subdirectory on your 32bit mode main drive and then without the CONFIG.SYS or AUTOEXEC.BAT files try a reinstall from the directory on the 32bit drive.  In other words let Windows 95 sort out the drivers for the other Hard Drives.  I find I can eliminate most problems when I do it this way using OSR/2.  Of course you will also need to remove the Win.INI System.INI and USER.DAT USER,DA0 and SYSTEM.DAT and SYSTEM.DA0 as well as any of the hidden .LOG files or SYSTEM.1ST files.  You may also have to remove the C:\WINDOWS\DESKTOP subdirectory and its contents.
I trust that some of these "ideas" may help.
0
 
LVL 25

Expert Comment

by:dew_associates
ID: 1753269
Snedly,
As you can see we were waiting for Dennis to answer after cweeks
rejected me at my request. i suggest you request to be rejected also.

Dennis need to address the busmastering issue.
0
 
LVL 14

Expert Comment

by:smeebud
ID: 1753270
Once again thanks for the help. I would also like to say that this is the first time that I have used the "Experts Exchange", and that I am thoroughly impressed with the conduct, manor, and helpfulness of you "experts", thanks again.

Sorry if the below is a bit drawn out, I have just included everything I did. I have no idea what information is wheat and what it chaff, that's why I have written it all down.  

Nothing has changed with my problem. I changed the cdrom to the secondary slave and one of the hard drives to the primary slave. As soon as I did this the cdrom disappeared. I therefore reinstalled my cdrom drivers to inform them that I had changed the cdroms position. This still did not bring back the cdrom. Just out of curiosity I tried unpluging the hard drive that was also on the secondary interface. The cdrom reappeared on the next bootup. This action and responce seems to be totally reproduceable on my machine. The pattern that seems to be developing seems to be that two drives on the secondary channel is a no go.

At this point I thought that perhaps installing the bus master drivers would solve this problem. I proceeded with the installation exactly as directed. The driver setup program removed the existing hard drive entrys in the device manager for me. When rebooting the computer after running the initial setup.exe program Windows recognized the bus and proceed to ask me for the file "ideatapi.mpd". I looked on a copy of my Win95 cd that I had made on the hard drive (remember my CDROM had disappeared), it was not there, I looked in the directory I had extracted the bus mastering drivers to, it was not there either, I also looked on the disk that contained my cdrom drivers and it was not there. At this point I clicked on "skip file", Windows proceeded to recognize the primary controller. I was then asked if I wanted to restart, I clicked no, and Windows then recognized the Secondary controller. I was then asked again if I wanted to reboot, I clicked yes. (I refused the first restart to save me some time, and because it has never made a difference in the past.) The computer then reset and Windows tried to reboot. It almost made it, but at the approximate time that I would expect my desktop to popup I got the following message "Windows protection error. You need to reboot your system.". I rebooted and was landed in safe mode. Again out of curiosity I had a look for the ideatapi.mpd file and I think it was in the following directorys (my memory is going)
C:\Windows
C:\Windows\IOSubSys
I find this a might strange, I manually looked twice on all of the sources that I mentioned to find the ideatapi.mpd file, I even looked within the .cab files on my Win95 CD, and I could not find it, so god only knows where it appeared from. While I was in safe mode I did 3 things :-

1) Copied the ideatapi.mpd file to an empty directory on my c:  
   drive.
2) Checked for duplicate entries in device manager (there were  
   none.)
3) Removed the bus mastering drivers using the setup.exe that
   came with them.

On rebooting, Windows made it all the way. Now having a copy of the ideatapi.mpd file I again tried to install the bus mastering
drivers. The eventual result was just the same "Windows protection error. ...blah blah blah.....".

Both Smedley and smeebud have suggested various methods of partially re-installing Windows or re-initiating systems within Windows. I seriously think that this will do no good as the problem existed even on a freshly installed system. A system that was installed on a blank hard drive, a system with no other software present other than Windows 95 itself, and a system that was installed with all of my current components present. If you think that the re-install/re-initiate methods will work on my system then given that I mentioned at the start that the problem existed on a fresh installation you must also think that they will work on a fresh installation. Is this the case ? I doubt this even with my simple knowledge (or is my simple knowledge the reason for me doubting this ?). Hope that makes sence.

I am now beginning to think that I will have to change hardware to get rid of the problem, do I change my two hard drives for one, or will a motherboard/chipset change be enough. Or even more drastic, shall I wait for Windows 98. Is is going to be a debugged version of Windows 95 and then some.

Please do not read any anger or "pointing the finger" into the above script, that passed long ago with computers. I am just adding my little knowledge and lots of time spent at my keyboard in the hope of
1) saving some more time and
2) it may trigger something off in your heads.

Computers are like the female half of the species - "If you don't know what's wrong then I am not going to tell you".

Thanks again. Cam...


0
 

Author Comment

by:cweeks
ID: 1753271
opps forgot read above.
0
Better Security Awareness With Threat Intelligence

See how one of the leading financial services organizations uses Recorded Future as part of a holistic threat intelligence program to promote security awareness and proactively and efficiently identify threats.

 

Author Comment

by:cweeks
ID: 1753272
Okay Cam, let's go from here then. First, don't misunderstand, but the installation instructions were set the way they were for a reason, as windows has difficulty dealing with multiple hardware assignments, which is why windws, during initial load, sorts and assigns the hardware and after the restart makes the final assignments if it is able to.

In any event, here's what usually causes a Windows Protection Error. Normally, there is a comment that goes with it such as "While initializing device....." and then the protection error message. Did this occur, and if so, what was the initialization error?

Windows Protection Errors are generated when any of the following conditions occur:
 
A real-mode driver and a protected-mode driver are in conflict.
 
The registry is damaged.
 
The Win.com or Command.com file is infected with a virus or is damaged.
 
A driver is being loaded from the System.ini file for which a protected-mode driver has already been initialized.
 
There is a physical I/O or RAM address conflict.
 
There are incorrect CMOS settings for a built-in peripheral device (such as cache settings, CPU timing, hard disks, and so on).
 
The Plug and Play feature of the computer's BIOS is not working correctly.
 
The computer contains a malfunctioning system cache or memory.
 
The computer's motherboard is not working properly.
=========================================

Let's deal first with what we do know. If you place two drives of any type on the primary IDE bus (channel) and one drive on the secondary IDE, everything works. If you then add a second drive to the secondary bus, the failure occurs, regardless of whether it is 16bit protected mode or an outright failure.

This is an indication of one of four things.

1. The secondary bus is not being configured correctly with its drivers, or

2. The side of the chipset for the secondary bus/second channel has failed, or

3. There's a drive incompatibility between the hard drives (highly unlikely when they are all from the same manufacturer unless there is a problem with the drive itself as in firmware failure (internal chipset failed), or

4. The cd rom driver is causing a problem.

You say you can replicate this problem. That's fine, we may need that, but there's some things we need to verify first:

1. What I would like you to do is go into Device Manager and scroll down to the hard disk controller section and expand it and post here exactly what you see.

2. Click Start, Run and type in Sysedit to bring up your startup files. Copy and paste here your autoexec.bat and config.sys file. The Ideatapi.mpd file is usually called by an Atapi manager for a cd rom drive. This creates known conflicts for Windows 95 and any of TX and later chipsets.

Once you do this, (short of a motherboard failure) I post an explicit procedure how to fix the problem.

Dennis

PS: Don't despair, we'll tell you what's wrong, but patience and accuracy count!

0
 
LVL 25

Expert Comment

by:dew_associates
ID: 1753273
Oops, sorry, I take it I did something wrong. I think I can only have deviated from your instruction by either  reinstalling my CDROM drivers or by not allowing Windows to restart after it detected the bus and the primary controller. Sorry anyhow. If I went wrong by not allowing Windows to restart when it requested and forcing it to detect the secondary controller on the same boot, then I can say that I have also just tried it the way Windows wanted, and this made no difference I was still landed with a “Windows protection error.”

Your last posting makes a lot of sense, it was right to the point and it lets me know that you have digested the general message that I have been trying to convey. Thanks for this, I was a bit of a faith giver.  

The current state of my system is that the Bus Mastering drivers have been installed and then removed using the setup.exe program that comes with them.

Right, here is the info you requested. :-

No device or other item was listed next to the “Windows protection error.” text.

Listed under the “Hard disk controller” section is :-

Intel 82371FB PCI Bus Master IDE Controller
Primary IDE controller (dual fifo)
Secondary IDE controller (dual fifo) – This entry has a black exclamation mark within a yellow circle.

Autoexec.bat :-

rem - McAfee VirusScan
rem - C:\PROGRA~1\MCAFEE\VIRUSS~1\SCANPM.EXE C:\
rem - @IF ERRORLEVEL 1 PAUSE

rem - PC Cillin Virus Checker
rem - C:\TSC\PC-CIL~1\PCSCAN.EXE C:\ C:\WINDOWS\COMMAND\ /NS
/WIN95
rem - C:\TSC\PC-CIL~1\TSRSCAN.COM

rem - Creative CD-Rom
SET CTCM=C:\WINDOWS

rem - Creative AWE64 gold sound card
SET SOUND=C:\PROGRA~1\CREATIVE\CTSND
SET MIDI=SYNTH:1 MAP:E MODE:0
SET BLASTER=A220 I5 D1 H5 P330 E620 T6

rem - Windows 95
PATH=C:\QR36;C:\ARJ;C:\LHA;C:\QPV
mode con codepage prepare=((850) C:\WINDOWS\COMMAND\ega.cpi)
mode con codepage select=850
keyb uk,,C:\WINDOWS\COMMAND\keyboard.sys
rem - By Windows Setup - MSCDEX.EXE /D:MSCD001 /V /M:8
DOSKEY /INSERT

rem - Monster 3D
SET SST_SCREENREFRESH=60
SET SST_RGAMMA=1.80
SET SST_GGAMMA=1.80
SET SST_BGAMMA=1.80
SET SST_GRXCLK=57

Config.sys :-

Rem - Windows 95
device=C:\WINDOWS\COMMAND\display.sys con=(ega,,1)
Country=044,850,C:\WINDOWS\COMMAND\country.sys
REM device=C:\SBIDE.SYS /D:MSCD001 /V /P:1F0,14

Rem - My lines
shell=C:\WINDOWS\COMMAND.COM /e:1024 /p

That’s it.

It may also me worth noting that I after uninstalling the bus mastering drivers Windows  reboots and re-detects the bus and the primary controller then requests a reboot. On the re-boot Windows then re-detects the secondary controller and goes into the desktop, the system works perfectly at this point
ie all drives are present and work in 32bit mode. On the following reboot the problem of either missing CD-ROM or 16bit hard drives re-appears.
 
P.S Thanks for your patience.

0
 

Author Comment

by:cweeks
ID: 1753274
Do I have to "Reopen question to other experts. " every time I add a comment that I want you "Dew_Associates" to read. Or can you read the dialogue to date without doing that.
0
 

Author Comment

by:cweeks
ID: 1753275
No it's okay to leave an answer posted, as you don't have to accept it until the issue is resolved. Everyone can still see all the posts and the email will continue until the issues is resolved.

Here are some changes to your autoexec.bat and config.sys files, however I would like you to follow the procedure noted before to load the TX chipset drivers that were discussed. Only this time allow the reboots to occur normally. This will eliminate the single and dual fifo and allow us to insert the correct protected mode driver instead of the default.

First, here are the changes:

Autoexec.bat :-

rem - McAfee VirusScan
rem - C:\PROGRA~1\MCAFEE\VIRUSS~1\SCANPM.EXE C:\
rem - @IF ERRORLEVEL 1 PAUSE

rem - PC Cillin Virus Checker
rem - C:\TSC\PC-CIL~1\PCSCAN.EXE C:\ C:\WINDOWS\COMMAND\ /NS
/WIN95
rem - C:\TSC\PC-CIL~1\TSRSCAN.COM

rem - Creative CD-Rom
REM SET CTCM=C:\WINDOWS

rem - Creative AWE64 gold sound card
SET SOUND=C:\PROGRA~1\CREATIVE\CTSND
SET MIDI=SYNTH:1 MAP:E MODE:0
SET BLASTER=A220 I5 D1 H5 P330 E620 T6

rem - Windows 95
PATH=C:\;C:\Windows;C:\Windows\Command;C:\QR36;C:\ARJ;C:\LHA;C:\QPV
mode con codepage prepare=((850) C:\WINDOWS\COMMAND\ega.cpi)
mode con codepage select=850
keyb uk,,C:\WINDOWS\COMMAND\keyboard.sys
rem - By Windows Setup - MSCDEX.EXE /D:MSCD001 /V /M:8
DOSKEY /INSERT

rem - Monster 3D
SET SST_SCREENREFRESH=60
SET SST_RGAMMA=1.80
SET SST_GGAMMA=1.80
SET SST_BGAMMA=1.80
SET SST_GRXCLK=57

Config.sys :-

Rem - Windows 95
device=C:\WINDOWS\COMMAND\display.sys con=(ega,,1)
Country=044,850,C:\WINDOWS\COMMAND\country.sys
REM device=C:\SBIDE.SYS /D:MSCD001 /V /P:1F0,14

Rem - My lines
shell=C:\WINDOWS\COMMAND.COM /e:1024 /p

NOTE: The only other line that I question is this one:

device=C:\WINDOWS\COMMAND\display.sys con=(ega,,1)

It appears to be loading a ega driver?

In any event, try the changes and then reload the TX chipset and let me know how you make out!
0
 
LVL 25

Accepted Solution

by:
dew_associates earned 200 total points
ID: 1753276
I love you. I would bear your children if I was a girl. :-)

You can take it from the above that all is now working. I think however that the problem was my sound card, while I was checking the http://www.bmdrivers.com site to make sure I had downloaded the right drivers I noticed this little gem of text.

--- Start of Quote ---

WIN95 "Protection Error Fix"

There is a incompatibility problem between the Creative Labs
SB32 and AWE 64 and the use of the Intel Bus Master Drivers v3.01. The default I/O address of 620, used by the Creative Wavetable synthesizer, causes a WINDOWS PROTECTION ERROR when useing with the Intel Bus Master Drivers v3.01.  It seems to mainly happen when you try to add another HDD drive to the primary IDE channel. The solution is to "uncheck" the "use automatic settings" for the Creative Waveffects synthesizer and choose "settings based on"-- Basic configuration 1. This moves the Creative wavetable I/O address to 640....this stops the protection error from ever happening. Thanks go to Jon Kaiser
for this fix!

- Go to Control Panel then double click on the System icon
- Under the Device Manager Tab, expand (double click on) Sound,    video and game controllers
- Now, find the line for Creative Wavetable Synthesizer and     double click on it
- Under the Resources tab, uncheck "Use Automatic Settings" and    choose "settings based on"---Basic Configuration 1

--- End of Quote ---

So I tried this and the Bus Mastering drivers installed, ran, and removed my problem without any problems.

I wish to thank you with deep sincerity. Without your rather calm comments I would have given up long ago.

Just two last questions before I go :-

1) Can I un-remark the lines in my autoexec.bat. To return it to    normal.
2) Every time I boot up my bios now reports  
   "Updateing ESCD   .....Success". It only used to do this when    I changed a driver or installed some new hardware, now it        does it all the time. Need I worry about this, is it another     problem waiting to happen ?

Once again thanks, you are a true trooper.

Cam.....


0
 

Author Comment

by:cweeks
ID: 1753277
Your quite welcome Cam:

Questions:

1. I only rem'd out 2 lines, which should have enabled windows 95 to use protected mode drivers. Therefore, if you haven't lost any functionality, leave them as is.

2. As for ESCD update, this is what it should have been doing originally!

If you need more, just ask!
Dennis
0
 
LVL 25

Expert Comment

by:dew_associates
ID: 1753278
1. I should of said "Can I un-rem the virus checker programs in autoexec.bat". Anyway I have tried it now and nothing went wrong, thank God.

2. I was sure that ESCD was only supposed to change on the boot following an alteration of a system/bios type setting. Not on every boot, even if I just load Windows and quit.

Thanks Again. Cam....

0
 

Author Comment

by:cweeks
ID: 1753279
Sorry Cam, my fault. I thought it was implied that you could re-enable the virus checker. You've done so well I took it for granted. Again, sorry. Let me explain a little about Bios issues and Windows 95. When you set your Bios/Cmos setup, it is software in an eprom, but nevertheless, still software. When you load windows, windows takes a snapshot of the Bios and will, on occasion, attempt to change those settings if windows feels that the settings will prevent a boot. Now most Bios settings cannot really be changed, but windows will try and make alterations. When you see a successful escd boot, it's telling you nothing more than the Bios was read and compared correctly with the hardware settings.
0
 
LVL 25

Expert Comment

by:dew_associates
ID: 1753280
Ok, my mind is settled, and so is my computer. :-)
We can now say that this problem has been concluded.
Thanks again. Cam.... as in Cameron Weeks...

0
 

Author Comment

by:cweeks
ID: 1753281
Well "Cameron Weeks" it was truly a pleasure working with you!

Please do not hesitate in joiningm us again!

Dennis
0

Featured Post

How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

Join & Write a Comment

Update 11/3/2014 - Although the below article will get you to relocate the WINSXS folder, Microsoft has finally released a utility to reduce the size of the WINSXS folder. For some reason, it's not that straightforward. It only works on Windows 2008…
A Bare Metal Image backup allows for the restore of an entire system to a similar or dissimilar hardware. They are highly useful for migrations and disaster recovery. Bare Metal Image backups support Full and Incremental backups. Differential backup…
In this video, we discuss why the need for additional vertical screen space has become more important in recent years, namely, due to the transition in the marketplace of 4x3 computer screens to 16x9 and 16x10 screens (so-called widescreen format). …
With the advent of Windows 10, Microsoft is pushing a Get Windows 10 icon into the notification area (system tray) of qualifying computers. There are many reasons for wanting to remove this icon. This two-part Experts Exchange video Micro Tutorial s…

747 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

13 Experts available now in Live!

Get 1:1 Help Now