No applications recognize internet connection

Yesterday I ran Win95 setup to fix a file error and I didn't have the installation disk for my Sportster Winmodem.  I bypassed it, but when I got a hold of the disk today I couldn't uninstall the modem, so I took it out, ran setup again, and then put the modem in and booted up.  It seems to be working now as I can use dial-up networking to connect to the internet, but no applications recognize the connection.  Eudora Light can't find my host, ICQ can't establish a connection, Netscape can't find the DNS.  I have checked everything that I can think of and the settings are as they should be.  In Control Panel->Networks, TCP/IP and the Network Adapter are installed.  I even uninstalled them and reinstalled them to no avail.  Any ideas?
lieffmAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

dew_associatesCommented:
Hi Lieffm, back again huh, well welcome back. Since I don't know what switches, if any, that you used when you ran Win95 setup, I'd venture to say that the file associations established when you installed the other software have been broken. The easiest way to check it would be to download a fresh copy of ICQ and install it. If that works, that will give you a clue what to do with the other software. If it doesn't, let me know and we'll drill down deeper.
Dennis
0
lieffmAuthor Commented:
Done, and the problem persists.  What else ya got?
0
dew_associatesCommented:
Okay, let's start from square one!

You mentioned that after running Win95 setup and not having the modem disk, you weren't able to delete the modem. Does this mean that you went into Control Panel, clicked the modem icon, highlighted the modem and clicked remove and it wouldn't remove it?
0
Fundamentals of JavaScript

Learn the fundamentals of the popular programming language JavaScript so that you can explore the realm of web development.

lieffmAuthor Commented:
No, when I got into Windows and tried to check the modem properties Windows told me that it found some information pertaining to the Winmodem and that it was removing the information, but the modem seemed to still be installed afterwards.  When I went to the Control Panel->Modems it led me through the detection of a new modem, but it didn't find one.  When I tried to install one manually it only gave me LPT to install the new modem on, I couldn't access COM 2.   I shut down, took the modem out, rebooted, shut down, put the modem in, and booted, but that didn't help.  Only running setup again allowed Windows to find the modem.
0
dew_associatesCommented:
Forgive me if I don't remeber your system information, but it's hard enough keeping track of the questions.

Give me the system info, motherboard make, model, chipset and Bios type as well as the exact modem info.

It sounds as though the Bios is blocking Com2, which should be disabled. Set the motherboard to plug and play aware if you can, disable Com 2 , remove the modem and reinstall it manually with the install disk. You should have a USR *.inf file to work with.
0
lieffmAuthor Commented:
I reinstalled the modem, and something odd (?) has been happening during the installation.  Windows auto-detects the modem and says it will search for updated drivers.  I put the installation disk in the a: drive and it says it found the drivers, and click Finish to continue.  I do, and then I have to Browse to a usrdrvr.003 folder on the a: drive in order to locate the files.  Then it says it can't find a file which is clearly in that directory--winmodem.cpl or something.  I click OK a few times and eventually it reads the drivers.  I downloaded the installation disk from the USR/3com site and the same thing happened, so it's not my disk.

I am connecting to two different ISPs fine, and everything looks normal on the Modems and Winmodem tabs.  The modem is installed on COM 2 fine.  I think the problem is with something else.  I will reinstall the Dial-Up Adapter and TCP/IP again as a friend told me he had to do it a few times to get it to work.

0
dew_associatesCommented:
Lieffm, which sporster do you have?  and is it internal or external?
0
j2Commented:
the winmodem is always internal, isnt it?
0
nebworthCommented:
  Well, since the Winmodem is a software Com port, it would be hard to have it exernal...    Your logon is fine?  It's not kicking you out or anything?  Here's the way it goes...
 
    server assigned IP address...  that's usual
    server assigned DNS.  No.  Usually this has to be entered.  If this is wrong, then you'll connect and everything will seem alright, but you won't be able to find ANYTHING on the internet.  This is what it sounds most like.

    Clear text authorization.  When you get a text login screen, you have to make sure that DUN/Modem/option/bring terminal windows up after connect is checked.  Otherwise, the computer will sit there for a while then disconnect.

    No TCP/IP, or a bad TCP/IP installation.  Well, you seem to have addressed this, but the result is usuall that ''windows is unable to negotiate a compatible set of protocols with the server.

   As for a modem issue, you seem to be communicating with the modem just fine, BUT, just in case, go to the control panel, Winmodem, and uninstall windmodem, then run WNREGCLN.EXE off the USR disk.  Restart Windows and reinstall the modem (windows will detect and prompt for drivers) And yes, having to click OK half a dozen times (for WINMODEM.CPL, I think) is actually NORMAL for those drivers...  Go figure.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
dew_associatesCommented:
J2, when you have time, meet me @ Q8630033554

Well Nebworth, USR modems use winmodem and the modems are available in both external and internal versions as you probably already know! Looks like this answer is another shot in the dark, just my 2 cents worth!
0
lieffmAuthor Commented:
I GOT IT TO WORK!!!  I uninstalled the modem and ran wnregcln and reinstalled the modem.  It still didn't work.  So I ran Windows setup (with the modem already installed) and it prompted me for the Winmodem Installation disk but then it told me that the modem was already installed.  I removed and added the Dial-Up Adapter and TCP/IP just for good measure and it's working!  I am so relieved!  Running wnregcln may have helped, and I think running setup with the modem already installed contributed as well.  
0
nebworthCommented:
  Dew, USR has external modems, but the winmodem is always internal.  All external modems have a hardware serial port.  All the winmodems have a software serial port...  They're kind of like Plugnplay HSP modems.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows OS

From novice to tech pro — start learning today.