QuickReport 1.1 Problems

I'm having problems with two things when printing reports.  First, the DBMemo adds 6-7 lines of blank space when printing and runs into the next band.  To be more specific, I have a Paradox memo field, which is right above the detaillink band.  If the Memo's data gets too long, it will stretch down the page (which it should) but it doesn't 'push' the detailband further down the page - so it writes 'over' the detaillink band.  Is this a bug? and how do I fix it (without moving to QR2).


Secondly, I can't figure out how to align DBText fields so that one field doesn't print over another in the QR Labels template. Below is the layout & problem.

FName LName       --------------> Layout
Address
City, State Zip

Jim Sample    ------------>Prints ok because he has a short name
123 Anywhere
Miami , FL 33333

StephaJohnson  -----------> Fields overlap due to long names
53773 Anywhere
San AntoniTX 30089     ------> Here too!

I don't want to set a fixed width field because I'd have the exact opposite problem - too much space in-between fields.
LVL 3
d4jaj1Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

ZifNabCommented:
I can't give you an answer for the first at the moment. Look at QR wabpage for answer or look for an update of QR.

 Or the detailbands and the detaillinkband linked to each other?

Second, do this :

 1. remove DBFName and DBLName
 2. instead place a normal text field (non DB) (e.g. TextName)
 3. In the beforeprint of the band, write this :
 
    TextName := DBFName + ' ' + DBLName;

    where DBFName (=datafield of fName)
          DBLName (=datafield of lName = Table1.FieldbyName('LName').AsString

 This is the only solution to your problem, I think.
   
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
d4jaj1Author Commented:
I'm using the latest version of QR for D2, (version 1.1) and the Detail Band & Detail Link are linked correctly.  Does this happen to you?

As for the second problem, I don't think I really understannd your code.  My example below compiles ok, but doesn'tt print out the name.

procedure TQRLabelsForm.DetailBeforePrint(var PrintBand: Boolean);
var
 fn,ln:    string;
begin
 fn := Table1.FieldbyName('FirstName').AsString;
 ln := Table1.FieldbyName('LastName').AsString;
 edit1.text := fn + ' ' + ln;
end;

0
ZifNabCommented:
I use QR 2.0j

edit1.text has to be a label component on your qr-form :

qrLabel1.caption := fn+' '+ln;
                         
0
Cloud Class® Course: CompTIA Healthcare IT Tech

This course will help prep you to earn the CompTIA Healthcare IT Technician certification showing that you have the knowledge and skills needed to succeed in installing, managing, and troubleshooting IT systems in medical and clinical settings.

d4jaj1Author Commented:
Okay, I just installed QR2 and it doesn't allow me to change the width in the multi-column report (Labels).  It appears the report takes the page Width and divides it by the total # of columns to get the column length.  Even if I chnage the Width in teh Properties dialog box, QR changes it back.  Is there a way to fix this.  I know I can use the ColumnSpace to shorten the width, but that adds space inbetween the labels.

To make my question more clear, can I:

Create a 3 column report with, each column 1 inch wide and left justified on the page (the columns left justified, not the text in the columns).

Thanks.
0
ZifNabCommented:
That I don't know.
Maybe make page width 3 inches.
Or put 3 labels of 1 inch each next to each other and manually fill them.
0
d4jaj1Author Commented:
Make the page width 3 inches is the answer, however, you will have to calculate the Left Margins, Column Space, # of columns manually to generate a correct page width to really make a customized report.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Delphi

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.