Solved

tmp files on desktop

Posted on 1998-01-16
47
721 Views
Last Modified: 2008-02-01
Whenever an Office program is opened it puts .tmp files on the desktop.  Is there anyway to change this so the .tmp files are stored someplace else?  Not a major problem, just annoying.
0
Comment
Question by:DSMORGAN
  • 16
  • 14
  • 12
  • +2
47 Comments
 
LVL 3

Expert Comment

by:ckezema
Comment Utility
Have you deleted your temp folder? It is usually found in the Windows folder..if it is not there, then just create a new folder (right click in the Windows folder and choose new folder) and name it Temp.

The only time I have ever seen other temp files appearing on the desktop is when I start up documents that are saved on the desktop..(ex: A word Document on the desktop that I just double click to open in word..)
but the temp files always go away if you close the file properly...(File, Close...or exiting Word)

You could also set a Temp=C:\Windows\Temp line in your Autoexec.bat file...(again make sure the temp directory exits)
Windows95 should have this set up for you automatically...(it set the temp variable for you)but you never know, it could have been changed...

anyways..hope this helps
Conan
0
 

Author Comment

by:DSMORGAN
Comment Utility
I've checked and there is a \windows\temp directory.  I tried adding TEMP=C:\WINDOWS\TEMP to the autoexec.bat.  When I rebooted it gave me a Bad Command or File Name.  Didn't make any difference as far as putting temp files on the desktop.  Should this maybe be someplace else (or maybe I need to modify the line)?
Let me know if you have any other ideas.
Thanks.
0
 
LVL 3

Expert Comment

by:ckezema
Comment Utility
sorry..the command is SET TEMP=C:\WINDOWS\TEMP

Again you shouldnt have to put the command into the autoexec because it should be already set up in Win95..but it is worth a try...

are you opening a file that resides on the desktop?

Also...check out Tools, Options (Try Word)and see where your autorecover path points to...mine is blank and so I assume it defaults to the temp directory...try making the path blank if there is anything listed...(by double clicking on it...)

let me know what you find out...

Conan
0
 

Author Comment

by:DSMORGAN
Comment Utility
I checked the autorecover path and it was blank.  I even tried setting it to c:\windows\temp.  Still the same thing.  
Adding set temp=c:\windows\temp to the autoexec.bat didn't help.

I get these tmp files whenever I start any office '95 program.  If I start Word a .tmp file is on the desktop before I open any document.

Most puzzling.  I'm open to any other suggestions you might have.
0
 
LVL 3

Expert Comment

by:ckezema
Comment Utility
Have you possibly installed Office to the c:\windows\desktop folder? (as opposed to the default of Program Files\MS Office?

(Just another "stab in the dark", but we will keep trying....)

You may want to decline my answer so that if anyone else has any ideas they can have a shot at this...

The only time I have ever seen this happen is when I open a document residing on the desktop..the temp file appears, but disappears when I close out of the application...

Are the temp files being left when you exit applications?

Conan
0
 

Author Comment

by:DSMORGAN
Comment Utility
Everything is where it should be.  And when I exit the tmp file disappears.  I think I will reopen this question.  Thanks for all your efforts.
0
 
LVL 3

Expert Comment

by:ckezema
Comment Utility
When you open word..you said that the temp file appears even before opening a document...what is the name of the temp file?

Conan
0
 

Author Comment

by:DSMORGAN
Comment Utility
Actually it creates a different tmp file each time.  They always start with ~ followed by a letter and some numbers.

Does that help?
0
 
LVL 25

Accepted Solution

by:
dew_associates earned 200 total points
Comment Utility
DSMORGAN: Try this, the "~" indicates long file name use.

In your autoexec.bat file include this line

SET TMP=C:\TEMP

The restart the system.

Dennis
0
 

Author Comment

by:DSMORGAN
Comment Utility
Sorry, adding SET TMP=C:\TEMP to Autoexec.bat didn't work either.  Any other ideas?
0
 
LVL 25

Expert Comment

by:dew_associates
Comment Utility
Does this occur just in Word, or does it occur across the board, like in excel and downloads etc?
0
 

Author Comment

by:DSMORGAN
Comment Utility
It seems to be only with Word.  I get the same behavior with mail if word is used as e-mail editor.
Any ideas?
0
 
LVL 25

Expert Comment

by:dew_associates
Comment Utility
Okay, let's start search for any variable that sets where tmp files will be placed.

Click Start, Run and type in Sysedit and click OK. This will bring up all of your system startup files except for IO.SYS and MSDOS.SYS.  Search Win.ini, System.ini, Config.sys, etc looking for any variable that has either temp or tmp. If that fails, then click Start, Run and type in Regedit and click OK. Use the edit, search feature and do the same thing.

Let me know!
0
 

Author Comment

by:DSMORGAN
Comment Utility
Sysedit only found the two lines I've added to autoexec.bat (SET TMP=C:\TEMP AND SET TEMP=C:\WINDOWS\TEMP).
Regedit found more hits (mainly templates) but no mention of c:\windows\desktop.
Any other ideas?
0
 
LVL 25

Expert Comment

by:dew_associates
Comment Utility
DSM: As a matter of fact I do have some thoughts, what browser are you using?
0
 

Author Comment

by:DSMORGAN
Comment Utility
I'm using IE4 (with all the latest updates) as my browser.  Could this be where the problem lies?  I'm not using any of its desktop features.
0
 
LVL 25

Expert Comment

by:dew_associates
Comment Utility
I very well could be DS, We've seen a lot of strange occurrences after IE 4.0 has been loaded. Can you tell me if this problem existed before IE 4, like right after installing Office 95? If not, do you recall when you first saw it and what changes may have been made to the system.

Here's another file to open and check, Msdos.sys

Use windows explorer and find Msdos.sys, it should be in the root of the drive. Right click on it and click properties. Uncheck hidden as well as the other attributes and click apply then OK. Reduce windows explorer and open word pad and then open Msdos.sys and check if there are any references in there as to temp path statements.

I wait on your!  We'll find the solution if it exists!
Dennis
0
 

Author Comment

by:DSMORGAN
Comment Utility
I checked msdos.sys.  Nothing there.  I believe I had this problem even before installing IE4.  By the way, I'm using Office 97 (in case that makes any difference).
I'm sure there's a solution to this.  You'd think Microsoft would make this easier.
0
 
LVL 25

Expert Comment

by:dew_associates
Comment Utility
You'd think M$ would do something. We have their entire database on-line and there's absolutely nothing on this at all.

Are you familiar with using regedit?
0
 

Author Comment

by:DSMORGAN
Comment Utility
I've used regedit.  What do you have in mind?
0
 
LVL 25

Expert Comment

by:dew_associates
Comment Utility
Use the search capability in regedit for all entries that involve tmp or temp. Note anything that implies a default temp directory. In the meantime, I will be asking another tech to join us.
Dennis
0
 
LVL 14

Expert Comment

by:smeebud
Comment Utility
Thanks for the invitation Dennis.

Something I did that works, don't know why.
Create a TMP directory, then in autoexec
SET TEMP=C:\TMP

It get it away from windows. It's worth a try. I'll look into it further.
0
 
LVL 14

Expert Comment

by:smeebud
Comment Utility
There's something missing here,
Hows your disk space, and how do you have your swap file setup.
And your computers Typical role?
YOU ram, how much?

It may be something that simple, BIG programs that handle files
need a good Network Typical role setting, plus the ability to cache them.
0
How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

 
LVL 25

Expert Comment

by:dew_associates
Comment Utility
I didn't give any thought to reversing the Set Temp=C:\Tmp instead of the other way around Set Tmp=C:\Temp.

Hmmmm...I'll have to look at that.
0
 
LVL 14

Expert Comment

by:smeebud
Comment Utility
I see where you said DSMORGAN,
"(SET TMP=C:\TEMP AND SET TEMP=C:\WINDOWS\TEMP)" were both in your autoexec
Ss far as I know, "SET TMP=C:\TEMP" is and invalid stayement.
Someone correct me if I'm wrong.

Rem both those statements and try my above suggestion.
Also, I asked, "Hows your disk space, and how do you have your swap file setup. And your computers Typical role?
YOU ram, how much?

Would you past those answers.
Finnally, from a dos window, at
C:\>TYPE
C:\>SET > SET.TXT [enter]
then in your root directory there will be a text file called set.txt.
Please post that;


0
 

Author Comment

by:DSMORGAN
Comment Utility
First, my hard drive is 80% free and I have 64 megs of ram.  Typical role is set to desktop comptuer.  What I get in set.txt is:
winbootdir=C:\WINDOWS
COMSPEC=C:\WINDOWS\COMMAND.COM
TEMP=C:\tmp
windir=C:\WINDOWS
SNDSCAPE=C:\WINDOWS
BLASTER=A220 I5 D1 T1
NWLANGUAGE=ENGLISH
DIRCMD=/O
TMP=C:
DFENV=X:\DF31C\USR\DFENV2.CFG
PROMPT=$P $G
LOGIN_NAME=DMORGAN
WP=/U-DSM
MAIL_BOX=DSM
WINDOWS_LOGIN=0
PATH=Z:.;Y:.;X:.;W:.;C:\NOVELL\CLIENT32;C:\WINDOWS;C:\WINDOWS\COMMAND

Any help?
0
 
LVL 14

Expert Comment

by:smeebud
Comment Utility
Your
TMP=C:
How does that match with what you have set in your autoexec.bat
as of now, or when you made the set.txt??

PATH=Z:.
There is an extra . there.
Will you modify temporarily by rem
REM PATH=Z:.;Y:.;X:.;W:.;C:\NOVELL\CLIENT32;
C:\WINDOWS;C:\WINDOWS\COMMAND
AND REPLACE WITH
PATH=C:\WINDOWS;C:\WINDOWS\COMMANDC:\NOVELL\CLIENT32

Dennis, what do you think
0
 

Author Comment

by:DSMORGAN
Comment Utility
My autoexec.bat currently looks like this:

@C:\PROGRA~1\NORTON~1\NAVBOOT.EXE /STARTUP
rem lh C:\WINDOWS\COMMAND\MSCDEX.EXE /d:mscd001
@ECHO OFF
SET PATH=C:\WINDOWS;C:\WINDOWS\COMMAND
PATH C:\Novell\Client32;%PATH%
REM
REM
REM
set temp=c:\tmp
set tmp=c:\temp
DOSKEY

Set NWLANGUAGE=ENGLISH

The Z:.;Y:.;X:.;W:.; part of the path are added by the login script.  The periods indicate (I believe) that sub directories of those search drives are included.  Is there a way to remove these (short of changing the login script for half the company - something I'm sure most people here won't find very amusing).
0
 
LVL 14

Expert Comment

by:smeebud
Comment Utility
Well, I don't know now that you brought that to my attention.
the . I'mean. I'll have to study that.

Use the
SET TEMP=C:\TMP
only.

Have to go eat. I'll be back. When I spoke of memory, i was more intersted in you hard drive free space and your swapfile settings.
0
 
LVL 25

Expert Comment

by:dew_associates
Comment Utility
DS, I agree with Bud on the Set Temp=C:\Tmp issue, there should only be one reference in autoexec.bat, either Set Temp=C:\Tmp or Set Temp=C:\Temp.

Rem out completely the line TMP=C:

Unfortunately the added network drives can't be removed without changing the way the network is setup.

We're trying to duplicate what your system is doing so we can correct it. Make the noted changes and let us know its effect. I wasn't aware of the network, which throws a new spin on things. Is Office 97 a shared network install or is it on your system locally?
Dennis

0
 

Author Comment

by:DSMORGAN
Comment Utility
OK, I now only have one set temp line.  For your other questions, Office 97 is loaded locally.  I have over 2 gigs of room left on the hard drive.  If by swap files setting you mean virtual memory it is being handled by windows.  Any other info you need?
0
 
LVL 25

Expert Comment

by:dew_associates
Comment Utility
Okay DS, thanks!

Change this:

SET PATH=C:\WINDOWS;C:\WINDOWS\COMMAND
PATH C:\Novell\Client32;%PATH%

to this:

SET PATH=C:\WINDOWS;C:\WINDOWS\COMMAND;C:\;C:\Novell\Client32

And try it!
Dennis
0
 
LVL 25

Expert Comment

by:dew_associates
Comment Utility
Sorry about this, with this small box you can't see everything when your typing it.

Remove the SET before path as well.

Set Path=C:\.......

to

Path=C:\..


0
 

Author Comment

by:DSMORGAN
Comment Utility
Sorry, this didn't work either.  Should we start thinking about selling the TV rights to Unsolved Mysteries?
0
 
LVL 25

Expert Comment

by:dew_associates
Comment Utility
DS, this also occurred to me, do you have these directories on your "C" drive:

C:\Temp

and

C:\Tmp   ?

If not, please make both.

Also both of the following statements are valid in windows 95

Set Temp=C:\Temp
Set Temp=C:\Tmp

Dennis
0
 
LVL 14

Expert Comment

by:smeebud
Comment Utility
A tough one.
0
 
LVL 25

Expert Comment

by:dew_associates
Comment Utility
I'm starting to think that somehow the network is causing this.

DS, could you copy and paste here both your config.sys and autoexec.bat files?

Thanks,
0
 
LVL 14

Expert Comment

by:smeebud
Comment Utility
Dennis, this is DS's "dos set readout"
notice this "TMP=C:".  I've never seen that. looks unusuall but I've no idea what it's telling his system??
---
winbootdir=C:\WINDOWS
COMSPEC=C:\WINDOWS\COMMAND.COM
TEMP=C:\tmp
windir=C:\WINDOWS
SNDSCAPE=C:\WINDOWS
BLASTER=A220 I5 D1 T1
NWLANGUAGE=ENGLISH
DIRCMD=/O
TMP=C:
DFENV=X:\DF31C\USR\DFENV2.CFG
PROMPT=$P $G
LOGIN_NAME=DMORGAN
WP=/U-DSM
MAIL_BOX=DSM
WINDOWS_LOGIN=0
PATH=Z:.;Y:.;X:.;W:.;C:\NOVELL\CLIENT32;C:\WINDOWS;C:\WINDOWS\COMMAND
0
 
LVL 14

Expert Comment

by:smeebud
Comment Utility
DS,
Please see:
http://support.microsoft.com/support/office/content/office97/toolbar.asp

Excerpt.
===
1.Close the Office Shortcut Bar.
2.Start Windows Explorer.
3.Open the folder in which you installed Office 97.
4.Open the Shortcut Bar folder in the Office folder.
The cache files (*.tmp) are stored in this location.
5.If no .tmp files are in the folder, click View on the menu bar and click Options. In the Options
dialog box, click Show All Files and click OK.
6.Press F5 to refresh the view.
7.Delete the .tmp files and restart the Office Shortcut Bar.
The cache is now cleared, and the shortcuts should be updated with the new icons.

0
 
LVL 14

Expert Comment

by:smeebud
Comment Utility
DSMORGAN:
If your networking envirenment allows this I'd like you to make a couple of changes to your typical role. The reasoning is sound and it will only help your system, even if it does not solve the problem.
----------Reasoning:
Swapping and /tmp files compete for the same resource.

Put simply, this means if a program runs the machine out
of swap space, /tmp will fill up, and if large files fill up /tmp
programs will not be able to get any memory to run.

If this restriction becomes a problem for you, a separate disk
partition can be allocated for /tmp.
---------Solution:
I left in the CD part, may not apply.
----
Many users have complained about Windows95 seizing up for up
to a minute because of random,
pointless disk activity. This is due to the way that Windows95 is
set to handle disk caching and virtual memory.

Think off this as a Standard Proceedure like Scandisk and Defrag;
Except you only have to do it ONCE.

Although Windows95 instructs you to "let Windows handle disk cache
settings" for best results, this
obviously does not yield the best results. Here's how to eliminate the
1. Random Disk Activity,
2. Improve System Performance
3. Handle Memory More Efficiently
                            Part One: Virtual Memory
1. Right click on My Computer, and select Properties.
2. Click the Performance tab, and then click Virtual Memory
3. Choose Let me specify my own virtual memory settings.
4. If you want to choose a different drive for your swapfile, run
Disk Defragmenter first.
5. Specify the same value for the Minimum size and the Maximum
size, so Windows95 won't spend so
much time re sizing the file.
A good size is roughly 2 1/2 times the amount of installed RAM
(i.e. create a 40MB swapfile if you
have 16MB of RAM).
6. Press OK, and then OK again, and confirm that you want to
restart your computer.
Note: if you have Norton Utilities, you'll be able to optimize the
swapfile. If you want to take the time,
you can optimize it manually by exiting windows, deleting the
swapfile, defragmenting the drive, and
restarting. Once you've set the swapfile size to be constant, you
 won't have to worry about a
defragmented (broken up) swapfile again.
"The advantage of this process is that Win95 doesn't waste CPU
cycles downsizing the swap file to its
auto-set-minimum. Downsize waste doesn't happen unless enough
applications are loaded and then
closed which exceed that minimum. This will be a low-probability
situation if you set the minimum swap file properly."
                             Part Two: Virtual Cache
1. Open SYSTEM.INI for editing.
2. Add the following two lines to the [vcache] section
(add the section if it's not there):
-------------------------------
[vcache]
MinFileCache=4096 [Experiment, some people set MinFileCache=0]
MaxFileCache=4096
------------------------------
For 32mg
[vcache]
MinFileCache=8192 [Experiment, some people set MinFileCache=0]
MaxFileCache=8192
------------------------------
3. These values, in kilobytes, regulate the size of the VChache,
so you can stop it from filling up all
available RAM and paging all loaded apps to disk.

Here are several little modifications you can make to improve
Windows95 performance:

Speed up system restart:
1. Add BootDelay=0 to the [Options] section of C:\MSDOS.SYS
Speed up the Start Menu:
2. In the Registry Editor, go to HKEY_CURRENT_USER\
Control Panel\ desktop, and add a string
value named MenuShowDelay, with a value specifying the
number of milliseconds (400 is default,
smaller numbers are faster).
================================

By making a few little tweaks to Windows 95's Control Panel settings,
you can realize some big
performance gains. Start by double-clicking on the Control Panel's
System icon, then clicking on the
Performance tab. Next, click on the File System button. You'll see
two settings in the resulting Hard
Disk dialog box:
The setting labeled Typical Role of This Machine determines how
much space is set aside in main
memory to handle path and filename caching. The default Desktop
Computer choice allocates space
for a paltry 32 paths and 677 filenames, whereas the Network Server
choice bumps those settings up
to 64 paths and 2,729 filenames.
Even if your computer is used strictly for desktop applications, change
the Typical Role box to Network
Server. Unfortunately, if you're using the original release of Windows
95--not the recently updated
version titled OEM Service Release 2 (OSR2)--you'll have to take an
additional step to correct a bug in
the Windows 95 Registry.
Change the value of
HKEY_LOCAL_MACHINE\SOFTWARE\ Microsoft\Windows\CurrentVersion\
FSTemplates\Server\NameCache to a9 0a 00 00, and
\PathCache to 40 00 00 00.
Or copy everything between the double lines, copy and paste to notepad
and "Save as"
"Role1.reg" and "Role2.reg". Then all you have to do is double click on
those files to enter them.
===================
REGEDIT4

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\FS
Templates\Server]
@="Network server"
"PathCache"=hex:40,00,00,00
"NameCache"=hex:a9,0a,00,00
===================
REGEDIT4

[HKEY_LOCAL_MACHINE\System\CurrentControlSet\control\FileSystem]
"NameCache"=hex:a9,0a,00,00
"PathCache"=hex:40,00,00,00
===================
Then:
The Read-Ahead Optimization slider establishes how much additional
data Windows 95 should fetch every time you retrieve data from your
hard disk. Read-ahead buffering improves performance by
reducing the number of times your machine has to go out to the relatively
slow hard disk to get data.
Set the slider all the way to the right, giving Windows 64K of read-ahead
buffering.

Next, click on the CD-ROM tab in the File System Properties box.
The Supplemental Cache Size slider
adjusts the room Windows 95 sets aside for read-ahead buffering
of your CD. The first three steps on
the slider add 64K or 128K each to the cache; the final three steps
add 256K apiece. The box labeled
Optimize Access Pattern For doesn't control access speed to your
CD; the setting's real function is to
reserve even more buffer space for caching CD reads.
The Single-Speed Drives and No Read-Ahead
settings don't increase the buffer size.
But the double-, triple-, and quad-speed settings add 50K,
100K, and 150K of cache, respectively.

If you use your CD drive frequently, move the Supplemental
Cache Size slider to Large, and specify
that you have a Quad Speed or Higher CD, even if you don't.
The combination will set aside about
1.2MB for CD caching, and ensure that your CD will run as fast
as possible.
---------------
An Alternate swapping method
Run Sysmon and check to see how much
memory you usually use (w/ your normal programs running).
Now set the minimum swap file to just slightly larger
than this number, but leave the max alone (let it use
the whole drive if needed). This way you will have a
permanant file on the drive that will let you use the
computer w/o win95 always resizing it, but when you
need more space win95 will be able to use up to the
rest of the drive. If you limit the top end when win95
needs more space it will choke and either refuse to run
the program or crash.

0
 
LVL 14

Expert Comment

by:smeebud
Comment Utility
BTW, the 2 1/2 X ram is only a rule of thumb.
0
 

Author Comment

by:DSMORGAN
Comment Utility
OK.  I've tried deleting all the tmp files from the shortcut folder.  Still no luck.  I've also tried the tweaks for better performance - no change on the temp files.  Anything else?
0
 
LVL 14

Expert Comment

by:smeebud
Comment Utility
Well,The best I can do,
and I'm fairly good at this is track down others with that problem.
I don't know the answer yet, but I'm sure between Dennis and myself we can come up with it.

Tell me, did
http://support.microsoft.com/support/office/content/office97/toolbar.asp

Offer you anything as far as the tmp file caching and the
Office Shortcut Bar?

Need to know if that's close.
0
 
LVL 25

Expert Comment

by:dew_associates
Comment Utility
Bud, I spoke with our MS liason this morning and he never heard of the problem before but has agreed to research it for us!
0
 

Author Comment

by:DSMORGAN
Comment Utility
I checked http://support.microsoft.com/support/office/content/office97/toolbar.asp but didn't see anything that was helpful.
0
 
LVL 14

Expert Comment

by:smeebud
Comment Utility
Ok, still on the case DS..........
0
 

Expert Comment

by:litho
Comment Utility
DS: Have you figured this one out yet?

The main problem here is the "TMP=C:" This is being set somewhere, and because the desktop folder is the default logged folder under Windows, that's where the temp files go.
(If it were "C:\", it's be a different story)

In addition to the standard places already mentioned, I would check your Netware login script(s) to see if there is a command like "DOS SET TEMP=C:"
Otherwise, do a good search for any other .bat file that might be setting this environment variable.

As a last resort workaround, it might work to link a batch file in your startup folder that simply does the "SET TMP=C:\TEMP"
0

Featured Post

What Should I Do With This Threat Intelligence?

Are you wondering if you actually need threat intelligence? The answer is yes. We explain the basics for creating useful threat intelligence.

Join & Write a Comment

This article will show you how to use shortcut menus in the Access run-time environment.
Outlook Free & Paid Tools
The viewer will learn how to make their project stand out over others by learning how to change colors and shapes, add spaces, change directions, and add bullets to their charts.
This video shows where to find templates, what they are used for, and how to create and save a custom template using Microsoft Word.

743 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

13 Experts available now in Live!

Get 1:1 Help Now