Mystery "F" drive in Explorer (My Computer)

I just installed a new 4.3 gig Western Digital EIDE drive into my system.  I originally had one 1.2 Gig drive (seagate).  I partitioned the new drive into 3 equal sizes, D drive being the primary dos partition, e drive extended dos parition (logical) and f drive the same as e.  Windows 95 detected these new drives at boot up and moved my cd rom to G.  For some reason, the e and f drive could not use long file names (strange), so I used fdisk to delete all previous info and create a D and E drive of 2.15 Gig each.  I formated these drives and everything worked fine.  Then I realized that window's 95 Still had my cd rom as the G drive and showed a "mystery" F drive with 0 bytes capacity, this "F" drive has the CD rom icon.

The system likes to hang when I first boot up and try to use explorer or my computer, obviously trying to resolve this hardware discrepency.  Apparently the resolution is to create the phantam "F" drive.

I can't figure out how to fix it, I want to get rid of the f drive and move my cdrom back f, where it should be.  

Background info: I installed the 4 new 16 MB EDO modules the same day (seems to be working fine).  I've never had any hardware or software trouble to date (1 year).

Any information on this matter would be greatly appreciated.
slewis112097Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

busukaCommented:
I believe I can help here: enter BIOS setup and check how HD is
detected (Normal, Large, LBA. In BIOS setup menu item 'IDE auto
identification'). If you have options Large or LBA (CHS) you MUST
select LBA and FDISK and REFORMAT HD.

Waiting for feedback. Ian
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
slewis112097Author Commented:
I went into my bios, and my settings are all Auto detect.  The options are:  Ide translation mode - Standard CHS, Logical block,
extended CHS and Autodetect.  

Multiple sector settings: Disabled, 4 sectors/ block, 8 sec/blk and Autodetect.

Fast program I/O modes - Autodetect

Ide devicd config: Autodetect

DO you think I need the extended CHS setting, or the logical block setting under "Ide translation mode" field.  But the drives are working fine, why would window's want to add this F drive?  I'd like to not reformat again, have already done it 3 times.
0
busukaCommented:
Hmm, looks like your BIOS not AWARD. Auto is just your suggestion
to BIOS auto-detect type of HD upon startup, BIOS detects HD and
uses detected type. You can see it (in AWARD case) right after POST
(Power-On Self Test) in small table, right before 'Starting Win95'
message, what exact type of addressation use HD. You need for new
HD select type LBA (Logical Block Addressation). I thought your
HD can't use long names. Now it can ?
0
Get expert help—faster!

Need expert help—fast? Use the Help Bell for personalized assistance getting answers to your important questions.

dew_associatesCommented:
SLewis, whe is drive "C" and why have you made drive "D" your primary Dos partition? Auto settings should be okay, but I believe that your setting the drive letter assignment in your config.sys and autoexec.bat files. In addition to the above questions, could you click Start, Run and then type in Sysedit and touch enter. This will bring up your system startup files, beginning with your autoexec.bat file. Using the edit function, copy and paste the contents of the config.sys and autoexec.bat files here and we'll check them!
Dennis
0
slewis112097Author Commented:
BUSUKA - yes I have long file names now and the drives work fine.

dew_associates:  C drive is boot drive with a primary dos partition as hell.

This is Config.sys
DEVICE=C:\WINDOWS\HIMEM.SYS
DOS=HIGH,UMB
DEVICE=C:\WINDOWS\EMM386.EXE NOEMS I=B000-B7FF
FILESHIGH=50
BUFFERSHIGH=20
STACKSHIGH=0,0
FCBSHIGH=1
DEVICEHIGH=C:\WINDOWS\MOUSE.SYS
DEVICEHIGH=C:\PBTOOLS\NEC_IDE.SYS /D:MSCD0001              

This is Autoexec.bat
rem - By Windows 95 Network - c:\windows\net start
                           
@ECHO OFF
C:\SOUND144\UTILITY\AZCAL.EXE
PROMPT $P$G
PATH C:\WINDOWS;C:\WINDOWS\COMMAND;C:\windows\system;C:\;c:\DOS
LH C:\WINDOWS\COMMAND\MSCDEX.EXE /D:MSCD0001 /M:20 /S /L:D
SET DIRCMD=/O
SET TEMP=C:\PBTOOLS\WINTEMP
SET WINPMT=[WINDOWS] $P$G
SET BLASTER=A220 I5 D1 T4
SET GALAXY=A220 I5 D1 K10 P530 T6
SET SOUND=C:\SOUND144
IF EXIST C:\VGA\CLMODE.EXE C:\VGA\CLMODE T640=60 T800=60 T1024=87 T1280=0
REM                          
REM              
REM                        
                         

0
slewis112097Author Commented:
Thanks for the help, I solved the problem by removing my Cd rom device from the WIN95 device list and rebooting.  Window's detected the drive and correctly placed it as the F drive.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows OS

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.