loss of route to dns

ok When running RedHat 4.1 i had no problems.

now that i am running RedHat 5.0 after about 5 minutes my linux box looses its route to the my campusses dns server.

I then can still ping and telnet to numerical sights. I however cannot ping or connect to sights by domain name. or telnet into my computer from a remote computer.

any ideas on how to fix this,   if you need more info just ask and i will try my best to supply it.
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Can you still ping your DNS? Or does it start saying "no route to host" after 5 minutes?
Krishna081697Author Commented:
i can ping the numerical address
if i ping the alpha address it just sits there

Hmm :)
Maybe you could post the output of "strace host <some symbolic address>" within the 5 minutes (when it still works) and after 5 minutes (when it doesn't)?
Cloud Class® Course: Amazon Web Services - Basic

Are you thinking about creating an Amazon Web Services account for your business? Not sure where to start? In this course you’ll get an overview of the history of AWS and take a tour of their user interface.

Hi Krishna

Have you installed any FireWall Software?
are there any filters (ipfwadm) active?

Regards michael
OK - what it looks like is happening is that the resolv.conf entry is being updated or erased. This is the file that tells the machine who the DNS server is. This is not strictly speaking a routing problem but an entry problem with resolv.conf. Can you tell me what the resolv.conf file looks like before and after the  problem occurs?
Krishna081697Author Commented:
the resolv.conf dosnt change befor and after it says:

search rhn.orst.edu

I would like to make a corrextion,  I can only ping people on my local ip address range (128.1983.136.XXX) outside of that i get a network unreachable.

i am not running any fire wall,  if i set up my computer to boot and use a bootp for configureing i get this error. If i manualy configure it i just get this error network unreachable

Sounds like you are losing a default route. Now I recall once having a similar problem myself, but can't remember what caused it and how I solved it. To confirm this, you can try running /sbin/route before and after.
Krishna081697Author Commented:
ok  doing that i can watch it loose its route to the dns

here's what it gave me: (well it was working)

Destination   Gateway          Genmask          Flags Metric Ref
localhost     *        UH    0      0 *          U     0      0     -              !     0      -  
default       orstw5-gw.orst          UG    0      0

Use Iface
1   io
4   eth0
0   -
14  eth0

this is what it gave me after it lost route:
Destination   Gateway Genmask          Flags Metric Ref Use Iface
localhost     *  UH    0      0   1   io *    U     0      0   4   eth0     -        !     0      -   0   -

so it dose look like it looses connection to the dns, but why and how.    

thanks for the help so far!!

Krishna081697Author Commented:
Adjusted points to 200
Btw it has nothing to do with DNS, it just loses the route to everything outside your local network.
As a workaround, I think you can manually do "route add default eth0", but as for making it work automatically after reboot...
Could you post the contents of your
/etc/sysconfig/network-scripts/ifcfg-eth0 and
MLEV is right - the reason why the defaultroute may be going down is that the interface is either resetting or the driver is buggy.
Krishna081697Author Commented:
ok here are the files

networking = yes
forward_ipv = no
hostname = duncanjo.rhn.orst.edu
gatewaydev =
gateway =


device = eth0
userctl = no
onboot = yes
bootproto = bootp
broadcast =
network =
netmask =
ipaddr =


device = lo
ipaddr =
netmask =
network =
broadcast =
onboot = yes
bootproto = none

the driver i use is just the ne compatible driver
ip 0x280 irq 5
hardware configured to these settings.
Try making /etc/sysconfig/network to read "gatewaydev=eth0"
and let's see if this helps.
Also, are you sure the netmask for eth0 is correct?
It seems like your router ( doesn't fit into it.
(though I am not sure whether this is a problem).
Should be advised that firewalls and other internet devices do not always appreciate ip addresses who have a value of 1 in an octet.

Krishna081697Author Commented:
the program winipcfg (when i run win95) says the gate way is

and that is what i was instructed to set it as and it works for win95 so i am preaty sure of that ip address.
my collage uses to subnetmasks, and i am on the half that useses the other is but that is the opisiate side of the campuss

i will try that and then post the results mlev

ask your unix dns administrator if your DNS servers is working properly ie: names other machine for you to access


sounds that you're missing a route, please post result of

  netstat -rn
Krishna081697Author Commented:
sorry jetx  but i have allready tryed that.

ahoffmann, the ruesults of what you requested were the same both before and after i lost connection, so here is what it gave me.

Active Internet connections (w/o servers)
Proto Recv-Q Send-Q Local Address           Foreign Address         State      
udp        0      0  *                          
udp        0      0*                          
Active UNIX domain sockets (w/o servers)
Proto RefCnt Flags       Type       State         I-Node Path
unix  2      [ ]         STREAM     CONNECTED     712    
unix  2      [ ]         STREAM                   713    /dev/log
unix  2      [ ]         STREAM     CONNECTED     771    
unix  2      [ ]         STREAM                   772    /dev/log
unix  2      [ ]         STREAM     CONNECTED     1097  
unix  2      [ ]         STREAM                   1098   /dev/log
unix  2      [ ]         STREAM     CONNECTED     1211  
unix  2      [ ]         STREAM                   1212   /dev/log
unix  2      [ ]         STREAM     CONNECTED     1267  
unix  2      [ ]         STREAM                   1268   /dev/log
unix  2      [ ]         STREAM     CONNECTED     1343  
unix  2      [ ]         STREAM                   1344   /dev/log
unix  1      [ ]         STREAM                   1405  
unix  2      [ ]         STREAM     CONNECTED     1782  
unix  2      [ ]         STREAM                   1784   /dev/log
unix  2      [ ]         STREAM     CONNECTED     1824  
unix  2      [ ]         STREAM                   1825   /dev/log
Active IPX sockets
Proto Recv-Q Send-Q Local Address              Foreign Address            State

could this be something with how the ne drivers were compiled vs how they were compiled in the older version of redhat? would it just be some form of hardware failer on the part of the nic? even though i can still ping and connect to othercomputers on my local net 128.193.136.xxx
first, edit your /etc/hosts, under your own host with ip, give the hostname and ipnumber of the dns server, this makes it as a host of it's own and will always communicate, so this is a temporary solution, i think you have to check the timeout of your linux host, i will search for this and notify you when i found something !

Krishna081697Author Commented:
I added both of the gateways to my /etc/hosts and now i can ping its alpha and numerical ip but still after about 5 min I cant ping any other ip outside of my local net (128.193.136.xxx)
Krishna081697Author Commented:
Adjusted points to 300

Do you have the command 'tcpdump'?  If not, get it from

If so, e-mail me the results of the following commands, both before and after the failure:

ifconfig -a
netstat -r
tcpdump -v -c 1024

-Marc (hallmarc@vt.edu)
I suggest: tcpdump -n -v -c 1024
'cause Krishna has problems with name resolution ;)
I had similar problems (routes disappearing), and I found it was because I had the routed and gated daemons running (oops).
As root, do the following:
"chkconfig --list routed" and, "chkconfig --list gated"
If the results show that they are "on", then you will want to
turn them off (they are flushing your route tables).
To stop routed and gated, go to the /etc/rc.d/rc3.d directory:
mv S32gated K32gated
mv S55routed K55routed
shutdown -r now (or init by some other means)
Afterwards, restablish your routes to your DNS server.


Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
THANK YOU THANK YOU THANK YOU!!!!!!!!!!!!!!!!!!!!!!!!!

gated was running and reseting the damn thing

thanks everyone else!
Krishna081697Author Commented:
You're welcome. (now if I can just figure out why DNS or WINS are not working from my Linux box ... arghhh!)

It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux Networking

From novice to tech pro — start learning today.