Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 436
  • Last Modified:

loss of route to dns

ok When running RedHat 4.1 i had no problems.

now that i am running RedHat 5.0 after about 5 minutes my linux box looses its route to the my campusses dns server.

I then can still ping and telnet to numerical sights. I however cannot ping or connect to sights by domain name. or telnet into my computer from a remote computer.

any ideas on how to fix this,   if you need more info just ask and i will try my best to supply it.
0
Krishna081697
Asked:
Krishna081697
  • 10
  • 5
  • 2
  • +7
1 Solution
 
mlevCommented:
Can you still ping your DNS? Or does it start saying "no route to host" after 5 minutes?
0
 
Krishna081697Author Commented:
i can ping the numerical address
if i ping the alpha address it just sits there

0
 
mlevCommented:
Hmm :)
Maybe you could post the output of "strace host <some symbolic address>" within the 5 minutes (when it still works) and after 5 minutes (when it doesn't)?
0
Free learning courses: Active Directory Deep Dive

Get a firm grasp on your IT environment when you learn Active Directory best practices with Veeam! Watch all, or choose any amount, of this three-part webinar series to improve your skills. From the basics to virtualization and backup, we got you covered.

 
handrichCommented:
Hi Krishna

Have you installed any FireWall Software?
are there any filters (ipfwadm) active?

Regards michael
0
 
unicorntechCommented:
OK - what it looks like is happening is that the resolv.conf entry is being updated or erased. This is the file that tells the machine who the DNS server is. This is not strictly speaking a routing problem but an entry problem with resolv.conf. Can you tell me what the resolv.conf file looks like before and after the  problem occurs?
0
 
Krishna081697Author Commented:
the resolv.conf dosnt change befor and after it says:

search rhn.orst.edu
nameserver 128.193.4.20

I would like to make a corrextion,  I can only ping people on my local ip address range (128.1983.136.XXX) outside of that i get a network unreachable.

i am not running any fire wall,  if i set up my computer to boot and use a bootp for configureing i get this error. If i manualy configure it i just get this error network unreachable


0
 
mlevCommented:
Sounds like you are losing a default route. Now I recall once having a similar problem myself, but can't remember what caused it and how I solved it. To confirm this, you can try running /sbin/route before and after.
0
 
Krishna081697Author Commented:
ok  doing that i can watch it loose its route to the dns

here's what it gave me: (well it was working)

Destination   Gateway          Genmask          Flags Metric Ref
localhost     *                255.255.255.255  UH    0      0   128.193.136.0 *                255.255.252.0    U     0      0  
127.0.0.0     -                255.0.0.0        !     0      -  
default       orstw5-gw.orst   0.0.0.0          UG    0      0

Use Iface
1   io
4   eth0
0   -
14  eth0


this is what it gave me after it lost route:
Destination   Gateway Genmask          Flags Metric Ref Use Iface
localhost     *       255.255.255.255  UH    0      0   1   io 128.193.136.0 *       255.255.252.0    U     0      0   4   eth0
127.0.0.0     -       255.0.0.0        !     0      -   0   -


so it dose look like it looses connection to the dns, but why and how.    

thanks for the help so far!!

0
 
Krishna081697Author Commented:
Adjusted points to 200
0
 
mlevCommented:
Btw it has nothing to do with DNS, it just loses the route to everything outside your local network.
As a workaround, I think you can manually do "route add default eth0", but as for making it work automatically after reboot...
Could you post the contents of your
/etc/sysconfig/network,
/etc/sysconfig/network-scripts/ifcfg-eth0 and
/etc/sysconfig/network-scripts/ifcfg-lo?
0
 
unicorntechCommented:
MLEV is right - the reason why the defaultroute may be going down is that the interface is either resetting or the driver is buggy.
0
 
Krishna081697Author Commented:
ok here are the files
/etc/sysconfig/network

networking = yes
forward_ipv = no
hostname = duncanjo.rhn.orst.edu
gatewaydev =
gateway = 128.193.140.1

/etc/sysconfig/network-scripts/ifcfg-eth0

device = eth0
userctl = no
onboot = yes
bootproto = bootp
broadcast = 128.193.139.255
network = 128.193.136.0
netmask = 255.255.252.0
ipaddr = 128.193.136.139

/etc/sysconfig/network-scripts/ifcfg-lo

device = lo
ipaddr = 127.0.0.1
netmask = 255.0.0.0
network = 127.0.0.0
broadcast = 127.255.255.255
onboot = yes
bootproto = none

the driver i use is just the ne compatible driver
ip 0x280 irq 5
hardware configured to these settings.
0
 
mlevCommented:
Try making /etc/sysconfig/network to read "gatewaydev=eth0"
and let's see if this helps.
Also, are you sure the netmask for eth0 is correct?
It seems like your router (128.193.140.1) doesn't fit into it.
(though I am not sure whether this is a problem).
0
 
cemaylorCommented:
Should be advised that firewalls and other internet devices do not always appreciate ip addresses who have a value of 1 in an octet.


0
 
Krishna081697Author Commented:
the program winipcfg (when i run win95) says the gate way is 128.193.140.1

and that is what i was instructed to set it as and it works for win95 so i am preaty sure of that ip address.
my collage uses to subnetmasks, and i am on the half that useses 255.255.252.0 the other is 255.255.255.254 but that is the opisiate side of the campuss

i will try that and then post the results mlev
0
 
jetxCommented:
Krishna,

ask your unix dns administrator if your DNS servers is working properly ie: names other machine for you to access

regards

jetx
0
 
ahoffmannCommented:
sounds that you're missing a route, please post result of

  netstat -rn
0
 
Krishna081697Author Commented:
sorry jetx  but i have allready tryed that.

ahoffmann, the ruesults of what you requested were the same both before and after i lost connection, so here is what it gave me.

Active Internet connections (w/o servers)
Proto Recv-Q Send-Q Local Address           Foreign Address         State      
udp        0      0 127.0.0.1:53            0.0.0.0:*                          
udp        0      0 128.193.136.139:53      0.0.0.0:*                          
Active UNIX domain sockets (w/o servers)
Proto RefCnt Flags       Type       State         I-Node Path
unix  2      [ ]         STREAM     CONNECTED     712    
unix  2      [ ]         STREAM                   713    /dev/log
unix  2      [ ]         STREAM     CONNECTED     771    
unix  2      [ ]         STREAM                   772    /dev/log
unix  2      [ ]         STREAM     CONNECTED     1097  
unix  2      [ ]         STREAM                   1098   /dev/log
unix  2      [ ]         STREAM     CONNECTED     1211  
unix  2      [ ]         STREAM                   1212   /dev/log
unix  2      [ ]         STREAM     CONNECTED     1267  
unix  2      [ ]         STREAM                   1268   /dev/log
unix  2      [ ]         STREAM     CONNECTED     1343  
unix  2      [ ]         STREAM                   1344   /dev/log
unix  1      [ ]         STREAM                   1405  
unix  2      [ ]         STREAM     CONNECTED     1782  
unix  2      [ ]         STREAM                   1784   /dev/log
unix  2      [ ]         STREAM     CONNECTED     1824  
unix  2      [ ]         STREAM                   1825   /dev/log
Active IPX sockets
Proto Recv-Q Send-Q Local Address              Foreign Address            State

could this be something with how the ne drivers were compiled vs how they were compiled in the older version of redhat? would it just be some form of hardware failer on the part of the nic? even though i can still ping and connect to othercomputers on my local net 128.193.136.xxx
0
 
frowijnCommented:
first, edit your /etc/hosts, under your own host with ip, give the hostname and ipnumber of the dns server, this makes it as a host of it's own and will always communicate, so this is a temporary solution, i think you have to check the timeout of your linux host, i will search for this and notify you when i found something !

Oscar
0
 
Krishna081697Author Commented:
I added both of the gateways to my /etc/hosts and now i can ping its alpha and numerical ip but still after about 5 min I cant ping any other ip outside of my local net (128.193.136.xxx)
0
 
Krishna081697Author Commented:
Adjusted points to 300
0
 
hallmarcCommented:
Krishna,

Do you have the command 'tcpdump'?  If not, get it from
ftp://sunsite.unc.edu/pub/Linux/system/Network/sunacm/Other/tcpdump/tcpdump.bin.tgz

If so, e-mail me the results of the following commands, both before and after the failure:

ifconfig -a
netstat -r
tcpdump -v -c 1024

-Marc (hallmarc@vt.edu)
0
 
ahoffmannCommented:
I suggest: tcpdump -n -v -c 1024
'cause Krishna has problems with name resolution ;)
0
 
wdawesCommented:
I had similar problems (routes disappearing), and I found it was because I had the routed and gated daemons running (oops).
As root, do the following:
"chkconfig --list routed" and, "chkconfig --list gated"
If the results show that they are "on", then you will want to
turn them off (they are flushing your route tables).
To stop routed and gated, go to the /etc/rc.d/rc3.d directory:
mv S32gated K32gated
mv S55routed K55routed
shutdown -r now (or init by some other means)
Afterwards, restablish your routes to your DNS server.

0
 
wdawesCommented:
THANK YOU THANK YOU THANK YOU!!!!!!!!!!!!!!!!!!!!!!!!!

gated was running and reseting the damn thing

thanks everyone else!
0
 
Krishna081697Author Commented:
You're welcome. (now if I can just figure out why DNS or WINS are not working from my Linux box ... arghhh!)

0

Featured Post

Nothing ever in the clear!

This technical paper will help you implement VMware’s VM encryption as well as implement Veeam encryption which together will achieve the nothing ever in the clear goal. If a bad guy steals VMs, backups or traffic they get nothing.

  • 10
  • 5
  • 2
  • +7
Tackle projects and never again get stuck behind a technical roadblock.
Join Now