Solved

Win95 keeps trying to load drivers already there

Posted on 1998-01-25
59
332 Views
Last Modified: 2013-12-16
How do I stop Windows 95 from loading drivers already loaded, even if I say NO (and don't ask me again) to install if it even asks me that, it still tries to install it again or I get
! item in device manager.

For me it happens with:

1. Matrox Millienium Powerdesk II

2. Matrox m3d drivers, it actually tries to install it twice at same time as an unsupported device and as regular multimedia device, only know cause it had identical stats (IRQ/addresses etc)

3. Syquest EZ135/230 drivers, I have external version and
it wants to install it again even though it's installed and working fine.

4. If I toast a driver for something not needed, it tries to shove it down my throat again....

What do I have to do?    Been dealing with this for a long time... finally gave in and asking here 8)

I get lots of screen freeze ups even though I have anti-crashing programs installed... First Aid Deluxe 97 and the latest win95 drivers for most everything under the sun.
I had to juggle my IRQ's and in BIOS I even shut em off for
the m3d card which rarely gets used, with or without IRQs for all I still get these problems...

and one other thing giving me grief, I can't scandisk or defrag the one system, tells me hard drive is not formatted
properly (no way!) or some util has locked it.  
I just reinstalled Win95 over a screwed up one and it still
says locked and nothing I have can explain it or sees it as a problem...  but my defrag rate on one partition is at 10%...

Please save me!  8)
0
Comment
Question by:bravado042997
  • 23
  • 9
  • 9
  • +4
59 Comments
 
LVL 1

Author Comment

by:bravado042997
Comment Utility
Edited text of question
0
 
LVL 9

Expert Comment

by:magigraf
Comment Utility
bravado...

Section 1:
==========

When you want in the future to reinstall windows to CORRECT problems please read the following:


FIRST:  BACKUP YOUR REGISTRY AS A SAFETY NET !!

Reinstall win95 from the command prompt using (setup /p f ) command.
This setup switches will clean your system files and replace missing and damaged files, keeping all your apps and updated drivers.

The switch  f

Means a Clean Registry mode. It forces Detection to clean the root branch of the registry before starting. It will also remove commands that are pointing to the wrong locations including Win 95 files.

The switch  /p

The string can contain one or more detection switches separated by a semicolon (;). For example, if you want to use  /p f

The switch /d

This switch can be used if you do not want Setup to use your existing configuration (like Win.ini and System.ini files).

To restore or adjust your windows installation:
 
 From dos insert your CD type this command... at your CD-ROM drive letter
" setup /d /p f "  Without quotes

You would want at that stage to choose from  "Full or Custom Setup", choose Custom. This will give you more control through a step by step of the setup.

This should set back all entries in place and restore all functions as before the problem occured.

So that would take care of that problem of reinstalling.


Section 2:
==========
Go to www.matrox.com
download the latest drivers, for your video card (these guys have drivers every 2 weeks)

1) Uninstall Matrox drivers
2) Uninstall any conflicting device or the ones causing the problems.
3) Don't restart, now start by reinstalling ONE device at a time.
4) Make sure you have no conficting devices in DEVICE MANAGER
5) Start by the Matrox, it has a setup (run it)
6) Same for the Syquest.

After that you could restart your system.
If everything went fine, windows should not prompt you any more.
The way it looks is that you haven't install then correctly, or something just went wrong.

Hope this helped
If you nee more info, just ask!
Regards


0
 
LVL 14

Expert Comment

by:smeebud
Comment Utility
magigraf, I am reopening.... only because I want more opinions
and figure more ppl will look if not locked ;)
I've been up all night so I'll come back here after the superbowl
probably 8)
Thanks for replies guys, too tired to fuss right now though ;)

Btw I have wiped HD's clean and started from scratch and still
get the same results...  

Are there any IRQ's that can be shared?  I am using em all...

laters...   -b sleepy
0
 
LVL 1

Author Comment

by:bravado042997
Comment Utility
bravado and magigraf, consider this:
----
Finding A Defective Driver or Device;  Step By Step
1) Boot into SAFE MODE, by following these steps:
- Press the F8 key when you see the "Starting Windows 95" message.
- From the Startup menu, choose Safe Mode.

2) Try the Step by Step:
When you see the "Starting Windows 95" message, press the F8 key. From the Startup menu,
choose Step-By-Step Confirmation. Step through each command in the Config.sys and
Autoexec.Bat files. Load only one line and see if the computer starts. If so, restart the computer and
load two lines. Continue until the startup problem returns. Once you have determined which line is
causing the problem, check the syntax of that line

3) Are the protected-mode drivers configured incorrectly or damaged?
To determine whether a protected-mode driver is preventing the computer from booting properly,
follow these steps:

1.Start Windows 95 in Safe mode.

2.Use the right mouse button to click My Computer, and then click Properties on the menu that
appears.

3.On the Device Manager tab, disable any devices in the following categories: Display adapters
Floppy disk controllers Hard disk controllers Keyboard Mouse Network adapters PCMCIA socket
Ports SCSI controllers Sound, video, and game controllers To disable a device, follow these steps:

a. In Device Manager, double-click the category name, and then double- click the device.
b. On the General tab, click the Original Configuration (Current) check box to clear it, and then click
OK.
c. Restart your computer.

4.Once Windows 95 restarts, enable the devices you disabled in step 3. Enable the devices in the
following order: Com ports Hard disk controllers Floppy disk controllers Other devices To enable a
device, follow these steps:
a. In Device Manager, double-click the category name, and then double- click the device.
b. On the General tab, click the Original Configuration (Current) check box to select it, and then
click OK.
c. While the properties for each device are open, click the Resources tab and make sure there are no
conflicts listed in the Conflicting Devices list.

5.Restart your computer.
0
 
LVL 14

Expert Comment

by:smeebud
Comment Utility
bravado...

Don't worry about the points, we want to help you out first, I guess you are well served here between Smeebud and myself, and if more experts shows up, they will still help regardless of the question being blocked or not.  We have established between us a sence of honesty and fairness.  So if Smeebud for example give you the solution, I will be more that happy if you would award him the points (I would even ask you to reject my answer).

For us what counts is to get you out of your problem.

Regards
0
 
LVL 9

Expert Comment

by:magigraf
Comment Utility
magigraf, yeah I hoped for that... that is how I work as well I have a few points under my belt....    and this is my first question
on here in my year of membership so I have points to give hehe
Unfortunately I woke up with only 4 hrs of sleep 8(

I got the 2nd PC, my gf's not even booting windows 95 anymore,
tells me can't load SHELL32.DLL, well it was crashing on any system util run pretty much and I looked at IRQ's and saw a Bus Mastering driver installed for IDE (and listed as not supported) and removed it and apparently killed poor windows...  she has a program for work on it but no backup of it other than my quick 135 cart transfer 8)  which I haven't tested on mine.

I removed everything from running except explorer and it still
tells me the harddrive is not formatted properly or locked.
It took me several orderly attempts to even get to the point to try
with nothing, it kept crashing...
I'm gonna reinstall again on her machine...   Possibly the fact I can't defrag might be a factor, perhaps I will install Win95 in a seperate dir and see if I can defrag it then.

I am guessing you guys are right, install win95 with NUT'N HONEY and then and them all when win95 asks for em....
Weird on her system it didn't find the modem on it's own but installed fine from control panel modem and that included a painful LOOK FOR NEW HARDWARE...

I was also surpised to see her Vibra-16 sound card at IRQ 9.

Maybe I should through it out the window 8)

As far as CONFIG.SYS and AUTOEXEC.BAT goes...

There isn't much there...

I'm gonna give it a good look over once shortly anyhow.

---------
My PC perhaps the uninstall reinstall of drivers will be enough...
at least I am able to get online with it hehe
IRQ wise on mine though I have all 15 used.
P5/233MMX with 64 EDO for the record.
More later I guess... 8)
Need any more info please ask!


0
 
LVL 1

Author Comment

by:bravado042997
Comment Utility
ack what bad typos I weave...

0
 
LVL 1

Author Comment

by:bravado042997
Comment Utility
Look at MSD for your IRQs instead of device manager.
Or look at them again in device manager.
It often appears that they are all being used when actually it's only showing the used ones.
This happens to me all the time, that is, counting the references.
0
 
LVL 14

Expert Comment

by:smeebud
Comment Utility
smeebud, u lost me...

'It often appears that they are all being used when actually it's only showing the used ones.'      care to rephrase that?

btw I found the culprit on my gf's machine but I can't figure out how to get rid of it.

Before it gets to the loading Win95 on my gf's machine it puts this
up for a split second:

Support Bus Master Device Driver ver 1.70

IDE DRIVE 0 = WDC AC23500H
     Support PIO mode: 4
Support multiword DMA mode: 2
Support 32bit I/O
Drive 0 DMA mode 2 active
Bus Master device driver installed

Where is that driver installed, I've looked at C:\ including hidden
files and moved anything looking odd, to no avail still loading that
sucka!    

I had to redo win95 to get it rolling at all due to the shell32.dll, just simply replacing it didn't make a difference.


0
 
LVL 1

Author Comment

by:bravado042997
Comment Utility
geeez that driver came in via BIOS setting,
no driver actually on HD, fooled me 8)
Have to see if that fixed things... will report...

0
 
LVL 1

Author Comment

by:bravado042997
Comment Utility
That was poorly said by me.
Look in MSD in your IRQ and see if it also reports all IRQs used.
0
 
LVL 14

Expert Comment

by:smeebud
Comment Utility
I rebooted and in device manager under HD controllers ONLY
the busmastering one is listed but says not supported and I
even got it red X'd out... but if I try to remove it, it crashes after I
do anything else.      
Gonna reinstall again in fresh dir...   best move?
I did run find new hardware and gonna see what it does first.

0
 
LVL 1

Author Comment

by:bravado042997
Comment Utility
I rebooted after win95 found IDE controllers and modem, but
no listing in device manager for a HD controller now.

Alas drive still not scandisk/defragable thru winblows.

Here goes new install...

0
 
LVL 1

Author Comment

by:bravado042997
Comment Utility
hmmmm I rebooted and was able to defrag D:
(2nd partion of only HD on system)
but can't scandisk or defrag C:, and can't scandisk D: but I could defrag D:?   what's going on here?  
Didn't reinstall in another dir yet...
I'm baffled now 8(

0
 
LVL 1

Author Comment

by:bravado042997
Comment Utility
bravado...

Where are we now, we started with problems in asking about devices already installed, now we are talking BUS MASTERING..
Could you update the situation here. Sorry but you lost me.
Regards
0
 
LVL 9

Expert Comment

by:magigraf
Comment Utility
mag, haha good I am not only lost one...

busmastering driver was running on the one system, it has been
handled but still I can't defrag/scandisk C:, although I did
defrag D:...

Anyho I am gonna reinstall a fresh '95 and see what happens...

0
 
LVL 1

Author Comment

by:bravado042997
Comment Utility
ack, I chickened out and am actually in good shape now with her system, a little magic somewhere.  

Now on to my computer....

I've gotta stew over your comments, I had to work solely on my gf's.... thanks a bunch.

.....stay tuned....

0
 
LVL 1

Author Comment

by:bravado042997
Comment Utility
We are tuned and curious too.
Regards
0
 
LVL 9

Expert Comment

by:magigraf
Comment Utility
ok on my PC, win95 even though I removed the hard drive bus-mastering controller, I get it reinstalled with primary and secondary, but now BOTH SB-16 and std Primary IDE/ESDI controller drivers try to install, if I kill em they just come back.
Very weird because I have nothing connected to my SB-16 ide
connector!   Now what?


0
 
LVL 1

Author Comment

by:bravado042997
Comment Utility
I believe these calls are coming from your registry.
Search reg for 'Primary ide"  no quotes, and delete all references to it. Do the same with SB 16.
OF course back up you registry first. I would take the extra
step of exporting everything you delete 1st to a save directory.

0
 
LVL 14

Expert Comment

by:smeebud
Comment Utility
Oh yea, magigraf's 1st answer I believe is the key, it will/should clean you registry; for instance:
-------
If your computer has a Plug and Play BIOS, reinstall Windows 95 using the "setup /P I" command to rule out a defective Plug and
Play BIOS.
--------------F SWITCH EXPLAINATION
X:\setup /d /p f
Where X is your CD drive letter
This will cause windows 95 to re-examine your setup.
This will clean, read and rewrite your Win.ini and System.ini,
without over-writing your updated dll's vxd's extensions.
f - This switch enables Clean Registry mode. It forces Detection
to clean and correct the root branch of the registry before starting.
This switch is ignored when Setup is run in the Windows 95
graphical user interface (GUI).
----------------D SWITCH EXPLAINATION
/d - If you do not want Setup to use your existing Windows configuration (such as your current
Win.ini and System.ini files), use this switch.To restore and adjust your windows installation try this:

iF YOUR SURE all references a gone from your ini files, use the
/d switch.
0
 
LVL 14

Expert Comment

by:smeebud
Comment Utility
 Personally, I would go into safe mode, device manager, and remove any PCI BRIDGE from system, and any PCI devices like drive controllers and display adapters, then reboot, and let win95 hardware detection take over.  You know, folks, it's like that game Concentration. There's a whole lot of questions and a whole lot of answers, and you just have to match them up.  Of course, I screwed up and matched this answer with a question about a TEAC CD-ROM...  So, you can all go and look and laugh for a while...  I just thought you should know!  =)
0
 
LVL 2

Expert Comment

by:nebworth
Comment Utility
I red X'd the offending items that kept trying to install and unchecked boxes for what config they work with and even unchecked the auto settings boxes for good measure.  

I'll poke around some more in the registry shortly...
But the way I have it I am not getting asked anymore
I was actually hoping there was a way to just stop win95 cold from even looking for new hardware....
tx
0
 
LVL 1

Author Comment

by:bravado042997
Comment Utility
ok can we start over 8)

My original question has not been solved...

I have to say this first... I have reinstalled Win95 on a virgin
partition with this hardware and old motherboards with most
of same components, I have NEVER been able to fix this issue of win95 adding drivers I don't need, wiping out and removing
reg entries and uninstalls and reinstalls aren't working...

There is no way to force win95 to NOT use PLUG & PLAY?

I get these 3 items that want to install but aren't really needed:

SB16 IDE controller   [not using]
Standard IDE/ESDI Controller  [using busmastering driver instead]
PCI Card [looks like it's m3d trying to install again]

I have uninstalled and reinstalled to no avail....

IS there a /switch for SB16 drivers loading in config.sys and/or
autoexec.bat that would tell it NOT functioning IDE connector?


0
 
LVL 1

Author Comment

by:bravado042997
Comment Utility
Bravado...

When you said OLD MOTHERBOARD, how old.

If you want to disable the PNP, you could go to your BIOS and IF your board support PNP, just disable them and change it to LEGACY.

This is your answer, on how to turn the plug and play off.

Take of all the offending dirvers, and make a clean MANUAL detect if you want, then reinstall every drivers fresh.

Could you update me if your motherboard support the PNP on and off or not, if not again reject my answer to attract more techs.

Regards
0
 
LVL 9

Expert Comment

by:magigraf
Comment Utility
magigraf,

haha ok OLD was a bad word choice:   my current mb is
an ASUS TX-97E and it's bios has PnP of course and I am
not a newbie here (for the record) and I have had it disabled and
enabled and either way it asks for this unnecessary CRAP!
What a struggle eh? 8)

And I have even upgraded the mb drivers...  uses Award BIOS btw.

I did go out and snag a new video card BIOS and drivers for my
Matrox Millienium 2 but that isn't in this problem.

Is e-e being run on a 286?  This page is taking 2 mins to load now even with images off...  [sorry had to vent]

Now what?

0
 
LVL 1

Author Comment

by:bravado042997
Comment Utility
To fill in questions of my hardware...

My system is as follows:

ASUS TX97-E mothboard with 512k cache
Intel Pentium 233MMX
64 megs of EDO RAM
Matrox Millenium II (4 meg PCI)
Matrox m3d (4 megs PCI)
Adaptec 2940U SCSI card (PCI)
Conner 1.6/3.2 Travan Tape Backup
Plextor 14/32 SCSI CD-ROM drive
Toshiba 15x SCSI CD-ROM drive (XM3801TA)
Ricoh MP6200s CD-RW (SCSI)
2 IDE HD's (one maxtor, one WD caviar)
1.4 gig Quantum SCSI HD
Panasonic S70 (17" monitor)
Syquest EZ Flyer 230
Sound Blaster 16 (basic edition)
JBL speakers
USR Sportster 33.6 upgraded to x2 (worthless upgrade in my area)
Hope that helps...


0
 
LVL 1

Author Comment

by:bravado042997
Comment Utility
bravado...

*lol*
Yes it took about 2 minutes indeed.
Thanks you straighten up that Newbie thing.
O.K.

Now let's try this: ( I hope your are patient )

1) Remove all the offending drivers, the one that windows keep reinstalling
2) Restart and let it install whatever it wants. (don't use any drivers you've got, let it use it's own drivers that are on the CD)
3) Restart windows, and let me know it it still ask you or not.

Now if windows is happy with what it has, you could then go to DM and expand every device and update it with the drivers you've got.

Let me know
Regards
0
 
LVL 9

Expert Comment

by:magigraf
Comment Utility
Wow,
All, Asus with TX. Doesn't that remove the PCI bridge issue???
I'm only asking because I don't know??
0
Threat Intelligence Starter Resources

Integrating threat intelligence can be challenging, and not all companies are ready. These resources can help you build awareness and prepare for defense.

 
LVL 14

Expert Comment

by:smeebud
Comment Utility

    First,  Being a TX board, have you run the .INF upgrade (otherwise know as the TX patch)?  That will help Windows95 recognize the PCI Bridge and all hardware attatched to the PCI Bus.  Otherwise, it may come up with problems like certain hardware doesn't seem to work, bad drive controllers that sort of thing.  Second, that unknown PCI CARD is a reference to the USB port which comes standard with the chipset, and for which Windows95 does not have built in support until you get to OSR 2.1.  There is a support patch offered for OSR 2, but as far as I know now, none available YET for 95a.  Third, once Windows recognizes a piece of hardware, it either asks for a driver, or goes ahead and installs it.  If it asks, you have the option of telling Windows not to ask you again, in which case, Windows does not load a driver, and places a bookmark of sorts under ? in device manager.  If the driver is there, Windows will not ask again.  If windows goes and installs a driver, and you don't want it to do that, then the particular piece of hardware has an .INF file under \WINDOWS\INF or under \WINDOWS\INF\OEM.  Remove the .INF for the hardware, and windows will go back to asking you for the driver files when the hardware is removed from the device manager.
0
 
LVL 2

Expert Comment

by:nebworth
Comment Utility
  All right, I'm going to go out on a limb here.  First, procure the TX patch.  It's available from a number of sites.  The easiest way to find it (I find) is to check out the web site of a TX motherboard manufacturer (in fact, there's a file called CHIPSET.ZIP available from supermicro.com).  Run this program.  It will adjust windows to recognize the TX chipset (and, of course, PCI Bridge) correctly.  The computer will reboot, and re-detect all PCI Bus hardware.  It should then work properly.  If not, reboot into safe mode and remove from the device manager any incorrect hardware, or anything detected more than once.  That is, for instance, you open up display adapters and you see two instances of your card.  Remove them both.  If you see your card, and some other card, remove the other card.  Reboot.  If at this point, any incorrect hardware suddenly loads itself in, then there is an incorrect .INF file under \WINDOWS\INF\OEM from a previous installation.  Remove the offending .INF file and reboot.  It really should work then.
0
 
LVL 2

Expert Comment

by:nebworth
Comment Utility
Ok, then it's not an automatic fix. That's what I was wondering. I'm at http://www.asus.com/search.asp now but cannot find
anything about thier TX Patch.
0
 
LVL 14

Expert Comment

by:smeebud
Comment Utility
Hey Neb, look behind you, someone's sawing off that limb! Thanks for the invite Bud!

Bravado, there is a way to fix this system and make it hum, but let me know whether you've accepted Nebworth's idea first or not, as posting mine takes time, but it works every time. BTW: Don't use the Supermicro file on any Tyan or Asus board!

When your ready, I'll post the answer from start to finish and we'll make that sucker cook!
Dennis
0
 
LVL 25

Expert Comment

by:dew_associates
Comment Utility
I have to hear Dennis' solution folks...
Dennis, like one of my fellow techs at my last job once said to me (ok several times to me) 'Spit it out, son!'  Don't tease us with a potential answer, I am expecting the 'open window, throw PC out window' answer btw.

Got back to reading responses again after a few hours of Diablo and no it did not crash on me.

At this point though I was thinking of just letting things go
as I have it, 2 things are Red X'd and after 3 reboots win95 has not asked for anything.    2 items: SB16 PNP controller &
that mysterious OTHER DEVICES: PCI CARD... are red X'd.

Welp if PCI card is really the USB, why is it coming under PCI card?  why was it sharing same irq and such with the Matrox m3d?
and I have no USB port on my motherboard, I remember trying to find it when I was looking to buy a scanner, I forgot that, I have a UMAX 610S...  on rarely...  and why does it not try to load if I yank out the m3d card?   8)

Is order of SCSI ID's or IRQ order a factor in any of this?

And my Syquest EZ Flyer 230 gets accessed sometimes for no apparent reason?  Occasionally click on START it hesistates and looks there...  ack it just did it whilst I was typing last line.
(just another symptom perhaps so thru it out there)

Who found the actual TX fix for 95 nebworth mentions, leave URL here please!?!  BTW I may have already run that, been awhile and the mb did come with a CD.

I'll look into the registry about what nebworth said and look for more msgs here later...
thanks all for the efforts so far... definitely a learning experience for all 8)

oh yeah btw when I have pnp on my sb16 is irq 5, off it is 10, odd?   Leaving on...  made no difference, I got reinstall attempts from win95 anyho...

ps #2 very patient mag...  8)

Let the opinions fly gentlemen... that is what this is all about... I hope!
0
 
LVL 1

Author Comment

by:bravado042997
Comment Utility
Another comment (the hell with sleep)  [6:09am]
I dug up the TX patch and a new BIOS upgrade for the ASUS tx97e.
No problems installing either...
On reboot it goes through the motions finds USB and all and red X's USB, I changed in cmos to disable USB and no longer RED X'd.

I have not gotten to registry check for INF files yet that will come later today.
It installed the Secondary Bus Master IDE Controller with a ! in device manager... once again how do I get rid of?  I don't have anything on secondary and disabled or enabled in CMOS had no effect, it reappeared anyhow.

SO as it stands...   still have red X'd sb16 ide controller and
! (now probably red X'd when I reboot) for the 2nd Bus Master IDE controller... ( i removed the entire busmastering set and rebooted after changing CMOS setting of primary ide enabled to both with no change... still installed both and ! on 2nd.)

I hope above was coherent... I felt my kb rambling ;)
zzzzzz time!

0
 
LVL 1

Author Comment

by:bravado042997
Comment Utility
Sorry for not reading all thread before (I'm lazy :) I'll tell you
one thing:
To get rid of unwanted device, installed even you remove it:
- let Win95 install device (and drivers)
- reboot
- boot to Safe Mode (F8 right after message 'Starting Win95', from
 menu choose Safe Mode)
- enter Device Manager
- select "troublemaker" device, click properties
- uncheck it from Original Configuration
- Voila

Hope this helps
0
 
LVL 7

Expert Comment

by:busuka
Comment Utility
  And I thought Dennis was going to answer.  The INF files are not in the registry.  They are in a directory (folder) \WINDOWS\INF or \WINDOWS\INF\OEM.  You might look in the registry for a key called NOIDE and delete the key if you find it.  That will keep your 32bit IDE from working. Actually, so far things seem to be working.  Otherwise, for the stuff that is Xd out, you have to go into the properties and uncheck 'disable device in this hardware profile'.  

   ps..  The INF thing is only for if windows is automatically loading the wrong drivers (like say you previously installed S3Virge drivers for an S3Virge/DX and now every time you delete the driver and reboot it comes back instead of asking you for a disk. Of course, changing display drivers is simple, but it's the only example I could think of...)
0
 
LVL 2

Expert Comment

by:nebworth
Comment Utility
  By the way, buzuka's answer won't make it work, it'll just make it disappear.  Also by the way, if reference to an earlier question, USB habitually takes IRQ 11, and will use it regardless of what else is using it (like the matrox, for instance).
0
 
LVL 2

Expert Comment

by:nebworth
Comment Utility
Busuka, I've gotta give you an A for your persistence but an F for your answer. Heck, if you need points that bad that you have to post any old answer, I'll give you some of mine.

Bravado, you have a real computer salad here with all of these components installed. Maybe if I help you understand the load process you'll have a better feel for what we're doing. Windows reads it's snapshot of the Bios/Cmos setup and begins loading drivers for components that it thinks it can identify. Most of these come from the inf files in \windows\system. However, if the inf files are not in that location, but rather in another directory because of the install procedure, windows won't see them until last, and then try and load them, thus a conflict.

The following will help you get everthing loaded where it's supposed to be. Patience and accuracy count though! In any event, we're going to remove some cards, load the bus drivers make sure the system reacts correctly and then add things back. Unfortunately the retail version is not as easy to work with as OSR2 when sorting things out. You may have done some of these things already, but I would prefer that they be repeated as part of this process.

1. Download and install the Service Pack 1 for Windows 95 and install it if you haven't already.

2. Physically pull the following out of the system, Matrox M3D, Conner Tape BU, Syquest, SCSI card with all of it's devices and the USR modem, then reboot the system. Go to device manager and remove any devices that show either a ! or a red "x", Except for the hard disk controller, but "don't" reboot.

3. Since I have no idea where you got the TX driver set, I'll presume for the moment it is correct and the latest possible. Transfer the TX driver set into a clean directory on your "C" drive where windows is located, expand or unzip it, transfer a copy of the files to a floppy and then install it from the directory on "C". Then go into device manager and remove the hard disk controller completely, then close everything and reboot. Windows should first find the master bus and install it, then find the primary IDE controller and then as for a restart. Do the restart and then it should install the secondary bus. Restart the system again. This should give you a master IDE bus, Primary and Secondary bus. If this doesn't occur, let me know before going further. If the drivers are correct, everything should be okay.

4. Now, add back the SCSI card and if possible, reload the 7800 driver family set. Right now your device manager entries should be clean without any problems and all the drives showing properly. If there are any problems, let us know now.

5. Next, add back the Matrox M3D as well as it's drivers, and check device manager again. If everything looks okay, go on.

6. Now add back the modem and use the latest driver file. Again, check everything.

7. Last, add back the Syquest EZ Flyer.

We can work on the sportster when everything else works properly. Let me know how you make out.
Dennis
0
 
LVL 25

Expert Comment

by:dew_associates
Comment Utility
nebworth, USB take IRQ 11 eh?  if no USB is there does it still
interfere with anything on that IRQ?  This is a general question, for any IRQ if a device is not present but driver says using
IRQ ## is it effecting performance?

Busuka must have just read the first msg, most of which is taken care of already 8)

Dennis, ummmm it's not worth the trouble in your step 2 to me...
That's too painful...  But I printed your solution out and
will consider it the last resort method.  Thanks much!

I'm going to surf the reg and windows directories for INFs and see what I can do there.

Removing everything and redoing could cause more grief then it's worth...  and a lot of time... and besides I did that already
sorta, but I am more enlightened now.




0
 
LVL 1

Author Comment

by:bravado042997
Comment Utility
I cant tell you with the Millenium but with the M3d you let it install as the PCI device then go into the control panel and then into system properties and go to other devices and update the drivers with the drivers that were included with the M3d. I suppose that you could do the same with the Millenium.
0
 
LVL 2

Expert Comment

by:aszure
Comment Utility
aszure, you're very late and didn't read all the text...
Others are sure to repeat my finding and someone else did same.

Basically the Matrox m3D was found and got drivers install and it sits in Device manager's Sound, video, and game controllers section. THe problem arises with a second unID'd PCI Card install
attempt...  Thankfully what fixed that was the TX patch I think
now it was actually the USB because it has vanished from DM...
ie I have no OTHER section now 8)

What remains to recap is ONLY DM's HD controllers section.
(X) SB16-PNP controller & (!) Secondary Bus Mastering IDE controller...


see above msgs for info...

I love that ppl think they can sneak in for a quick 201 pointer...
Can't blame you too much but the points are meaningless really
or did they start paying ppl?  8)

[STOP ANSWERING THE ORIGINAL QUESTION PLEASE!]

btw this is my first and only question here so far,
I was able to edit the question early on but haven't seen that option lately.
Maybe caz I switched to reading these in Opera?

0
 
LVL 1

Author Comment

by:bravado042997
Comment Utility
  To remove some question, the INF files are in \WINDOWS\INF not \WINDOWS\SYSTEM.  VXDs, DLL's and other stuf like IOS stuff is in \WINDOWS\SYSTEM.  I haven't been having any real problems with USB stealing an IRQ.  I used to think it was a problem once upon a time, but I think I was wrong...  Otherwise (the big one) this thread is so long, what is the actual status right now?  Is one or both IDE port giving you trouble, and what's attached to the IDE?
0
 
LVL 2

Expert Comment

by:nebworth
Comment Utility
  Oh yeah, in response to earlier.  Even though there are no USB ports on the outide of your case, they are on the motherboard.  They'll probably be a double row of pins that resembles a bit the header connector for the comm port (UART1, UART2).
0
 
LVL 2

Expert Comment

by:nebworth
Comment Utility
Well Bravado you do as you like like. We try and keep our time on a system to a minimum, and we've learned the hard way that Windows is not as adept at placing hardware configurations as we may want it to be.

The primary issue is getting the tx chipset to load correctly and have the master, primary and secondary buses loaded properly. This will then correct the PCI bus and and IDE/EIDE bus as well.

Azure, how about reading the dialogue here before posting a guess for an answer!

0
 
LVL 25

Expert Comment

by:dew_associates
Comment Utility
Nebworth, not to burst your bubble or anything, but windows and other programs do not limit *.inf files to \windows\inf, therefore a profound statement "not" doesn't make it!

You will find them in:
\windows
\windows\inf
\windows\system
\windows\occache
\windows\plus
and a raft of others!

0
 
LVL 25

Expert Comment

by:dew_associates
Comment Utility
Like I said above all cosmetically wrong is the X on SB16-PNP controller and ! on secondary bus mastering IDE controller in device manager, I repeat repeat I do not not have anything on
my secondary IDE, I only have 2 IDE devices... both hard drives.

my master HD is a DMA 33 drive, I'm gonna look for a good win95 HD benchmark prog that doesn't take too long to give me a score... anyone know of a good one and what kinda of scores I should get?  

This will tell me if all is well, I can live with just two not
really been installed drivers on my system.

On my gf's system it still tries to reinstall the Syquest drive a second time over and over if I delete but doesn't really matter I suppose as long as it works.

thanks to all... dunno where these points are gonna go....

0
 
LVL 1

Author Comment

by:bravado042997
Comment Utility
Bravado, I'm going to post the correct answer for no other reason that it is correct. At the same time, I'll respond to your last post so that you can understand what is going on in your system.

1. As for hard disk controllers, you should have an Intel Bus Master Controller (this is the master controller), under that you should have a primary IDE controller and then a secondary IDE controller. I don't care if you've got one or four hard drives, this will not change.

2. As a signal to you, if the secondary is not loading properly, in all probability Windows is not loading the PCI bus as well.

3. If your getting a Red circle with an X in it, that signifies one of two things, either the correct driver is not being loaded or you have manually disabled the device. In the case of the SB16 cards IDE device, you can disable it if you like or you can enable it and load the proper device driver. Either way it will have no performance impact on your system if done properly.

4. As for your DMA (or UDMA) hard drive, if the bus isn't working properly, you can test that drive until the cows come home and it won't work right. UDMA drives require active bus mastering and DMA ported through the PCI bus to the cpu.

5. The reason you gf's Syquest drive is trying to reload drivers is because of a conflict.

Dennis
0
 
LVL 25

Expert Comment

by:dew_associates
Comment Utility
Hi again Dennis, on my gf's p5/133 there is no conflict...
I've checked, the syquest drive works fine and there are actually 4 IRQs not being used on hers.
at the start hers was acting goofy with no allowing me to defrag or scan disk her HD but that has gone the way of the dodo.

As far as the red X with sb16, I disabled it....

You are telling me even with NOTHING on my 2nd IDE port that busmastering driver has to load?  fine it isn't loaded...

There is nothing else I can do eh folks?

Next time I'll break my questions up into separate ones ;)

0
 
LVL 1

Author Comment

by:bravado042997
Comment Utility
  One other thing (as I trail off into the sunset here) about the syquest.  Those drivers had some strange problems locking up serial ports and I don't know what else...  There are some issues at syquest's page about this.  You just made me think of it, that's all.  Try Syquest for some inspiration about the driver.  My fix (for interference with the serial ports) was a /D on the options line in the driver.
0
 
LVL 2

Expert Comment

by:nebworth
Comment Utility
OK. Try to enter BIOS setup and disable secondary IDE channel.
(BIOS Setup -> Integrated Peripherals)
0
 
LVL 7

Expert Comment

by:busuka
Comment Utility
Bravado, all of this dialogue has become pointless as it appears you don't want an answer even if it's correct. However, to your comment, " on my gf's p5/133 there is no conflict. ..  I've checked, the syquest drive works fine and there are actually 4 IRQs not being used on hers".
Conflicts do not necessarily appear in device manager. PnP devices report their existence to Windows 95 via the Bios and Windows 95 attempts to match that information with a driver or device INF. If the reply information from the driver or INF file differs from the PnP info, Windows searches for another driver, and a conflict does exist as transparent as it may be.

As for, "As far as the red X with sb16, I disabled it.... " then so be it!

As for, "You are telling me even with NOTHING on my 2nd IDE port that busmastering driver has to load?", that's exactly what I'm saying. It's a hardware device issue, not a software issue. It's part of the PCI bus architecture.

Ian, you can search all you want, you wont find a place to shut off the secondary IDE channel.

Have a good day!
0
 
LVL 25

Expert Comment

by:dew_associates
Comment Utility
Dew, at my home, plain old "el cheapo" VX with AWARD 4.51 PnP
BIOS has this option. As well as assign PIO mode for 2nd Master
and 2nd Slave (now Auto both). Maybe bravado have these.
0
 
LVL 7

Expert Comment

by:busuka
Comment Utility
  Yeah, I was going to say, in most cases the BIOS has a way to shut off the secondary on chip IDE controller.  Award has it under built in peripherals.
0
 
LVL 2

Expert Comment

by:nebworth
Comment Utility
What a nice dialog...
0
 
LVL 9

Expert Comment

by:magigraf
Comment Utility
Ok, my turn.
Rule Out a Defective Plug and Play BIOS. "setup /p i"
If Windows 95 still hangs during the shutdown process after you
reinstall it, your computer may have faulty hardware or faulty system
components including RAM, the CPU, the motherboard, or an
internal or external cache. Contact your computer's manufacturer for assistance.

                    Clean Up Duplicate Device Manager Entries
1. When windows detects two devices (usually this happens with pnp) you should delete all the
devices of the same type detected. Then reboot windows, and windows will detect the device. Install
the drivers, and you solved the problem. If the pnp system detects a device twice, simply ignore the
install request, and get the latest driver for it. This is important. Windows will detect all the pnp
unknown hardware.
NOTE: to avoid problems ensure to have all the drivers needed for your PC.
BACKUP YOUR REGISTRY FIRST
2. I did a search of my registry with regedit, using as a "Search Phrase", Supra, that's my Supra Fax
Modem in Device Manager. I found all entries for it in the registry. I then deleted all references to the
modem. Deleted the entire key, not just the entry. On I re-booting Win95, the Supra was detected
and installed installed.
All Devices won't be that easy, some you will need your drivers for.

Let me know.
0
 
LVL 14

Accepted Solution

by:
smeebud earned 200 total points
Comment Utility
Ian and Busuka, I'm aware of the ability in both Award, Ami and Mr. Bios to shutoff or disable the *physical bus*, but this does not disable either the *X chipset or Intel Bus. It just shuts off the physical bus.
Dennis
0
 
LVL 25

Expert Comment

by:dew_associates
Comment Utility
Thanks to all, sorry but someone had to get the points.....

0
 
LVL 1

Author Comment

by:bravado042997
Comment Utility
I do hope it's working.

Regards
Bud
0

Featured Post

How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

Join & Write a Comment

Our Group Policy work started with Small Business Server in 2000. Microsoft gave us an excellent OU and GPO model in subsequent SBS editions that utilized WMI filters, OU linking, and VBS scripts. These are some of experiences plus our spending a lo…
This is an article about Leadership and accepting and adapting to new challenges. It focuses mostly on upgrading to Windows 10.
Windows 8 came with a dramatically different user interface known as Metro. Notably missing from that interface was a Start button and Start Menu. Microsoft responded to negative user feedback of the Metro interface, bringing back the Start button a…
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.

743 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

12 Experts available now in Live!

Get 1:1 Help Now