• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 197
  • Last Modified:

diamond supraexpress 28.8i class 2.0 or class 2 compatible?

Does anyone know if the diamond supra express 28.8i is class 2 or class 2.0 compatible?
If it is what AT string do I need to send to the fax(-modem) to check it.
These question are placed because I need to know for a c++ program.
0
TheMaster
Asked:
TheMaster
  • 3
1 Solution
 
nebworthCommented:
  Wow, I didn't know they had moved up to class 2.  No information at http://www.diamondmm.com??
0
 
TheMasterAuthor Commented:
Adjusted points to 50
0
 
nebworthCommented:
 Silly me, I had been thinking class 0 and class 1...  Brain mush...  Isn't there an AT+FCLASS=? or something like that...  Geez, I have to look some of this stuff up...
0
 
nebworthCommented:

   Ok...  I was on the right track.  Do this:

   AT+FCLASS=?

   That should return 0,1 or 2 to indicate then class the modem supports, 0 being data only, 1 being class 1, and 2 being class 2.

   Conversely, you can set the fax class AT+FCLASS=n [n:0,1,2].  An incorrect class assignment should result in an ERROR.

   Good?
0

Featured Post

A Cyber Security RX to Protect Your Organization

Join us on December 13th for a webinar to learn how medical providers can defend against malware with a cyber security "Rx" that supports a healthy technology adoption plan for every healthcare organization.

  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now