Solved

Problem with CSI.COM and pop3 mail

Posted on 1998-01-27
4
221 Views
Last Modified: 2010-03-18
Has anyone had any success connecting to their CSI pop mail pox using fetchmail under Linux 2. I am using red hat linux 4.2, User name and password authenticates stat and list work, on retr command, csi end goes dead. The same happens if I do it manually by telneting to port 110 and issuing the commands. However, If I telnet manually under Windows 95, it all works perfectly.

I have tried using the poprpa package, it authenticates perfectly, but also gets stuck after sending a RETR 1 command. I have tried with kernel 2.0.30  and also 2.1.79  and neither work. I have tried on two different machine with two different modems.

I immagine I could have some compile option not set properly, or maybe something missing in /etc/conf.modules

Thanks for your time,
Nicholas Waltham


Thanks again for your suggestings,
Nicholas Waltham
0
Comment
Question by:nwaltham
4 Comments
 
LVL 4

Expert Comment

by:unicorntech
ID: 1587453
Sometimes this can happen if it is trying to retrieve the mail from /usr/spool/mail/username rather than /var/spool/mail/username. In the later versions chrooting occurs which basically means that although there is a sym link between /usr/spool and /var/spool the chroot process creates a sub file system for security that doesn't include the sym links.

Try looking at the source code for the fetchmail and see where it looks for its mail box. If it looks in /usr/spool try changing it to /var/spool or vice versa. This is a common problem and is usually fixed in this way. Regards,

Jason
0
 

Author Comment

by:nwaltham
ID: 1587454
Thanks for you suggestion, but this problem is not unique to fetchmail, I can reproduce it with telnet, and poprpa (a version of popclient) fails at the same point.

0
 
LVL 3

Expert Comment

by:sauron
ID: 1587455
Suggest you attempt retrieval with telnet, under linux, and windows. Do a packet capture on both, and look for differences.

This may give you somewhere to start. Perhaps your terminal setup is causing differences that make it work under windows but not linux. There must be a differnce in the setup somewhere - if you can find this you may be able to solve the problem.
0
 
LVL 7

Accepted Solution

by:
linda101698 earned 100 total points
ID: 1587456
I am posted the solution found by nwaltham to solve the problem.

Linda Gardner
Customer Service @ Experts Exchange

Solution:
I have found the answer, I needed to set mtu and mru to
         296 and now everything is fine.
0

Featured Post

How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

Join & Write a Comment

Suggested Solutions

I have seen several blogs and forum entries elsewhere state that because NTFS volumes do not support linux ownership or permissions, they cannot be used for anonymous ftp upload through the vsftpd program.   IT can be done and here's how to get i…
Note: for this to work properly you need to use a Cross-Over network cable. 1. Connect both servers S1 and S2 on the second network slots respectively. Note that you can use the 1st slots but usually these would be occupied by the Service Provide…
Access reports are powerful and flexible. Learn how to create a query and then a grouped report using the wizard. Modify the report design after the wizard is done to make it look better. There will be another video to explain how to put the final p…
You have products, that come in variants and want to set different prices for them? Watch this micro tutorial that describes how to configure prices for Magento super attributes. Assigning simple products to configurable: We assigned simple products…

758 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

19 Experts available now in Live!

Get 1:1 Help Now