Should install the latest version of comctrl32.dll?

I have developped an application with VC++ 4.1. It is interesting or not installing the latest version of comctrl32.dll.
Has it a lot of bugs? Will it allow me to use flatbars and icon menus?
My application has a wizard, and it doesn´t work on Win NT. This new dll will allow the wizard to work on NT.
(The problem is that an exception comes when Next is pressed on the first page of the wizard. In Win 95 it doesn't work the first time is built but the next ones works O.K.)

Thanks
MarisolAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

galkinCommented:
There several versions of comctl32.dll Latest controls, uncluding flat toolbar, flat scroll bars , rebar, etc. are available with version 4.70 or higher. Latest release version of comctl32.dll is available for downloadong and free redestributing via the package. You can get it here http://www.microsoft.com/msdn/downloads/files/40Comupd.htm
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
MarisolAuthor Commented:
Yes, I have already downloaded this package.
 What I would really like to know is if this dll is compatible with a proyect developped with VC 4.1 and if it will arrange my problem with the wizard on Win NT.
Last but not least,  I am not very confidence with the latest release of anything from Microsoft, so I was wondering if this latest version of comctl32 has a lot of bugs or it works mainly O.K.
0
galkinCommented:
This DLL is system DLL, it is compatible with any program which uses common controls rather directly through the messages or through any libary like MFC which defines several classes for common controls wrappers. If yuo want to use any of the control available with IE3.0 or higher, like flat toolbar etc. you must upgrade existing DLL if it's vetrsion is less then 4.70. Also no version of MFC provides wrapper classes for these controls so anyway you must use messages directly to communicate with controls or define your own wrapper classes. From my experience the package available for downloding from MS and upgrades comctl32.dll to version 4.72 works rather OK and I haven't run into any big bug yet.
0
pswannCommented:
We have had a number of problems regarding the use of this dll when running and installing on NT 4. If you attempt tpo place a later version of the comctl32.dll on Windows NT it can bring down the sytem but works perfectly okay on Windows 95. We have downloaded the comupd40.exe self extracting utility from the microsoft web site reference above only to fing that it fails to run on NT because it cannot find CreateMutexA(). Is it possible to get this self extracting executable from another source ?
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
System Programming

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.