Solved

NFS Portmap: RPC: Program not registered

Posted on 1998-01-28
5
548 Views
Last Modified: 2013-12-23
The server and client both are alpha 300 machines running
OSF1 4.0

I get the message
"NFS Portmap: RPC: Program not registered"

when I try to run on client

# mount -t nfs server:/usr /tmp_mnt

I have mountd, nfsd running on server and in /etc/exports
I do have the client listed to mount the filesystem with the same priveleges as does root on the server.

Thanks for any ideas.
0
Comment
Question by:monish
  • 2
  • 2
5 Comments
 
LVL 51

Accepted Solution

by:
ahoffmann earned 10 total points
ID: 1583095
Your server does not have a service spcified in the portmaper configuratin file (usually /etc/inetd.conf). You should have somthing like:
  mountd stream rpc/tcp wait/lc root /usr/etc/rpc.mountd     mountd
0
 

Author Comment

by:monish
ID: 1583096
Hmm, Adding the line to the server
mountd stream rpc/tcp wait root /usr/etc/rpc.mountd mountd
to /etc/inetd.conf and HUPintg inetd didn't help.

I also added a line to /etc/services to the server
mountd          60/tcp          mountd

I still get the same error message.
0
 
LVL 51

Expert Comment

by:ahoffmann
ID: 1583097
Ups, I gave you an example. You need to check out if this is valid for you mashine.
After changing these files you need to HUP inetd, best you reboot.
0
 

Expert Comment

by:nish
ID: 1583098
This might be a little off but check your dfstab on your
server that is giving share i think it is that part that has
been either not shared properly or even if it has been u
have not killed the process and restarted them
/usr/sbin/biod
/usr/sbin/exportfs -a
/usr/sbin/nfsd 8
/usr/sbin/rpc.mountd
/usr/sbin/rpc.statd
/usr/sbin/rpc.lockd

or preferably if u can reboot the machine that way u can make sure it works.
0
 

Expert Comment

by:nish
ID: 1583099
This might be a little off but check your dfstab on your
server that is giving share i think it is that part that has
been either not shared properly or even if it has been u
have not killed the process and restarted them
echo "share -F nfs -o ro /export/apps" >> /etc/dfs/dfstab
shares /export/apps with read only option more options can be
added to either have rw for a particular server /machine etc
look at man dfstab or give scenario and i might be able to help.
please check the path of dfstab it might not be the same as i have mention on your os.

/etc/init.d/nfs.server start

or preferably if u can reboot the machine that way u can make sure it works.

good luck.
0

Featured Post

Windows Server 2016: All you need to know

Learn about Hyper-V features that increase functionality and usability of Microsoft Windows Server 2016. Also, throughout this eBook, you’ll find some basic PowerShell examples that will help you leverage the scripts in your environments!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

This is an article about my experiences with remote access to my clients (so that I may serve them) and eventually to my home office system via Radmin Remote Control. I have been using remote access for over 10 years and have been improving my metho…
Don’t let your business fall victim to the coming apocalypse – use our Survival Guide for the Fax Apocalypse to identify the risks and signs of zombie fax activities at your business.
Viewers will learn how to connect to a wireless network using the network security key. They will also learn how to access the IP address and DNS server for connections that must be done manually. After setting up a router, find the network security…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

803 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question